Subject: [Manet-dt] Packet Format - Address TLV - Subnet Behind MANET Router

From: Ian Chakeres <[email-masked]>
Date: Wed, 9 Nov 2005 12:40:21 -0800

Is there a mechanism to represent a network subnet is reachable via  
an address in an address block? I am thinking about DYMO-like  
functionality, where a subnet might live behind an address  
participating in the MANET.

Ian

_______________________________________________
Manet-dt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet-dt

---

From: Thomas Clausen <[email-masked]>
Date: Wed, 9 Nov 2005 23:00:07 +0100

Yes, there is. Wasn't spelled out clearly in the previous draft but the 
functionality (which in RFC3626 - OLSRv1 - was through HNA messages) is 
present and will be made explicitly clear in the upcoming 
draft-ietf-manet-olsrv2-01.txt.

On 9 Nov 2005, at 21:40, Ian Chakeres wrote:

> Is there a mechanism to represent a network subnet is reachable via an 
> address in an address block? I am thinking about DYMO-like

---

From: Ian Chakeres <[email-masked]>
Date: Wed, 9 Nov 2005 15:15:44 -0800

Is it simply an address-tlv? If so, is it a vector or a single value
tlv? Just wondering if it is something we might leverage in a common
fashion.

Ian

---

From: "Joe Macker" <[email-masked]>
Date: Thu, 10 Nov 2005 12:42:19 -0500

I think is really good example of something that if done in a common way
might be very useful in a heterogeneous world. personally I was thinking a
vector is used as there are often many different subnetworks behind a manet
router. The vector values might have some atributes?

>-----Original Message-----
>From: [email-masked] 
>[mailto:[email-masked]] On Behalf Of Ian Chakeres
>Sent: Wednesday, November 09, 2005 6:16 PM
>To: Thomas Clausen
>Cc: [email-masked]
>Subject: Re: [Manet-dt] Packet Format - Address TLV - Subnet 
>Behind MANETRouter
>
>Is it simply an address-tlv? If so, is it a vector or a single 
>value tlv? Just wondering if it is something we might leverage 
>in a common fashion.
>
>Ian
>
>> Yes, there is. Wasn't spelled out clearly in the previous draft but 
>> the functionality (which in RFC3626 - OLSRv1 - was through HNA 
>> messages) is present and will be made explicitly clear in 
>the upcoming