Subject: [Manet-dt] DYMO Sequence Number Length

From: Ian Chakeres <[email-masked]>
Date: Tue, 8 Nov 2005 07:23:27 -0800

How do people feel about dropping the destination sequence number  
from 32-bits to 16-bits in DYMO?

I think using 32-bits is a little overkill.  Also, reducing the  
overhead would be nice, especially if someone does do path accumulation.

If you agree or disagree, please chime in.

Ian Chakeres

_______________________________________________
Manet-dt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet-dt

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 08 Nov 2005 11:15:01 -0800

Hello Ian,

I definitely agree with this.
In fact, I think we could probably do with 8 bits.
Perhaps even better, with the proposed TLV
structure in the address block, we could have one
TLV for 8 bit values and another for 16 bit
values in case there were ever any networks
that needed such longer sequence numbers.

Regards,
Charlie P.

---

From: Luke Klein-Berndt <[email-masked]>
Date: Tue, 08 Nov 2005 15:55:26 -0500

I like this. If we are going to be trying to minimize sequence number 
increase, we should take full advantage of all of the benefits.

Also I would be in favor of dropping the UERR... Even though I have 
already implemented them! :)

-Luke

---

From: "Pedro M. Ruiz" <[email-masked]>
Date: Tue, 08 Nov 2005 14:03:14 -0800

Reducing sequence number fields seems like a good idea to me.

No oppinion about UERR so far. I'd need to think more about its implicaions.

--Pedro