Subject: [Manet-dt] NHDP - solicit?

From: "Ian Chakeres" <[email-masked]>
Date: Fri, 23 Feb 2007 16:18:35 -0800

I've been reading through some of the MANEMO messages and there was
mention that ND is more appropriate for certain things as it has the
ability to solicit messages from nearby nodes. Do you think NHDP
should include semantics for soliciting responses from nearby NHDP
nodes?

Ian

_______________________________________________
Manet-dt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet-dt

---

From: "Krishna Sankar \(ksankar\)" <[email-masked]>
Date: Fri, 23 Feb 2007 16:38:44 -0800

This is a good idea - especially when a node moves into a new
neighborhood. It need not wait for the welcome wagon (in our case the
HELLO wagon ;o)) to know who lives there.

Couple of caveats:

A)	If we go this route, we need to clearly articulate when to do
it, why and under what circumstances
B)	We also need a quenching mechanism, else when a set of new nodes
appear they can flood the system with solicitations. 
C)	I assume we will restrict this to 1 hop and 2 hop symmetric
circles

My 0.02$

Cheers & have a nice weekend
<k/>

> -----Original Message-----
> From: Ian Chakeres [mailto:[email-masked]] 
> Sent: Friday, February 23, 2007 4:19 PM
> To: [email-masked]
> Subject: [Manet-dt] NHDP - solicit?
> 
> I've been reading through some of the MANEMO messages and 
> there was mention that ND is more appropriate for certain 
> things as it has the ability to solicit messages from nearby 
> nodes. Do you think NHDP should include semantics for 
> soliciting responses from nearby NHDP nodes?
> 
> Ian
>

---

From: "Joe Macker" <[email-masked]>
Date: Tue, 27 Feb 2007 14:38:14 -0500

I also feel event-driven capability should be supported and could be better
described.  The issue of reactive messaging in NHDP was actually discussed
at the last WG meeting and a brief note on it is in the minutes.  

I think all agreed it would nice to have and that some document work was
needed in this regard.  Not sure if this has been addressed further by the
individual authors at this point.

-Joe

>From: Krishna Sankar (ksankar) [mailto:[email-masked]] 
>Sent: Friday, February 23, 2007 7:39 PM
>To: Ian Chakeres; [email-masked]
>Subject: RE: [Manet-dt] NHDP - solicit?
>
>neighborhood. It need not wait for the welcome wagon (in our 
>case the HELLO wagon ;o)) to know who lives there.
>
>Couple of caveats:
>