Subject: RE: [manet] SAODV - signature

From: "#ZHOU ZHI#" <[email-masked]>
Date: Thu, 20 Nov 2003 21:02:47 +0800

I am not sure about the advantages of this kind of signature scheme because as Manel Guerrero said, there do exist some signature schemes making life easy. Furthermore, from the cryptographic point of view, this property may be undesirable because contents are related to the final signature size, which gives hints for cracking. 

-----Original Message-----
From: Joao Girao [mailto:[email-masked]] 
Sent: 2003年11月20日 20:51
To: #ZHOU ZHI#
Cc: [email-masked]
Subject: RE: [manet] SAODV - signature

That's exactly what I meant.
For the same digest size, the signature size can be different depending on the contents.

On Thu, 2003-11-20 at 11:00, #ZHOU ZHI# wrote:
> do you mean the signature size depends on the content of the "Length" field? 
> If you calculate signature over just any single byte of data, will your signature size be the fixed? 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of 
> Joao Girao
> Sent: 2003年11月20日 17:34
> To: [email-masked]
> Subject: [manet] SAODV - signature
> 
> Hello,
> 
> According to draft-guerrero-manet-saodv-00, in the signature for the extension, some fields of the extension itself are also signed. These normally include the Length of the extension.
> 
> The Length of the extension is calculated as the size of the extension 
> except the type and length fields. (according to the rfc)
> 
> My question is simple: If the signature is variable in length and depends on the data, how can we sign over the length field of the extension which depends on the same signature we are producing?
> Depending on the algorithm being used, it can be impossible to predict a multiple of 4 bytes for the size of the signature.
> 
> Should length be zeroed out for signature calculation?
> 
> Thanks in advance,
> 
> joao girao
> 
> --
> João Girão ([email-masked])
> NEC Europe Ltd., Network Laboratories
> Tel. (+49) 6221 90511-17
> Fax: (+49) 6221 90511-55
--
João Girão ([email-masked])
NEC Europe Ltd., Network Laboratories
Tel. (+49) 6221 90511-17
Fax: (+49) 6221 90511-55
	���fj)b�	b�ٚ��bz��m��?�0�'�~���f��f��X��)ߣ����

---

From: Joao Girao <[email-masked]>
Date: 20 Nov 2003 14:11:34 +0100

Well, ok.
My approach will then be to calculate a maximum signature size and use
that to calculate de length to be signed.

That should fall well with other encryption schemes in which the size of
the future signature is known in advanced.

Thank you for your help,

joao girao