Subject: RE: [manet] AODV Question

From: "Robert Cain" <[email-masked]>
Date: Thu, 13 Nov 2003 10:38:34 +0000

Connectivity is the number of other nodes each node can reach with 1 hop.
Therefore a connectivity of 10 means there is 10 nodes that a can reach
directly. Obviously in an actual network this would vary from node to node.

Rob Cain :-)

>What does the connectivity parameter specify?  Is it saying in 100,000
nodes only 10 nodes would be connected?
>
>-----Original Message-----
>From: Robert Cain [mailto:[email-masked]]
>Sent: Wednesday, November 12, 2003 11:13 AM
>To: DANIEL BYRNE
>Subject: Re: [manet] AODV Question
>
>
>1 byte seems OK to me.
>
>With some simple analysis assuming a circular homogeneous network of node
>count K and a reasonable connectivity C then the radius of the network in
>hops can be derived to be the square root of K/C. Which for a network size
>of 100,000 and a connectivity of 10 gives a hop count radius of 100.
Seeing
>as a network of size 100,000 will be probably at practical limits of size
>due to performance degradation then I think 1 byte may well be enough.
>
>hope that helps :-)
>
>Rob Cain
>
>>if the 
>>
>>"AODV routing protocol is designed for mobile ad hoc networks
>>   with populations of tens to thousands of mobile nodes"
>>
>>why is the HopCount limited to only a BYTE?  This effectively limits the
>number of hops to 255.  Why not expand the hop count to two bytes into the
>reseved region of the RREQ packet.  Something similar could be done with
>the RREP packet as well.
>>
>>
>>_______________________________________________
>>manet mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/manet
>>
>

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Jitesh Shah <[email-masked]>
Date: Thu, 13 Nov 2003 13:36:13 +0000 (GMT)

Hi,

It depends on how you see the network. If you are
refering to a network which has a CHAIN topology then
the byte used for RREP and RREQ might be way
insignificant. But when you refer to a well connected
network then the byte seems sufficient.

Rgds
Jitesh

 --- Robert Cain <[email-masked]> wrote: >
Connectivity is the number of other nodes each node
> can reach with 1 hop.

________________________________________________________________________
Yahoo! India Mobile: Download the latest polyphonic ringtones.
Go to http://in.mobile.yahoo.com