Subject: RE: [manet] AODV Question

From: DANIEL BYRNE <[email-masked]>
Date: Thu, 13 Nov 2003 08:52:21 -0600

Agreed.  A branched chain configuration would be difficult to support with only a BYTE. My point is that although most everyone involved in development and testing of this protocol have envisioned a 'cluster of connected nodes' arrangement, the reality is the sum total of all possible topolgies in a wireless network of this type is potentially limitless.  Limited in effect by only the range of the radios in the network.  How are we to know how some future person or organization will use this protocol?  Will they need the extra BYTE?  Should we place artificial limits on the protocol by purposefully limiting the hop count, address range, etc.?

One solution is the "extensions" field in the latest draft of AODV could potentially provide a means to expand upon the protocol in the future if neccessary.  
http://moment.cs.ucsb.edu/pub/draft-perkins-manet-aodvbis-00.txt

-----Original Message-----
From: Jitesh Shah [mailto:[email-masked]]
Sent: Thursday, November 13, 2003 7:36 AM
To: [email-masked]; [email-masked]
Subject: RE: [manet] AODV Question

Hi,

It depends on how you see the network. If you are
refering to a network which has a CHAIN topology then
the byte used for RREP and RREQ might be way
insignificant. But when you refer to a well connected
network then the byte seems sufficient.

Rgds
Jitesh

 --- Robert Cain <[email-masked]> wrote: >
Connectivity is the number of other nodes each node
> can reach with 1 hop.
> Therefore a connectivity of 10 means there is 10
> nodes that a can reach
> directly. Obviously in an actual network this would
> vary from node to node.
> 
> 
> Rob Cain :-)
> 
> 
> >What does the connectivity parameter specify?  Is
> it saying in 100,000
> nodes only 10 nodes would be connected?
> >
> >-----Original Message-----
> >From: Robert Cain [mailto:[email-masked]]
> >Sent: Wednesday, November 12, 2003 11:13 AM
> >To: DANIEL BYRNE
> >Subject: Re: [manet] AODV Question
> >
> >
> >1 byte seems OK to me.
> >
> >With some simple analysis assuming a circular
> homogeneous network of node
> >count K and a reasonable connectivity C then the
> radius of the network in
> >hops can be derived to be the square root of K/C.
> Which for a network size
> >of 100,000 and a connectivity of 10 gives a hop
> count radius of 100.
> Seeing
> >as a network of size 100,000 will be probably at
> practical limits of size
> >due to performance degradation then I think 1 byte
> may well be enough.
> >
> >hope that helps :-)
> >
> >Rob Cain
> >
> >>if the 
> >>
> >>"AODV routing protocol is designed for mobile ad
> hoc networks
> >>   with populations of tens to thousands of mobile
> nodes"
> >>
> >>why is the HopCount limited to only a BYTE?  This
> effectively limits the
> >number of hops to 255.  Why not expand the hop
> count to two bytes into the
> >reseved region of the RREQ packet.  Something
> similar could be done with
> >the RREP packet as well.
> >>
> >>
> >>_______________________________________________
> >>manet mailing list
> >>[email-masked]
> >>https://www1.ietf.org/mailman/listinfo/manet
> >>
> >
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet 

________________________________________________________________________
Yahoo! India Mobile: Download the latest polyphonic ringtones.
Go to http://in.mobile.yahoo.com

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Jitesh Shah <[email-masked]>
Date: Fri, 14 Nov 2003 04:25:31 +0000 (GMT)

Hi Daniel,

I completely agree with you when you suggest that one
must take care of the future needs when we are in the
development stage. 

We might have to face a situation in the real life
when we might actually need more than a byte. The
things being in development stage, I believe perhaps
this is the right time to incorporate the changes
rather than evolving with AODV 1.1 at a later stage
:-)

Rgds
Jitesh

 --- DANIEL BYRNE <[email-masked]> wrote: >
Agreed.  A branched chain configuration would be
> difficult to support with only a BYTE. My point is
> that although most everyone involved in development
> and testing of this protocol have envisioned a
> 'cluster of connected nodes' arrangement, the
> reality is the sum total of all possible topolgies
> in a wireless network of this type is potentially
> limitless.  Limited in effect by only the range of
> the radios in the network.  How are we to know how
> some future person or organization will use this
> protocol?  Will they need the extra BYTE?  Should we
> place artificial limits on the protocol by
> purposefully limiting the hop count, address range,
> etc.?
> 
> One solution is the "extensions" field in the latest
> draft of AODV could potentially provide a means to
> expand upon the protocol in the future if
> neccessary.  
>

---

From: Manel Guerrero <[email-masked]>
Date: Fri, 14 Nov 2003 11:22:42 +0100

Hello everybody,

I tried to ignore this thread from the beginning because I have better 
things to do. But now I cannot help it. ;)

1) IPv4 headers have a 8-bit field called TTL (Time To Live).
("TTL (time to live): each router must decrement by 1 and discard if 
zero. Also decrement if router holds for longer than 1 sec.")

2) IPv6 headers have a 8-bit field called Hop Limit.
("hop limit (8 bit): Decremented by one by each node that forwards the 
packet. When the hop limit field reaches zero, the packet is discarded.")

3) AODV is a UDP protocol. So The AODV message goes wrapped in an IP 
header. Even if AODV message would have a bigger hop count, the IP 
packet has only a 8-bit field. Therefore, it will die after the 255 hops.

4) Point number 3 is not a big problem since I have seen some AODV 
implementations that reset IP's TTL or Hop Limit to 255 at each hop. 
Anyway, once the route is constructed, when you would send the data, the 
IP packets would die before reaching the final destination. (Yep, at the 
255 hops :) ) (And there is no much point in to constructing a route 
that cannot be used ;) ).

Regards,

	Manel Guerrero Zapata

P.D.: This is my new email address. The previous one:
([email-masked]) does not work anymore.

Jitesh Shah wrote:
>>>directly. Obviously in an actual network this
>>
>>would
>>
>>>vary from node to node.
>>>
>>>
>>>Rob Cain :-)
>>>
>>>
>>>
>>>>due to performance degradation then I think 1
>>
>>byte
>>
>>>may well be enough.
>>>
>>>>hope that helps :-)
>>>>
>>>>Rob Cain
>>>>
>>>>
>>>>>if the 
>>>>>
>>>>>  with populations of tens to thousands of
>>
>>mobile
>>
>>>nodes"
>>>
>>>>>why is the HopCount limited to only a BYTE? 
>>
>>This
>>
>>>effectively limits the
>>>

---

From: Erik Nordström <[email-masked]>
Date: Fri, 14 Nov 2003 11:40:56 +0100

Why would anyone want to flood an ad hoc 255 hops away? Maybe an even
more important question is, would that route be usable? I think not...
Only extremely large ad hoc networks would have a radius of 255 hops
unless they are very stretched out. Besides, as people have already
pointed out, the IP ttl is already an 8-bit field.

cheers,

Erik

---

From: Einar Vollset <[email-masked]>
Date: Fri, 14 Nov 2003 11:07:47 +0000

See now I can't help myself either ;-)

On Friday, Nov 14, 2003, at 10:40 Europe/London, Erik Nordström wrote:

> Why would anyone want to flood an ad hoc 255 hops away?

I presume you mean why would anyone want to communicate with a node
255 hops away.
I don't think it is in the realm of science fiction to envisage much 
larger networks
using MANET technology (such as those envisaged in pervasive or 
ubiquitous
computing scenarios).
I know you disagree on this by the way as I was there for the 
presentation of
your very good paper at PWC arguing this point*.
However, it can be argued that the uses of ad hoc networking technology 
can be
envisaged to extend beyond the current focus of extending the reach of 
base
stations and for use in laptops and PDAs. There is an argument (which I 
hear
_alot_ from non-MANET people) which goes, why try to do this, surely 
soon
the world will be one big hotspot?

*
C. Tschudin, H. Lundgren, E. Nordström,
"Embedding MANETs in the Real World",
PWC 2003, Venice ITALY

> Maybe an even

On the above we totally agree.

Cheers,

Einar

----------------------------------------
Einar Vollset
PhD Student
School of Computing Science
University of Newcastle, UK
http://vollset.org
-----------------------------------------

---

From: Erik Nordström <[email-masked]>
Date: Fri, 14 Nov 2003 12:19:27 +0100

> using MANET technology (such as those envisaged in pervasive or 

Then the question would be whether you would use AODV in such a scenario
or some specialized protocol? If we are assuming science fiction
scenarios, can't we also assume that there will be some science fiction
technology available at that time that works much better than today's
AODV would?

I think it is hard enough to design for a 100 node network...

BR

Erik