Subject: RE: [manet] OSPF extensions for manets

From: Theodoros Salonidis <[email-masked]>
Date: Tue, 11 Nov 2003 21:15:15 -0500 (EST)

Dear Manet-OSPF work group,

Extending OSPF to MANETs is an attractive
idea for several reasons. However (for an equal
number of reasons :-) ) I was wondering what MANET
sizes or mobility scenarios could be supported
by a link state protocol.

Is there a desired MANET environment or application
towards which this effort is geared?
Or is it because it may become easier to be globally
adopted, being a wireless extension of an existing standard?

 Regards,

    Theodoros

--------------------------------------------------
Theodoros Salonidis
Ph.D. Candidate

Institute of Systems Research &
Dept. of Electrical and Computer Engineering
University of Maryland, College Park
3187 A.V. Williams Bldg.
College Park, MD  20742

(301) 405-2942
[email-masked]
http://www.ece.umd.edu/~thsalon
---------------------------------------------------------

On Mon, 10 Nov 2003, Joe Macker wrote:

> At 01:16 PM 11/10/2003, Henderson, Thomas R wrote:
> >Richard,
> >Thanks for your comments and list of issues.  As I mentioned to
> >you previously, I agree that some of these technical choices
> >need to be discussed further, once the IETF decides whether
> >or not this becomes a work effort.  Hopefully there will be
> >strong support for the problem statement that will be presented
> >at the OSPF and MANET WGs this week, and we can then focus on
> >the particulars of the solution via a design team.
>
> We will have time for presentations and issues at the meeting.
> The main goal, however, is to determine if the problem statement can be used
> to move forward with a design team approach.  This is one possible way
> forward for some of the proactive "lessons learned" to transition.
>
> Of course, there are new issues too.
>
> -Joe
>
> >Tom
> >
> >> -----Original Message-----
> >> From: Richard Ogier [mailto:[email-masked]]
> >> Sent: Sunday, November 09, 2003 10:00 PM
> >> To: [email-masked]
> >> Cc: [email-masked]
> >> Subject: [manet] OSPF extensions for manets
> >>
> >>
> >> I would like to offer some comments on:
> >>
> >> draft-spagnolo-manet-ospf-wireless-interface-00.txt
> >>
> >> and to compare it with the solution in
> >>
> >> http://www.erg.sri.com/projects/tbrpf/docs/draft-ogier-manet-o
> >> spf-extension-00.txt
> >>
> >...
> >
> >_______________________________________________
> >manet mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/manet
>
>
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
>

--------------------------------------------------
Theodoros Salonidis
Ph.D. Candidate

Institute of Systems Research &
Dept. of Electrical and Computer Engineering
University of Maryland, College Park
3187 A.V. Williams Bldg.
College Park, MD  20742

(301) 405-2942
[email-masked]
http://www.ece.umd.edu/~thsalon
---------------------------------------------------------

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Richard Ogier <[email-masked]>
Date: Tue, 11 Nov 2003 21:42:27 -0800

I have some comments on the strategy of the working group.
On Thursday, Thomas Henderson will discuss an initial solution to the
problem of extending OSPF, using MPRs and unreliable flooding.
As he has said, this is only an initial solution that needs work,
and other solutions will also be considered.

There is clearly no consensus on whether the OSPF extension should
use MPRs or a CDS, and on whether it should use reliable flooding.
This is indicated in Fred Baker's slides, where he uses the term
"overlapping relays" instead of CDS, and where he discusses the
problems with unreliable flooding.

However, the draft by Henderson et al. describes an extension that
uses MPRs and unreliable, periodic flooding (even though he claims
that future versions may use reliable flooding).
Therefore, since the draft describes a protocol that does not
agree with working group consensus, it would make no sense to
accept the draft as is.

We first need to agree on the general design of the protocol, e.g.,
should it use a CDS or MPRS?  Should it use reliable flooding?

One argument I heard was that the draft should be considered
as an initial solution because it has been implemented.  I don't
think that is important at this early stage, when the problem
statement has just been announced and we haven't even agreed on
what the protocol should look like.
Having an implementation is irrelevant if the protocol does not
have consensus of the working group.

Besides, this is apparently a recent implementation, so another
extension could be implemented within a few months, and waiting
a few months is a small price to pay considering that people
will have to live with the resulting standard for many years.

But this brings up another issue.  How can we be sure that
the design team will make the right decisions, and will give
fair consideration to the alternative solutions proposed
by the working group?  I'm not saying the team will not give
fair consideration to alternative solutions, but there is no
guarantee that they will.

One answer to this is something that I have suggested before.
We should make it so that anyone who proposes an alternative
technique can run simulations (or have someone else run simulations)
to determine how their technique affects performance on an agreed
set of scenarios (such as the ones being developed by the ANS
research group).  This is not research, but a selection process
to help decide between alternative designs. (Of course, performance
is not the only criteria, but is an important one.)

In addition, it would be good to have an arbitrator, someone who
everyone agrees would be fair and unbiased.  I think Fred Baker would
be a good choice, since he is giving fair consideration to alternative
solutions, and has not been involved in the MANET fighting of the past.

Regards,
Richard

---

From: "HyunWook Cha" <[email-masked]>
Date: Wed, 12 Nov 2003 09:10:27 -0600

Hello, folks.

Yeah, I also want to know that.
Is there anybody who can tell why these approaches should be dealt with
high priority? 
I think that many people may have same curiosity. Please, answer before
forwarding.
Thanks in advance.

HyunWook Cha

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Theodoros Salonidis
> Sent: Tuesday, November 11, 2003 8:15 PM
> To: [email-masked]
> Subject: RE: [manet] OSPF extensions for manets
> 
> 
> 
>

---

From: "Philippe Jacquet" <[email-masked]>
Date: Wed, 12 Nov 2003 18:00:35 +0100

Dear Richard,

I don't think there is any conceptual conflict between MPR, CDS and
overlapping relays. To be short MPR is a practical implementation of CDS.
Since it is now mature enough, it is proposed in a draft for a wireless
extension of OSPF. MPRs contain nice features that have been added by the
working group during the past years such as "willingness to forward"
parameter, adaptability to link qualities, possibility of drastic reduction
of advertized link set size, etc. However they are certainly not yet
absolutely optimal, since optimal CDS selection is an NP hard problem. If
you give me a polynomial algorithm that select a good CDS, I will find
another polynomial algorithm that select a better CDS;-)  However, MPRs have
shown acceptable performance so far that we did not find practical
algorithms that significantly outperform it.

Best regards,
Philippe

---

From: Joe Macker <[email-masked]>
Date: Wed, 12 Nov 2003 13:02:57 -0500

>by a link state protocol.

First off, it is not my belief that extending OSPF with a MANET
interface and other optimizations is the only MANET solution
that is needed.  At the last few meetings there seemed
to be rough consensus on proceeding forward with a proactive
and a reactive track.  This is a POSSIBLE AREA for proactive
"lessons learned" to transition.  In fact, its already happening.
There is energy here from a vendor and previous author community
to we are pursuing discussion.

MANET-like optimizations (e.g., flooding improvements)
will provide some scaling improvements intraarea.
Mobility support will be improved by allowing peer areas to be
larger 

The MANET-like wireless interface is needed. I don't think there
is much question of that.

>adopted, being a wireless extension of an existing standard?

In my opinion, there are a number of pragmatic hybrid wireless
networks where this would apply.  
OSPF has some clear advantages there..

Once again, I think it may only address moderate mobility initially
but may help address more heterogeneous environment
and improve MANET-like support in backbone wireless networks..

In my PDA, I would prefer to run something lighterweight ;-)

I think your second observation is also true to a degree.
I have heard vendor feedback to that tune.

---

From: Joe Macker <[email-masked]>
Date: Wed, 12 Nov 2003 15:42:10 -0500

>agree with working group consensus, it would make no sense to

There is no intention to considering accepting WG design documents immediately.
This should be considered an informational presentation of a prototype 
implementation not a design recommendation for the WG.

We need problem statement acceptance. If any decisions are made
that is the area we need consensus on first.   despite the fact that there are multiple ways 
to solve a problem..is there enough on the table to begin an engineering effort?
does it meet a need? if accepted where and how can we work the problem?

Most people discussing this have been raising similar open design issues that need some 
addressing during a design process.  That is clear.
I don't see much disagreement among the parties in that regard. 
 
Can I read into your design enthusiasm that you support the problem statement?