Subject: [manet] I have a few of questions about the energy consumption of IEEE 802.11.

From: Hang Su <[email-masked]>
Date: Sun, 2 Nov 2003 21:05:59 +0800

Hi all,

Firstly,
In the paper

Laura Marie Feeney, Martin Nilsson
"Investigating the Energy Consumption of a Wireless Network Interface in an
Ad Hoc Networking Environment (2001)"
IEEE Infocom 2001

The Lucent IEEE802.11 2Mbps WaveLAN PC Card power consumption characters is measured as
follow, Idle power : 843mW , Receive power : 967mW , Transmit power : 1327mW.

>From the above, we can see the Idle power is close to the receive power.
The live time of a node is greatly depend on the idle power.
Assume the node initial energy is 1000W*s and there are two node.
One always receives data and the other never.
Then the one that always receives dies after 1000 / 843e-3 = 1186(s).
and the one that never receives dies after 1000 / 967e-3 = 1034 (s).
The tow nodes did at the almost same time.

So in the IEEE 802.11, the energy consumption of the promiscuous receive mode and 
the discard mode is almost the same. 

Is the above analysis right?

Secondly,
And I have another question why the idle power is so great.
If I do some simulation about the energy consumption, can I set the idle power to zero?

Thanks in advance.

-- 

Hang Su.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: John Stine <[email-masked]>
Date: Sun, 02 Nov 2003 11:18:21 -0500

Hang Su,

The observation below was empirical of a single device and was not the result of employing
any of the energy conservation protocols that are part of the 802.11 MAC.  This
observations says that when a node is in the receive state in anticipation of receiving a
packet it will consume more energy than when it is in the receive state and can drop a
packet because it knows the packet is not destined for itself.  The fact the node does not
process the packet conserves energy.  However, 802.11 devices have even greater energy
conserving states where they consume about 5-10% the energy they consume while in the
full-up receive state.  The challenge in using these latter protocols is that they result
in  nodes being unaware of what is going on in the network.  If feasible, entering a doze
state could result in significant savings.

In my judgement, the interesting part of this observation has more to do with transition
time.  A challenge in using low energy states is that it can take a long time to enter and
then to leave those states.  This transition from full-up receive and receive without
packet processing seemed nearly instantaneous as opposed to tens to hundreds of
milliseconds.  Perhaps in future 802.11 modems, additional low energy states, perhaps at
30-60% of the receive state power, with faster transition times (tens of microseconds) will
be made available.

John

---

From: Hang Su <[email-masked]>
Date: Mon, 3 Nov 2003 13:32:23 +0800

Hi John Stine,

In the paper,
Juan Carlos Cano and Pietro Manzoni, 
"Evaluating the energyconsumption reduction in a MANET by dynamically switching-off network interfaces,"
Proceedings of the 6th IEEE Symposium on Computers and Communications, Hammamet, Tunisia, July 2001.

the idle power mode current which is used to do the simulation is set to 15mA.
That is to say the power consumption is 15 * 5 = 75(mW) in the idle mode.
While the power consumption is 178 * 5 = 890(mW) in the L.M. Feeney's paper.
Why the distinction between the two papers is so sharp.

Regards,

---
Hang Su

On Sun, 02 Nov 2003 11:18:21 -0500

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 3 Nov 2003 01:20:32 -0500 (EST)

Hi Hang,

These numbers appear to be (relatively) consistent with other published 
data. Of course, there is also the "sleep" mode, in which the power 
consumption is significantly reduced. For example, see the following
reference on how to use this feature to increase the node lifetime:

	M.R. Pearlman, J. Deng, B. Liang, Z.J. Haas, ``Elective Participation
	in Ad Hoc Networks Based on Energy Consumption,'' IEEE GLOBECOM 2002, 
	Taipei, Taiwan, November 17-21, 2002

(you can download the paper from http://wnl.ece.cornell.edu/wnlprojects.html). 

Best,

ZYgmunt.
==-=-=====
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-
Prof. Zygmunt J. Haas                    http://people.ece.cornell.edu/haas 
Wireless Networks Laboratory		 http://wnl.ece.cornell.edu
School of Electrical Engineering         
Cornell University			 tel: +1-607-255-3454
323 Frank Rhodes Hall			 fax: +1-607-255-9072
Ithaca, NY 14853			 e-mail: [email-masked]
U.S.A                             
	WNL web page: http://wnl.ece.cornell.edu
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-

---

From: "J.Carlos Cano" <[email-masked]>
Date: Mon, 3 Nov 2003 12:15:07 +0100

Hi,

In the first page of the paper "Evaluating the energy consumption
reduction ..." when we present the energy consumption of the ORINOCO
Card. We said idle when we wanted to say sleep.

Bye.

-----Mensaje original-----
De: [email-masked] [mailto:[email-masked]] En nombre de Hang
Su
Enviado el: lunes, 03 de noviembre de 2003 6:32
Para: John Stine
CC: [email-masked]
Asunto: Re: [manet] I have a few of questions about the energy
consumption of IEEE802.11.

Hi John Stine,

In the paper,
Juan Carlos Cano and Pietro Manzoni, 
"Evaluating the energyconsumption reduction in a MANET by dynamically
switching-off network interfaces,"
Proceedings of the 6th IEEE Symposium on Computers and Communications,
Hammamet, Tunisia, July 2001.

the idle power mode current which is used to do the simulation is set to
15mA.
That is to say the power consumption is 15 * 5 = 75(mW) in the idle
mode.
While the power consumption is 178 * 5 = 890(mW) in the L.M. Feeney's
paper.
Why the distinction between the two papers is so sharp.

Regards,

---
Hang Su

---

From: John Stine <[email-masked]>
Date: Mon, 03 Nov 2003 07:06:49 -0500

Those numbers are consistent with what I said.  The idle power mentioned in this paper is the energy
conservation state provided by the card they used.  Feeney's observation of a card using less energy when it
does not process a packet was not using this low energy state.  The energy conservation was a result of not
processing the packet.  The node was still sensing the channel and participating in the network.

John

---

From: Hang Su <[email-masked]>
Date: Mon, 3 Nov 2003 20:35:20 +0800

Hi ,

Here you said the "idle" equaled to "sleep". So when a node did not send a 
packet or receive a packet, which state did it work at, idle(890mW), or 
sleep(75mW) ?

Another question.
In your paper "Evaluating the energy consumption
reduction ...", you did the simulation without considering 
the idle power.
you said ``In this work we asssume that the idle status is energy free,
 - as well the evaluated MANET protocols will have similar energy cosumption.''
(in the paper p.188).
That is to say the node in your simulation only had two states ,tran. or recv..
The question is when the node work in idle mode, and when in sleep mode.

Regards,

Hang Su
-----

On Mon, 3 Nov 2003 12:15:07 +0100

---

From: Peter Pham <[email-masked]>
Date: Tue, 04 Nov 2003 10:47:12 +1030

Hi all

I have the following question and really appreaciate any feedback.

I am interested to know how much power we save when we reduce the 
transmission range of the sender. That is the power that drives the 
transmitter. Let say we used P1 for the transmission of range R1(250 m 
for WLAN). If I reduce the transmission range to R2 (R2<R1) how much 
power I will save ?. How can I express P2 as a function of P1 and the 
two transmission range, packet length..etc...Is there any model that I 
can use.

Thanks

Peter Pham

---

From: Justin Lipman <[email-masked]>
Date: Tue, 4 Nov 2003 11:26:59 +1100

Hi Peter,

I sent you a model a few weeks back...

In my papers I always use a simple first order radio model:

E_tx (k,d) = E_elec * k + E_amp * k * d^2
E_rx (k) = E_elec * k

where

E_elec = 50 nJ/bit
E_amp = 100 pJ/(bit*m^2)

as described in:

Wendi Rabiner Heinzelman and Anantha Chandrakasan and Hari Balakrishnan, 
"Energy-Efficient Communication Protocol for Wireless Microsensor Networks",
Proceedings of the Hawaii International Conference on System Sciences, 2000.

Hope this helps,
Justin

- 
PhD Candidate
Telecommunications & Information Technology Research Institute
School of Computer, Electrical & Telecommunications Engineering
University of Wollongong, Australia 
http://www.titr.uow.edu.au/~justin

> two transmission range, packet length..etc...Is there any model that I

-

---

From: Peter Pham <[email-masked]>
Date: Tue, 04 Nov 2003 16:30:23 +1030

Hi Justin
Thanks for the info. I really appreaciate this.
However, it is questionable whether the model is close to the reality. 
In some other paper, in the receiving mode and idle mode, the node 
spends the same amount of energy approximately no matter whether it 
actually receives the data or not.
Furthermore, it does not model the fact that for a sent packet every 
node around the sending station in a certain range will  ``hear'' the 
packet thus will consume energy.
Cheers
Peter Pham

---

From: Justin Lipman <[email-masked]>
Date: Tue, 4 Nov 2003 20:22:10 +1100

Hi Peter,

> actually receives the data or not.

If you consider Feeny's measurements.
Idle power : 843mW , Receive power : 967mW , Transmit power : 1327mW.

The model could probably be adapted to encorporate these values including idle 
time etc.  However, Im pretty sure Feeny's paper has some linear models of 
consumption, does it not? I also think that differences between idle, receive 
and transmit power consumption are important when one considers the total 
number of packets sent and received by all nodes. Thus I think the validity 
of the model really depends on how you intend to use and interpret the 
results.

One more point, since I know you are looking at power saving schemes for ad 
hoc networks. Perhaps you should look at something along the lines of 
Activity Scheduling as described in:

J. Shaikh, J. Solano, I. Stojmenovic and J. Wu, New metrics for dominating set 
based energy efficient activity scheduling in ad hoc networks, Proc. WLN 
Workshop at IEEE Conf. on Local Computer Networks, Bonn, Germany, Oct. 20-24, 
2003.

It would be very interesting to find out the differences between idle, receive 
and transmit in newer 802.11 cards.

> packet thus will consume energy.

Yes it does. If you want to model the energy consumed by a broadcast, then 
every node upon receiving a k-bit frame should adjust its available energy by 
E_rx(k). Likewise the transmitting node should adjust its remaining energy by 
E_tx(k,d). It just does not account for idle energy over time. 

cheerio,
Justin

> >"Energy-Efficient Communication Protocol for Wireless Microsensor
> > Networks", Proceedings of the Hawaii International Conference on System
> > Sciences, 2000.
> >
> >Hope this helps,
> >Justin
> >
> >-
> >PhD Candidate

---

From: John Stine <[email-masked]>
Date: Tue, 04 Nov 2003 05:59:43 -0500

I believe it is important to realize that Feeney did not measure the energy
consumed in an idle state but observed that an active node that does not process
an arriving packet consumes less energy than a node that tries to process an
incoming packet.  The paradox here is that a node will consume more energy when
there are no packets being sent.  This conservation occurs only after discerning
that an incoming packet is not intended for a node.  The node is still very much
active not idle.  This energy conservation is not part of any protocol and occurs
simply because the incoming packet is not processed.  There is nothing to study
here.  Meanwhile, 802.11 devices have doze states that consume significantly less
energy than that specified below which can be controlled by protocols so energy
can be conserved when no one is using the network.  Its power is usually in the
manufacturer's literature.  What is usually missing is the time to move in and out
of that state.  If these transition times are large, this state is hard to
exploit.

John