Subject: [manet] Need for DAD in Ad Hoc Networks

From: Sourabh Sharma <[email-masked]>
Date: Mon, 03 Nov 2003 08:45:55 +0800 (SGT)

Dear All,

 I would like some authoritative answers on this.

 Since IPv6 Autoconf scheme uses 48 bit MACID for autconfiguration
 of IPaddress - DAD is proposed due to the following reasons:
 -  MAC Ids are designed to be unique but are not gauranteed.
 -  Some users/ devices may use random MAC IDs -->might lead to duplicates

 My argument for Not using DAD in Ad hoc networks is as follows:

 - Finding a node within an ad hoc network with the same MACID has
    a very low probability
 - Finding a node within an ad hoc network with the same MACID + SubNET ID
   has an even lower probability.
   In case of Small ad hoc networks - this probability can be safely
   assumed to be zero.

  Thus, in case of using DSR ( where it is assumed that nw_diameter is
  small --> especially in the case of IPv6 where each IP address in the
  source route is 32 bytes, the network cannot support more than 5-7
   hops.) we can say that not using DAD will not cause any problems.

 Please let me know of your opinion on this.

 Regards,
 Sourabh Sharma
 I2R, Singapore

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 4 Nov 2003 10:50:10 +0900

Hi Sourabh,

Like your opinion, in IPv6, address duplication hardly happens, especially on the basis of EUI-64 format.
However, we need some ways to detect address duplication in order to prevent routing problem 
due to address conflict.
For examples, there are Weak-DAD and Passive-DAD etc.
You can also refer to my draft;
  http://www.ietf.org/internet-drafts/draft-jeong-adhoc-ip-addr-autoconf-01.txt

About IPv6 link-local address, the current DAD, Strong-DAD within one-hop, can not guarantee
the uniqueness of the address when DAD is successful but address duplication happens due to MANET mergence.
Of course, when link-local address is based on EUI-64, the duplication probability is very low.
IMHO, in MANET having dynamic topology, IPv6 link-local addess also seems useless.

Regards,
Paul

----- Original Message ----- 
From: "Sourabh Sharma" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, November 03, 2003 9:45 AM
Subject: [manet] Need for DAD in Ad Hoc Networks

> &jw™¨¥Šx%ŠËfjw‰ë_¢¸!¶Úlÿü0ÃXžµú+ƒùšŠYšŸùb²Ø§~æjw