Subject: Re: [manet] Question on 802.11DCF

From: Luigi Iannone <[email-masked]>
Date: Tue, 11 Nov 2003 19:00:05 +0100 (CET)

> Message: 4
> Date: Tue, 11 Nov 2003 12:35:54 -0500
> From: bjkwak <[email-masked]>
> Organization: NIST, MD
> To: [email-masked]
> CC: Dong Zheng <[email-masked]>
> Subject: Re: [manet] Question on 802.11DCF
>

I think you  did a nice job in your description, though I have a remaining
doubt:
In the first case of the switch I'm not sure the packet is
transmitted right away. I think a backoff is done.
Ciao
                    Luigi

> STA A Tx a packet;
> STA A receives an ACK;
> STA A waits for DIFS;
> STA A choose a random number for backoff and counts down to zero;
> If (STA A has a packet in the queue)
>   then
>     STA A Tx the packet;
>   else
>     STA A waits until a packet arrives;
>     switch (channel idle time)
>         case (the channel has been idle for more than DIFS):
>           STA A Tx the packet right away;
>         case (the channel has been idle for T_idle < DIFS):
>           STA A waits for DIFS - T_idle;
>           STA A enters a normal backoff procedure;
>         case (the channel is busy)
>           STA A waits until the channel becomes idle;
>           STA A waits DIFS;
>           STA A enters a normal backoff procedure;
>     endswitch
> endif
>
------------------------>>>>>>>>
Luigi Iannone -  Laboratoire D'Informatique Paris 6
   e.mail:       [email-masked]
   Tel:          +33 (0)1 44 27 71 28

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: bjkwak <[email-masked]>
Date: Tue, 11 Nov 2003 15:55:56 -0500

> I think you  did a nice job in your description, though I have a remaining

Thanks :)

> transmitted right away. I think a backoff is done.

Please read Section 9.2.5.1 Basic access of the standard
and figure 51 therein.

Thanks!

Byung-Jae Kwak

-- 
 Anyone can be passionate,
 but it takes real lovers to be silly.  - Rose Franklin