Subject: [manet] Simulating 802.11b and g

From: Emmanuel Agu <[email-masked]>
Date: Mon, 17 Nov 2003 13:42:33 -0500 (EST)

Hi everyone,

>From what I understand, NS simulates
802.11 using 2mbps, based on an old Lucent
WaveLAN card. A lot of recent papers
have used these values. Are there newer
NS implementations (versions) that simulate
11 mbps or 54 mbps, which is more realistic
for today's cards? If NS does not support
the newer speeds, does anyone have more
up-to-date NS 802.11 implementations?

Thanks in advance for any information.

Emmanuel Agu

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "#LI ZHIFEI#" <[email-masked]>
Date: Mon, 24 Nov 2003 13:33:20 +0800

Hi, frank

Here is my answer to your question though my answer is definitely not 'autoritative' as you are looking for :):

Whenever the received power of a frame is above the CS threshold and the channel is sensed as busy,
whether or not the PLCP header of that frame can be received correctly depends on how large the carrier sensing energy
threshold is. If the threshold is large enough, the PLCP header can always be interpreted.  Otherwise, there is some possibility that the PLCP is un-interpretable. However, since
the PLCP header is very short and is always transmitted in the lowest rate,  the probability that the PLCP header is interpretable should be very large. This is especially true if the wireless card developers follow the recommented value of the threshold in the standard. 

I hope this will help.

Best regards
Li zhifei

Let me repeat the same question in my previous mail. Assume the received power is just above the CS threshold and the channel is sensed as busy. Does this mean that the PHY header (PMD/PLCP) can be correctly decoded but not the MPDU, or even the PHY header itself can NOT be decoded? Can anyone give me an 'authoritative' answer to this point? Thanks.

Frank

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Frank Li
Sent: dimarts, 18 / novembre / 2003 20:10
To: Claude Chaudet
Cc: [email-masked]
Subject: RE: [manet] Simulating 802.11b and g

Hi Claude, 

I guess you are using two-ray model with 'receiver sensitivity' -83 dBm and Tx power 15 dBm to get the following CS threshold.

Phy/WirelessPhy set CSThresh_ 5.011872e-12

My question is - is it sensible to use 'receiver sensitivity' to calculate CS threshold? (Using the same calculation for -94 dBm at 1 Mbps, the sensing range will be 796 m).
Furthermore, does the CS threshold mean that the PHY header can be correctly decoded if received power is above the threshold, or the channel is sensed as busy but the PHY header can NOT be decoded? 

BTW, CPThresh is the capture threshold, not required SNR to 'understand' the frame. When multiple frames are detected, the frame with strongest power (CPThresh>10) will be decoded, otherwise, all frames are discarded. 

BR
Frank

-----Original Message-----
From: Claude Chaudet [mailto:[email-masked]]
Sent: 18. november 2003 10:59
To: Emmanuel Agu
Cc: [email-masked]
Subject: Re: [manet] Simulating 802.11b and g

Hello,

That's true, NS (at least version 2.26) simulates 2Mbps 802.11.

Nevertheless, you can change this by simply putting in your script the 
following lines :
	Mac/802_11 set bandwidth_   11e6
	Mac/802_11 set dataRate_      11e6
	Mac/802_11 set basicRate_     2e6

This only changes the rate at which data is sent. This can be useful 
for simulating
802.11b protocol, for which only the physical layer changes. But 
simulating 802.11a
will need at least some timings modifications in the mac/mac-802_11.* 
files.

Concerning the physical layer parameters, I tried to update some 
parameters based on the
specification of an Avaya card. Nevertheless, being no expert in 
physical layers, I cannot
guarantee this will be the exact parameters.
Here they are :
	Phy/WirelessPhy set CPThresh_ 10.0
	Phy/WirelessPhy set CSThresh_ 5.011872e-12
	Phy/WirelessPhy set RXThresh_ 1.15209e-10
	Phy/WirelessPhy set Rb_ 11e6
	Phy/WirelessPhy set bandwidth_ 11e6
	Phy/WirelessPhy set Pt_ 0.031622777
	Phy/WirelessPhy set freq_ 2457e+6
	Phy/WirelessPhy set L_ 1.0

Concerning this, I wondered if anyone on this list could provide good 
values once
and for all, so that we can use ns, opnet and any other simulator on 
the same basis.
I am especially interested in the CPThresh parameter, i.e. the signal 
over noise
ratio (in dB) required to understand a frame. I found no value in any 
NIC specification.
I suppose it depends on the physical layer. 10 dB was used for early 
802.11, is it still
the good value for newer ones ?

Claude Chaudet.

---

From: "Frank Li" <[email-masked]>
Date: Mon, 24 Nov 2003 14:40:36 +0100

Hi Zhifei,

I think you are talking about the PMD_ED and PMD_CS thresholds in the standard. Is it always 
true that PMD_CS < PMD_ED? Do you know the concrete values of PMD_CS and PMD_ED thresholds for any wlan card? Furthermore, is it correct to use 'receiver sensitivity' to calculate sensing range? 

Frank

-----Original Message-----
From: #LI ZHIFEI# [mailto:[email-masked]]
Sent: 24. november 2003 06:33
To: Frank Li; [email-masked]
Subject: RE: [manet] Simulating 802.11b and g

Hi, frank

I hope this will help.

Best regards
Li zhifei

Frank

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Frank Li
Sent: dimarts, 18 / novembre / 2003 20:10
To: Claude Chaudet
Cc: [email-masked]
Subject: RE: [manet] Simulating 802.11b and g

Hi Claude, 

BR
Frank

-----Original Message-----
From: Claude Chaudet [mailto:[email-masked]]
Sent: 18. november 2003 10:59
To: Emmanuel Agu
Cc: [email-masked]
Subject: Re: [manet] Simulating 802.11b and g

Hello,

Claude Chaudet.

---

From: "#LI ZHIFEI#" <[email-masked]>
Date: Tue, 25 Nov 2003 13:12:09 +0800

Hi, Frank

>>>I think you are talking about the PMD_ED and PMD_CS thresholds in the standard. 

Yes, I refer to that.

>>> Is it always true that PMD_CS < PMD_ED? Do you know the concrete values of PMD_CS and PMD_ED thresholds for any wlan card?

I am not familar with the parameters used in practical  WLAN cards. However, for the standard itself, the condition PMD_CS < PMD_ED should be true, at least for IEEE 802.11a where
the PMD_ED is 20 DB greater than PMD_CS.

>>>Furthermore, is it correct to use 'receiver sensitivity' to calculate sensing range? 
I think the receiver-sensitivity is used to calculate the transmission range, while the CCA sensitivity (or CS threshold) is used to calculate the sensing range.

Please point out if I made any mistakes.

Best regards
Li zhifei

-----Original Message-----
From: Frank Li [mailto:[email-masked]]
Sent: dilluns, 24 / novembre / 2003 21:41
To: #LI ZHIFEI#
Cc: [email-masked]
Subject: RE: [manet] Simulating 802.11b and g

Hi Zhifei,

Frank

-----Original Message-----
From: #LI ZHIFEI# [mailto:[email-masked]]
Sent: 24. november 2003 06:33
To: Frank Li; [email-masked]
Subject: RE: [manet] Simulating 802.11b and g

Hi, frank

I hope this will help.

Best regards
Li zhifei

Frank

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Frank Li
Sent: dimarts, 18 / novembre / 2003 20:10
To: Claude Chaudet
Cc: [email-masked]
Subject: RE: [manet] Simulating 802.11b and g

Hi Claude, 

BR
Frank

-----Original Message-----
From: Claude Chaudet [mailto:[email-masked]]
Sent: 18. november 2003 10:59
To: Emmanuel Agu
Cc: [email-masked]
Subject: Re: [manet] Simulating 802.11b and g

Hello,

Claude Chaudet.

---

From: "#LI ZHIFEI#" <[email-masked]>
Date: Thu, 27 Nov 2003 22:12:52 +0800

Hi, frank

Receive Sensitivity is how much energy a signal should be to allow a card receive it correctly with large probability. For more details, pls check at:
http://www.freenetworks.org/moin/index.cgi/ReceiveSensitivity

Therefore, I still think that Receive Sensitivity is roughly related to transmission range, while PMD_CS / PMD_ED is related to sensing range.

In fact, whether the PMD_ED or PMD_CS should be used as the threshold depends on the CCA mode (please see Page-58 in IEEE 802.11b-1999) being used.
The PMD_ED should be greater than PMD_CS because a non-DSSS signal (e.g., signal from micro-wave oven) has smaller interference to the IEEE 802.11.

If any confuse, pls point out.

Best regards
Li zhifei

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Frank Li
Sent: dijous, 27 / novembre / 2003 21:23
To: Mineo Takai
Cc: [email-masked]
Subject: Re: [manet] Simulating 802.11b and g

Hi Mineo,

>
> No, PMD_CS and PMD_ED do not correspond to CST and RXT in my paper. 
> CCA returns busy if the radio successfully received a signal preamble 
> whose power is more than or equal to PMD_CS. 

This is quite clear now. But does PMD_CS correspond to 
receriver-sensitivity in the card specification?

> If it did not receive a signal preamble, the threshold 

The threshold for sensing or PLCP decoding?

> is raised by 20 dB (PMD_ED) due to difficulty (or instability) of 
> detecting energy on the channel without synchronization. So, PMD_CS 
> and PMD_ED together correspond to CST.

So you mean the PLCP header can be correctly decoded if the received 
signal is strong enough, even though the bit sequence is not synchronized? 

>
> We are making our 802.11 model more detailed by replacing CST with 
> these two thresholds.
>  

Are there any papers/reports on your model? What is the relationship 
between CST and these two thresholds? Do you express CST as x*PMD_CS + 
y*PMD_ED?

Frank