Subject: [manet] AODV paquet

From: redouane <[email-masked]>
Date: Thu, 13 Nov 2003 20:29:44 +0100 (CET)

Hi

AODV use port UDP 654, I ask if AODV paquets are
encapsulated in IP paquet without any other data. Or
is possible to have other data (or other protocols
paquets) in the same IP paquet?

thanks

redouane

___________________________________________________________
Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Yahoo! Mail : http://fr.mail.yahoo.com

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Antti Tuominen <[email-masked]>
Date: Fri, 14 Nov 2003 12:47:04 +0200

> paquets) in the same IP paquet?

Hello Redouane,

No, you can't send any other data in the AODV control message packet.
UDP is a final protocol, and you can't put two final protocols in one
packet.  If you use something like the Hop-By-Hop flooding stuff,
mentioned in AODV for IPv6 draft, you can have any final protocol in
the packet.  There also is (or was?) a draft about including more than
one final protocol in one IP packet.

Regards,

Antti

---

From: Francis Dupont <[email-masked]>
Date: Fri, 14 Nov 2003 16:31:03 +0100

In your previous mail you wrote:

   the packet.

=> yes, there must be at most one final protocol (the no-next-header
is used when there is none).

   There also is (or was?) a draft about including more than
   one final protocol in one IP packet.
   
=> this draft was explicitly written to explain why
it was (and still is) a very bad idea.

Regards

[email-masked]