Subject: RE: [manet] AODV Question

From: "Robert Cain" <[email-masked]>
Date: Thu, 13 Nov 2003 20:12:48 +0000

I also agree, the single byte could well be inadequate for a chain
configured network which was carrying small amounts of data. 
However in such chain networks where hop counts are exceeding the limit set
by use of the byte then unless the network was unusually stable the routes
would be continually failing due to the high hop count. In such a network
AODV is not the best way to route packets. If the network was very stable
and resembled a fixed link network then perhaps something like OLSR would
be more appropriate than AODV.

Rob Cain

>Agreed.  A branched chain configuration would be difficult to support with
only a BYTE. My point is that although most everyone involved in
development and testing of this protocol have envisioned a 'cluster of
connected nodes' arrangement, the reality is the sum total of all possible
topolgies in a wireless network of this type is potentially limitless. 
Limited in effect by only the range of the radios in the network.  How are
we to know how some future person or organization will use this protocol? 
Will they need the extra BYTE?  Should we place artificial limits on the
protocol by purposefully limiting the hop count, address range, etc.?
>
>One solution is the "extensions" field in the latest draft of AODV could
potentially provide a means to expand upon the protocol in the future if
neccessary.  
>http://moment.cs.ucsb.edu/pub/draft-perkins-manet-aodvbis-00.txt
>
>
>
>-----Original Message-----
>From: Jitesh Shah [mailto:[email-masked]]
>Sent: Thursday, November 13, 2003 7:36 AM
>To: [email-masked]; [email-masked]
>Subject: RE: [manet] AODV Question
>
>
>Hi,
>
>It depends on how you see the network. If you are
>refering to a network which has a CHAIN topology then
>the byte used for RREP and RREQ might be way
>insignificant. But when you refer to a well connected
>network then the byte seems sufficient.
>
>Rgds
>Jitesh
>
> --- Robert Cain <[email-masked]> wrote: >
>Connectivity is the number of other nodes each node
>> can reach with 1 hop.
>> Therefore a connectivity of 10 means there is 10
>> nodes that a can reach
>> directly. Obviously in an actual network this would
>> vary from node to node.
>> 
>> 
>> Rob Cain :-)
>> 
>> 
>> >What does the connectivity parameter specify?  Is
>> it saying in 100,000
>> nodes only 10 nodes would be connected?
>> >
>> >-----Original Message-----
>> >From: Robert Cain [mailto:[email-masked]]
>> >Sent: Wednesday, November 12, 2003 11:13 AM
>> >To: DANIEL BYRNE
>> >Subject: Re: [manet] AODV Question
>> >
>> >
>> >1 byte seems OK to me.
>> >
>> >With some simple analysis assuming a circular
>> homogeneous network of node
>> >count K and a reasonable connectivity C then the
>> radius of the network in
>> >hops can be derived to be the square root of K/C.
>> Which for a network size
>> >of 100,000 and a connectivity of 10 gives a hop
>> count radius of 100.
>> Seeing
>> >as a network of size 100,000 will be probably at
>> practical limits of size
>> >due to performance degradation then I think 1 byte
>> may well be enough.
>> >
>> >hope that helps :-)
>> >
>> >Rob Cain
>> >
>> >>if the 
>> >>
>> >>"AODV routing protocol is designed for mobile ad
>> hoc networks
>> >>   with populations of tens to thousands of mobile
>> nodes"
>> >>
>> >>why is the HopCount limited to only a BYTE?  This
>> effectively limits the
>> >number of hops to 255.  Why not expand the hop
>> count to two bytes into the
>> >reseved region of the RREQ packet.  Something
>> similar could be done with
>> >the RREP packet as well.
>> >>
>> >>
>> >>_______________________________________________
>> >>manet mailing list
>> >>[email-masked]
>> >>https://www1.ietf.org/mailman/listinfo/manet
>> >>
>> >
>> 
>> _______________________________________________
>> manet mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/manet 
>
>________________________________________________________________________
>Yahoo! India Mobile: Download the latest polyphonic ringtones.
>Go to http://in.mobile.yahoo.com
>
>_______________________________________________
>manet mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/manet
>
>_______________________________________________
>manet mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/manet
>

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: DANIEL BYRNE <[email-masked]>
Date: Fri, 14 Nov 2003 09:13:29 -0600

I forgot about the IPv4 TTL.  Good point.  Sounds like the limitations in AODV goes beyond what can be fixed within the protocol itself.

However, to the point that "who would want to connect to a station 255 hops away?"  well I would, but maybe not with AODV.

-----Original Message-----
From: Manel Guerrero [mailto:[email-masked]]
Sent: Friday, November 14, 2003 4:23 AM
To: Jitesh Shah
Cc: DANIEL BYRNE; [email-masked]; [email-masked]
Subject: Re: [manet] AODV Question

Hello everybody,

I tried to ignore this thread from the beginning because I have better 
things to do. But now I cannot help it. ;)

1) IPv4 headers have a 8-bit field called TTL (Time To Live).
("TTL (time to live): each router must decrement by 1 and discard if 
zero. Also decrement if router holds for longer than 1 sec.")

2) IPv6 headers have a 8-bit field called Hop Limit.
("hop limit (8 bit): Decremented by one by each node that forwards the 
packet. When the hop limit field reaches zero, the packet is discarded.")

3) AODV is a UDP protocol. So The AODV message goes wrapped in an IP 
header. Even if AODV message would have a bigger hop count, the IP 
packet has only a 8-bit field. Therefore, it will die after the 255 hops.

4) Point number 3 is not a big problem since I have seen some AODV 
implementations that reset IP's TTL or Hop Limit to 255 at each hop. 
Anyway, once the route is constructed, when you would send the data, the 
IP packets would die before reaching the final destination. (Yep, at the 
255 hops :) ) (And there is no much point in to constructing a route 
that cannot be used ;) ).

Regards,

	Manel Guerrero Zapata

P.D.: This is my new email address. The previous one:
([email-masked]) does not work anymore.

Jitesh Shah wrote:
> Hi Daniel,
> 
> I completely agree with you when you suggest that one
> must take care of the future needs when we are in the
> development stage. 
> 
> We might have to face a situation in the real life
> when we might actually need more than a byte. The
> things being in development stage, I believe perhaps
> this is the right time to incorporate the changes
> rather than evolving with AODV 1.1 at a later stage
> :-)
> 
> Rgds
> Jitesh
> 
> 
> 
>  --- DANIEL BYRNE <[email-masked]> wrote: >
> Agreed.  A branched chain configuration would be
> 
>>difficult to support with only a BYTE. My point is
>>that although most everyone involved in development
>>and testing of this protocol have envisioned a
>>'cluster of connected nodes' arrangement, the
>>reality is the sum total of all possible topolgies
>>in a wireless network of this type is potentially
>>limitless.  Limited in effect by only the range of
>>the radios in the network.  How are we to know how
>>some future person or organization will use this
>>protocol?  Will they need the extra BYTE?  Should we
>>place artificial limits on the protocol by
>>purposefully limiting the hop count, address range,
>>etc.?
>>
>>One solution is the "extensions" field in the latest
>>draft of AODV could potentially provide a means to
>>expand upon the protocol in the future if
>>neccessary.  
>>
> 
>>>directly. Obviously in an actual network this
>>
>>would
>>
>>>vary from node to node.
>>>
>>>
>>>Rob Cain :-)
>>>
>>>
>>>
>>>>due to performance degradation then I think 1
>>
>>byte
>>
>>>may well be enough.
>>>
>>>>hope that helps :-)
>>>>
>>>>Rob Cain
>>>>
>>>>
>>>>>if the 
>>>>>
>>>>>  with populations of tens to thousands of
>>
>>mobile
>>
>>>nodes"
>>>
>>>>>why is the HopCount limited to only a BYTE? 
>>
>>This
>>
>>>effectively limits the
>>>

---

From: DANIEL BYRNE <[email-masked]>
Date: Fri, 14 Nov 2003 14:37:03 -0600

Good points, thanks.

>Your idea has promise, especially in areas where right-of-way is a
>problem.  However, it may not be necessary to use a MANET protocol.  If
>the relay points are stationary and in a known relationship with one
>...

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Mon, 17 Nov 2003 11:22:21 -0500

Hi John,

Seems to me that what you describe ought to work just fine with any IGP. Wired networks also have routers that go up and down, after all.

I think this is only a matter of degree. If the infrastructure is not meant to be ad hoc, i.e. the density of nodes that behave as routers is roughly what it needs to be to provide reliable connectivity, such that flooding of hello messages will not overwhelm an overly dense set of routers, then you don't need to rely one special enhancements of standard IGPs.

All you're describing, I think, is a typical internet in which routers happen to have RF links?

Bert

> From: John Mullen [mailto:[email-masked]]
> Sent: Monday, November 17, 2003 11:07 AM
> Hi Charlie,
> Well, I can see one application of MANET technology in a situation in
> which the nodes do not move.  Consider the Dine' (Navajo) nation which
> covers thousands of square miles in the southwestern US.  
> Connecting the
> many isolated communities with wire or fiber does not seem to be an
> option.  Furthermore, the Dine' would prefer not to use the 
> ideal places
> for antennas because of religious and other reasons.  Every 
> time you dig
> a hole on the reservation, you need an archeologist.  Other American
> Indian jurisdictions are checkerboarded.  That is, there are 
> parcels of
> fee simple land owned by non-members of the Tribe interspersed
> throughout the area.  In those cases, right of way is a big problem.
> 
> It is not just that putting up telephone poles is a problem, but also
> that a common electrical supply is often not available.  That is, any
> repeaters would have to be self-powered.
> 
> Now, imagine a network of nodes that are powered by 
> batteries, which in
> turn, are recharged by solar energy.  Also, assume the net is dense
> enough that many nodes can go to standby while the others 
> take the load.
> However, as the evening wears on, the active nodes, one by one, will
> have to shut down due to low power.  Others could, at any 
> time, have to
> shut down due to malfunctions (we a talking of many nodes in a very
> hostile environment).  As each does so, one or more inactive 
> nodes wakes
> up to take the load.
> 
> Such a net would have no mobile nodes, but would require frequent
> automatic reconfiguration.  It wouldn't be entirely a MANET, 
> since each
> node could know where every other node was, but would require a degree
> of automatic reconfiguration that ordinary protocols would not support
> due to the frequent changes in the pattern of available 
> nodes.  I would
> think that at least part of a MANET protocol would be 
> helpful.  Also, if
> such a protocol were to be used, mobile nodes could be more easily
> accommodated as they move throughout the communications area.
> 
> Just a thought.
> 
> John Mullen
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Charles E. Perkins
> Sent: Monday, November 17, 2003 8:27 AM
> To: DANIEL BYRNE
> Cc: 'Erik Nordström'; [email-masked]; [email-masked]
> Hello folks,
> One or two comments below:
> 
> DANIEL BYRNE wrote:
> 
> > Yes we did, but everyone here is now saying that AODV doesn't work 
> > well over 50 or more hops.
> 
> I can believe that the performance would suffer
> greatly, depending on the mobility of the intermediate
> nodes.  If the nodes didn't move, then I wonder what
> would go wrong?
> 
> Regarding the idea about replacing land lines,
> I guess that any routing protocol would work,
> even manual configuration.  To overcome the 
> hop limit, you could do encapsulations.
> 
> It doesn't seem to be a close match for the
> technology provided for use with mobile ad
> hoc networks since:
> 1) the nodes aren't mobile, and
> 2) the network isn't ad hoc.
> 
> Regards,
> Charlie P.
>

---

From: "Pete Sholander" <[email-masked]>
Date: Mon, 17 Nov 2003 13:02:12 -0500

IMHO ... John's application is why simple QoS metrics (e.g, "node energy status" or "link stability") might should be included in the next round of MANET WG proposals.  Similar problems exist in military sensor networks.

--Pete Sholander
Atlanta, GA

>>> "Manfredi, Albert E" <[email-masked]> 11/17/03 11:22AM >>>
Hi John,

Bert