Subject: [mpls-tp] poll to make draft-busi-mpls-tp-oam-framework an mpls working group document

From: Loa Andersson <[email-masked]>
Date: Thu, 19 Mar 2009 13:44:42 +0100

Working Group,

the authors of draft-busi-mpls-tp-oam-framework-02-02-1.txt has
requested the document shall be accepted as a working group document.

This is a one week poll to see if there are support for making it a
working group document, please respond to the mpls-tp mailing list
before Wednesday March 26.

The document will be found at:

http://www.tla-group.com/~loa/draft-busi-mpls-tp-oam-framework-02-02-1.txt

Disclaimer: I've decided to start this poll even though the draft is not
available from the IETF repository.

/Loa

-- 

Loa Andersson

Sr Strategy and Standards Manager    phone:  +46 10 717 52 13
Ericsson ///                                 +46 767 72 92 13 

                                       email:  [email-masked]
                                               [email-masked]
                                               [email-masked]

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Thu, 19 Mar 2009 13:46:26 +0100

SUpport

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Loa Andersson
Sent: Thursday, March 19, 2009 14:45
To: [email-masked]; [email-masked]
Subject: [mpls-tp] poll to make draft-busi-mpls-tp-oam-framework an mpls
working group document

Working Group,

http://www.tla-group.com/~loa/draft-busi-mpls-tp-oam-framework-02-02-1.t
xt

/Loa

-- 

Loa Andersson

                                       email:
[email-masked]
                                               [email-masked]
                                               [email-masked]

_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: "Annamaria Fulignoli" <[email-masked]>
Date: Thu, 19 Mar 2009 13:53:51 +0100

I support.
BR
Annamaria 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: giovedì 19 marzo 2009 13.45
To: [email-masked]; [email-masked]
Subject: [mpls] poll to make draft-busi-mpls-tp-oam-framework an mpls working group document

Working Group,

the authors of draft-busi-mpls-tp-oam-framework-02-02-1.txt has requested the document shall be accepted as a working group document.

This is a one week poll to see if there are support for making it a working group document, please respond to the mpls-tp mailing list before Wednesday March 26.

Disclaimer: I've decided to start this poll even though the draft is not available from the IETF repository.

/Loa

-- 

Loa Andersson

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Thu, 19 Mar 2009 13:30:20 +0000

Support (I'm an author). Ben

---

From: "Lam, Hing-Kam \(Kam\)" <[email-masked]>
Date: Thu, 19 Mar 2009 08:40:26 -0500

I support.

--Kam

> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Loa Andersson
> Sent: Thursday, March 19, 2009 8:45 AM

---

From: Dieter Beller <[email-masked]>
Date: Thu, 19 Mar 2009 14:43:21 +0100

support

Cheers,

Dieter

Loa Andersson wrote:

Working
Group,

Disclaimer: I've decided to start this poll even though the draft is
not

/Loa

--

---

From: Huub van Helvoort <[email-masked]>
Date: Thu, 19 Mar 2009 14:48:02 +0100

Hej Loa,

> requested the document shall be accepted as a working group document.

I support accepting this draft as WG document.
(can the issue numbering be adjusted at that time)  ;-)

Cheers, Huub.

-- 
================================================================
Always remember that you are unique...just like everyone else...

---

From: "Daniele Ceccarelli" <[email-masked]>
Date: Thu, 19 Mar 2009 16:29:31 +0100

Support.

Cheers,
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: giovedì 19 marzo 2009 13.45
To: [email-masked]; [email-masked]
Subject: [mpls] poll to make draft-busi-mpls-tp-oam-framework an mpls working group document

Working Group,

/Loa

-- 

Loa Andersson

---

From: "Rolf Winter" <[email-masked]>
Date: Thu, 19 Mar 2009 18:01:37 +0100

+1 Support.

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> Behalf Of Loa Andersson
> Sent: Donnerstag, 19. März 2009 13:45
> Subject: [mpls-tp] poll to make draft-busi-mpls-tp-oam-framework an
> mpls working group document
> 
> Working Group,
> 
>

---

From: [email-masked]
Date: Fri, 20 Mar 2009 10:13:37 +0800

support, but I have a question about OAM packet and OAM message 
conception in this draft. in this draft defined the follow:
   OAM Message: An OAM information element that performs some OAM 
   functionality (e.g. continuity and connectivity verification) ;

    OAM Packet: A packet that carries one or more OAM messages (i.e. OAM 
   information elements). 

 IMO. there may  encapsulate one or more OAM message in a OAM packet. the 
key problem is how to carry more one  kinds of OAM messages in a OAM 
packet , whether need to encapsulate these OAM messages by the way of TLV 
like this draft:draft-liu-mpls-tp-bnm-00 .there may carry more one kinds 
of other OAM function message in the same OAM packet.   which bring two 
advantages:
 one: it may extend original OAM packet function to realize more one OAM 
functions by the kind of OAM packet;
 two: it improve the efficiency of transporting OAM packet of services 
path.
 is my understand true? thank you.
 regards
 liu 

Loa Andersson <[email-masked]> 
发件人:  [email-masked]
2009-03-19 20:44

收件人
[email-masked], [email-masked]
抄送

主题
[mpls] poll to make draft-busi-mpls-tp-oam-framework an mpls working group 
document

Working Group,

/Loa

-- 

Loa Andersson

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Fri, 20 Mar 2009 10:56:49 +0000

Liu,

TLV is the standard way to encode multiple information elements within an IP
protocol. However, it is not within scope of the OAM framework to define the
protocol packet formats.

Ben

---

From: "BUSI ITALO" <[email-masked]>
Date: Fri, 20 Mar 2009 17:42:22 +0100

Support (I am a co-editor)(

> Sent: Thursday, March 19, 2009 5:45 AM

---

From: <[email-masked]>
Date: Sat, 21 Mar 2009 01:22:11 +0100

I support to make it a WG document.

Best regards,
Manuel

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Loa Andersson
Gesendet: Donnerstag, 19. März 2009 05:45
An: [email-masked]; [email-masked]
Betreff: [mpls] poll to make draft-busi-mpls-tp-oam-framework an mpls working group document

Working Group,

/Loa

-- 

Loa Andersson

---

From: [email-masked]
Date: Sat, 21 Mar 2009 14:03:01 +0800

ben:
 thank you for your interpret, but I can't completely understand your 
meaning. can you provide me a apply scene of A OAM Packet may carry more 
one OAM message? so it is easy for you to understand it.

regards
liu

Ben Niven-Jenkins <[email-masked]> 
2009-03-20 18:56

收件人
<[email-masked]>
抄送
<[email-masked]>
主题
Re: [mpls-tp] [mpls] poll to make draft-busi-mpls-tp-oam-framework an mpls 
working group document

Liu,

TLV is the standard way to encode multiple information elements within an 
IP
protocol. However, it is not within scope of the OAM framework to define 
the
protocol packet formats.

Ben

---

From: <[email-masked]>
Date: Wed, 25 Mar 2009 22:57:25 +0100

Support It! 

Regards
Markus

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Loa Andersson
Gesendet: Donnerstag, 19. März 2009 13:45
An: [email-masked]; [email-masked]
Betreff: [mpls-tp] poll to make draft-busi-mpls-tp-oam-framework an mpls working group document

Working Group,

/Loa

-- 

Loa Andersson

---

From: hejia 48726 <[email-masked]>
Date: Thu, 26 Mar 2009 07:31:14 +0800

Support!

Regards,
Jia

******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained here in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this email in error, please notify the sender by phone or email
 immediately and delete it!
 *****************************************************************************************

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Wed, 25 Mar 2009 23:38:45 +0000

A single OAM packet may carry for example a CC OAM message to test
connectivity and an RDI OAM message to indicate a remote defect (e.g. It is
not receiving CC messages from the other end of the transport path).

Ben

On 21/03/2009 06:03, "[email-masked]" <[email-masked]> wrote:

> ZTE Information Security Notice: The information contained in this mail is
> solely property of the sender's organization. This mail communication is
> confidential. Recipients named above are obligated to maintain secrecy and are
> not permitted to disclose the contents of this communication to others.
> This email and any files transmitted with it are confidential and intended
> solely for the use of the individual or entity to whom they are addressed. If
> you have received this email in error please notify the originator of the
> message. Any views expressed in this message are those of the individual
> sender.

---

From: <[email-masked]>
Date: Thu, 26 Mar 2009 09:35:44 -0000

One slight caution here.  Piggybacking the BDI inside a CV packet only works for p2p connections because they are symmetric.  It does not work for p2mp connections as these are not symmetric....in fact BDI must be disabled in the CV packets for the root->leaf direction.

Aside=> mp2mp and mp2p constructs are NOT connections.  A connection can only have a single source.

regards, Neil 

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Ben Niven-Jenkins
> Sent: 25 March 2009 23:39
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [mpls-tp] [mpls] poll to make 
> draft-busi-mpls-tp-oam-framework an mpls working group document
> 
> >>  IMO. there may  encapsulate one or more OAM message in a 
> OAM packet.
> > the
> >> packet , whether need to encapsulate these OAM messages by 
> the way of
> > TLV
> >> [mpls] poll to make draft-busi-mpls-tp-oam-framework an 
> mpls working
> > group
> >> document
> >> 
> >> 
> >> 
> >> 
> >> 
> >> 
> >> Working Group,
> >> 
> >>

---

From: Loa Andersson <[email-masked]>
Date: Thu, 26 Mar 2009 17:39:37 +0100

All,

this poll has ended.

We have accepted draft-busi-mpls-tp-oam-framework as an MPLS wg
document.

Could the authors/editors please republish the draft as
draft-ietf-mpls-tp-oam-framework-00.txt

Loa and George

-- 

Loa Andersson

---

From: [email-masked]
Date: Fri, 27 Mar 2009 09:07:53 +0800

thank Neil and ben for explain to me. now I have already understand it. 
for BDI for P2MP connection, whether may extend BDI function and make 
selective BDI message, which only select a sub-connection path of P2MP 
connection to work like P2P connections.
is it considerable and reasonable for you? 

regards
liu 

<[email-masked]> 
2009-03-26 17:35

收件人
<[email-masked]>, <[email-masked]>
抄送
<[email-masked]>
主题
RE: [mpls-tp] [mpls] poll to make draft-busi-mpls-tp-oam-framework an mpls 
working group document

One slight caution here.  Piggybacking the BDI inside a CV packet only 
works for p2p connections because they are symmetric.  It does not work 
for p2mp connections as these are not symmetric....in fact BDI must be 
disabled in the CV packets for the root->leaf direction.

Aside=> mp2mp and mp2p constructs are NOT connections.  A connection can 
only have a single source.

regards, Neil

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Sun, 29 Mar 2009 04:00:59 +0000

Liu,

> is it considerable and reasonable for you?

What's the use case you are trying to address?

Root->leaf BDI makes little sense as there is not leaf->root traffic flow as
P2MP connections are unidirectional and traffic only flows from root->leaf.

Often there may not be a traffic path between Leaves and the root do
Leaf->root BDI often makes little sense also.

Ben