Subject: [mpls-tp] comments for draft-boutros-mpls-tp-loopback-02

From: [email-masked]
Date: Thu, 26 Mar 2009 16:01:59 +0800

Sami：
I have a question about Loopback draft to need your explain and admission.
  section 1 Introduction:
    for OLB: C loops only the OAM control packets (those OAM control 
packets
      will be identified by an ACH code point and will be generated
      by node A) back to A, and all other packets from A are sent
      towards C. We refer to this mode "OAM Loopback" (OLB).
     those OAM control packets may be identified by special label GAL too, 
while you only say the OAM control packets
     will be identified by an ACH code point. whether you are against 
applying GAL identifed OAM packet?
     for red line, maybe change " and all other packets from A sent 
towards D";

     another part:If the MPLS-TP LSP was previously locked, A sends 
another MPLS Loopback request message to D to unlock it.
     question: when A sends another Loopback request message to D to 
unlock it, whether to need to add the following sentence at the end : D 
sends loopback response message to A to ACK/NCK it?

   i don't know whether my understanding is true?

   regards
    liu 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Sami Boutros <[email-masked]>
Date: Thu, 26 Mar 2009 12:55:20 -0700

Hi Liu

At 01:01 AM 3/26/2009, [email-masked] wrote:

>Sami£º
>     for OLB: C loops only the OAM control packets (those OAM control packets
>      those OAM control packets may be 
> identified by special label GAL too, while you 
> only say the OAM control packets
>      will be identified by an ACH code point. 
> whether you are against applying GAL identifed OAM packet?

A GAL label needs to exist in the OAM pkt for an 
MPLS LSP in the presence of an ACH.
But an OAM pkt at an intermediate LSR will only 
be intercepted if the TTL expires.

>      for red line, maybe change " and all other 
> packets from A sent towards D";
>
>      another part:If the MPLS-TP LSP was 
> previously locked, A sends another MPLS 
> Loopback request message to D to unlock it.
>      question: when A sends another Loopback 
> request message to D to unlock it, whether to 
> need to add the following sentence at the end : 
> D sends loopback response message to A to ACK/NCK it?
>

Correct the unlock need to be ACKed.

Thanks,

Sami

>ZTE Information Security Notice: The information 
>contained in this mail is solely property of the 
>sender's organization. This mail communication 
>is confidential. Recipients named above are 
>obligated to maintain secrecy and are not 
>permitted to disclose the contents of this communication to others.
>This email and any files transmitted with it are 
>confidential and intended solely for the use of 
>the individual or entity to whom they are 
>addressed. If you have received this email in 
>error please notify the originator of the 
>message. Any views expressed in this message are 
>those of the individual sender.

---

From: [email-masked]
Date: Fri, 27 Mar 2009 10:42:25 +0800

Sami:
 thank for your interepret, I have a question to ask you, this TTL field 
is in outside label or GAL label?
 whether other traffic packet will be intercepted by intermediate LSR ?

  regards
  liu

Sami Boutros <[email-masked]> 
2009-03-27 03:55

收件人
[email-masked]
抄送
[email-masked]
主题
Re: comments for draft-boutros-mpls-tp-loopback-02

Hi Liu

Sami£º 

  section 1 Introduction: 

A GAL label needs to exist in the OAM pkt for an MPLS LSP in the presence 
of an ACH.
But an OAM pkt at an intermediate LSR will only be intercepted if the TTL 
expires.

    another part:If the MPLS-TP LSP was previously locked, A sends another 
MPLS Loopback request message to D to unlock it. 
     question: when A sends another Loopback request message to D to 
unlock it, whether to need to add the following sentence at the end : D 
sends loopback response message to A to ACK/NCK it? 

Thanks,

Sami

   regards 
    liu 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail
is solely property of the sender's organization. This mail communication
is confidential. Recipients named above are obligated to maintain secrecy
and are not permitted to disclose the contents of this communication to
others.
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they are
addressed. If you have received this email in error please notify the
originator of the message. Any views expressed in this message are those
of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam
system.

---

From: [email-masked]
Date: Fri, 27 Mar 2009 11:02:21 +0800

Sami:
 IMO, there is not necessary to set two loopback method , OLB may be 
replaced by FLB.
 in FLB mode, when these traffic packets needn't to loop back to source 
point, we may set a TTL field value to 255 in outside label.
so the loop points (intermediate LSR) will not intercept these traffic 
packets, only intercept OAM control packet by TTL expires.
. by the way, it may realize OLB function(only loopback OAM control 
packet)

regards
liu

收件人
[email-masked]
抄送
[email-masked]
主题

Hi Liu

Sami£º 

  section 1 Introduction: 

Thanks,

Sami

   regards 
    liu

---

From: Sami Boutros <[email-masked]>
Date: Fri, 27 Mar 2009 09:24:44 -0700

At 07:42 PM 3/26/2009, [email-masked] wrote:

>Sami:
>  thank for your interepret, I have a question 
> to ask you, this TTL field is in outside label or GAL label?

I meant TTL field is on the top label.

Thanks,

Sami

>    those OAM control packets may be identified 
> by special label GAL too, while you only say the OAM control packets

---

From: Sami Boutros <[email-masked]>
Date: Sat, 28 Mar 2009 18:55:47 -0700

Hi Liu,

At 11:14 PM 3/27/2009, [email-masked] wrote:

>Sami:
>  you only reply my first question. for second 
> problem, at OLB mode, can other traffic packet 
> except OAM control packets be intercepted at 
> loopback point? if your answer is no, it isn't 
> necessary for loopback points to indentify and 
> judge what type of packet.only loopback all 
> packets which will be intercepted by TTL expires.
>is my understand true?

Please find this text in the draft..

When operating the MPLS-TP LSP in OLB, C loops 
only AM packets generated by A with the specific ACH codepoint back to A.

Thanks,
Sami

>2009-03-28 00:24
>æ”¶ä»¶äºº
>æŠ„é€
>ä¸»é¢˜
>thank for your interepret, I have a question to 
>ask you, this TTL field is in outside label or GAL label?
>Ã¦â€Â¶Ã¤Â»Â¶Ã¤ÂºÂº
>Ã¦Š„Ã©€Â
>Ã¤Â¸Â»Ã©Â¢˜
>SamiÃ‚Â£Ã‚Âº

---

From: [email-masked]
Date: Mon, 30 Mar 2009 09:26:48 +0800

Sami:
  you may not understand my meaning , in order to clarify my question, now 
I describle according to the follow figure:
 
I may set C as Loopback point. my question is :under OLB mode, all packets 
which send from A will have two process way:

   1 all packets regardless of OAM packet or traffic packets will be 
intercepted by C by TTL expired. then C process and alaysis these packets, 
if it is OAM packet, it will be loopback to A . or else ,it will continue 
to be sent to  D;

   2 only OAM control packet will be intercepted at C by TTL expired, then 
these OAM packets will be loopbacked to A, other traffic packets will be 
transported transparently at C as MIP   of LSP.
 
   which way do you think to use?
   regards
   liu 

2009-03-29 09:55

收件人
[email-masked]
抄送
[email-masked]
主题

Hi Liu,

Sami: 
 you only reply my first question. for second problem, at OLB mode, can 
other traffic packet except OAM control packets be intercepted at loopback 
point? if your answer is no, it isn't necessary for loopback points to 
indentify and judge what type of packet.only loopback all packets which 
will be intercepted by TTL expires. 
is my understand true? 

When operating the MPLS-TP LSP in OLB, C loops only AM packets
generated by A with the specific ACH codepoint back to A.

Thanks,
Sami

regards 
liu 

2009-03-28 00:24 
æ”¶ä»¶äºº
[email-masked] 
æŠ„é€
[email-masked] 
ä¸»é¢˜

Sami: 
thank for your interepret, I have a question to ask you, this TTL field is 
in outside label or GAL label? 
whether other traffic packet will be intercepted by intermediate LSR ? 

Thanks,

Sami

  regards 
 liu 

2009-03-27 03:55 

Ã¦â€Â¶Ã¤Â»Â¶Ã¤ÂºÂº

[email-masked] 

Ã¦Š„Ã©€Â

[email-masked] 

Ã¤Â¸Â»Ã©Â¢˜

Hi Liu

SamiÃ‚Â£Ã‚Âº 

section 1 Introduction: 

    for red line, maybe change " and all other packets from A sent towards 
D"; 

  another part:If the MPLS-TP LSP was previously locked, A sends another 
MPLS Loopback request message to D to unlock it. 
   question: when A sends another Loopback request message to D to unlock 
it, whether to need to add the following sentence at the end : D sends 
loopback response message to A to ACK/NCK it? 

Thanks,

Sami

 regards 
  liu

---

From: Sami Boutros <[email-masked]>
Date: Mon, 30 Mar 2009 08:42:52 -0700

Liu,

At 06:26 PM 3/29/2009, [email-masked] wrote:

>Sami:
>   you may not understand my meaning , in order 
> to clarify my question, now I describle according to the follow figure:
>
>[]
>
>I may set C as Loopback point. my question is 
>:under OLB mode, all packets which send from A will have two process way:
>
>    1 all packets regardless of OAM packet or 
> traffic packets will be intercepted by C by TTL 
> expired. then C process and alaysis these 
> packets, if it is OAM packet, it will be 
> loopback to A . or else ,it will continue to be sent to  D;
>
>    2 only OAM control packet will be 
> intercepted at C by TTL expired, then these OAM 
> packets will be loopbacked to A, other traffic 
> packets will be transported transparently at C as MIP         of LSP.

Only TTL expired OAM control pkts with a new ACH 
codepoint will be looped back if node C is in OLB.

Thanks,

Sami

>ÃƒÂ¦Ã¢€ÂÃ‚Â¶ÃƒÂ¤¤Ã‚Â»Ã‚Â¶ÃƒÂ¤Ã‚ÂºÃ‚Âº
>
>
>[email-masked]
>
>
>ÃƒÂ¦Š„ÃƒÂ©€Ã‚ÂÃ‚Â
>
>
>[email-masked]
>
>
>ÃƒÂ¤Ã‚Â¸Ã‚Â»ÃƒÂ©Ã‚Â¢˜
>
>
>SamiÃƒ‚ÃÃ‚Â£Ãƒ‚Ã‚Âº
>  those OAM control packets may be identified by 
> special label GAL too, while you only say the OAM control packets
>  another part:If the MPLS-TP LSP was previously 
> locked, A sends another MPLS Loopback request message to D to unlock it.