Subject: Re: [mpls-tp] New Version Notification for draft-ietf-mpls-tp-requirements-05

From: Ben Niven-Jenkins <[email-masked]>
Date: Mon, 09 Mar 2009 23:23:53 +0000

Colleagues,

FYI I just posted -05 of draft-mpls-tp-requirements which addresses the
bulk, but not all, of the last call comments received. I thought it valuable
to post a new version at this time to enable folks to read/digest prior to
IETF given the level of changes made.

Specific work still to do:

1) Expand acronyms on first use
2) Check references to ensure correct normative/informative split
3) Last Call comments received on the MPLS-TP mailing list after 14:00 GMT
on 28th February.
4) Ongoing discussion on last call comments received and replied to via the
MPLS-TP mailing list.

I will endeavour to complete the above work prior to IETF at the end of the
month.

Draft can be downloaded from
http://www.ietf.org/internet-drafts/draft-ietf-mpls-tp-requirements-05.txt

Ben

On 09/03/2009 23:13, "IETF I-D Submission Tool" <[email-masked]>
wrote:

> 
> A new version of I-D, draft-ietf-mpls-tp-requirements-05.txt has been
> successfuly submitted by Ben Niven-Jenkins and posted to the IETF repository.
> 
> Filename:  draft-ietf-mpls-tp-requirements
> Revision:  05
> Title:   MPLS-TP Requirements
> Creation_date:  2009-03-10
> WG ID:   mpls
> Number_of_pages: 31
> 
> Abstract:
> This document specifies the requirements of an MPLS Transport Profile
> (MPLS-TP).  This document is a product of a joint International
> Telecommunications Union (ITU)-IETF effort to include an MPLS
> Transport Profile within the IETF MPLS and PWE3 architectures to
> support the capabilities and functionalities of a packet transport
> network as defined by International Telecommunications Union -
> Telecommunications Standardization Sector (ITU-T).
> 
> This work is based on two sources of requirements; MPLS and PWE3
> architectures as defined by IETF, and packet transport networks as
> defined by ITU-T.
> 
> The requirements expressed in this document are for the behavior of
> the protocol mechanisms and procedures that constitute building
> blocks out of which the MPLS transport profile is constructed.  The
> requirements are not implementation requirements.
>                  
> 
> 
> The IETF Secretariat.
> 
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 16 Mar 2009 17:21:33 -0000

Hi Peng,

I think that at some point rings with multiple points of interconnection are 
called meshes.

But seriously, we have been asking for a while for someone to describe for 
us a set of realistic ring deployment scenarios. Without those, we will 
simply describe what we think is appropriate and carry on the work.

Thanks,
Adrian
----- Original Message ----- 
From: "Peng He" <[email-masked]>
To: "Ben Niven-Jenkins" <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, March 16, 2009 3:35 PM
Subject: RE: New Version Notification for draft-ietf-mpls-tp-requirements-05

> Ben,
>
> In Req. 18 B: "It MUST be possible to deploy MPLS-TP in arbitrarily 
> interconnected rings with one or two points of interconnection."
>
> I suppose that the scenario of arbitrarily interconnected rings with 
> more-than-two points of interconnection is included in the scenario of two 
> points of interconnection? Or we just do not consider that case? Thanks a 
> lot.
>
>
> Regards,
> Peng
>
>> -----Original Message-----
>> From: Ben Niven-Jenkins [mailto:[email-masked]]
>> Sent: Monday, March 09, 2009 7:24 PM
>> To: [email-masked]
>> Cc: [email-masked]
>> Subject: Re: New Version Notification for draft-ietf-mpls-tp-
>> requirements-05
>>
>> Colleagues,
>>

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Mon, 16 Mar 2009 19:49:14 +0000

Adrian, Peng,

> I think that at some point rings with multiple points of interconnection are

:-)

> simply describe what we think is appropriate and carry on the work.

ITU-T provided a reference network and a set of requirements for MPLS-TP
rings, one of which is quoted below

"1. Support inter-ring connectivity, in case:
a.     the rings are connected at a single node and no links are shared
between the rings
b.     the rings are connected at two nodes and the connecting link is
shared by the rings"

So in short, we only require two points of connection because nobody has
asked for more or shown a use case (realistic or not) that requires more.

Ben

---

From: "Drake, John E" <[email-masked]>
Date: Mon, 16 Mar 2009 13:39:35 -0700

Italo said that he was working on ring protection/restoration
requirements in the combined WG session in Minneapolis.  To date, I
haven't seen anything. 

> Sent: Monday, March 16, 2009 12:49 PM
> To: Adrian Farrel; Peng He; [email-masked]
> Subject: Re: [mpls-tp] New Version Notification 
> fordraft-ietf-mpls-tp-requirements-05
> 
> Adrian, Peng,
> 
> > I think that at some point rings with multiple points of 
> > interconnection are called meshes.
> 
> :-)
> 
> > But seriously, we have been asking for a while for someone 
> to describe 
> > for us a set of realistic ring deployment scenarios. 
> Without those, we 
> > will simply describe what we think is appropriate and carry 
> on the work.
> 
> ITU-T provided a reference network and a set of requirements 
> for MPLS-TP rings, one of which is quoted below
> 
> So in short, we only require two points of connection because 
> nobody has asked for more or shown a use case (realistic or 
> not) that requires more.
> 
> Ben
> 
> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp
>

---

From: "BUSI ITALO" <[email-masked]>
Date: Tue, 17 Mar 2009 10:19:39 +0100

I agree with Ben.

Italo

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Ben Niven-Jenkins
> Sent: Monday, March 16, 2009 8:49 PM
> to describe for
> nobody has

---

From: "BUSI ITALO" <[email-masked]>
Date: Tue, 17 Mar 2009 10:19:42 +0100

John,

As indicated in section 5 of draft-ietf-mpls-tp-requirements-05, last
December while we were in Geneve for the ITU-T SG15 meeting, ad hoc
discussion group addressed the requirements for deployment and
survivability in ring topologies.

I have attended this ad-hoc group and provided my inputs that have been
included into the MPLS-TP Requirements draft (section 2.8.5.1).

With the current status of the work, I do not see any value in writing a
draft that will be basically a copy of section 2.8.5.1 of
draft-ietf-mpls-tp-requirements-05. Therefore I am focusing on providing
comments on draft-ietf-mpls-tp-requirements.

Of course, if you think that additional information is needed, I can
provide them either as inputs to draft-ietf-mpls-tp-requirements or as a
separated draft.

In this case, please let me know which specific additional information
you need to complete the work on ring protection switching requirements.

Thanks, Italo

> [mailto:[email-masked]] On Behalf Of Drake, John E
> Sent: Monday, March 16, 2009 9:40 PM
> To: Ben Niven-Jenkins; Adrian Farrel; Peng He; [email-masked]
> Subject: Re: [mpls-tp] New Version 
> Notificationfordraft-ietf-mpls-tp-requirements-05
>

---

From: Huub van Helvoort <[email-masked]>
Date: Tue, 17 Mar 2009 12:16:10 +0100

Hi Ben,

> a.     the rings are connected at a single node and no links are shared

Some care should be taken, or more detail should be provided for this
topology.
-a1-
It could mean that a single node can be a member of two rings:
I.e. node P is member of both rings. Node P is single point of
failure.
    --------------   --------------
    |            |   |            |
-------        -------        -------
|  A  |        |  P  |        |  Z  |
-------        -------        -------
    |            |   |            |
    --------------   --------------
-a2-
Another possibility is that two rings are connected at single nodes:
Between the rings there is only one connecting link from P to Q.
This link is the single point of failure.
    --------------          --------------
    |            |          |            |
-------      -------    -------      -------
|  A  |      |  P  |----|  Q  |      |  Z  |
-------      -------    -------      -------
    |            |          |            |
    --------------          --------------

This is the ITU-T G.842 scenario in section 6.1

> b.     the rings are connected at two nodes and the connecting link is

-b1-
It could mean that a the two nodes can be a member of two rings:
I.e. nodes P and R are members of both rings. The link between
P and R is shared by both rings.
    --------------   --------------
    |            |   |            |
-------        -------        -------
|  A  |        |  P  |        |  Y  |
-------        -------        -------
    |              |              |
-------        -------        -------
|  B  |        |  M  |        |  Z  |
-------        -------        -------
    |            |   |            |
    --------------   --------------

-b2-
Another possibility is that two rings are connected at two nodes:
The traffic between the two rings uses two links, so there is no
single point of failure. This scenario allows the rings to exist
in different (operator) domains.
    --------------          --------------
    |            |          |            |
-------      -------    -------      -------
|  A  |      |  P  |----|  Q  |      |  Y  |
-------      -------    -------      -------
    |            |          |            |
-------      -------    -------      -------
|  B  |      |  M  |----|  N  |      |  Z  |
-------      -------    -------      -------
    |            |          |            |
    --------------          --------------

This is the ITU-T G.842 scenario in section 6.2 and
generally referred to as Dual Node Interconnect.

> asked for more or shown a use case (realistic or not) that requires more.

Cheers, Huub.

-- 
================================================================
Always remember that you are unique...just like everyone else...

---

From: Huub van Helvoort <[email-masked]>
Date: Tue, 17 Mar 2009 12:18:15 +0100

All,

I agree with Italo's observation.
I was also present during the discussion in december in Geneva.

regards, Huub.

=================

-- 
================================================================
                   http://www.van-helvoort.eu/
================================================================
Always remember that you are unique...just like everyone else...

---

From: "Drake, John E" <[email-masked]>
Date: Tue, 17 Mar 2009 06:16:43 -0700

Italo,

That's great, but this is the first I have heard of either the ad hoc
discussion group or its input to the requirements I-D.

Thanks,

John 

> From: BUSI ITALO [mailto:[email-masked]] 
> Sent: Tuesday, March 17, 2009 2:20 AM
> To: Drake, John E; Ben Niven-Jenkins; Adrian Farrel; Peng He; 
> [email-masked]
> Subject: RE: [mpls-tp] New Version 
> As indicated in section 5 of 
> draft-ietf-mpls-tp-requirements-05, last December while we 
> were in Geneve for the ITU-T SG15 meeting, ad hoc discussion 
> group addressed the requirements for deployment and 
> I have attended this ad-hoc group and provided my inputs that 
> have been included into the MPLS-TP Requirements draft 
> (section 2.8.5.1).
> 
> With the current status of the work, I do not see any value 
> in writing a draft that will be basically a copy of section 
> 2.8.5.1 of draft-ietf-mpls-tp-requirements-05. Therefore I am 
> focusing on providing comments on draft-ietf-mpls-tp-requirements.
> 
> Of course, if you think that additional information is 
> needed, I can provide them either as inputs to 
> draft-ietf-mpls-tp-requirements or as a separated draft.
> 
> In this case, please let me know which specific additional 
> information you need to complete the work on ring protection 
> switching requirements.
> 
> Thanks, Italo
> 
> > > ITU-T provided a reference network and a set of requirements for 
> > > MPLS-TP rings, one of which is quoted below
> > > 
> > > So in short, we only require two points of connection 
> because nobody 
> > > has asked for more or shown a use case (realistic or
> > > not) that requires more.
> > > 
> > > Ben
> > >

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Tue, 17 Mar 2009 14:21:06 +0000

John,

Although maybe not the most obvious there is credit in the draft to an
ad-hoc review team that formed during an ITU meeting in Geneva and Adrian
sent the comments they generated to the MPLS-TP list on 8th December but the
comments were munged with some other comments/suggested text that he & Nurit
had produced.

Anyway I think this issue is closed.  The draft contains all the input from
ITU either direct via liaison or indirect via comments to the MPLS-TP list
from ITU participants. At last call no comments were raised on ring
interconnection either by IETF or ITU participants or liaison.

I therefore must conclude that the documented requirements related to ring
protection are sufficient. Or as a British policeman may say "Move along,
Nothing to see here".

Ben

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Tue, 17 Mar 2009 14:30:07 +0000

> Some care should be taken, or more detail should be provided for this

So the text I quoted came direct from ITU-T. The actual text in -05 of the
draft is this:

   18  MPLS-TP MUST NOT dictate the deployment of any particular network
       topology either physical or logical, however:

       A.  It MUST be possible to deploy MPLS-TP in rings.

       B.  It MUST be possible to deploy MPLS-TP in arbitrarily
           interconnected rings with one or two points of
           interconnection.

       C.  MPLS-TP MUST support rings of at least 16 nodes in order to
           support the upgrade of existing TDM rings to MPLS-TP.
           MPLS-TP SHOULD support rings with more than 16 nodes.

I believe use of "arbitrarily interconnected" means the requirement covers
all the cases you present below.

When it comes to ring requirements I rely on others to present me the real
use cases as I have no requirements for packet based rings and on 21CN I
don't even use rings in the transport layer.

If you still feel that additional detail should be provided then please
propose text and I will incorporate it once we've agreed the wording.

Ben

---

From: "Drake, John E" <[email-masked]>
Date: Tue, 17 Mar 2009 07:33:32 -0700

Ben,

No problem.  I do remember Adrian re-writing the entire requirements I-D
back in the December timeframe.

Thanks,

John 

> Sent: Tuesday, March 17, 2009 7:21 AM
> To: Drake, John E; BUSI ITALO; Adrian Farrel; Peng He; 
> [email-masked]
> Subject: Re: [mpls-tp] New 
> VersionNotificationfordraft-ietf-mpls-tp-requirements-05
> 
> John,
> 
> Although maybe not the most obvious there is credit in the 
> draft to an ad-hoc review team that formed during an ITU 
> meeting in Geneva and Adrian sent the comments they generated 
> to the MPLS-TP list on 8th December but the comments were 
> munged with some other comments/suggested text that he & 
> Nurit had produced.
> 
> Anyway I think this issue is closed.  The draft contains all 
> the input from ITU either direct via liaison or indirect via 
> comments to the MPLS-TP list from ITU participants. At last 
> call no comments were raised on ring interconnection either 
> by IETF or ITU participants or liaison.
> 
> I therefore must conclude that the documented requirements 
> related to ring protection are sufficient. Or as a British 
> policeman may say "Move along, Nothing to see here".
> 
> Ben
> 
> 
> 
> 
> >> draft-ietf-mpls-tp-requirements-05, last December while we were in 
> >> Geneve for the ITU-T SG15 meeting, ad hoc discussion group 
> addressed 
> >> the requirements for deployment and survivability in ring 
> topologies.
> >> 
> >> I have attended this ad-hoc group and provided my inputs that have 
> >> been included into the MPLS-TP Requirements draft (section 
> 2.8.5.1).
> >> 
> >> With the current status of the work, I do not see any value in 
> >> writing a draft that will be basically a copy of section