Subject: Re: [mpls-tp] poll to make draft-busi-mpls-tp-oam-framework an mplsworking group document

From: "Xueqin WEI (Shuetsing WEI)" <[email-masked]>
Date: Mon, 23 Mar 2009 13:38:29 +0800

Support!

And I want confirm following items:
1, In figure 1, why there is no PME for PW 3X?
2, Why there are no PME for PW13, PW3X and PWXY in Figure 5?
3, Why "Use of on-demand CC & CV is dependent on the existence
of a bi-directional connection ME"? (At the end of first paragraph 
of section 6.1)

Sincerely Yours
Xueqin Wei (Shuetsing Wei)

==================== Following is your email=====================
Subject:[mpls-tp] poll to make draft-busi-mpls-tp-oam-framework an mplsworking group document
Sent：2009-03-19 20:43:13
From:Loa Andersson
To:mpls-tp; mpls
CC to:

>Working Group,
>
>
>the authors of draft-busi-mpls-tp-oam-framework-02-02-1.txt has
>requested the document shall be accepted as a working group document.
>
>This is a one week poll to see if there are support for making it a
>working group document, please respond to the mpls-tp mailing list
>before Wednesday March 26.
>
>The document will be found at:
>
>http://www.tla-group.com/~loa/draft-busi-mpls-tp-oam-framework-02-02-1.txt
>
>Disclaimer: I've decided to start this poll even though the draft is not
>available from the IETF repository.
>
>
>/Loa
>
>
>-- 
>
>
>Loa Andersson
>
>Sr Strategy and Standards Manager    phone:  +46 10 717 52 13
>Ericsson ///                                 +46 767 72 92 13 
>
>
>                                       email:  [email-masked]
>                                               [email-masked]
>                                               [email-masked]
>
>
>_______________________________________________
>mpls-tp mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mpls-tp
>

=================================================================

---

From: "BUSI ITALO" <[email-masked]>
Date: Tue, 24 Mar 2009 02:24:12 +0100

See my answers in line marked with [ib]

Italo 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Xueqin WEI 
> (Shuetsing WEI)
> Sent: Sunday, March 22, 2009 10:38 PM
> To: Loa Andersson
> Cc: MPLS-TP
> Subject: Re: [mpls-tp] poll to make 
> draft-busi-mpls-tp-oam-framework anmplsworking group document
> 
> Support!
> 

[ib] PW3X is a PW Segment of the e2e MS-PW1Z. As such it is possible to instantiate just a tandem connection, PW3X PTCME.

This is not described in the document because we expect that typically TCM are used to monitor an OAM domain (like PW13 PTCME and PWXZ PTCME rather than the segment between two OAM domains. 

However the OAM framework does not pose any contraints on the way TCM are instantiated as long as the are not overlapping.

> 2, Why there are no PME for PW13, PW3X and PWXY in Figure 5?

[ib] Because PW13, PW3X and PWXY are segments of the MS-PW1Z. PME monitors the MS-PW e2e so there is only PW1Z PME.

> of a bi-directional connection ME"? (At the end of first paragraph 

[ib] Because on-demand CC&CV requires a return path. I think this issue needs to be clarified in the next version of the draft.

> Subject:[mpls-tp] poll to make 
> draft-busi-mpls-tp-oam-framework an mplsworking group document
> Sent：2009-03-19 20:43:13
> From:Loa Andersson
> To:mpls-tp; mpls
> CC to:
> 
> >Working Group,
> >
> >
> >http://www.tla-group.com/‾loa/draft-busi-mpls-tp-oam-framewor
> k-02-02-1.txt
> >

---

From: "Xueqin WEI (Shuetsing WEI)" <[email-masked]>
Date: Tue, 24 Mar 2009 12:35:01 +0800

BUSI:

I think I got what you said, and thanks a lots!
I suggest that we should add some texts to clearify the item 1, because it easy make confusion.

Sincerely Yours
2009-03-24  12:31:33

==================== Following is your email=====================
Subject:RE: [mpls-tp] poll to make draft-busi-mpls-tp-oam-framework anmplsworking group document
Sent：2009-03-24 09:22:40
From:BUSI ITALO
To:[email-masked]; Loa Andersson
CC to:MPLS-TP

---

From: "BUSI ITALO" <[email-masked]>
Date: Tue, 24 Mar 2009 18:30:02 +0100

That's fine. We will add text to clarify the point in the next version of the draft.

Thanks for the comments

Italo 

> Sent: Monday, March 23, 2009 9:35 PM
> To: BUSI ITALO
> Cc: MPLS-TP
> draft-busi-mpls-tp-oam-frameworkanmplsworking group document
> 
> BUSI:
> 
> Subject:RE: [mpls-tp] poll to make 
> >[ib] PW3X is a PW Segment of the e2e MS-PW1Z. As such it is 
> possible to instantiate just a tandem connection, PW3X PTCME.
> >
> >This is not described in the document because we expect that 
> typically TCM are used to monitor an OAM domain (like PW13 
> PTCME and PWXZ PTCME rather than the segment between two OAM domains. 
> >
> >However the OAM framework does not pose any contraints on 
> the way TCM are instantiated as long as the are not overlapping.
> >
> >[ib] Because PW13, PW3X and PWXY are segments of the 
> MS-PW1Z. PME monitors the MS-PW e2e so there is only PW1Z PME.
> >
> >[ib] Because on-demand CC&CV requires a return path. I think 
> this issue needs to be clarified in the next version of the draft.
> >
> >> 
> >> Sincerely Yours

---

From: [email-masked]
Date: Wed, 25 Mar 2009 17:18:11 +0800

hi,Italo:
 today I review your mpls-tp OAM framework draft, maybe I don't completely 
understand this section 5.3 Alarm Suppression."when a server MEP detects a 
signal fail conditions in the server (sub-)layer, this server MEP will 
generate AIS message packet that is used to suppress alarms at the MEP in 
the client layer". 
under this condition, I don't know how the server MEP transports the AIS 
message packet to the client MEP? because the two MEP isn't at the same 
layer. one is at server layer network. another is at client layer network. 
here consider two conditions:

 1 if this AIS message packet is transported through client layer path, 
maybe the node of this server MEP will be a MIP for client layer path, so 
it can't generate and initiate a OAM message packet.how to generate AIS 
message packet?

 2 if this AIS message packet is transported through server layer path. so 
this AIS message pakcet will be a OAM message packet of the server layer 
network. maybe this AIS message packet will be terminated at another MEP 
of the server layer path.in addtion, client MEP and remote peer Server MEP 
maybe not be the same node. how can this AIS message packet be tranported 
to client MEP? 

regards
liu

"BUSI ITALO" <[email-masked]> 
发件人:  [email-masked]
2009-03-25 01:30

收件人
<[email-masked]>
抄送
MPLS-TP <[email-masked]>
主题
Re: [mpls-tp] poll to make draft-busi-mpls-tp-oam-frameworkanmplsworking 
group document

That's fine. We will add text to clarify the point in the next version of 
the draft.

Thanks for the comments

Italo 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Maarten Vissers <[email-masked]>
Date: Wed, 25 Mar 2009 11:26:43 +0100

Liu,
 
A Server MEP function consists of a Termination function and an Adaptation
function. 
When the Termination Sink function in a MEP detects a Signal Fail condition
it will signal
this SF condition to the attached adaptation sink function. The adaptation
sink function 
has awareness of both the server and the client layer and can as such
generate and 
insert client AIS messsages.
 
E.g. when a SDH VC-4 carries ATM VP signals, the VC-4 MEP function will
insert VP-AIS 
in each ATM VP when the VC-4 termination sink function detects a SF
condition. 
Similarly, when a VC-4 carries MPLS-TP LSP signals, the VC-4 MEP function
will insert 
MPLS-TP AIS in each LSP when the VC-4 termination sink function detects a SF
condition.
 
Regards,
Maarten

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of [email-masked]
Sent: woensdag 25 maart 2009 10:18
To: BUSI ITALO
Cc: [email-masked]
Subject: Re: [mpls-tp] poll to make
draft-busi-mpls-tp-oam-frameworkanmplsworking group document

hi,Italo: 

 1 if this AIS message packet is transported through client layer path,
maybe the node of this server MEP will be a MIP for client layer path, so it
can't generate and initiate a OAM message packet.how to generate AIS message
packet? 

 2 if this AIS message packet is transported through server layer path. so
this AIS message pakcet will be a OAM message packet of the server layer
network. maybe this AIS message packet will be terminated at another MEP of
the server layer path.in addtion, client MEP and remote peer Server MEP
maybe not be the same node. how can this AIS message packet be tranported to
client MEP? 

regards 
liu 

2009-03-25 01:30 

收件人
<[email-masked]> 

抄送

主题
Re: [mpls-tp] poll to make
draft-busi-mpls-tp-oam-frameworkanmplsworking group document

Thanks for the comments

Italo 

ZTE Information Security Notice: The information contained in this mail is
solely property of the sender's organization. This mail communication is
confidential. Recipients named above are obligated to maintain secrecy and
are not permitted to disclose the contents of this communication to others.

This email and any files transmitted with it are confidential and intended
solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the originator of the
message. Any views expressed in this message are those of the individual
sender.

---

From: [email-masked]
Date: Thu, 26 Mar 2009 09:20:39 +0800

maarten:
 thank you for your explain, according to your describle, this AIS message 
will be generated by an adaptation function of server MEP. so whether we 
may say the adaptation sink function can be a MIP on client layer path?
is my understanding to your explain true?
 
regards 
liu

Maarten Vissers <[email-masked]> 
2009-03-25 18:26

收件人
[email-masked]
抄送
[email-masked]
主题
RE: [mpls-tp] poll to make draft-busi-mpls-tp-oam-frameworkanmplsworking 
group document

Liu,
 
When the Termination Sink function in a MEP detects a Signal Fail 
condition it will signal
 
E.g. when a SDH VC-4 carries ATM VP signals, the VC-4 MEP function will 
insert VP-AIS 
in each ATM VP when the VC-4 termination sink function detects a SF 
condition. 
Similarly, when a VC-4 carries MPLS-TP LSP signals, the VC-4 MEP function 
will insert 
MPLS-TP AIS in each LSP when the VC-4 termination sink function detects a 
SF condition.
 
Regards,
Maarten

hi,Italo: 

regards 
liu 

收件人
<[email-masked]> 
抄送

Thanks for the comments

Italo 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is 
solely property of the sender's organization. This mail communication is 
confidential. Recipients named above are obligated to maintain secrecy and 
are not permitted to disclose the contents of this communication to 
others.
This email and any files transmitted with it are confidential and intended 
solely for the use of the individual or entity to whom they are addressed. 
If you have received this email in error please notify the originator of 
the message. Any views expressed in this message are those of the 
individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam 
system.