Subject: RE: [IP-Optical] Joint Routing

From: "David Allan" <[email-masked]>
Date: Fri, 27 Oct 2000 10:10:20 -0500

True, they are separate concepts. Centralzied computing is A solution to the
problem of ensuring a synchronized and authoriative view of the network
which is what I would assume joint routing requires. So what I am really
discussing is the scaling limitations that a synched and comprehensive
network view has regardless of how the algorithm is implemented, especially
as the dynamic behavior of the network increases with time.

Dave

> -----Original Message-----
> From:	Mark Stewart [SMTP:[email-masked]]
> Sent:	Friday, October 27, 2000 11:02 AM
> To:	Allan, David [CAR:NS00:EXCH]
> Cc:	alchiu; 'Yakov Rekhter'; ip-optical; mpls; sc; xuyg; yxue
> Subject:	Re: [IP-Optical] Joint Routing was RE: Optical link
> bundling. Was Re:  DraftMinutes From Pittsburgh
> 
> Hi Dave
> 
> Why are we equating joint routing with centralized computation? Few (if
> any) members of the IETF would dispute that centralized computation has
> nasty scaling problems; but I thought we were discussing joint routing.
> 
> Mark
> 
	<snip>

---

From: Mark Stewart <[email-masked]>
Date: Fri, 27 Oct 2000 11:42:24 -0400

Hi Dave

Well I certainly hope no one is proposing to mandate a centralized
mechanism to implement joint routing. It's quite possible to do a source
based solution which simply invokes dykstra twice instead of once and
then has the same scaling and synchronization issues as OSPF.

ciao

mark

David Allan wrote:

>
>
> True, they are separate concepts. Centralzied computing is A solution
> to the problem of ensuring a synchronized and authoriative view of the
> network which is what I would assume joint routing requires. So what I
> am really discussing is the scaling limitations that a synched and
> comprehensive network view has regardless of how the algorithm is
> implemented, especially as the dynamic behavior of the network
> increases with time.
>
> Dave
>
>      Subject:        Re: [IP-Optical] Joint Routing was RE: Optical
>      link bundling. Was Re:  DraftMinutes From Pittsburgh
>
>      Hi Dave
>

---

From: "Frank Hujber" <[email-masked]>
Date: Fri, 27 Oct 2000 14:11:15 -0400

Dave, Mark, et al,

I've been watching this one for a while and I cannot let it go by without offering my viewpoint. Which is...

There ought to be a compromise between the distributed approach and the centralized approach whereby the ingress (or maybe the egress) router has a picture of the topology and from that makes the explicit route. A distributed approach will not assure diverse paths and will force the computation to be delayed until the fault has occurred and some fault analysis algorithm takes some time to specify which link or node to avoid. A fully centralized approach clearly has scaling problems. I agree, keeping the topology picture uniform will be a challenge. If it wasn't it would've been done already. However, consider that the amount of time that a lightpath is likely to exist may be longer than the average datagram. The time constant associated with router updates may be longer as well, so this eases the burden a bit when it comes to updating the topology picture (i.e. the optical link state.)

I've seen hints of this compromise passing by over the past few days, but somehow I think it keeps getting lost in the definitions of "centralized" and "distributed." It just doesn't seem to me like a three-sigma answer is the right one.

Frank Hujber
[email-masked]