Subject: RE: [IP-Optical] RE: Optical link bundling. Was Re: DraftMinutes From Pittsburgh

From: Kireeti Kompella <[email-masked]>
Date: Mon, 23 Oct 2000 13:24:57 -0700 (PDT)

Hi John,

> What's needed is a way for you to ask for a lightpath that's physically
> diverse from one or more other lightpaths, whether or not the other
> lightpaths have the same terminals as the new lightpath.

Yes, that is correct.

> This is done
> routinely at DS3 and (I think) OC-n levels today by PL services like
> AT&T's EDRO (Enhanced Diversity Routing Option).

Are you (or others) proposing the mechanisms to do this in the
UNI/GMPLS framework?

> The heuristics to simultaneously route a number of circuits simultaneously
> subject to diversity constraints essentially require zillions of calls
> to a Dijkstra algorithm and so don't seem to lend themselves to incorporation
> in the control plane.

In the IP world, I see the use for simultaneous set up of a small
number of disjoint paths, basically, a primary and one or more
backups for an LSP.  So, this may not be an issue.  What is the
requirement driving having lots of simultaneous diverse paths in
the telephony world?

> I'd be interested in hearing more about the drivers for your example. I would
> expect that if you want physical diversity you are setting up lightpaths that
> are going to be around for a while.

Yes, but as I said above, I visualize lots of LSPs, each requiring
two or three diverse paths, not hundreds of diverse paths.  So, this
should not be an issue.

> There's a book by Ramesh Bhandari that addresses some of the algorithm issues.
> I don't believe that the heuristics used for services like EDRO are in the
> public domain though.

More's the pity :-)

Kireeti.

PS. BTW, your mail replies are MIME encoded, even when they are
simple ASCII.

---

From: "John Strand" <[email-masked]>
Date: Mon, 23 Oct 2000 18:48:39 -0400

Hi Kireeti,
Comments in-line. Sorry about the MIME encoding ... when I get a
chance I'll check into my options.
John

John Strand
AT&T
Lightwave Networks Research Dept.
100 Schulz Drive, Room 4-212
Red Bank, N.J. 07701-7033
(732)345-3255
[email-masked] 

-----Original Message-----
From: Kireeti Kompella [mailto:[email-masked]]
Sent: Monday, October 23, 2000 4:25 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [IP-Optical] RE: Optical link bundling. Was Re:
DraftMinutes From Pittsburgh

Hi John,

Yes, that is correct.

[JLS Comment] The Carrier Group requirements specify an interface that should
support the necessary information flow - in particular, specify that lambda
n+1 should be diverse from a specified list of existing lambdas. (At present it
doesnt explicitly say these existing lambdas can have different end points. I'm
going to try to get this fixed.) My OIF 2000.109 has additional specific requirements.

[JLS Comment] Large single-customer PL networks. Frequently they have done their own
reliability analysis and come in with a matrix showing which circuits need to be diverse.
There are some examples in the OIF 2000.109 that give a little more information. For
another entirely different example consider a SONET ring: All edges of the ring must
be diverse.

[JLS Comment] I agree - sounds like you're at the easy end of this sort of problem.

More's the pity :-)

Kireeti.

---

From: "S. Chkaravorty" <[email-masked]>
Date: Mon, 23 Oct 2000 20:45:47 -0400

Kireeti,

> Are you (or others) proposing the mechanisms to do this in the

Why is that so important?

> requirement driving having lots of simultaneous diverse paths in

Very simple.  It is an age old practice in all transmission networks to provide
route diversity for failure back-up and peak traffic conditions.