Subject: Query on draft-ietf-mpls-ldp-state-03.txt

From: Suvarna Singh <[email-masked]>
Date: Thu, 12 Oct 2000 14:31:42 +0530

Hi all,
         In draft-ietf-mpls-ldp-state-03.txt under section 3.1.5.2, under

State:	RESPONSE_AWAITED

Event:	LDP Mapping

New State:	ESTABLISHED

Actions:

1) If the LSP is triggered by the local router (Trigger Control Block
Pointer is not zero), send event 'Internal LSP UP'  to the Trigger control
block

Could anyone please explain what this action exactly means....

thanks in advance,
suvarna

Suvarna Singh
Software Engineer
Mindtree House, #88,
Gandhi Bazaar Main Road
Basavangudi
Bangalore-560004
Tel : 6528333-1028

---

From: Eric Gray <[email-masked]>
Date: Thu, 12 Oct 2000 16:09:34 -0700

Suvarna,
 
    There are basically two things that would cause an LSR
to send a Label Request message: either a new label is
required to satisfy a Label Request it has itself received
from another LSR peer or a new label is required based on 
some form of "internal" determination.  An example of an
"internal" determination is if the LSR is the ingress to an
LSP that will be established for Traffic Engineering.  The 
two causes have in common that some event provoked a
need for a new label and closure requires a response to that
event.
 
    If a label was requested to satisfy a Label Request from
another LSR peer (or peers), then the response is to return a 
Label Mapping to that (or those) peer(s).  If the Label Request
was intended to satisfy some "internal" need, then the source
of the triggering event needs to be notified.
 
    Note that the term "internal" is relative to the LSR's state
machine as specified.  The actual event that occurred internally 
may have itself been provoked by an external stimuli (example: 
NMS activity).
 
    Another way to look at it is that the "trigger control block
pointer" may - in some implementations - be a simple pointer
to a specific call-back function that was registered at the time
that the LSP setup was initiated.  This makes the description
general enough that it could apply to almost any cause of LSP
setup - including downstream LSP setup in response to an 
upstream request.  What sorts of "internal" triggers might apply
within an implementation is entirely an implementation issue 
and outside of the scope of the draft.
 
    Hopefully, one of these explanations was helpful.
 
--
Eric Gray

-----Original Message-----
From: Suvarna Singh [mailto:[email-masked]]
Sent: Thursday, October 12, 2000 2:02 AM
To: [email-masked]
Subject: Query on draft-ietf-mpls-ldp-state-03.txt

Hi all, 

State:  RESPONSE_AWAITED 

Event:  LDP Mapping 

New State:      ESTABLISHED 

Actions: 

thanks in advance, 
suvarna 

Suvarna Singh 
Software Engineer 
Mindtree House, #88, 
Gandhi Bazaar Main Road 
Basavangudi 
Bangalore-560004 
Tel : 6528333-1028