Subject: RE: Question about Label Distribution Peers

From: Stephen Su <[email-masked]>
Date: Wed, 4 Oct 2000 18:07:24 -0700

Zaheer, first of all, thanks for the example.
OSPF allows import of routes from other protocols
such as RIP, then why do we need condition 2. It
seems condition 1 already covers this case.

      1. R1's route to X is a route which it learned about via a
         particular instance of a particular IGP, and R2 is a neighbor
         of R1 in that instance of that IGP

-Stephen

-----Original Message-----
From: Zaheer Aziz [mailto:[email-masked]]
Sent: Wednesday, October 04, 2000 5:02 PM
To: Stephen Su; [email-masked]
Subject: Re: Question about Label Distribution Peers

At 04:42 PM 10/04/2000 -0700, Stephen Su wrote:

>Hi all, 

>I have a question in regarding to section 4.1.2.1 of 
>"draft-ietf-mpls-arch-07.txt". Could someone explain (perhaps 
>with an example) the following? 
>
>      2. R1's route to X is a route which it learned about by some 
>         instance of routing algorithm A1, and that route is 
>         redistributed into an instance of routing algorithm A2, and R2 
>         is a neighbor of R1 in that instance of A2 

for example,

X---RIP---R1--OSPF-----R2

R1 learns X via RIP and R1 redistribute that via OSPF to R2. R1 are R2 are
OSPF neighbors.

A1 is RIP
A2 is OSPF in my example

Zaheer

>Thanks, 
>-Stephen

---

From: Eric Rosen <[email-masked]>
Date: Thu, 05 Oct 2000 11:04:30 -0400

Stephen> Zaheer, first of all, thanks for the example.
Stephen> OSPF allows import of routes from other protocols
Stephen> such as RIP, then why do we need condition 2. It
Stephen> seems condition 1 already covers this case.

Stephen> 1. R1's route to X is a route which it learned about via a
Stephen> particular instance of a particular IGP, and R2 is a neighbor
Stephen> of R1 in that instance of that IGP

In  Zaheer's example,  R1 learns  the route  via RIP,  but R1  is not  a RIP
neighbor of  R2.  R1 is an  OSPF neighbor of R2,  but R1 does  not learn the
router via OSPF.  Therefore condition 1 does not hold.