Subject: Question on vpn-ipv4 address format

From: Janardan Ramesh <[email-masked]>
Date: Thu, 26 Oct 2000 11:25:00 -0700

RFC-2547.bis says that format for vpn-ipv4 address
is 8 byte RD + 4 byte prefix. Suresh sent out a
question regarding the prefix length.

In the reply received from Yakov, it said that the
prefix length is endoded as per multiprotocol extensions to
BGP (rfc2858).

My undertanding of the MPLS_REACH_NLRI (based on 2858 and
carrying labels in BGP draft is as follows)

NLRI Len (1 byte), Label (3bytes), NLRI variable.

The draft says that the length includes the length of the label and
the NLRI length.

For the VPN-ipv4 case, the MP_REACH_NLRI will look like

NLRI Len (1byte) = 14, Label (bytes), NLRI Len=prefixlen, 8 byte NLRI + 4
byte prefix.

I feel that this model has deviated from the representation of IP prefix in
traditional
ipv4 BGP.

Should the format for vpn-ipv4 address be as follows?

8 byte RD + 1 byte prefix len + 4 bytes prefix  (with trailing zeros)

What is the current format used both when conveying the information
and storing the routes in the routing table?

Regards
Ramesh

---

From: Yakov Rekhter <[email-masked]>
Date: Thu, 26 Oct 2000 16:47:03 -0700

Janardan,
 
> NLRI Len (1 byte), Label (3bytes), NLRI variable.

Not exactly - the label part may carry one or more labels
(see the carrying labels in BGP draft).

> The draft says that the length includes the length of the label and

yes, as with any TLV-style encoding...

> NLRI Len (1byte) = 14, Label (bytes), NLRI Len=prefixlen, 8 byte NLRI + 4

No, this is not correct. From draft-ietf-mpls-bgp4-mpls-03.txt:

   The Length field indicates the length in bits of the address prefix plus
   the label(s). 
> traditional > ipv4 BGP.

No, the address prefix that is handled by BGP in the BGP/MPLS VPN case
is *not* an IPv4 prefix, but a VPN-IPv4 prefix.

> and storing the routes in the routing table?

I am not sure I understand this question. Please elaborate.

Yakov.