Subject: RE: MPLS/BGP routing question

From: "Metz, E.T." <[email-masked]>
Date: Mon, 02 Oct 2000 16:31:24 +0100

Why would the MP-BGP next-hop change? 

In general this is the address of a logical interface right?, since these
only tend to disappear when deleted, at router failure, or complete router
isolation (which does not seems the case here), I do not see why it should
change. Am I missing something?

cheers,
	Eduard

> -----Original Message-----
> From: GUESDON Herve FTRD/DAC/ISS
> [mailto:[email-masked]]
> Sent: maandag 2 oktober 2000 7:04
> To: 'S.Matsushima'; [email-masked]
> Cc: [email-masked]; [email-masked]'
> Subject: RE: MPLS/BGP routing question
> 
> 
> Hi
> 
> If a network event breaks the MPLS LSP between two PE in a 
> BGP/MPLS VPN
> design, then I agree that the rerouting is an IGP issue. But 
> there is also a
> MP-BGP-MPLS synchronisation issue if this rerouting leads to 
> a change in the
> MP-BGP next hop. The switch to the LSP corresponding to the 
> new MP-BGP net
> hop has to be transparent to the customer VPN traffic.
> 
> Regards
> 
> hervé
> 
> ****************************************************************
> Hervé Guesdon                                    DAC/CPN/RRI
> Research and Development Engineer
> IP Routing and VPN lab
> France Télécom - R&D
> 38-40 rue du Général-Leclerc  
> 92794 Issy Moulineaux Cedex 9  France
> phone : +33.1.45.29.43.74  fax : +33.1.45.29.54.11
> ****************************************************************
> 
> "L'avenir c'est du passé en préparation."
> 
> 
> >-----Message d'origine-----
> >De : S.Matsushima [mailto:[email-masked]]
> >Envoyé : samedi 30 septembre 2000 03:24
> >À : [email-masked]; Satoru Matsushima
> >Cc : [email-masked]
> >Objet : Re: MPLS/BGP routing question 
> >
> >
> >on 00.9.30 0:32 AM, Eric Rosen at [email-masked] wrote:
> >
> >> 
> >> Matsushima> When a  LSP of PE to  PE broken, BGP  has no way 
> >of  LSP broken.
> >> Matsushima> Then, BGP keep  up of VPN routes and VPN  
> >traffic going to black
> >> Matsushima> hole, until LSP available.
> >> 
> >> Matsushima> As a result,  VPN customer can not back up  
> >their traffic to any
> >> Matsushima> link.
> >> 
> >> Matsushima> I think this is one of most seriously problem of 
> >BGP/MPLS VPN.
> >> 
> >> The  situation you  are worried  about is  where there  is  
> >IGP connectivity
> >> between the edges,  but for some reason labeled packets  
> >cannot make it from
> >> one edge to another.
> >
> >Yes, exactly.
> >
> >> I guess we don't really see this as a realistic failure
> >> scenario.  Sure, buggy software could cause this, but 
> >there's a million ways
> >> in which buggy software could cause undetected packet loss.
> >> 
> >
> >I think that LSP failure was caused by not only buggy 
> software but also
> >oparation failure.
> >For example, i) erase a interface as LDP ID ;-< , ii) routes 
> >summarization
> >failure on ospf area,...
> >
> >IMO, BGP which on PE should has some way to know of LSP failure.
> >This is for customer.
> >
> >--
> >Satoru Matsushima
> >
>

---

From: Jesus Rodriguez Stuart <[email-masked]>
Date: Tue, 03 Oct 2000 22:58:55 -0500

Sirs

Question in MPLS/BGP VPN context::
If I have 2 PEs  with 10 CEs  in one of them and 20 in the other. All of CEs
belong to a same IP-VPN.  How can I Reserve Bandwith between the two PEs for
this IP-VPN, also How can I reserve Bandwith for diferent class of service
(Premium, Standard) between the PEs for the IP-VPN.
The same question If we have many VPNs .

Thanks in advance

JRSTUART
Jesus Rodriguez Stuart
Network Planning
Telefonica del Peru
51-1-2104835

---

From: Juha Heinanen <[email-masked]>
Date: Tue, 17 Oct 2000 18:43:41 +0300 (EEST)

> The same question If we have many VPNs .

my answer is to use profiles and conservative admission control instead
of making explicit reservation over the core.  regarding traffic
classes, the packets need to be marked with appropriate diffserv code
points.

-- juha