Subject: RESV session

From: Gaitonde Anandprasanna <[email-masked]>
Date: Sat, 21 Oct 2000 21:56:53 +0530 (IST)

Please let me know the answers to the question asked below.

Either i missed the anserws sent on this mailing list or perhaps no one
replied to the question .

Thanx in advance

Prasanna

---------- Forwarded message ----------
Date: Tue, 26 Sep 2000 11:16:29 -0700 (PDT)
From: jenny li <[email-masked]>
To: [email-masked]
Subject: RESV session 

Hi,

Suppose I have a multipoint-to-point LSPs.

Host1
           LSR      Host3
Host2

Host1 and host2 as ingress node send path message with
different tunnel and LSP ID to Host3, and suppose
Host3 will use SE style to send Resv message back and
assign same label to two senders.

my questions:
1. in session part of Resv message, what content
should be put there, since I have two session between
host1/host2 to host3.
2. usually the content of session in Resv and Path is
the same or not. for example, only have host1 and
host3, and host1 sent path message to host 3, their
content of session in both path and resv message is
the same?

Thanks in advance.

Jenny

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

---

From: David Charlap <[email-masked]>
Date: Mon, 23 Oct 2000 10:11:17 -0400

Gaitonde Anandprasanna wrote:
> Either i missed the anserws sent on this mailing list or perhaps no
> one replied to the question .
> 

This is not legal in MPLS.  Multicast is not specified at this time.

Perhaps you are trying to create two unicast LSPs which share a common
egress router?

> Host1
>            LSR      Host3
> Host2
> 
> Host1 and host2 as ingress node send path message with different
> tunnel and LSP ID to Host3, and suppose Host3 will use SE style to
> send Resv message back and assign same label to two senders.

1: If they use different tunnel IDs, then this is not a multipoint-to-
   point LSP.  You simply have two separate unicast LSPs in two separate
   sessions.

2: Since you have two sessions, they will not share resources with each
   other.  It doesn't matter what reservation style Host3 chooses to
   use.

> my questions:
> 1. in session part of Resv message, what content should be put there,
> since I have two session between host1/host2 to host3.

You can't do this with one Resv message.  You have two sessions. 
Therefore you must send two Resv messages.

> 2. usually the content of session in Resv and Path is the same or not.
> for example, only have host1 and host3, and host1 sent path message to
> host 3, their content of session in both path and resv message is
> the same?

Is there a question in here?  I can't figure out your English.

I think you don't understand how RSVP is supposed to work.

If you want two LSPs to share resources, then they must be in the same
session.  This means they must have the same tunnel egress address, the
same tunnel ID, and the same extended tunnel ID.

If you require two senders to use different sessions, then there is no
way they can possibly share resources.

-- David