Subject: Re: Traffic engineering and RSVP

From: Sudheer Dharanikota <[email-masked]>
Date: Thu, 19 Oct 2000 13:44:37 -0500

Yes sir.. you are missing many things.

TE is mainly used for core. In core nobody in right mind
will do 5 tuple lookup on the the Ip packet :-)

- sudheer

Rajeev Manur wrote:
> 
> see below...
> 
> -----Original Message-----
> From: Sudheer Dharanikota [mailto:[email-masked]]
> Sent: Thursday, October 19, 2000 7:21 AM
> To: Mike Badil
> Cc: [email-masked]
> Subject: Re: Traffic engineering and RSVP
> 
> Mike Badil wrote:
> >
> > Hi
> >
> > I confused  when I read traffic engineering with MPLS.
> >
> > My question is:
> >
> > MPLS is combination of layer 2 swithing and layer 3 routing. Traffic eng.
> is
> > part of layer 3. In MPLS route(LSP) is established in advance according to
> > the constraints. in other word, instead of choosing shortest path, it
> choose
> > the path which satisfy its requirments, and to make link utulization
> better.
> > In order to have done this with MPLS there are some works which say that
> > OSPF,IS-IS can be modified by adding constraint to it.
> >
> > That is clear so far,
> >
> > I wondering that whether we can have those traffic engineering conditions
> be
> > satisfied by other tech.
> >
> > For example; RSVP-Intserv set up route in advance also. If we use extended
> > OSPF,IS-IS etc.algorithm with Intserv-RSVP as we use in MPLS,
> > we can choose the path which satisfy our constraints instead of choosing
> > Shortest path. Link load balancing can be done as in MPLS. So most of
> > traffic engineering requirements will be satisfied.(let don't consider
> > scalibility problem with RSVP now). Or it can work any other technology
> > which use RSVP.
> >
> 
> The problem is in applying filter at every node to make sure your IP
> packet
> is following the selected path. Hence data path becomes slow.
> 
> RAJEEV> I thought almost all the boxes today perform complete packet
> processing at line-rate with or without the application of packet filters. I
> don't see the relevence of the above statment. Am i missing anything..
> 
> - sudheer
> 
> > What am I missing here?
> >
> > _________________________________________________________________________
> > Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.
> >
> > Share information about yourself, create your own public profile at
> > http://profiles.msn.com.

---

From: "Rajeev Manur" <[email-masked]>
Date: Thu, 19 Oct 2000 14:08:51 -0700

see below

-----Original Message-----
From: Sudheer Dharanikota [mailto:[email-masked]]
Sent: Thursday, October 19, 2000 11:45 AM
To: Rajeev Manur
Cc: Mike Badil; [email-masked]
Subject: Re: Traffic engineering and RSVP

RAJEEV> I never said anybody would or would not do 5 tuple lkup in the core.
All i am saying is that your statement "Hence data path becomes slow" does
not make any sense, because as far as i know today's packet processors can
handle this without affecting the line-rate performance..

with regards,
Rajeev.

- sudheer

---

From: David Charlap <[email-masked]>
Date: Thu, 19 Oct 2000 17:35:35 -0400

Rajeev Manur wrote:
> 
> I never said anybody would or would not do 5 tuple lkup in the core.
> All i am saying is that your statement "Hence data path becomes slow"
> does not make any sense, because as far as i know today's packet
> processors can handle this without affecting the line-rate
> performance..

What do you define as "line rate"?

OC-3?  OC-12?  OC-48?  OC-192?  Faster?

And how many ports per switching fabric?  4? 16? 256? more?

No matter how fast the chips in your switching/routing processor can do
5-tuple lookups, there are environments where they are not fast enough.
And these environments are what you typically find in the core of major
networks.

Customers are looking for ever-increasing line rates, and increasing
port densities.  And their demands are increasing faster than the
ability of chip vendors to implement IP routing-table lookups. 
Especially if those lookups involve more than just matching destination
addresses.

-- David

---

From: Bora Akyol <[email-masked]>
Date: Thu, 19 Oct 2000 16:20:45 -0700

I would not jump on this so fast, there is at least one router out there that can
do line rate 5-tuple lookups for many, many rules.

Just because **you** don't know how to do it, doesn't mean it can't be done.

Bora

---

From: Wushao Wen <[email-masked]>
Date: Thu, 19 Oct 2000 17:26:56 -0700 (PDT)

In fact, I think the discussion here missed something on the the basic
operation of the IP network. To send a data packet from a source to a
destination, we need to refer to  two components--the
information carried inside the packet and a routing tabel (or switching
table). Because  the
conventional IP network's routing is based on the destination address, if
we want to route the packet via an explicit path, it is necessary for the
IP header to carry some additional information. IP uses optional header to
carry the explicit route information so that the router inside the network
can process the explicit route request instead of   the
destination-based routing. However, the processing overhead for such
optional header is prohibiting high and it is not a very good solution for
traffic engineering. Without MPLS, evern though we can use OSPF or other
link-state routing protocol to distribute the routing information, and use
the RSVP or other protocols to reserved the network resource, it
can not eliminate the requirement of the data packet to carrry the
explicit route information. Otherwise, the data packet will not follow the
 explicit path. 

MPLS solve this problem by doing label swapping instead  of the
destination-based routing. Therefore, it is possible for a data packet to
use a
very short header to direct the router to send the packet to the
pre-selected route. 

Wushao

---

From: Debanjan Saha <[email-masked]>
Date: Thu, 19 Oct 2000 20:59:40 -0400

> do line rate 5-tuple lookups for many, many rules.

Just curious -- what is the line rate and what does "many, many" stand for? :-)

Regards,
Debanjan

---

From: Sudheer Dharanikota <[email-masked]>
Date: Fri, 20 Oct 2000 09:04:08 -0500

Rajeev:

See below.

> handle this without affecting the line-rate performance..

Yes.. most of the router vendors have to do 5 tuple lookup for
some reason or the other. But the following should be the
considerations.

From data plane point-of-view:

 1. How many look ups do you want to do?
 2. Does other routers in the same domain (or AS) do the same for 
    the traffic (at line rate)?
 3. What are the line rates we are talking about?

From control plane point-of-view:

 1. Does make sense to have the state kept for all these intserv conns?
 2. Do we (being ISPs) have to care about the individual connections
    from the other ISPs?

- sudheer

---

From: Sudheer Dharanikota <[email-masked]>
Date: Fri, 20 Oct 2000 09:10:24 -0500

Good that there are routers who does the 5 tuple lookup 
for 1 million connections at line rate of OC-48 :-)
But do we need them in the core?

- sudheer