Subject: RE: [IP-Optical] RE: Optical link bundling. Was Re: Draft Minutes From Pittsburgh

From: [email-masked]
Date: Fri, 20 Oct 2000 11:43:19 +0100

Hi John,

Thanks for the intelligent replies.  If you disagree with my observations,
I'd be happier if you could give me an explanation as to why though.  My
current thinking is that the peer model is impractical in a multi-client
OTN.  Feel free to explain to me why that thinking is wrong.

Regards,
Darren. 

-----Original Message-----
From: John Drake [mailto:[email-masked]]
Sent: 19 October 2000 18:33
To: [email-masked]'; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]
Subject: RE: [IP-Optical] RE: Optical link bundling. Was Re: Draft
Minutes From Pittsburgh

Whatever

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, October 19, 2000 10:21 AM
To: John Drake; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]
Subject: RE: [IP-Optical] RE: Optical link bundling. Was Re: Draft
Minutes From Pittsburgh

Hi John,

At the risk of sounding repetitous ...

>> There's no reason why the back
>> end couldn't be GMPLS in peer mode

I believe there is a reason.  And I've yet to be convinced otherwise by
anyone.  The way I see it, peer model = single control plane.  Single
control plane = common addressing, signalling, & routing.  Common addressing
= only possible if the OTN has a single client.  This has been explained in
the recent "server layer trails = client layer links" links discussions =>
i.e. common addressing not possible in a multi-client OTN => i.e. peer model
impractical in a multi-client OTN.  I think this fundamental issue has to be
recognised.

Regards,
Darren.

-----Original Message-----
From: John Drake [mailto:[email-masked]]
Sent: 19 October 2000 17:58
To: 'Bala Rajagopalan'
Cc: [email-masked]'; [email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: RE: [IP-Optical] RE: Optical link bundling. Was Re: Draft
Minutes From Pittsburgh

Bala,

I think that there's a big difference between the service interface offered
to a user (aka the front end) and the interface that a service device uses
to attach to the rest of the network (aka the back end).  There's no reason
why the back end couldn't be GMPLS in peer mode even if the front end was
something silly like ATM UNI.

Thanks,

John 

-----Original Message-----
From: Bala Rajagopalan [mailto:[email-masked]]
Sent: Thursday, October 19, 2000 9:42 AM
To: John Drake
Cc: [email-masked]'; [email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: Re: [IP-Optical] RE: Optical link bundling. Was Re: Draft
MinutesFrom Pittsburgh

Hello,

John Drake wrote:

>
>
> For example, a few years ago, one would build an IP service using routers
> mesh connected in an overlay on top of a PNNI  transport network.  This
was
> perceived as an exquisitely painful way of doing things and led directly
to
> the development of MPLS.  I.e., extend the IP control plane to support
> traffic engineering and then have the ATM switches implement MPLS.  This
> eliminates the artificial overlay boundary between IP routers and ATM
> switches.  (On the other hand, there would still be operational benefits
to
> using MPLS to control the ATM switches even if the network owner wished to
> maintain this overlay boundary.)

In the case of IP over optical,
I would just like to add that once you do have an IP-centric control
plane within optical networks, you could have routing between IP and
optical network that in fact supports the overlay model, alleviating the
scalability concerns that arise with IP over ATM model described above.

It's then a question of the coupling between the IP and optical control
planes. This can be as loose or tight as you want, for example, supporting
a UNI that separates the control planes, or the peer model without any
separation.

I do agree that if  you considered other types of clients,  the
peer model constructs don't seem  practical.

regards,

--

Bala Rajagopalan
Tellium, Inc.
2 Crescent Place
P.O. Box 901
Oceanport, NJ 07757-0901
Tel: (732) 923-4237
Fax: (732) 923-9804
Email: [email-masked]

_______________________________________________
IP-Optical mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/ip-optical

---

From: Debanjan Saha <[email-masked]>
Date: Fri, 20 Oct 2000 10:32:00 -0500

Darren,

[email-masked] wrote:
>  My current thinking is that the peer model is impractical 
>  in a multi-client OTN.  

That's my thinking too. Clearly, there are "faithfuls" out there 
who don't agree with this view :-)

Debanjan

-- 
Debanjan Saha                         Phone: 732-923-4264
Senior Network Architect              Fax:   732-923-9804
Tellium Optical Systems               http://www.tellium.com

---

From: "Frank Hujber" <[email-masked]>
Date: Sat, 21 Oct 2000 19:59:24 -0400

Daren, Debjan,

Do they at least agree that the OTN _will_ be multi-client? Or do they think
that each client will own their own OTN?

Frank Hujber
[email-masked]
----- Original Message -----
From: "Debanjan Saha" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Friday, October 20, 2000 11:32 AM
Subject: Re: [IP-Optical] RE: Optical link bundling. Was Re: Draft Minutes
FromPittsburgh