Subject: (Reply) Hi seenu

From: [email-masked]
Date: Thu, 19 Oct 2000 00:04:01 +0900

Hi mohan,

Sorry for a late reply.

Take the case  where an LSR has sent a No_Lbl_Resources notification to the peers that have requested for a label.
When Labels are available the LSR sends first a Lbl_Resources_Available notification and then sends a Label_Mapping msg.
See in this case, instead of sending two messages seperately, y can't u include the Status code ( Lbl_Resources_Available) in the
label mapping msg itself, which takes less time compared to the earlier one (since processing of a msg takes more time than a TLV).
Anyway if an LSR is not ready to handle that tlv it can always ignore it (draft-notifocation msg)

Take one more case : An upstream peer has detected a loop, so first it will send a loop_detected_noti and then sends a Lbl_release msg.
In this case also, u can include Status_tlv in the Lbl_Release msg

So depending on the situation it will reduces the computation.

Hope it will help u.

regards
Seenu

>       In the ldp-11 draft ,it's given that the status TLV
>  can be included in ldp messages which need not be
>  notif.
>      I feel there is a situation like the LSP got preempted,
>   which is a defined new status code, in such case it's helpful.
  
>      But do u think it's helpful in adding the status TLV 
> which ceratinly increases the processing at each node.

---

From: Gaitonde Anandprasanna <[email-masked]>
Date: Fri, 20 Oct 2000 22:44:34 +0530 (IST)

I wanted to know whether  the messages   like Label withdraw/ Label
release are as spcified by LDP or are the present in RSVP-TE also.

The same case for No_Lbl_Resources notification message.

Thanks in advance
Pras

                     _____________________________                  
                   _ |ANANDPRASANNA GAITONDE     | _ 
                  / )|COMP. SCIENCE & AUTOMATION |( \
                 / / |D-7,IISc HOSTEL            | \ \
                / /  |INDIAN INSTITUTE OF SCIENCE|  \ \
              _( (_  |BANGALORE-560012.          |  _) )_
              (((\ \>|_/->___________________<-\_|</ /)))
              (\\\\ \_/ /LAB Ph.(080)3092906  \ \_/ ////)
               \       /HOSTEL Ph.-            \       /  
                \    _/     (080)3092452        \_    /     
                /   /-----------------------------\   \                  
               /  Email Id-                            \ 
              /      [email-masked]         \
	     ---------------------------------------------
            -----------------------------------------------

--------------------------------------------------------------------------------
		
*************************************************************************  
| | | | __ ___   _____     __ _    _ __ (_) ___ ___     __| | __ _ _   _
| |_| |/ _` \ \ / / _ \   / _` |  | '_ \| |/ __/ _ \   / _` |/ _` | | | |
|  _  | (_| |\ V /  __/  | (_| |  | | | | | (_|  __/  | (_| | (_| | |_| |
|_| |_|\__,_| \_/ \___|   \__,_|  |_| |_|_|\___\___|   \__,_|\__,_|\__, |
*************************************************************************