Subject: RE: VPN solution

From: Barry Hass <[email-masked]>
Date: Thu, 26 Oct 2000 08:15:38 -0400

Darren,

Could you elaborate on what you think are the relative
strengths and weaknesses of L2 and L3 VPNs, and what
yout think are the most appropriate uses of each?

Thanks.

> -----Original Message-----
> From: Darren Patterson [mailto:[email-masked]]
> Sent: Thursday, October 26, 2000 6:14 AM
> To: Rob Jaeger; Juan Diego Otero
> Cc: Wenbo Sheng; MPLS WG
> Subject: RE: VPN solution
> 
> 
> I would have argued that l2 and l3 vpns would co-exist on any 
> providers
> network and be sold and used where appropriate. i dont think these are
> mutually exclusive, but rather complimentary...the real 
> arguement is on the
> model used for l3 vpn's.
> 
> regards
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On Behalf Of Rob
> > Jaeger
> > Sent: Wednesday, 25 October 2000 9:40 PM
> > To: Juan Diego Otero
> > Cc: Wenbo Sheng; MPLS WG
> > Subject: Re: VPN solution
> >
> >
> >
> > Juan/Wenbo,
> >
> > An alternative to draft-rosen-rfc2547bis is l2vpn as described in
> > draft-kompella-mpls-l2vpn-01.txt .   One advantage of this 
> method is the
> > separation of administrative responsibilities.  In MPLS L2VPNs,  the
> > service provider does not participate in the customer's L3 
> routing. This
> > may provide better stability than L3 VPNs.
> >
> > Rob
> >
> >
> > On Wed, 25 Oct 2000, Juan Diego Otero wrote:
> >
> > > Hi Wenbo,
> > >
> > > The method to build VPNs most discussed (and that makes me think
> > > that is the most popular) in this mailing list is
> > > the BGP/MPLS model explained in  draft-rosen-rfc2547bis-02.txt
> > . Personally I
> > > think this method has a lot of advantages such as scalability,
> > security, manageability
> > > and use of private addressing. Some of this advantages
> > (specially scalability) have been
> > > discussed in this mailing list.
> > >
> > > Best Regards,
> > >
> > > Diego
> > >
> > > Wenbo Sheng wrote:
> > >       HI,
> > >
> > >       Assuming my customer need to create a VPN, I just want to
> > know which solution is better - using
> > >       MPLS-VPN or virtual routers? Which solution is/will be
> > more popular in creating a VPN?
> > >
> > >       Thanks in advance,
> > >
> > >       W.S.
> > >
> > >
> > > --
> > > http://www.geocities.com/diego_otero/
> > >
> > >
>

---

From: "Darren Patterson" <[email-masked]>
Date: Thu, 26 Oct 2000 23:15:06 +0800

L2 - simple transport from service providers perspective, does not require
knowledge of customer ip addressing or routing topology, also means less
provisioning overhead in the core as the lsp's are dynamically created
unlike n^2 issues. from the customer's perspective not much over their
traditional existing fr / atm / ll type services ( i might be overlooking
something here).

L3 - from the service providers side the ability to offer enhanced ip
services which provides qos capabilites to the customer and can provide
things like differential billing and sla's based upon these types of
services. so for the provider incremental revenues, whilst lowering the
costs of operation as it also uses dynamic creation of the lsp's in the core
just like L2. more importantly from the customers perspective they are
getting a tailored service which can provide integrated services and
guarantees whilst lowering their cost. basically a network service built for
their network traffic type - ip (assuming this is their network traffic type
and they are not running other types of protocols).

these are just a few of the top of my head quickly.

regards

> From: Barry Hass [mailto:[email-masked]]
> Sent: Thursday, 26 October 2000 8:16 PM
> To: Darren Patterson; Rob Jaeger; Juan Diego Otero
> Cc: Wenbo Sheng; MPLS WG