Subject: Route Exchange between CE and PE

From: "Wayne" <[email-masked]>
Date: Mon, 30 Oct 2000 17:43:18 +0800

Hi,

I am reading the RFC2547bis and came up with a question for route exchange between the CE and PE. Suppose there are 2 CEs belongs to different VRFs and connect to the same PE. RIP is used to exchange routing. Though there is 2 different VRFs in the PE, would the RIP process in it re-advertise the learned routes to the other CE in another VPN? The RFC also suggests other routing options. Other the static route implementation, I cannot find an answer for it. But I may miss some important point while reading. Could anyone show me how this can be solved?

Thanks,
Wayne

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 30 Oct 2000 22:38:46 -0800

> Wayne wrote:
> 
> Hi,
> 
> I am reading the RFC2547bis and came up with a question for route
> exchange between the CE and PE. Suppose there are 2 CEs belongs to
> different VRFs and connect to the same PE. RIP is used to exchange
> routing. Though there is 2 different VRFs in the PE, would the RIP
> process in it re-advertise the learned routes to the other CE in
> another VPN?

Not really. RIP on PE-CE1 would be isolated by implementation with the
RIP PE-CE2. Re-advertising or inter-vrf importing is done via bgp based
on the ext comunities values.

> The RFC also suggests other routing options. Other the
> static route implementation, I cannot find an answer for it. But I may
> miss some important point while reading. Could anyone show me how this
> can be solved?

You can in fact implement any IGP between PE-CE. All you need to make
sure that the routes learned by one context will be isolated by another
inside your PE.

R.

---

From: Rajesh Saluja <[email-masked]>
Date: Tue, 31 Oct 2000 10:57:39 -0500

> on the ext comunities values.

In the above example, If these two VRFs have at least one common VPN,
shouldn't RIP readvertise the routes learnt from one CE to other CE?

Thanks,
Rajesh