Subject: RE: Optical link bundling. Was Re: Draft Minutes From Pittsburgh

From: [email-masked]
Date: Tue, 17 Oct 2000 16:55:52 -0500

Keereti,

I believe what Frank is talking about is not merely the separation
of the control channel(s) from the data channels, but rather a more
general notion of non-associated out-of-band signaling.

-Vishal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, October 17, 2000 5:30 PM
> To: [email-masked]; [email-masked]
> Subject: Re: Draft Minutes From Pittsburgh
> 
> 
> Hi Frank,
> 
> > My perspective is naive, but as I understand it, the 
> current proposals
> > require a control link to "overlay" an optical link 
> exactly, and for the
> > control path(s) to be associated with groups of optical 
> links according to
> > their characteristics (i.e. bandwidth - OC-48 vs OC-192).
> 
> > Some of us in the optical world, growing from the telephony 
> (SONET/SDH)
> > world do NOT assume that this overlay occurs. We prefer to offer the
> > provider (in my case, my customer) to have management 
> networks that are not
> > the same as the transport networks. This is because in-band 
> signaling is not
> > yet available (though OIF is working on it) and because 
> providers may not
> > want to dedicate a wavelength to relatively low-speed 
> management traffic.
> 
> We have the notion of separate control channels and data paths in many
> drafts.  See draft-ietf-mpls-lmp-00.txt for a brief description.
> 
> Kireeti.
>

---

From: Yangguang Xu <[email-masked]>
Date: Tue, 17 Oct 2000 18:16:39 -0400

Hi,

This general notion is correct and it is against the very basic assumption of IP
network where control traffic is mixed together with data traffic. 

In circuit switched network, there should be no assumption about the relation of
data plane topology and control plane topology at all. For two NEs to talk, you
don't need a dedicated control link. You only need a TCP session for a NE pair,
not only a whatever bundle. 

Cheers,

Yangguang

---

From: Alex Zinin <[email-masked]>
Date: Wed, 18 Oct 2000 09:03:17 -0700

Yangguang,

I wouldn't oversimplify this.
Don't forget about IGPs and signaling.

-- 
Alex Zinin

---

From: Yangguang Xu <[email-masked]>
Date: Wed, 18 Oct 2000 13:13:39 -0400

Alex,

I wasn't simplifying it. Indeed, I make it more complicated and generic. IGP and
signaling shouldn't make invalid assumptions either. Circuit switched transport
network is different from IP network. 

Yangguang

---

From: Alex Zinin <[email-masked]>
Date: Wed, 18 Oct 2000 10:29:41 -0700

Yangguang,

> network is different from IP network. 

Do you mind explaining how you expect the two components to work over
a TCP connection btw non-adjacent routers?

Thanks,

Alex.

---

From: Yangguang Xu <[email-masked]>
Date: Wed, 18 Oct 2000 14:05:10 -0400

Alex,

When using independent application to distribute optical topology, a TCP session
is enough.

If we want to apply OSPF directly, we can set up a FA-LSP between two NEs that
are adjacent in their transport(data) plane but not adjacent in their control
plane.

Either way, you don't need a dedicated physical control channel.

Thanks,

Yangguang

---

From: Alex Zinin <[email-masked]>
Date: Wed, 18 Oct 2000 11:11:20 -0700

Yangguang,

> When using independent application to distribute optical topology, a TCP session

Got it.
It was a more generic comment.

> are adjacent in their transport(data) plane but not adjacent in their control

The purpose of FAs is exactly the opposite---announce an LSP as a
topological entity without establishing a control adjacency over
it. I believe you mean just an LSP.

Thanks,

Alex.