Subject: RE: route exchange between CE and PE routers ...

From: Peng Li <[email-masked]>
Date: Fri, 18 May 2001 15:26:16 -0700

Hi elwin,
  I think you can always create a static route for bgp neighbor address to
setup bgp connection between PE and CE routers.  It doesn't matter CE is in
a transit VPN or in a stub VPN.   

cheers,
peng

-----Original Message-----
From: Elwin Eliazer [mailto:[email-masked]]
Sent: Friday, May 18, 2001 2:42 PM
To: [email-masked]; [email-masked]
Subject: route exchange between CE and PE routers ...

Hi,

RFC2547bis suggests the use of EBGP between
CE and PE routers; In this case, how is the EBGP
peering setup if the CE router is with a local
(VPN) IP address?

Your response would be appreciated.

- Elwin.

=====
-------
Elwin Stelzer Eliazer
Corona Networks
-------

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - buy the things you want at great prices
http://auctions.yahoo.com/

---

From: "Alexander Marhold" <[email-masked]>
Date: Sat, 19 May 2001 08:04:30 +0200

E-BGP is used in a VRF-specific context, which means:
a) the route to teh neighbor is looked up in the VRF-specific routing table
b) all prefixes received will gop into the vrf-specific BGP-table
c) the BGP scan-task will synchronize this VRF-specific BGP table with the
vrf-specific routing table
d) the content of the vrf-specific BGP-table will be advertised by MP-BGP as
VPNV4 route by prepending the RD defined for that vrf.

Therfore you
a) should have the PE-CE link inside that vrf ("ip vrf forwarding
<vrf-name>")
b) you should either use the CE-link address as neighbor address
OR
define a loopback within that vrf
specify the CE loopback as neighbor
define neighbor x.x.x.x update-source loopback y
define neighbor x.x.x.x ebgp-multihop 3

In case that you also need global e-BGP connectivity (additionally) between
PE and CE
you need to create a second Layer-3 virtual interface (physical, or
subinterface or tunnel) and this one should not put into a vrf, and then you
can connect via normal e-BGP to that CE

regards

Alexander Marhold
Senior Consultant
PROIN

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Peng Li
Sent: Saturday, May 19, 2001 12:26 AM
To: 'Elwin Eliazer'; [email-masked]
Subject: RE: route exchange between CE and PE routers ...

Hi elwin,

cheers,
peng

-----Original Message-----
From: Elwin Eliazer [mailto:[email-masked]]
Sent: Friday, May 18, 2001 2:42 PM
To: [email-masked]; [email-masked]
Subject: route exchange between CE and PE routers ...

Hi,

- Elwin.

=====
-------
Elwin Stelzer Eliazer
Corona Networks
-------

---

From: Elwin Eliazer <[email-masked]>
Date: Sat, 19 May 2001 20:54:08 -0700 (PDT)

Thanks Alexander and Peng for the details.
Is it a must to have this CE loopback address to be
global? The concern that i have is when it can be
a local IP address.

regards,
Elwin.

=====
-------
Elwin Stelzer Eliazer
Corona Networks
-------

---

From: "Alexander Marhold" <[email-masked]>
Date: Sun, 20 May 2001 08:06:46 +0200

>global? The concern that i have is when it can be

No, the CE address is within the VPN (vrf) and therefore local
The PE has to have the neighbor y.y.y.y next-hop-self (on the MP-IBGP
connections)
in order to change the next-hop attribute to be globally reachable.
Otherwise you would see a next-hop-inaccessible on all other PEs.
So only the PE?s loopback address needs to be global, but this address is
also the address for the iBGP connection in the core.

regards
Alexander Marhold
PROIN