Subject: BGP/MPLS VPN PE LSR

From: Shahram Davari <[email-masked]>
Date: Wed, 9 May 2001 12:16:14 -0700

Hi,

In an BGP/MPLS VPN scenario if a CE router sends an MPLS packet rather than an IP packet to a PE router, the PE router should still push 2 labels. My question is, should the PE router swap the customer's label too or leave it unchanged?

Yours,
-Shahram

---

From: Gopal Jayaraman <[email-masked]>
Date: Wed, 09 May 2001 14:54:12 -0500

shahram,

the PE that is connected to the final CE, uses the second label
to identify which CE/CE port it has to be deliverd. The whole mpls
header is trimmed before delivering to CE.

Once the CE port is identified, packet is deliverd as raw IPv4 to
the CE by the PE. The second label is not looked up by any of the
intermediate P nodes. PE is typically a egress node.

-Gopal.

---

From: "Vipul Sharma" <[email-masked]>
Date: Wed, 9 May 2001 16:25:58 -0400

Guys,
	What is a PE and CE router?? .... Thanx.

Vip

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Gopal
Jayaraman
Sent: Wednesday, May 09, 2001 3:54 PM
Cc: [email-masked]'
Subject: Re: BGP/MPLS VPN PE LSR

shahram,

-Gopal.

Shahram Davari wrote:
>
> Hi,
>
> In an BGP/MPLS VPN scenario if a CE router sends an MPLS packet rather
than an IP packet to a PE router, the PE router should still push 2 labels.
My question is, should the PE router swap the customer's label too or leave
it unchanged?