Subject: MPLS over Ethernet and SONET

From: Ian Bartley <[email-masked]>
Date: Wed, 16 May 2001 18:44:27 +0100

Can anyone help,

I'm trying to find out about sending MPLS over an Ethernet
or SONET network, I understand that a shim header should
be used to pass the MPLS label. But I'm enquiring about the
Layer2 information needed to send over the appropriate media.

I'm wondering how can the destination MAC address be
determined, surely we want to avoid using the next hop IPv4
address and resolving it to a dest mac. This would mean
additional lookups.
Does the destination MAC need to be established when the
LSP is set up and should it be places in the OutSegmentEntry
as described in draft-ietf-mpls-lsr-mib-07.
Is there an etherent MIB anywhere that describes exactly what is
necessary for the ethernet interfaces?

Also if anyone knows of any similar MIB for MPLS over SONET
please let me know,

Thanks
Ian

---

From: Mohit Misra <[email-masked]>
Date: Thu, 17 May 2001 10:20:29 +0530

Hi,
You need to have L2 information association with the NHLFE(s) in the ILM or
FTN. This is done during LSP Setup when you send label request to the FEC
Nexthop. You need to arp for next hop before sending it to the label request
. Once the Destination MAC 
address is known, it could be linked to next hop entries in NHLFEs and next
time it is directly picked up from there for all the
labeled/unlabeled packets. I guess you can keep this information with
outsegment Entry. I am not sure of SONET though.
							/Mohit

NetBrahma Technologies
www.netbrahma.com

> ----------
> From: 	Ian Bartley[SMTP:[email-masked]]
> Sent: 	Wednesday, May 16, 2001 12:44 PM
> To: 	[email-masked]
> Subject: 	MPLS over Ethernet and SONET
> 
> Can anyone help,
>