Subject: Parameters in LDP entity table

From: Felix Chang <[email-masked]>
Date: Sun, 6 May 2001 15:57:29 +0800

hi,everyone

	I am confused by some parameters in the LDP entity table.
	Suppose there are several kinds of mpls-capable interfaces(eg.ATM-based, fr-based) in a LSR, it should use per interface label space. So it has several LDP entities. Is that right? In these entities, are the values of some parameters such as mplsLdpEntityLabelDistributionMethod, mplsLdpEntityLabelRetentionMode, the same?

	Best regards!
                        Felix Chang
                          [email-masked]

---

From: "Hans Sj?strand" <[email-masked]>
Date: Mon, 7 May 2001 11:07:28 +0200

It's true that for many ATM or FR based interfaces uses the
encap from rfc3034 or rfc3035. It's also true that those use
per intreface label space. In that case you have several
entities. distribution and retention method isn't neccesary
the same over the label switch even though it's defently the
most common case.

from RFC 3037 LDP Applicability, section 3
   Downstream on Demand distribution with conservative label retention
   and ordered control is appropriate in situations where labels are a
   relatively scarce resource that must be conserved, and Downstream
   Unsolicited distribution with liberal label retention and independent
   control is appropriate where labels are plentiful and need not be
   carefully conserved.  However, the protocol permits other
   combinations of distribution method, label retention mode and control
   mode, including hybrid variants of them.

Regards
/// Hasse

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of Felix Chang
> Sent: den 6 maj 2001 09:57
> To: mpls_maillist
> Subject: Parameters in LDP entity table
>
>
> hi,everyone
>
>       Suppose there are several kinds of mpls-capable
> interfaces(eg.ATM-based, fr-based) in a LSR, it should use per
> interface label space. So it has several LDP entities. Is that
> right? In these entities, are the values of some parameters such
> as mplsLdpEntityLabelDistributionMethod,
> mplsLdpEntityLabelRetentionMode, the same?
>
>
>       Best regards!
>                         Felix Chang
>                           [email-masked]