Subject: RE: a simple question!

From: Sasha Vainshtein <[email-masked]>
Date: Mon, 7 May 2001 16:25:37 +0200

I see another reason: it makes support of the hop-by-hop forwarding
application 
(i.e., forwarding which follows the routes buit by the IGP) very easy.

______________________________________________
With best regards,
Sasha Vainshtein
mailto: [email-masked]
phone: +972-3-7659993 (office)
fax:      +972-3-6487779 (office)

>>-----Original Message-----
>>From: Guangzhi Li [mailto:[email-masked]]
>>Sent: Monday, May 07, 2001 3:16 PM
>>To: [email-masked]
>>Cc: [email-masked]
>>Subject: Re: a simple question!
>>
>>
>>Hi,
>>
>>I can figure out one reason:
>>
>>(1) It is convenient to achieve LSP merging, i.e., to 
>>generate a destination
>>rooted tree.
>>
>>--- guangzhi
>>
>>[email-masked] wrote:
>>
>>> hi!
>>>      why was downstream label assignment chosen in MPLS 
>>over upstream label
>>> assignment as is the case with generalised MPLS? Is there 
>>any specific
>>> advantage/constraint posed by the downstream label 
>>assignment method?
>>>
>>> regards
>>> sumit
>>

---

From: "Peter Ashwood-Smith" <[email-masked]>
Date: Mon, 7 May 2001 10:37:55 -0400

Its strictly a performance thing. For pure optical switches it takes time to
position a mirror, bubble, tune a laser etc. If you allow for upstream label
assignment it means that by the time the signaling has arrived all the way
downstream, most of the data path is already in place. 

In 'traditional' MPLS the labels are in-band and programming the hardware to
use them is effectively instantaneous so a downstream mode seems more
rational since it is the downstream that really has to worry about the
availability of those labels.

Cheers,

Peter Ashwood-Smith 

	-----Original Message-----
	From:	[email-masked] [SMTP:[email-masked]]
	Sent:	Sunday, May 06, 2001 11:57 PM
	To:	[email-masked]
	Subject:	a simple question!

	hi!
	     why was downstream label assignment chosen in MPLS over
upstream label
	assignment as is the case with generalised MPLS? Is there any
specific
	advantage/constraint posed by the downstream label assignment
method?

	regards
	sumit