Subject: FEC: Address Prefix and Host Address

From: "Anil Gunturu" <[email-masked]>
Date: Mon, 30 Apr 2001 23:33:06 -0700

RFC 3036 defines the following types of FECs
"
      1. Address Prefix.  This element is an address prefix of any
         length from 0 to a full address, inclusive.

      2. Host Address.  This element is a full host address.
"

Isn't host address a special case of Address Prefix where the length is full
address length (IPV4 = 32)? Especially, because the RFC indicates that
length is from 0 to a full address.

Thanks,
-Anil

---

From: [email-masked]
Date: Tue, 1 May 2001 19:19:13 +0530

Anil,

Let the network topology is like this

          mpls domain
Router A--------------------------Router B---------host C

Let there comes a unlabeled packet at the ingress router A for the destination
host C.
Lets assume

 1. there is a routing table entry in the router A for the host C, specifying
the next hop as router B.
 2. there is no LSP for the host C in the router A.
 3. there is a LSP between router A and router B.

Now two cases arises

1. The LSP between router A and router B is using address prefix which is a full
address of router B. Then router A will forward the datagram on the LSP between
A and B, as is written in RFC 3036

"If it is known that a packet must traverse a particular egress
         router, and there is an LSP which has an Address Prefix FEC
         element which is an address of that router, then the packet is
         mapped to that LSP.  The procedure for obtaining this knowledge
         is beyond the scope of this document."

2. The LSP between router A and router B is using host address to identify
router B. Then router A may not send the datagram on the LSP between A and B, as
is written in RFC 3036.

"A packet which does not match a particular Host Address FEC
         element may not be sent on the corresponding LSP, even if the
         Host Address FEC element identifies the packet's egress router."

pls correct me if i am wrong.
Regards
Mohit Goel

"Anil Gunturu" <[email-masked]> on 05/01/2001 12:03:06 PM

Please respond to [email-masked]

To:   [email-masked]
cc:    (bcc: Mohit Goel/HSS)

Subject:  FEC: Address Prefix and Host Address

Thanks,
-Anil