Subject: Inputs to get the label

From: Khuzema Pithewan <[email-masked]>
Date: Fri, 11 May 2001 17:06:55 +0530

Hi,

what are the parameters other than LABEL_REQUEST object that RSVP-TE should
pass to MPLS to get a LABEL?

draft-ietf-mpls-rsvp-lsp-tunnel-08, while discussing the handling of LABEL
object in Resv Messages downstream, says 

"A node is expected to send a Resv message before its refresh timers expire
if the contents of the LABEL object change." 

my query is how can a LABEL object change in LSR and how will RSVP come to
know about that.

Khuzema.

---

From: Bhupesh Bajaj <[email-masked]>
Date: Fri, 11 May 2001 17:25:24 +0500

hi,
i believe that , as MPLS is supposed to do a mapping 
between Labels and FEC's , so In the "Resv" message 
the RSVP - TE should pass "FEC" to MPLS.

as FEC is the only thing on which the MPLS bases its 
label assignment/ mapping.

correct me if i am wrong,
thanks and regards,
bhupesh

-----Original Message-----
From: Khuzema Pithewan [mailto:[email-masked]]
Sent: Friday, May 11, 2001 5:07 PM
To: [email-masked]'; [email-masked]'
Subject: Inputs to get the label

Hi,

Khuzema.

---

From: Khuzema Pithewan <[email-masked]>
Date: Fri, 11 May 2001 17:26:44 +0530

Hi,

FEC is a very generic term, but what are the parameters should be passed as
FEC to MPLS to get the label.

Khuzema.

> ----------
> From: 	Bhupesh Bajaj
> Sent: 	Friday, May 11, 2001 5:55 PM
> To: 	Khuzema Pithewan
> Cc: 	[email-masked]
> Subject: 	RE: Inputs to get the label
> Importance: 	High
> 
> hi,

---

From: Khuzema Pithewan <[email-masked]>
Date: Fri, 11 May 2001 17:55:09 +0530

Hi,

RSVP-TE path messages does not carry an object named FEC explicitly, but
other parameters like LABEL_REQUEST, LSP ID, Tunnel Id, Flow Spec etc..are
there, and I am wondering if these parameters can be used to get LABEL from
MPLS.

Khuzema.

> ----------
> From: 	Bhupesh Bajaj
> Sent: 	Friday, May 11, 2001 6:21 PM
> To: 	Khuzema Pithewan; [email-masked]
> hi ,
> as far as i am aware ..FEC itself is a number.
> and its not that there are parameters to FEC ,
> the FEC itself is calculated having different considerations
> of QoS , TE , Administration and link contraints.so once the 
> FEC is decided , the labels are mapped directly on the basis of FEC
> 
> so as far as your first question is concerned , my opinion is 
> that RSVP -TE should send FEC( which is nothing else , just a number or
> variable)
> , to get the label mapping for That FEC which has been calculated in
> various
> above said paraments.
> 
> thanks and regards
> bhupesh
> 
> 
> Sent: Friday, May 11, 2001 5:27 PM
> To: [email-masked]