Subject: Label Withdraw Message !!

From: Manoj Dutta <[email-masked]>
Date: Thu, 24 May 2001 05:07:52 -0700

Hi,

According to RFC 3036 section A.1.5  LWd.7, a recognize new FEC event is
generated when LSR is using
downstream on demand with independent control.  Lets consider a scenario
where LSR A gets withdraw msg
from LSR B.

1) What if the LSR B is not  a next hop (according to routing table
entries)? Does LSR A still need to send label request to this LSR B (a
consequence of LWd.7)?

2) Also, does LSR A need to send mappings again to all other relevant
peers (again consequence of LWd.7). If it does that, will it use
InitAttributes as the label mapping attributes ?  I think LSR A should
not be resending the mappings again.

Thanks in advance
manoj

---

From: Eric Gray <[email-masked]>
Date: Thu, 24 May 2001 09:31:20 -0400

Manoj,

You wrote:

> generated when LSR is using downstream on demand with independent control.
> Lets consider a scenario where LSR A gets withdraw msg from LSR B.
>

You need to consider that the procedures are executed serially
and completely.  As has been stated previously, the procedures
in the Appendix of the LDP specification are not intended to be
a complete computer program.

Hence, you should consider that - if a label was previously
retained from LSR B because it was the next hop, LSR B is
no longer the next hop and this may be the reason why LSR
B is withdrawing the label - then a new next hop procedure
has already been called (or will be called soon).  Thinking
about the procedures in this way, you should realize that -
if LSR A has retained a label from LSR B - it is because
LSR A wants to have a label from LSR B.  This would be
the case if LSR B is the next hop for the FEC in question,
but it would also be the case if LSR A is using liberal label
retention.  Without spending too many seconds on whether
or not it really makes sense to combine DoD, liberal label
retention and independent control - if you are using this
combination, then you have to request a new label from any
downstream peer any time the downstream peer withdraws
one.  This would be the case whether or not the downstream
peer is the current next hop or not.

> not be resending the mappings again.

And it will not (theoretically, at least) if it is in DoD.  This
is not guaranteed, however likely it is to be true, because it
is possible for an LSR to be using DoD distribution WRT a
downstream peer and DU distribution WRT an upstream
peer.  However, again, the procedures are not a complete
computer program and an implementer may have to use some
degree of judgement.

> manoj

Hope this helps,

--
Eric Gray

---

From: Chris Kuszmaul <[email-masked]>
Date: Thu, 24 May 2001 10:52:16 -0700

Regarding your first question:
   When LSR A gets a label withdrawal from B:
   If A is performing liberal label retention, then it is not unreasonable
to request a new label of B, even if B is not presently the next hop from A.
The label for the FEC on an LSP from A to B remains of interest should the
next hop change - indeed, in this retention mode, B must have at one time
been the next hop. If I were implementing for sake of efficiency (of the
network) then I would detect the case where A has conservative label
retention at LWd.7, and anticipating that A will not retain the label
mapping it is about to request, would not actually request it. But,
requesting it does not appear to give *incorrect* behavior, just
inefficient.

Regarding your second question:

  I am not sure where it is that you think new (possibly unnecessary) label
mappings are generated as a result of LWd.7 - in the Recognize new FEC
procedure (A.1.6), or in the loop demarked by LWd.8-LWd.12.

 In the new FEC procedure, the only loops over the peers happen in
advertisement/retention modes that would preclude ever reaching LWd.7

 In the loop that follows LWd.7, it does not appear that any label mappings
are made. Further, LWd.7 need not be reached, and its result do not effect
whether LWd.8 and onward are performed.

CLK

---

From: Chris Kuszmaul <[email-masked]>
Date: Thu, 24 May 2001 11:03:11 -0700

I miswrote in one spot that I noticed:

> next hop change - indeed, in this retention mode, B must have at one time

                  should read      ...in this ADVERTISEMENT mode...

---

From: Eric Gray <[email-masked]>
Date: Thu, 24 May 2001 19:22:39 -0400

Chris,

    Label advertisement roles are not platform wide (if they
were they MUST also be MPLS domain wide).  The fact
that an LSR is using DoD with respect to a (downstream)
LSR peer, does not mean it would not be using DU label
advertisement mode with respect to one or two (upstream)
LSR peers.

    See my earlier reply yo Monoj on this thread.

--
Eric Gray