Subject: RE: BGP/MPLS VPN PE LSR

From: Shahram Davari <[email-masked]>
Date: Wed, 9 May 2001 13:01:40 -0700

Hi Gopal,

But I was talking of having 3 labels. The bottom most label belonging to the customer, the second label being the VPN label and the top label being the MPLS routing label. Does the PE swap the bottom most label?

-Shahram

> -----Original Message-----
> From: Gopal Jayaraman [mailto:[email-masked]]
> Sent: Wednesday, May 09, 2001 3:53 PM
> To: Shahram Davari
> Subject: Re: BGP/MPLS VPN PE LSR
> 
> 
> shahram,
> 
> the PE that is connected to the final CE, uses the second label
> to identify which CE/CE port it has to be deliverd. The whole mpls
> header is trimmed before delivering to CE.
> 
> Once the CE port is identified, packet is deliverd as raw IPv4 to
> the CE by the PE. The second label is not looked up by any of the
> intermediate P nodes. PE is typically a egress node.
> 
> 
> -Gopal.
> 
> Shahram Davari wrote:
> > 
> > Hi,
> > 
> > In an BGP/MPLS VPN scenario if a CE router sends an MPLS 
> packet rather than an IP packet to a PE router, the PE router 
> should still push 2 labels. My question is, should the PE 
> router swap the customer's label too or leave it unchanged?
> > 
> > Yours,
> > -Shahram
>

---

From: Shahram Davari <[email-masked]>
Date: Wed, 9 May 2001 13:31:53 -0700

PE: Provider Edge Router
CE: Customer Edge Router

> From: Vipul Sharma [mailto:[email-masked]]
> Sent: Wednesday, May 09, 2001 4:26 PM
> To: 'Gopal Jayaraman'
> Cc: [email-masked]'
> Subject: RE: BGP/MPLS VPN PE LSR
> 
> 
> Guys,
> 	What is a PE and CE router?? .... Thanx.
> 
> Vip
> 
> From: [email-masked] [mailto:[email-masked]]On Behalf Of Gopal
> Jayaraman
> Sent: Wednesday, May 09, 2001 3:54 PM
> Cc: [email-masked]'
> packet rather
> than an IP packet to a PE router, the PE router should still 
> push 2 labels.
> My question is, should the PE router swap the customer's 
> label too or leave
> it unchanged?
> >
> > Yours,
> > -Shahram
>

---

From: Narayanan Vidya-CVN065 <[email-masked]>
Date: Wed, 9 May 2001 17:13:39 -0500

I would imagine that to be dependent on the VPN implementation. If the CE and PE routers actually exchange label information, then, I would imagine the label to be swapped. Otherwise, if labels are exchanged independently among PE routers (iBGP peers)and among CE routers (possibly through the PE routers), then, there would be 3 labels in the scenario you described. To my knowledge, MPLS capable CE devices have not been addressed much at all, although that is mentioned as a possibility in the VPN drafts. 

-Vidya

> From: Shahram Davari [mailto:[email-masked]]
> Sent: Wednesday, May 09, 2001 2:16 PM
> To: [email-masked]'
> Subject: BGP/MPLS VPN PE LSR
> 
> 
> Hi,
>