Subject: RE: BGP/MPLS VPN PE LSR

From: jim guichard <[email-masked]>
Date: Mon, 14 May 2001 09:35:21 +0100

Sasha,

At 11:03 14/05/2001 +0200, Sasha Vainshtein wrote:
>Regarding the Carriers Carrier model:
>My assumption is that in this model the label on the packet
>sent by the upstream CE router to its appropriate  PE has been assigned
>(to some FEC)

your assumption is not correct. The label that the CE will use is 
distributed by its upstream PE router. The external routes of the site are 
distributed to other sites using iBGP. The BGP next-hops for these prefixes 
are exchanged with the MPLS VPN backbone using standard routing protocols 
but also LDP label distribution. The BGP next-hops are placed into the PE 
routers VRF and then advertised across the backbone as VPNv4 prefixes. Once 
imported into the receiving PE routers VRF, they are advertised using 
standard routing protocols to the CE but also with LDP label distribution. 
All of this provides an end-to-end LSP between ASBRs in different sites, 
and provides the ability to off load large amounts of prefix information 
from the MPLS VPN backbone .. Jim

>  by the peer downstream CE router at the
>other side of the CE<-->CE tunnel and then distributed to
>the upstream CE (e.g., via a direct LDP session between the two CE routers)
>  without any involvement of the PE routers (save from that that
>they provide an IP VPN connectivity between CEs
>so that the latter can run LDP sessions between them).
>This means that PE cannot do anything with such a label per se!
>One way to overcome siuch a situation would be for the two CEs to run either
>
>MPLS-in-IP or MPLS-in-GRE between them as described in
><draft-worster-mpls-in-ip-04.txt>.
>
>With best regards,
>                                    Sasha Vainshtein
>email:     [email-masked]
>tel:       +972-3-7659993 (office)
>            +972-8-9254948 (res.)
>            +972-58-674833 (cell.)
>
>
>
> > -----Original Message-----
> > From: jim guichard [mailto:[email-masked]]
> > Sent: Thursday, May 10, 2001 11:41 AM
> > To: Metz, Eduard
> > Cc: 'Shahram Davari'; [email-masked]'
> > Subject: RE: BGP/MPLS VPN PE LSR
> >
> >
> > The case where a PE will receive a labelled packet is
> > referred to as the
> > Carriers Carrier architecture and it has several flavours. In
> > the case
> > where the VPN site is running MPLS, then you will see a two
> > level label
> > stack across the carrier backbone. A three level label stack
> > will be seen
> > when the VPN site is running MPLS VPN and this is referred to as a
> > hierarchical VPN. Jim
> >
> > At 10:43 10/05/2001 +0200, Metz, Eduard wrote:
> >
> > >I assume you are referring to the 'carriers-carrier' model.
> > This section in
> > >the draft is pretty vague. However, are you sure 2 labels
> > will be added?
> > >Could the PE not also use the customer label as the inner
> > label (and thus
> > >swap it)?
> > >
> > >
> > > > -----Original Message-----
> > > > From: Shahram Davari [mailto:[email-masked]]
> > > > Sent: 09 May 2001 21:16
> > > > To: [email-masked]'
> > > > Subject: BGP/MPLS VPN PE LSR
> > > >
> > > >
> > > > Hi,
> > > >
> > > > In an BGP/MPLS VPN scenario if a CE router sends an MPLS
> > > > packet rather than an IP packet to a PE router, the PE router
> > > > should still push 2 labels. My question is, should the PE
> > > > router swap the customer's label too or leave it unchanged?
> > > >
> > > > Yours,
> > > > -Shahram
> > > >
> > > >
> >
> >
> >
> > Jim Guichard CCIE #2069
> > Technical Leader EMEA
> >
> > +44 208 756 8806
> > Mobile: +44 7802 809763
> >

Jim Guichard CCIE #2069
Technical Leader EMEA

+44 208 756 8806
Mobile: +44 7802 809763

---

From: Sasha Vainshtein <[email-masked]>
Date: Mon, 14 May 2001 11:03:24 +0200

(to some FEC) by the peer downstream CE router at the 

With best regards,
                                   Sasha Vainshtein
email:     [email-masked]