Subject: RE: BGP/MPLS VPN PE LSR

From: "Metz, Eduard" <[email-masked]>
Date: Thu, 10 May 2001 10:43:20 +0200

I assume you are referring to the 'carriers-carrier' model. This section in
the draft is pretty vague. However, are you sure 2 labels will be added?
Could the PE not also use the customer label as the inner label (and thus
swap it)?

> -----Original Message-----
> From: Shahram Davari [mailto:[email-masked]]
> Sent: 09 May 2001 21:16
> To: [email-masked]'
> Subject: BGP/MPLS VPN PE LSR
> 
> 
> Hi,
> 
> In an BGP/MPLS VPN scenario if a CE router sends an MPLS 
> packet rather than an IP packet to a PE router, the PE router 
> should still push 2 labels. My question is, should the PE 
> router swap the customer's label too or leave it unchanged?
> 
> Yours,
> -Shahram
> 
>

---

From: jim guichard <[email-masked]>
Date: Thu, 10 May 2001 10:41:06 +0100

The case where a PE will receive a labelled packet is referred to as the 
Carriers Carrier architecture and it has several flavours. In the case 
where the VPN site is running MPLS, then you will see a two level label 
stack across the carrier backbone. A three level label stack will be seen 
when the VPN site is running MPLS VPN and this is referred to as a 
hierarchical VPN. Jim

> > router swap the customer's label too or leave it unchanged?

Jim Guichard CCIE #2069
Technical Leader EMEA

+44 208 756 8806
Mobile: +44 7802 809763