Subject: RE: Question about logical link in Link bundling

From: "Fong, Man Wing" <[email-masked]>
Date: Wed, 2 May 2001 12:41:45 -0500

Yakov,

Thanks for clearing my doubt.

Regards,
Man Wing

 -----Original Message-----
From: 	Yakov Rekhter [mailto:[email-masked]] 
Sent:	Wednesday, May 02, 2001 12:01 PM
To:	Fong, Man Wing
Cc:	[email-masked]; 'Kireeti Kompella'; [email-masked]
Subject:	Re: Question about logical link in Link bundling 

Man Wing,

> >From "draft-kompella-mpls-bundle-05.txt", it indicates that multiple
links
> between two LSRs can be bundled as a single link to improve the routing
> scalability. Apparently, it can be used to bundle multiple links from
> multiple physical interfaces (e.g. multiple T1s, DS3s, OC-12s, OC-48s,
> etc...) to be a single link. However, can it be used to bundle logical
links
> like T1s in channelized T3, or DS3s, STS-3c in channelized OC-12
interface?

Could you please point me to the text in the draft that restricts
its application to only physical interfaces ?

Yakov.

---

From: "Anuj Bhatnagar" <[email-masked]>
Date: Wed, 2 May 2001 16:33:48 -0400

This is a good point and I kind of agree with Kireeti.  If we define our
domain to be just IP (which I believe it is for this document) then
*logical* connectivity between routers can be bundled into one link.
Another reason for it is that if we have two or more interfaces between
peering routers then we may not know which route a packet is going to take
to get to the next hop.  However, if we are defining inter layer
(SONET/SDH/FR - Layer 1, ATM - Layer 2, and IP - Layer 3) somewhere in any
IETF document and also defining the correlation between the layers then
these *logical* links cannot be bundled into one link for all the layers
(ITU G805 clearly specify how to handle layered networks).  So, if any IETF
document that specifies multiple layers correlation and have such statement
like all links can be bundled into one link between routers should be
addressed and corrected.  Does anybody know such document(s)?

Regards,
Anuj

Kireeti Kompella <[email-masked]> on 05/02/2001 02:17:28 PM

To:   [email-masked]
cc:    (bcc: Anuj Bhatnagar/Telcordia)
Subject:  Re: Question about logical link in Link bundling

Hi Tom,

>          Perhaps the text be clarified to explicitly include
> logical links? I understood the text to read that both physical
> and logical links were allowed.

Two points:
1) Terminology: calling a T1 in a channelized T3, or an STS-3c in
   an OC-48 a *logical* link will confuse lots of folks.
2) From a routing point of view, there is entirely no difference
   between an STS-3c in an OC-48, and a "standalone" STS-3c/OC-3c.

So, while I'm not opposed to making the above "clarification", it
seems unnecessary; moreover, there are plenty of other documents
that would then need this same "clarification".

Kireeti.

---

From: Bala Rajagopalan <[email-masked]>
Date: Tue, 8 May 2001 16:24:00 -0400

Hello,

I'm a bit confused by the question. If you
had a channelized OC-12 link, wouldn't you
just advertise it with suitable Min Reservable
Bw values to indicate that it can carry lower
granularity traffic? In other words, why would
you introduce the notion of a "logical" link
in this case? 

REgards,

Bala Rajagopalan
Tellium, Inc.
2 Crescent Place
P.O. Box 901
Oceanport, NJ 07757-0901
Tel: (732) 923-4237
Fax: (732) 923-9804
Email: [email-masked] 

> From: Fong, Man Wing [mailto:[email-masked]]
> Sent: Monday, April 30, 2001 3:31 PM
> To: [email-masked]; 'Kireeti Kompella'
> Cc: [email-masked]
> Subject: Question about logical link in Link bundling
> 
> 
> Hi All,
> 
> From "draft-kompella-mpls-bundle-05.txt", it indicates that 
> multiple links
> etc...) to be a single link. However, can it be used to 
> bundle logical links
> like T1s in channelized T3, or DS3s, STS-3c in channelized 
> OC-12 interface?
> 
> Thanks.
> 
> Regards,
> Man Wing
> 
> 
>

---

From: "Fong, Man Wing" <[email-masked]>
Date: Tue, 8 May 2001 17:10:30 -0500

Of course, the routers connected to the optical network will use the
channelized interfaces.

Man Wing

 -----Original Message-----
From: 	Fong, Man Wing [mailto:[email-masked]] 
Sent:	Tuesday, May 08, 2001 5:04 PM
To:	'Bala Rajagopalan'; [email-masked]; 'Kireeti Kompella'
Cc:	[email-masked]
Subject:	RE: Question about logical link in Link bundling

Bala,

Correct me if I am wrong. For my understanding, a channelized OC-12
interface can support 12 channels (12 logical DS3 interfaces). Some even
capable of defining logical interface within those DS3 channel to support
T1. Then, each logical DS3 interfaces can create a (logical) link to the
remote routers' DS3 interfaces. The original used of the channelized OC-12
interface is to reduce the cabling and additional equipment cost and labor
cost at the central location. Since it is a channelized interface, I
believe, it would not allow the user to use it as an OC-12c interface. By
applying link bundling on that, now you can size your pipe whatever you want
upto the maximum BW (in this case, it will be STS-12c). In addition, using
O-UNI, you will get a true bandwidth on demand.

Just a thought.

Man Wing

 -----Original Message-----
From: 	Bala Rajagopalan [mailto:[email-masked]] 
Sent:	Tuesday, May 08, 2001 3:24 PM
To:	'Fong, Man Wing'; [email-masked]; 'Kireeti Kompella'
Cc:	[email-masked]
Subject:	RE: Question about logical link in Link bundling

Hello,

REgards,

Bala Rajagopalan
Tellium, Inc.
2 Crescent Place
P.O. Box 901
Oceanport, NJ 07757-0901
Tel: (732) 923-4237
Fax: (732) 923-9804
Email: [email-masked]

---

From: "Fong, Man Wing" <[email-masked]>
Date: Wed, 9 May 2001 10:14:17 -0500

Debanjan,

As I mentioned in the email, the key is to provide bandwidth on demand.
Certainly, if the user needs the STS-12c link up all the time, the OC-12c
interface will make more sense. However, if the user doesn't need it all the
time, the OC-12c interface will tie the whole STS-12c BW. So that applying
link bundling on the channelized OC-12 interface can bundle a few channels
to create the right size link the user need between the routers, and the
unused STSs within the transport network can be used in somewhere else. 

What do you think?

Man Wing

 -----Original Message-----
From: 	Debanjan Saha [mailto:[email-masked]] 
Sent:	Tuesday, May 08, 2001 7:25 PM
To:	'Fong, Man Wing'; Bala Rajagopalan; [email-masked]; 'Kireeti Kompella'
Cc:	[email-masked]
Subject:	RE: Question about logical link in Link bundling

Fong,
You're right. A channelize OC-12 can have 12 DS-3s (STS-1)within it.
However, if all of them are terminating on
the same LSR, I'm not sure why you'll use a channelized
OC-12 and not an OC-12c.

Debanjan

-----Original Message-----
From: Fong, Man Wing [mailto:[email-masked]]
Sent: Tuesday, May 08, 2001 5:04 PM
To: 'Bala Rajagopalan'; [email-masked]; 'Kireeti Kompella'
Cc: [email-masked]
Subject: RE: Question about logical link in Link bundling

Bala,

Just a thought.

Man Wing