Subject: Question on LdpEntityIndex ??

From: "Hari Kishan" <[email-masked]>
Date: Mon, 7 May 2001 11:32:06 -0700

The draft-ietf-mpls-ldp-mib-07.txt has the following
description about EntityIndex.

" mplsLdpEntityIndex OBJECT-TYPE

			....
			....

             A secondary index (this object) is needed by some
             but not all, LDP implementations.  For example
             in an LDP implementation which uses PPP, this
             index may be needed."
         ::= { mplsLdpEntityEntry 2 } "

Can anybody tell me one practical scenario where this entityindex
MUST be used. ( I could not understand the PPP example
written in the draft)

This Entity Index is made part of the INDEX for many tables like
adjacency table, session table , etc.,

As per my understanding a LDP Session can be uniquely identified by
{ mplsLdpEntityLdpId,mplsLdpPeerLdpId }, but the ldp-mib uses
{mplsLdpEntityLdpId,mplsLdpEntityIndex, mplsLdpPeerLdpId } as the
INDEX.

If {a,b} forms the INDEX of a table, {a,b,c} ( assume 'c' is a column
in
the table ) also works ( of course any superset of {a,b} works ).

Again, I would like to know when exactly does it become a MUST to use
this
entityindex to uniquely identify a LDP session in LDP Session table.

thanks,
Kishan

---------------------------------
Hari Kishan Desineni,
Ericsson Inc,
Data Backbone & Optical Division,
Santabarbara,
California - 93117
Office:(805) 562 6419
Home:(805) 968 1894

---

From: [email-masked]
Date: Thu, 10 May 2001 21:42:11 -0400

>MUST be used. ( I could not understand the PPP example

Kishan, 

We had only the mpldLdpEntityLdpId in there (see earlier
versions of the MIB) and the request was made by several
members that said an additional index was needed for PPP.
I do not remember the details and would refer you to
the email archives.  Certainly, the LDP MIB should
support LDP using PPP (or ATM, or FrameRelay, etc).

This index may not be important to
all implementations, but it would still need to be supported
as a MIB index for SNMP to work.  It is consistent throughout
the MIB which is why it appears in the other tables also.

   Thanks, Joan