Subject: RE: clarification on "MPLS support of Diff-Serv"

From: Shahram Davari <[email-masked]>
Date: Mon, 14 May 2001 06:26:43 -0700

Hi,

This draft is about supporting Diffserv. In Diffserv there is no per-flow scheduling, rather per-class (aggregate) scheduling. The way that it works in your example is that at the edge the L-LSPs are policed to 5Mbit/s an 10Mbit/s respectively and in the core enough BW is reserved for the aggregate (10+5=15Mbit/s). Therefore without explicitly scheduling per-LSP flows, the class scheduler could schedule them correctly and maintain the 2 to 1 ratio that you were talking about.

Yours,
-Shahram

> -----Original Message-----
> From: Wayne W. Szeto [mailto:[email-masked]]
> Sent: Sunday, May 13, 2001 6:29 PM
> To: [email-masked]
> Subject: clarification on "MPLS support of Diff-Serv"
> 
> 
> On p6, second paragraph of the "MPLS support of Diff-Serv" 
> document, it
> reads "... establishing an E-LSP or L-LSP with bandwidth 
> reservation does
> not mean that per-LSP scheduling is required...".  I'm not sure why
> per-LSP scheduling is not required.  If there are two L-LSPs, carrying
> packets that has the same PHB, and they intersect on a link where they
> have reserved 5Mbits and 10Mbits of bandwidth respectively.  
> Then without
> per-LSP scheduling, their packets will be treated without 
> consideration on
> their reserved bandwidth.  I would expect that for every 
> packets of the
> first L-LSP transmitted on the intersecting link, two packets of the
> second L-LSP will be transmitted.  However, when there're no per-LSP
> scheduling, I don't see how this could happen.  Could someone explain
> whats the true meaning of the quote above?  
> 
> Wayne
>

---

From: Abhijit M Gadgil <[email-masked]>
Date: Tue, 15 May 2001 09:50:51 +0530 (IST)

> This draft is about supporting Diffserv. In Diffserv there is no
> per-flow scheduling, rather per-class (aggregate) scheduling. The way
> that it works in your example is that at the edge the L-LSPs are
> policed to 5Mbit/s an 10Mbit/s respectively and in the core enough BW
> is reserved for the aggregate (10+5=15Mbit/s). Therefore without
> explicitly scheduling per-LSP flows, the class scheduler could
> schedule them correctly and maintain the 2 to 1 ratio that you were
> talking about.

Aren't u doing per-LSP scheduling here?

Shouldn't draft say that
"....does not mean that per LSP Flow Scheduling is required"
                                ^^^^
am i correct?

-abhijit