Subject: RE: Inputs to get the label

From: Bhupesh Bajaj <[email-masked]>
Date: Fri, 11 May 2001 17:51:09 +0500

hi ,
as far as i am aware ..FEC itself is a number.
and its not that there are parameters to FEC ,
the FEC itself is calculated having different considerations
of QoS , TE , Administration and link contraints.so once the 
FEC is decided , the labels are mapped directly on the basis of FEC

so as far as your first question is concerned , my opinion is 
that RSVP -TE should send FEC( which is nothing else , just a number or
variable)
, to get the label mapping for That FEC which has been calculated in various
above said paraments.

thanks and regards
bhupesh

-----Original Message-----
From: Khuzema Pithewan [mailto:[email-masked]]
Sent: Friday, May 11, 2001 5:27 PM
To: [email-masked]
Subject: RE: Inputs to get the label

Hi,

FEC is a very generic term, but what are the parameters should be passed as
FEC to MPLS to get the label.

Khuzema.

> ----------
> From: 	Bhupesh Bajaj
> Sent: 	Friday, May 11, 2001 5:55 PM
> To: 	Khuzema Pithewan
> Cc: 	[email-masked]
> Subject: 	RE: Inputs to get the label
> Importance: 	High
> 
> hi,
> i believe that , as MPLS is supposed to do a mapping 
> between Labels and FEC's , so In the "Resv" message 
> the RSVP - TE should pass "FEC" to MPLS.
> 
> as FEC is the only thing on which the MPLS bases its 
> label assignment/ mapping.
> 
> correct me if i am wrong,
> thanks and regards,
> bhupesh
> 
> 
> -----Original Message-----
> From: Khuzema Pithewan [mailto:[email-masked]]
> Sent: Friday, May 11, 2001 5:07 PM
> To: [email-masked]'; [email-masked]'
> Subject: Inputs to get the label
> 
> 
> Hi,
> 
> what are the parameters other than LABEL_REQUEST object that RSVP-TE
> should
> pass to MPLS to get a LABEL?
> 
> draft-ietf-mpls-rsvp-lsp-tunnel-08, while discussing the handling of LABEL
> object in Resv Messages downstream, says 
> 
> "A node is expected to send a Resv message before its refresh timers
> expire
> if the contents of the LABEL object change." 
> 
> my query is how can a LABEL object change in LSR and how will RSVP come to
> know about that.
> 
> Khuzema.
>

---

From: Abhijit M Gadgil <[email-masked]>
Date: Fri, 11 May 2001 18:45:42 +0530 (IST)

follow inline please

Abhijit Gadgil

> that RSVP -TE should send FEC( which is nothing else , just a number or

If its a number then what is the scope of that number? If it is a global
scope (what i really mean is not really GLOBAL, but within the MPLS
domain) then how do u ensure that the same number is consistent within the
mpls domain. And if the number is not global, then how do u ensure the
consistency of qos treatments packets will receive when they are actually
forwarded?

regards

-abhijit