Subject: RE: GMPLS TE MIB

From: [email-masked]
Date: Wed, 9 May 2001 13:12:14 -0400

Hi Adrian,

 The SYNTAX of the MplsGeneralizedLabel TC specifies a fixed length of
64 bits. This conflicts with the GMPLS functional specification which
defines a generalized label as being of variable length. The SYNTAX
is inconsistent with the length of the Waveband label, for example.

-Dan 

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]]
Sent: Wednesday, May 09, 2001 10:06 AM
To: [email-masked]; [email-masked]
Subject: GMPLS TE MIB

We have submitted a draft to extend the TE-MIB to support
GMPLS.
This is available at
http://search.ietf.org/internet-drafts/draft-nadeau-mpls-gmp
ls-te-mib-00.txt

We would welcome your thoughts and comments

Adrian
--
Adrian Farrel
Movaz Networks Inc.
[email-masked]

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 9 May 2001 14:49:56 -0400

Thanks Dan,

Yes, we're aware of this issue and are discussing it.  The current 64 bit field
is something of a place holder.

Our concerns are
- to allow flexible configuration of different label types
- to keep the MIB from sprawling
- to arrive at a label type that can be used to index a GMPLS LSR MIB

Best regards,
Adrian
--
Adrian Farrel
Movaz Networks Inc.
[email-masked]