Subject: Advertising Routes learnt from PE to PE

From: "Sugar, Sylvia" <[email-masked]>
Date: Wed, 14 May 2003 15:06:40 +0100 (BST)

Hi,
WIll a PE router ever advertise a route it learns from another PE router to some other PE router.
I dont think it will ever do that as all the PE routers are IBGP peers and would generally be in
full mesh. 

Is there any case when this might happen .. i.e. a PE router advertises a Route learnt from one PE
to another PE. How can one do that .. because IMHO the label that will be advertised by the former
PE router will be for the PE router to which he sends the UPDATE. How can this PE router advertise
another PE router the same label?

Moreover, if for some reason he has to .. does he assign a new label and then advertise?

ANy comments on this would be very helpful!

Silviya Sugar

__________________________________________________
Yahoo! Plus
For a better Internet experience
http://www.yahoo.co.uk/btoffer

---

From: "Rod Martin" <[email-masked]>
Date: Wed, 14 May 2003 10:19:24 -0400

Hello Sylvia,

In this scenario, this would be a RR, speaking to terminating PE, in which
you would use the BGP statement under the vpn4 family:

Next-hop-unchanged.

Rod

ROD L. MARTIN
CCDP, CFE, JNCIS, CFOE
(OFFICE) 703-621-1646
(MOBILE) 703-967-9503
[email-masked]
http://www.mplsvpn.net
http://www.mplscon.com
http://www.vpnc.org

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Sugar,
Sylvia
Sent: Wednesday, May 14, 2003 10:07 AM
To: [email-masked]
Cc: [email-masked]
Subject: Advertising Routes learnt from PE to PE

Hi,
WIll a PE router ever advertise a route it learns from another PE router to
some other PE router.
I dont think it will ever do that as all the PE routers are IBGP peers and
would generally be in
full mesh.

Is there any case when this might happen .. i.e. a PE router advertises a
Route learnt from one PE
to another PE. How can one do that .. because IMHO the label that will be
advertised by the former
PE router will be for the PE router to which he sends the UPDATE. How can
this PE router advertise
another PE router the same label?

Moreover, if for some reason he has to .. does he assign a new label and
then advertise?

Silviya Sugar

__________________________________________________
Yahoo! Plus
For a better Internet experience
http://www.yahoo.co.uk/btoffer
---
Incoming mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.481 / Virus Database: 277 - Release Date: 5/13/2003

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.481 / Virus Database: 277 - Release Date: 5/13/2003

---

From: "Ferit Yegenoglu" <[email-masked]>
Date: Wed, 14 May 2003 10:51:58 -0400

Sylvia,

One possible scenario where this could happen is the hub-spoke BGP/MPLS
VPN. In this case the spoke PEs advertise their routes with a Route
Target value "Hub". The hub PE imports these routes and advertises them
to the CE router in the hub site. These routes are advertised across the
hub site and eventually back to the PE hub router via a different
interface. The PE hub router then readvertises these routes to the spoke
PEs with a Route Target value "Spoke" and a different VPN label. 

Ferit

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Sugar,
> Sylvia
> WIll a PE router ever advertise a route it learns from another PE
router
> to some other PE router.

---

From: Aamer Akhter <[email-masked]>
Date: Wed, 14 May 2003 14:44:12 -0400

On 5/14/03 1:58 PM, "Spice Sylvia" <[email-masked]> wrote:

> Hello Aamer,
> 
> Why would the "rd" have changed?

|--------1
HUBCE    HUBPE
|--------2

Suppose the sites prefixes are sent to the HUBPE, which advertises to HUBCE
over link 2 (lets' call this vrf2), the HUBCE advertises this back to the
HUBPE over link 1 (vrf1). vrf2 and vrf1 will have different rd's because
they are different vrfs.

> 
> Is this a new feature?
> 
> How does changing RD help?
> 
> 
> Aamer Akhter <[email-masked]> wrote:
> On 5/14/03 10:51 AM, "Ferit Yegenoglu" wrote:
> 
>> 
>> Sylvia,
>> 
> But to BGP, these "readvertised" prefixes are not the same. The rd will have
> changed.
> 
>> 
>> Ferit
>> 
>> 
>> 

-- 
Aamer Akhter / [email-masked]
NSITE - cisco Systems

---

From: Aamer Akhter <[email-masked]>
Date: Wed, 14 May 2003 11:39:15 -0400

---

From: Aamer Akhter <[email-masked]>
Date: Wed, 14 May 2003 15:09:57 -0400

On 5/14/03 3:02 PM, "Spice Sylvia" <[email-masked]> wrote:

> Pardon me if I am not clear,
> 
> Why would RD have changed?

The prefix is no longer is the same vrf.

> 
> Same IP route to same prefix but why different RD?
> 
> Why would one not give both to same vrf1 in hub and spoke?

Both what? Once vrf2 learns the routes from a spoke PE, it's not going to
readvertise that prefix to other spokes because of ibgp behavior. To get
around this you have to advertise the prefix to the hub PE which advertises
the prefix back to you in ANOTHER vrf. At this point, it's not the same
vpnv4 prefix, so you can export and advertise to the spoke PEs.

> On 5/14/03 1:58 PM, "Spice Sylvia" wrote:
> 
>> Hello Aamer,
>> 
>> Aamer Akhter wrote:

---

From: Spice Sylvia <[email-masked]>
Date: Wed, 14 May 2003 20:02:05 +0100 (BST)

|--------1
HUBCE HUBPE
|--------2

-------
The MPLS-OPS Mailing List
Subscribe/Unsubscribe: http://www.mplsrc.com/mplsops.shtml
Archive: http://www.mplsrc.com/mpls-ops_archive.shtml

---------------------------------
Yahoo! Plus - For a better Internet experience

---

From: Spice Sylvia <[email-masked]>
Date: Wed, 14 May 2003 20:24:18 +0100 (BST)

Perhaps am not clear,
 
1. Why would hub and spoke put things in 2 different VRFs. What does this achieve which prefix filter/Route Target filter cannot achieve?
Hub and spoke is a central site and remote side model. How does 2 VRF help?
 
2. How exciting if we had hub and spoke on the other side too?
and put routes learnt from BGP-MPLS back into IGP and then those from IGP back into BGP from vrf2 and so on.
 
We  have prefix1:rd1 from vrf1 then one from prefix1:rd2, then one from prefix1:rd3 then one from prefix1:rd4 and so on. I wonder what would be the next -hop too.
 
-S.F.

---

From: Spice Sylvia <[email-masked]>
Date: Wed, 14 May 2003 18:58:46 +0100 (BST)

Hello Aamer,

Is this a new feature?

-------

---

From: "jgrewal" <[email-masked]>
Date: Thu, 15 May 2003 10:19:55 +0530

Hi,

As far i know IBGP dont advertise routes learned from its IBGP peer.

J.Grewal

----- Original Message -----
From: "Sugar, Sylvia" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, May 14, 2003 7:36 PM
Subject: [MPLS-OPS]: Advertising Routes learnt from PE to PE

would generally be in
Route learnt from one PE
advertised by the former
this PE router advertise
then advertise?

---

From: Spice Sylvia <[email-masked]>
Date: Thu, 15 May 2003 17:47:02 +0100 (BST)

Hi Aamer,
 
no reply?
 
I would also like to know the cutomer base cisco has on MPLS VPN after reading your mail.
 
or is there none?
 
-S.F.

-------

---

From: Aamer Akhter <[email-masked]>
Date: Wed, 14 May 2003 11:16:20 -0400

> I dont think it will ever do that as all the PE routers are IBGP peers and

You're correct. The exception would a route-reflector / confederation. But
as you know by default, these bgp nodes don't change the next-hop.

> Moreover, if for some reason he has to .. does he assign a new label and then

A RR will allocate a label (locally) if the next-hop changes. Of course this
doens't mean much unless the next-hop is the RR itself. ;-)