Subject: RE: AD review of draft-ietf-mpls-ldp-mib-10.txt

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Mon, 12 May 2003 15:25:54 +0200

I am asking to add some text that notifications of this type
are not expected to occur more often than X per second
or Z per minute or such.

Thanks,
Bert 

> -----Original Message-----
> From: Thomas D. Nadeau [mailto:[email-masked]]
> Sent: maandag 12 mei 2003 14:18
> To: 'Wijnen, Bert (Bert)'; [email-masked]; 'Mpls (E-mail)'
> Subject: RE: AD review of draft-ietf-mpls-ldp-mib-10.txt
> 
> 
> 
> 
> > > >4. How many notifications can be generated per second?
> > > 
> > > Are you asking for a worst case scenario?
> > > 
> > > In a network where LDP is configured on each device (and not being
> > > reconfigured) would not expect notifications to be generated once 
> > > sessions are established.  So would not quantify X 
> > notifications per 
> > > second.
> > > 
> > > Maybe another way to ask this question is: how long does 
> > the average 
> > > LDP Session last?
> > > 
> > > Would say most last longer than a second, but
> > > would be good to get operator experience here.
> > > 
> > The thing is that we do not want the network and the NMS to 
> be flooded
> > (congested) with notifications. If there is a true story that they 
> > will be infrequent, then just add that explanation, and we're 
> > OK. Do remember that a NMS may be receiveing such 
> > notification from many managed devices. So if you had one a 
> > second per managed device, and you had to manage 1000s of 
> > devices, then there is potential still for NMS 
> > overload/congestion. So some words to make people feel 
> > comfortable is goodness. If the evaluation is that there 
> > might be too many notifications, then we may need to add a 
> > throttle object.
> 
> 	Bert, 
> 
> 	I don't understand what you are getting at here.
> How can any one device know what the other devices in the
> network are doing? Given your description above, you seem to
> be advocating that every notification have a throttling value
> associated with it. Although I totally agree that this is something 
> that is often appropriate on a per-box-basis (indeed my boxes 
> do this), 
> having to put this into every new notification seems difficult to
> implement at best. Imagine if you have accidentally not set 
> these values across sevearal MIBs to be inconsistent? Imagine
> the fun the agent has to go throught to appropriately throttle
> each MIB's notifications.
> 
> 	--Tom
> 
> 	
> 
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 12 May 2003 09:33:01 -0400

I am cool with that!

	--Tom

> From: Wijnen, Bert (Bert) [mailto:[email-masked]] 
> Sent: Monday, May 12, 2003 9:26 AM
> To: [email-masked]; 'Wijnen, Bert (Bert)'; 
> [email-masked]; 'Mpls (E-mail)'
> are not expected to occur more often than X per second or Z 
> per minute or such.
> 
> Thanks,
> Bert 
> 
> network are 
> > doing? Given your description above, you seem to be advocating that 
> > every notification have a throttling value associated with it. 
> > Although I totally agree that this is something that is often 
> > appropriate on a per-box-basis (indeed my boxes do this),