Subject: errors in draft-ietf-te-mib-12.txt

From: Stefan Winter <[email-masked]>
Date: Sun, 7 Sep 2003 09:45:54 +0200

Hello,

sorry for bothering you again. But during the implementation of the MPLS MIBs 
I came across some more inconsistencies...

1) concerning data types: mplsTunnelIndex is of syntax mplsTunnelIndex, 
derived from UNSIGNED32. But the corresponding scalar mplsTunnelIndexNext is 
of type IndexIntegerNextFree, derived from INTEGER32. I don't think it is a 
good idea to have different data types for these two.

2) DESCRIPTION clause of mplsTunnelIndex states "should obtain new values for 
row creation in this table by reading mplsTunnelIndexNextFree". The scalar in 
question is not called mplsTunnelIndexNextFree but mplsTunnelIndexNext.

BTW, I never got a reply to my comments in message 
http://cell.onecall.net/mhonarc/mpls/2003-Aug/msg00105.html
I hope it didn't get lost...

Greetings,

Stefan Winter

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 8 Sep 2003 10:36:31 -0400

>good idea to have different data types for these two.

	We imported the IndexIntegerNextFree
from the Diffserv MIB to re-use their definitions w/o
having to re-define them. I think that the text in the 
description is pretty clear that the value must be either 0 
or a valid value that is consistent with mplsTunnelIndex. 
This means that the value returned cannot be anything other 
than 0 or Unsigned32. 

mplsTunnelIndexNext OBJECT-TYPE
   SYNTAX        IndexIntegerNextFree
   MAX-ACCESS    read-only
   STATUS        current
   DESCRIPTION  
       "This object contains an unused value for
        mplsTunnelIndex, or a zero to indicate
        that none exist.
 
        Note that this object offers an unused value
        for an mplsTunnelIndex value at the ingress 
        side of a tunnel. At other LSRs the value
        of mplsTunnelIndex SHOULD be taken from the
        value signaled by the MPLS signaling protocol.
       "
   ::= { mplsTeObjects 1 }

>2) DESCRIPTION clause of mplsTunnelIndex states "should obtain 
>new values for row creation in this table by reading 
>mplsTunnelIndexNextFree". The scalar in 

	Typo; will fix.

>I hope it didn't get lost...

	Good catch. These need to be made consistent. The
param. table no longer exists in the LSR MIB.

 	Will fix all of these after LC is finished.

	--Tom