Subject: RE: (NAT) H.323

From: Srikanth Nayani <[email-masked]>
Date: Thu, 17 Jun 1999 14:17:04 -0700

Mr.Jose,
    Instead of implimenting a full blown H.323 proxy on the firewall can I
do this:

 Have a statefull inspection of the call setup connections, inspect their
payloads and trasnslate the addresses(IP + port) inside . 
	To what extent would netmeeting work with such an arrangement for the
internal users.

Regards,
Srikanth.

At 01:54 PM 6/17/99 -0700, you wrote:
>You will need a H.323 proxy running on the NAT/Firewall to allow Netmeeting
>to work
>for the internal users.
>
>jose
>
>++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
>Jose Puthenkulam
>Sr. Software Engineer, Broadband & IP Telephony, Intel Architecture Labs
>[email-masked] 
>++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
>
>
>
>
>-----Original Message-----
>From: Srikanth Nayani [mailto:[email-masked]]
>Sent: Thursday, June 17, 1999 1:32 PM
>To: [email-masked]
>Subject: (NAT) H.323
>
>
>
> Hi,
>   How far can Netmeeting be supported for internal users in an environment
>where a Firewall(With NAT : Ports also) protects them.
>
>
>Regards,
>Srikanth.
>
>-
>To unsubscribe, email [email-masked]' with
>'unsubscribe nat' in the body of the message.
>-
>To unsubscribe, email [email-masked]' with
>'unsubscribe nat' in the body of the message.
>

-
To unsubscribe, email [email-masked]' with
'unsubscribe nat' in the body of the message.

---

From: Srinivasa Rao Addepalli <[email-masked]>
Date: Thu, 17 Jun 1999 15:32:15 -0700

Srikanth,
   You can do it eitherways, implement it in network layer(stateful inspection)
   or write
   an application proxy.

   Application proxy is easier to develop though as this requires
   intrepretation of audio call control and H.323 Call setup protocols
   to identify the port. Disadvantage with this approach is that performance
   may be less than the implementing in network layer.

   Hybrid approach may be the best. That is, application proxy
   is active until extracting the port number and then this can be
   suspended and move the control to network layer.

Regards
Srini

-

---

From: "Bernard Aboba" <[email-masked]>
Date: Tue, 22 Jun 1999 20:32:07 -0700

This is more or less what was implemented in Windows 98 Second
Edition, so H.323 ALGs are not necessarily required (though they
may be useful for other reasons).

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Srikanth Nayani
Sent: Thursday, June 17, 1999 2:17 PM
To: Puthenkulam, Jose P
Cc: [email-masked]
Subject: RE: (NAT) H.323

Mr.Jose,

Regards,
Srikanth.

-

-