Subject: [Netconf] confirm WG consensus on potential new WG work-item: notification

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Wed, 26 Nov 2008 18:56:09 +0100

WG participants,

At our NetConf Session at IETF73, the people in the room expressed strong
support for the following statements:

  - We do not want to define extensive Notification content NOW
  - We just want to define content for notifications that we URGENTLY
    need now (within the next year). That is one or two notifications
  - Less urgent notification content we can define once the NETMOD
    results become available

The WG chairs consider this to be WG consensus. If anyone on the mailing
list does not agree, please speak up before Dec 3rd 2008.  That is one week.
We want to try and get updated charter to IESG before X-mas.

The WG chairs do not want to consider 
draft-chisholm-netconf-not-content-00.txt
as a starting point. The reason being that it wants to do much more than the
minimal approach that is expressed above.

The WG chairs will propose/draft new charter text that we will circulate
for consensus checking. Once we have such a draft text, we will also
call for volunteers to become editors of the document.

Bert and Mehmet

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 26 Nov 2008 14:27:11 -0500

Hi

I believe how several people expressed things was a header plus a small
set (1-3) notifications that we really need.

As indicated, I'm willing to work with the editor to extract out the
appropriate portions of the not-content individual submission that meets
this agreed to scope. First though, we need to agree on what the small
set of notification would be. I'd vote for configuration change events
and software upgrade notifications.

Sharon 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Bert Wijnen (IETF)
Sent: Wednesday, November 26, 2008 12:56 PM
To: Netconf
Subject: [Netconf] confirm WG consensus on potential new WG
work-item:notification

WG participants,

At our NetConf Session at IETF73, the people in the room expressed
strong support for the following statements:

The WG chairs consider this to be WG consensus. If anyone on the mailing
list does not agree, please speak up before Dec 3rd 2008.  That is one
week.
We want to try and get updated charter to IESG before X-mas.

The WG chairs do not want to consider
draft-chisholm-netconf-not-content-00.txt
as a starting point. The reason being that it wants to do much more than
the minimal approach that is expressed above.

Bert and Mehmet

---

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 26 Nov 2008 14:27:11 -0500

Hi

Sharon 

-----Original Message-----

WG participants,

Bert and Mehmet

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 26 Nov 2008 22:56:18 +0100

> We want to try and get updated charter to IESG before X-mas.

My problem is that it remains unclear to me what the URGENTLY needed
notifications are - neither the ID nor the Minneapolis audio stream I
listened to answered that question. If something gets added to the
charter, then I think it must be more concrete than "URGENTLY needed
notifications". Perhaps someone can post a more concrete proposal?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 26 Nov 2008 22:56:18 +0100

/js

---

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Wed, 26 Nov 2008 23:17:45 +0100

Juergen wrote:

Sharon has mentioned 2  to the list recently (Iirc) and I have heard that Phil has
2 in mind as well. Maybe Phil can post his list.

Bert

---

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Wed, 26 Nov 2008 23:17:45 +0100

Juergen wrote:

Bert

---

From: Phil Shafer <[email-masked]>
Date: Wed, 26 Nov 2008 17:41:41 -0500

Juergen Schoenwaelder writes:
>If something gets added to the
>notifications".

My concern is that we have a number of fish in the fire.  I would
like to see this work happen after the YANG drafts have been put
to bed.  We are facing agressive deadlines and need eyes to review
those documents (and fingers to type them).  With resources being
scant and getting more so, I'd appreciate delaying this work until
we finish other work.  I see no notifications that are in the same
class of URGENT as completing our data modeling work.

Thanks,
 Phil

---

From: Phil Shafer <[email-masked]>
Date: Wed, 26 Nov 2008 17:41:41 -0500

Thanks,
 Phil

---

From: Phil Shafer <[email-masked]>
Date: Wed, 26 Nov 2008 17:49:13 -0500

"Bert Wijnen \(IETF\)" writes:
>Sharon has mentioned 2  to the list recently (Iirc) and I have heard =
>that Phil has

I mentioned thes same two when we spoke about this, but firmly
believe there's nothing urgent about either of them.  Better to put
out nose to the grindstone of finishing off YANG, imho.

Thanks,
 Phil

---

From: Phil Shafer <[email-masked]>
Date: Wed, 26 Nov 2008 17:49:13 -0500

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Wed, 26 Nov 2008 15:10:31 -0800

> and software upgrade notifications.

I think it is reasonable to work on very limited content
since there are volunteers to work on it (I would be willing
to help Sharon if needed).

I do not think the YANG schedule has much impact,
as long as the notifications use only YANG-compatible
data structures.  I cannot imagine anything more complicated
than a few leafs getting defined now.

The focus should be result-oriented.
How many header fields can we agree on in 3 months?
One?  Two?  Can we agree on a basic config-change notification
as well?

I think a very short (4 - 6 month) charter would be appropriate,
even though NETMOD is not finished.  The same people
work on both, so any incompatibilities will get detected
early on.

> Sharon 

Andy

---

From: Andy Bierman <[email-masked]>
Date: Wed, 26 Nov 2008 15:10:31 -0800

Andy

---

From: Balazs Lengyel <[email-masked]>
Date: Thu, 27 Nov 2008 09:35:28 +0100

Hello,
- I agree with Jurgen, that we can not update the charter without defining what notifications
are urgent
- I don't believe we can finish anything before YANG
- I agree with Phil that resources should be concentrated on the current netconf/netmod drafts

So I am against this work.

On the other hand if it does go ahead, my priorities would be:
Some common header data:
- eventIdentifier, eventclass, sending resource
Notifications:
- conveying results to long running operations

Balazs

Bert Wijnen (IETF) wrote:
> the

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Balazs Lengyel <[email-masked]>
Date: Thu, 27 Nov 2008 09:35:28 +0100

Hello,

Balazs

---

From: "tom.petch" <[email-masked]>
Date: Fri, 28 Nov 2008 16:34:10 +0100

I disagree.

I think that we should make more progress with YANG before starting on content.

I did not express a view at Minneapolis.

Tom Petch

----- Original Message -----
From: "Bert Wijnen (IETF)" <[email-masked]>
To: "Netconf" <[email-masked]>
Sent: Wednesday, November 26, 2008 6:56 PM
Subject: [Netconf] confirm WG consensus on potential new WG
work-item:notification

> listFrom [email-masked]  Fri Nov 28 10:52:10 2008
From: "tom.petch" <[email-masked]>
To: "Bert Wijnen \(IETF\)" <[email-masked]>, "Netconf" <[email-masked]>
Date: Fri, 28 Nov 2008 16:34:10 +0100
Subject: Re: [Netconf] confirm WG consensus on potential new WG
	work-item:notification
Reply-To: "tom.petch" <[email-masked]>
Sender: [email-masked]

I disagree.

I think that we should make more progress with YANG before starting on content.

I did not express a view at Minneapolis.

Tom Petch

----- Original Message -----
From: "Bert Wijnen (IETF)" <[email-masked]>
To: "Netconf" <[email-masked]>
Sent: Wednesday, November 26, 2008 6:56 PM
Subject: [Netconf] confirm WG consensus on potential new WG
work-item:notification

> The WG chairs consider this to be WG consensus. If anyone on the mailing
 does not agree, please speak up before Dec 3rd 2008.  That is one week.