Subject: Re: [Netconf] Fwd: I-DAction:draft-ietf-netconf-with-defaults-13.txt

From: "Andy Bierman" <[email-masked]>
Date: Thu, 11 Nov 2010 08:10:03 +0800

Ok... I will change the reference to 4741bis.

Andy

----- Reply message -----
From: "t.petch" <[email-masked]>
Date: Thu, Nov 11, 2010 01:46
Subject: [Netconf] Fwd: I-DAction:draft-ietf-netconf-with-defaults-13.txt
To: "Andy Bierman" <[email-masked]>, "Bert \(IETF\) Wijnen" <[email-masked]>, "netconf" <[email-masked]>

----- Original Message -----
From: "Andy Bierman" <[email-masked]>
To: "t.petch" <[email-masked]>; "Bert (IETF) Wijnen"
<[email-masked]>; "netconf" <[email-masked]>
Sent: Wednesday, November 10, 2010 4:12 PM
Subject: RE: [Netconf] Fwd: I-DAction:draft-ietf-netconf-with-defaults-13.txt

RFC 4741 sec 5.1 defines a datastore.
The section heading is not called 'Terminology', but the term is defined.
What is your concern?

It defines a configuration datastore, which, as has been discussed before, is
not the only kind of datastore, so the definition of datastore is a superset of
the definition given in RFC4741 for configuration datastore.  As I said, there
is a definition of datastore unqualified in 4741bis so I think the reference
should be change to that.

Tom Petch

Andy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
t.petch
Sent: Wednesday, November 10, 2010 3:59 AM
To: Bert (IETF) Wijnen; netconf
Subject: Re: [Netconf] Fwd: I-D Action:draft-ietf-netconf-with-defaults-13.txt

----- Original Message -----
From: "Bert (IETF) Wijnen" <[email-masked]>
To: "netconf" <[email-masked]>
Sent: Tuesday, November 09, 2010 8:48 AM

> Netcon WG participants,
>
> This revision is the result of IETF LC and IESG review.
> While I am checking with the IESG if this revision indeed
> addresses all their concerns, pls take a look and speak
> up if you see anything weird.
>
> Do not re-open old issues that we have already decided on.

Bert

Trouble is, I do not know what issues we have decided on, and re-reading the
archives leaves me none the wiser.  There is an issue that I raised in August,
that caused changes to be made, that were objected to, that caused changes to be
unmade, at the end of which the I-D remains wrong (IMO).  I am unclear if you
regard this as a beaten-to-death issue not to be re-raised, but I expect Alfred
will
raise it as an erratum if it is not resolved now so here goes.

s1.1 says
"   The following terms are defined in [RFC4741]:
   o  client
   o  datastore"

RFC4741 does not have a definitions section; s5.1 defines a configuration
datastore which is the term used extensively, along with target datastore, but
'datastore' per se is never defined.

Perhaps we should reference 4741bis instead

Tom Petch

> Bert and Mehmet
>
> -------- Original Message --------
> Subject: [Netconf] I-D Action:draft-ietf-netconf-with-defaults-13.txt
> Date: Mon, 08 Nov 2010 20:30:02 -0800
> From: [email-masked]
> To: [email-masked]
> CC: [email-masked]
>
>
>
> A New Internet-Draft is available from the on-line Internet-Drafts
directories.
> This draft is a work item of the Network Configuration Working Group of the
IETF.
>
>
> Title           : With-defaults capability for NETCONF
> Author(s)       : A. Bierman, B. Lengyel
> Filename        : draft-ietf-netconf-with-defaults-13.txt
> Pages           : 32
> Date            : 2010-11-08
>
> The NETCONF protocol defines ways to read and edit configuration data
> from a NETCONF server.  In some cases, part of this data may not be
> set by the NETCONF client, but rather a default value known to the
> server is used instead.  In many situations the NETCONF client has a
> priori knowledge about default data, so the NETCONF server does not
> need to save it in a NETCONF configuration datastore or send it to
> the client in a retrieval operation reply.  In other situations the
> NETCONF client will need this data from the server.  Not all server
> implementations treat this default data the same way.  This document
> defines a capability-based extension to the NETCONF protocol that
> allows the NETCONF client to identify how defaults are processed by
> the server, and also defines new mechanisms for client control of
> server processing of default data.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-netconf-with-defaults-13.txt
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>
>
>

--------------------------------------------------------------------------------

> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Thu, 18 Nov 2010 17:37:52 +0100

Tom, revision 14 now references 4741bis and no lobnger RFC4741.

May Iconsider your concern addressed?

Bert Wijnen
document shepherd
----- Original Message ----- 
From: "Andy Bierman" <[email-masked]>
To: "t.petch" <[email-masked]>; "Andy Bierman" <[email-masked]>; 
"Bert \(IETF\) Wijnen" <[email-masked]>; "netconf" <[email-masked]>
Sent: Thursday, November 11, 2010 1:10 AM
Subject: Re: [Netconf] Fwd: 
I-DAction:draft-ietf-netconf-with-defaults-13.txt

Andy

----- Reply message -----
From: "t.petch" <[email-masked]>
Date: Thu, Nov 11, 2010 01:46
Subject: [Netconf] Fwd: I-DAction:draft-ietf-netconf-with-defaults-13.txt
To: "Andy Bierman" <[email-masked]>, "Bert \(IETF\) Wijnen" 
<[email-masked]>, "netconf" <[email-masked]>

----- Original Message -----
From: "Andy Bierman" <[email-masked]>
To: "t.petch" <[email-masked]>; "Bert (IETF) Wijnen"
<[email-masked]>; "netconf" <[email-masked]>
Sent: Wednesday, November 10, 2010 4:12 PM
Subject: RE: [Netconf] Fwd: 
I-DAction:draft-ietf-netconf-with-defaults-13.txt

It defines a configuration datastore, which, as has been discussed before, 
is
not the only kind of datastore, so the definition of datastore is a superset 
of
the definition given in RFC4741 for configuration datastore.  As I said, 
there
is a definition of datastore unqualified in 4741bis so I think the reference
should be change to that.

Tom Petch

Andy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf 
Of
t.petch
Sent: Wednesday, November 10, 2010 3:59 AM
To: Bert (IETF) Wijnen; netconf
Subject: Re: [Netconf] Fwd: I-D 
Action:draft-ietf-netconf-with-defaults-13.txt

----- Original Message -----
From: "Bert (IETF) Wijnen" <[email-masked]>
To: "netconf" <[email-masked]>
Sent: Tuesday, November 09, 2010 8:48 AM

Bert

Trouble is, I do not know what issues we have decided on, and re-reading the
archives leaves me none the wiser.  There is an issue that I raised in 
August,
that caused changes to be made, that were objected to, that caused changes 
to be
unmade, at the end of which the I-D remains wrong (IMO).  I am unclear if 
you
regard this as a beaten-to-death issue not to be re-raised, but I expect 
Alfred
will
raise it as an erratum if it is not resolved now so here goes.

s1.1 says

RFC4741 does not have a definitions section; s5.1 defines a configuration
datastore which is the term used extensively, along with target datastore, 
but
'datastore' per se is never defined.

Tom Petch

directories.
IETF.

---

From: "t.petch" <[email-masked]>
Date: Fri, 19 Nov 2010 09:53:52 +0100

----- Original Message -----
From: "Bert Wijnen (IETF)" <[email-masked]>
To: "t.petch" <[email-masked]>; "netconf" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, November 18, 2010 5:37 PM

> May Iconsider your concern addressed?

Ok.

When next this is revised, you may want to amend:

s8 The security  consideration apply
to either
The security  considerations apply
or
The security  consideration applies

s1.2 The actual nodes omitted depends
to
The actual nodes omitted depend

s1 knowledge can be obtained a document
to
 knowledge can be obtained from a document

Tom Petch

---

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Fri, 19 Nov 2010 11:04:59 +0100

Thanks Tom.
I ecpect the RFC-Editor tio catch the remaining editorial changes too.
If not, I herewith ask the editors/authors of the document to keep an
eye on this during AUTH48.

Bert
----- Original Message ----- 
From: "t.petch" <[email-masked]>
To: "Bert Wijnen (IETF)" <[email-masked]>; "netconf" 
<[email-masked]>
Cc: <[email-masked]>
Sent: Friday, November 19, 2010 9:53 AM
Subject: Re: [Netconf] Fwd: 
I-DAction:draft-ietf-netconf-with-defaults-14.txt

----- Original Message -----
From: "Bert Wijnen (IETF)" <[email-masked]>
To: "t.petch" <[email-masked]>; "netconf" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, November 18, 2010 5:37 PM

Ok.

Tom Petch