Subject: [Netconf] Fwd: New Version Notification for draft-mahesh-netconf-binary-encoding-00.txt

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 21 Feb 2018 18:29:57 -0800

This short draft proposes a mechanism for NETCONF clients and servers to negotiate an alternate form of encoding, e.g. binary encoding.

Cheers.

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-mahesh-netconf-binary-encoding-00.txt
> Date: February 21, 2018 at 6:18:45 PM PST
> To: "Jason Lam" <[email-masked]>, "Alfred Leung" <[email-masked]>, "Mahesh Jethanandani" <[email-masked]>
> 
> 
> A new version of I-D, draft-mahesh-netconf-binary-encoding-00.txt
> has been successfully submitted by Mahesh Jethanandani and posted to the
> IETF repository.
> 
> Name:		draft-mahesh-netconf-binary-encoding
> Revision:	00
> Title:		Binary Encoding for NETCONF
> Document date:	2018-02-23
> Group:		Individual Submission
> Pages:		6
> URL:            https://www.ietf.org/internet-drafts/draft-mahesh-netconf-binary-encoding-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-mahesh-netconf-binary-encoding/
> Htmlized:       https://tools.ietf.org/html/draft-mahesh-netconf-binary-encoding-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-mahesh-netconf-binary-encoding-00
> 
> 
> Abstract:
>   This document describes a method by which a NETCONF [RFC6241] client
>   and server can negotiate an alternate form of encoding.
> 
>   This document updates RFC 6241.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 

Mahesh Jethanandani
[email-masked]

---

From: Robert Wilton <[email-masked]>
Date: Fri, 23 Feb 2018 12:08:39 +0000

Hi Mahesh,

Some quick thoughts/comments on this draft:

1) I think that it is good for NETCONF to support other encodings, 
particularly CBOR, and possibly JSON as well.  I particularly the like 
the CBOR+SID encoding that seems to be compact but not hard to support.
2) I think that it would be good if RESTCONF could also support CBOR as 
well.  I'm not sure whether that could be covered by this draft of 
something else.
3) There needs to be a well defined registry of encodings, perhaps as 
identities.
4) CBOR supports using SIDs or strings for identifiers, so there would 
need to be a way of choosing between these.  Perhaps these would be 
listed as two different encodings.
5) Versioning might want to be considered, e.g. if there was an updated 
version of CBOR how would that be reported.
6) If CBOR is being used, and in which case, SIDs is probably the way to 
go, then there might need to be some consideration about how the client 
learns the SIDs, this may be covered by some of the CORE WG drafts, or 
might require new NETCONF/RESTCONF RPCs.
7) There is no encoding of metadata in CBOR, it might be useful if that 
was also considered, probably that would end up being a separate draft.
7b) Related to 7, how would the <edit-config> operations (merge, create, 
remove,  etc) be encoded.
7c) Would errors also be reported using a binary encoding, or would they 
stay in XML?
8) Does there need to be any comment/considerations regarding YANG push 
and friends.

But in general, I'm supportive of IETF allowing binary encodings to be 
used in NETCONF/RESTCONF for devices that want to use them. They seem to 
be particularly relevant to streaming telemetry related applications.

Thanks,
Rob

On 22/02/2018 02:29, Mahesh Jethanandani wrote:
> This short draft proposes a mechanism for NETCONF clients and servers 
> to negotiate an alternate form of encoding, e.g. binary encoding.
>
> Cheers.
>
>> Begin forwarded message:
>>
>> *From: [email-masked] <mailto:[email-masked]>
>> *Subject: **New Version Notification for 
>> draft-mahesh-netconf-binary-encoding-00.txt*
>> *Date: *February 21, 2018 at 6:18:45 PM PST
>> *To: *"Jason Lam" <[email-masked] <mailto:[email-masked]>>, "Alfred 
>> Leung" <[email-masked] <mailto:[email-masked]>>, "Mahesh 
>> Jethanandani" <[email-masked] <mailto:[email-masked]>>
>>
>>
>> Name:draft-mahesh-netconf-binary-encoding
>> Revision:00
>> Title:Binary Encoding for NETCONF
>> Document date:2018-02-23
>> Group:Individual Submission
>> Pages:6
>> URL: 
>> https://www.ietf.org/internet-drafts/draft-mahesh-netconf-binary-encoding-00.txt
>> Status: 
>> https://datatracker.ietf.org/doc/draft-mahesh-netconf-binary-encoding/
>> Htmlized: 
>> https://tools.ietf.org/html/draft-mahesh-netconf-binary-encoding-00
>> Htmlized: 
>> https://datatracker.ietf.org/doc/html/draft-mahesh-netconf-binary-encoding-00
>>
>>
>> Abstract:
>> until the htmlized version and diff are available at tools.ietf.org 
>> <http://tools.ietf.org>.
>>
>> The IETF Secretariat
>>
>
> Mahesh Jethanandani
> [email-masked] <mailto:[email-masked]>
>
>
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf