Subject: [Netconf] [Technical Errata Reported] RFC8040 (5255)

From: RFC Errata System <[email-masked]>
Date: Tue, 6 Feb 2018 03:21:12 -0800 (PST)

The following errata report has been submitted for RFC8040,
"RESTCONF Protocol".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5255

--------------------------------------
Type: Technical
Reported by: Balazs Lengyel <[email-masked]>

Section: 3.5.3.

Original Text
-------------
If there are multiple key leaf values, the path 
segment is constructed by having the list name, 
followed by the value of each leaf identified 
in the "key" statement, encoded in the order
specified in the YANG "key" statement.  Each key 
leaf value except the last one is followed by 
a comma character.

Corrected Text
--------------
If there are multiple key leaf values, the path 
segment is constructed by having the list name,  
followed by an "=" character, 
followed by the value of each leaf identified 
in the "key" statement, encoded in the order
specified in the YANG "key" statement.  Each key 
leaf value except the last one is followed by 
a comma character.

Notes
-----
When describing the encoding of key values for a list, in the case of multiple keys the "=" equal sign is not mentioned although it is used in the examples.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8040 (draft-ietf-netconf-restconf-18)
--------------------------------------
Title               : RESTCONF Protocol
Publication Date    : January 2017
Author(s)           : A. Bierman, M. Bjorklund, K. Watsen
Category            : PROPOSED STANDARD
Source              : Network Configuration
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 06 Feb 2018 12:56:49 +0100 (CET)

Hi,

This errata report is correct and should be applied.

/martin

---

From: Benoit Claise <[email-masked]>
Date: Tue, 6 Feb 2018 13:00:03 +0100

Hi,

Now "verified"

Regards, B.
> .