Subject: [Network-tokens] Deterministic latency service

From: Hesham ElBakoury <[email-masked]>
Date: Fri, 23 Jul 2021 02:42:37 -0700

How network tokens can be used to provide deterministic service which is
needed for example in industrial control systems.

Thanks
Hesham

---

From: "Yiannis Yiakoumis" <[email-masked]>
Date: Fri, 23 Jul 2021 18:27:50 +0000

Hi Hesham,

They can be used to expose/access a low latency service in the network, with fine granularity, no need to configure iptables and long ACL lists, and implement security policies (e.g., which applications/devices/users can access these services, how to revoke/limit trust). They don't implement the low-latency service itself (i.e., forwarding, queue management, etc).

Is there any specific use case you have in mind?

Thanks,

Yiannis

=====================
Yiannis Yiakoumis
Co-Founder & CEO
https://selfienetworks.com | +1-650-644-7857

On Fri, Jul 23, 2021 at 2:42 AM, Hesham ElBakoury < [email-masked] > wrote:

> --
> Network-tokens mailing list
> Network-tokens@ ietf. org ( [email-masked] )
> https:/ / www. ietf. org/ mailman/ listinfo/ network-tokens (
> https://www.ietf.org/mailman/listinfo/network-tokens )
> 
> 
>

---

From: Hesham ElBakoury <[email-masked]>
Date: Fri, 23 Jul 2021 13:18:11 -0700

Hi Yiannis

Thanks for your prompt response.

There are all the use cases provided by IETF DetNet WG and IEEE 802.1 
TSN TG.

I addition to support deterministic latency which pretty much means that 
packets should arrive on time (with zero or very small jitter), we also 
need to support in-time packet delivery. For example, we want packets 
not to arrive earlier than certain time. On-time and in-time packet 
delivery is part of what we call it High Precision Communications (HPC).

Please let me know if there is a paper that describes how with network 
tokens we do not need to configure iptables, and long ACL lists, 
implement security policies, ....

How Network token is used to establish SLA with a user who is interested 
in HPC service and how we can detect if the user or the network violate 
the SLA and take the proper action.

Hesham

On 7/23/2021 11:27 AM, Yiannis Yiakoumis wrote:
> Hi Hesham,
>
> They can be used to expose/access a low latency service in the 
> network, with fine granularity, no need to configure iptables and long 
> ACL lists, and implement security policies (e.g., which 
> applications/devices/users can access these services, how to 
> revoke/limit trust). They don't implement the low-latency service 
> itself (i.e., forwarding, queue management, etc).
>
> https://selfienetworks.com <https://selfienetworks.com> | +1-650-644-7857
>
>
> On Fri, Jul 23, 2021 at 2:42 AM, Hesham ElBakoury 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     How network tokens can be used to provide deterministic service
>     which is needed for example in industrial control systems.
>
>     Thanks
>     Hesham
>
>     -- 
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/listinfo/network-tokens
>     <https://www.ietf.org/mailman/listinfo/network-tokens>
>
>