Subject: Re: [ogpx] Draft Agenda for VWRAP WG Session at IETF77

From: Mark Lentczner <[email-masked]>
Date: Mon, 1 Mar 2010 10:45:18 -0800

On Feb 28, 2010, at 9:19 PM, Joshua Bell wrote:
> Can I ask all of those who are planning to attend (physically or virtually) *and* present/lead discussions to reply on-list and confirm, and give an updated time estimate?

I'm confirming my attendance, and I'm ready to present on:
10min - Open Issues in "Foundation" 
20min - Open Issues in "Abstract Type System"

*IF* we want to get into the issue of client-to-server messaging (event queue or other methods) in this session, than the section on Foundation would be the place to do it, and if so, then 10 min will likely be too short. 20?  If there is agreement that we should work on this at the session, then we should get some preliminary discussion going here. Thoughts?

	- Mark Lentczner

Mark Lentczner
Sr. Systems Architect
Technology Integration
Linden Lab

[email-masked]

Zero Linden
[email-masked]

---

From: David W Levine <[email-masked]>
Date: Mon, 1 Mar 2010 13:50:13 -0500

I think the messaging topic is one we really need to get on the table. I 
*think* it may be best to break it out as a topic, rather than short other 
stuff we need to be sure we cover. 

- David
- Zha

From:
Mark Lentczner <[email-masked]>
To:
ogpx <[email-masked]>
Date:
03/01/2010 01:46 PM
Subject:
Re: [ogpx] Draft Agenda for VWRAP WG Session at IETF77
Sent by:
[email-masked]

On Feb 28, 2010, at 9:19 PM, Joshua Bell wrote:
Can I ask all of those who are planning to attend (physically or 
virtually) *and* present/lead discussions to reply on-list and confirm, 
and give an updated time estimate?

*IF* we want to get into the issue of client-to-server messaging (event 
queue or other methods) in this session, than the section on Foundation 
would be the place to do it, and if so, then 10 min will likely be too 
short. 20?  If there is agreement that we should work on this at the 
session, then we should get some preliminary discussion going here. 
Thoughts?

- Mark Lentczner

Mark Lentczner
Sr. Systems Architect
Technology Integration
Linden Lab

[email-masked]

Zero Linden

_______________________________________________
ogpx mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ogpx

---

From: Meadhbh Hamrick <[email-masked]>
Date: Mon, 1 Mar 2010 19:02:02 -0800

try 3. between getting eaten by a MTA grue and me forgetting to cc: it
to the list rather than just josh, this message has had a hard time of
it.

On Mon, Mar 1, 2010 at 7:24 AM, Meadhbh Hamrick <[email-masked]> wrote:
> hey josh,
>
> i'm planning on being there. the times in the original look good.
> however, i'm thinking it might be easier for the items marked
> meadhbh/mark be assigned to one of us, rather than both. i would
> recommend mark take foundation and abstract type system and i'll take
> intro, authentication and keep the launch message.
>
> and.. 9am? who did we offend to get the morning slot?
>
> -cheers
> -meadhbh
>
> --
> meadhbh hamrick * it's pronounced "maeve"
> @OhMeadhbh * http://meadhbh.org/ * [email-masked]

---

From: "Hurliman, John" <[email-masked]>
Date: Wed, 3 Mar 2010 16:24:38 -0700

Confirming my attendance and presentation on "Cable Beach and VWRAP". Since we have more time I'd prefer 10 minutes plus time for questions, but I can make do with whatever the schedule allows. I plan to give equal time covering our research with the Cable Beach project and lessons learned during implementation and deployment. I can also talk on my experience implementing LLSD/LLIDL, but I didn't see a time slot for that.

John

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Joshua Bell
> Sent: Sunday, February 28, 2010 9:19 PM
> To: ogpx
> Subject: Re: [ogpx] Draft Agenda for VWRAP WG Session at IETF77
> 
> The final agenda has been published:
> 
> https://datatracker.ietf.org/meeting/77/agenda.html
> 
> Note that the time for the VWRAP session changed to Tuesday, March 23rd
> 09:00-11:30 Pacific. I'm pretty sure we will not use the entire 2.5-
> hour slot, but it gives us more breathing room.
> 
> I'm confirming my attendance, and believe my discussion topic ("What's
> not in VWRAP") will fill about 10 minutes.
> 
> 
> On Tue, Feb 23, 2010 at 8:46 AM, Joshua Bell <[email-masked]>
> wrote:
> 
> 
> 	What, no feedback? C'mon, peeps!
> 
> 	A bit of an update though:
> 
> 	* We have a tentative time slot of Tuesday (March 23rd) evening
> (1740-1940 / 5:40pm-7:40pm) Pacific Time. The final schedule will not
> be announced until the 26th, however.
> 
> 	* That also gives us two hours, which means we aren't quite as
> constrained.
> 
> 	I would lean towards beefing up time spent for issue bashing on
> the three active drafts (intro, foundation, type system) and the
> "presentations" (deployment patterns, cable beach, accessibility,
> what's not...). Opinions?
> 
> 
> 	On Fri, Feb 19, 2010 at 10:16 AM, Joshua Bell
> <[email-masked]> wrote:
> 
> 
> 		Please get out your slings and arrows - it's time to bash
> the agenda for the upcoming face-to-face meeting next month in Anaheim.
> 
> 		We asked for a 90 minute session, so we should probably
> plan on dropping (from the list below) discussion of drafts which are
> not looking at submissions to the IESG in the next few months to
> dedicate more time for active work on the issues in the shorter term
> drafts (intro/foundation/type system). Also, if you'd previously
> proposed a topic and I did not include it, that's an oversight on my
> part not an intentional deletion, so please re-raise the request.
> 
> 		2min - Mixed Reality Status Check[1]  - Joshua Bell
> 		5min - Welcome, Introductions, Agenda Review/Bashing, News
> - Barry Leiba, Joshua Bell
> 		10min - Open Issues in "Introduction and Goals"  - Meadhbh
> Hamrick
> 		10min - Open Issues in "Foundation"  - Meadhbh Hamrick/Mark
> Lentczner
> 		20min - Open Issues in "Abstract Type System"[2] - Meadhbh
> Hamrick/Mark Lentczner
> 		5min - Status/Issues in "User Authentication"[3]  - Meadhbh
> Hamrick
> 		5min - Status/Issues in"Client Application Launch Message"
> - Meadhbh Hamrick
> 		5min - Status/Issues in "Deployment and Trust Patterns" -
> David W Levine
> 		5min - Cable Beach and VWRAP  - John Hurliman
> 		5min - Virtual World Accessibility[4] - Katherine Mancuso
> 		5min - What's NOT in VWRAP (a dissection of the Linden
> "Legacy" Protocol)  - Joshua Bell
> 		5min - Next Steps - Barry Leiba, Joshua Bell
> 
> 		[1] this is NOT to diagnose/fix issues; it's simply to
> confirm that a channel is functional or not, and redirect participants
> appropriately
> 		[2] Including implementation experiences, possibly by John
> Hurliman
> 		[3] Should include discussion on OAuth
> 		[4] Tentative, based on the scheduling of our session
> 
> 		Feedback appreciated:
> 		* What to add to the agenda
> 		* What to drop from the agenda
> 		* Time allotments/priorities
> 		* Overall order (I have Meadhbh/Mark on the podium for a
> long period of time; break it up a bit?)
> 
> 
>

---

From: Meadhbh Hamrick <[email-masked]>
Date: Mon, 1 Mar 2010 07:24:37 -0800

hey josh,

-cheers
-meadhbh

On Sun, Feb 28, 2010 at 9:19 PM, Joshua Bell <[email-masked]> wrote:
> 09:00-11:30 Pacific. I'm pretty sure we will not use the entire 2.5-hour
> slot, but it gives us more breathing room.
> Can I ask all of those who are planning to attend (physically or virtually)
> *and* present/lead discussions to reply on-list and confirm, and give an
> updated time estimate?
> I'm confirming my attendance, and believe my discussion topic ("What's not
> in VWRAP") will fill about 10 minutes.
>
> On Tue, Feb 23, 2010 at 8:46 AM, Joshua Bell <[email-masked]> wrote:
>>
>> * We have a tentative time slot of Tuesday (March 23rd) evening (1740-1940
>> / 5:40pm-7:40pm) Pacific Time. The final schedule will not be announced
>> until the 26th, however.
>> I would lean towards beefing up time spent for issue bashing on the three
>> active drafts (intro, foundation, type system) and the "presentations"
>> (deployment patterns, cable beach, accessibility, what's not...). Opinions?
>>
>> On Fri, Feb 19, 2010 at 10:16 AM, Joshua Bell <[email-masked]> wrote:
>>>
>>> Please get out your slings and arrows - it's time to bash the agenda for
>>> the upcoming face-to-face meeting next month in Anaheim.
>>> We asked for a 90 minute session, so we should probably plan on dropping
>>> (from the list below) discussion of drafts which are not looking at
>>> submissions to the IESG in the next few months to dedicate more time for
>>> active work on the issues in the shorter term drafts (intro/foundation/type
>>> system). Also, if you'd previously proposed a topic and I did not include
>>> it, that's an oversight on my part not an intentional deletion, so please
>>> re-raise the request.
>>> 5min - Welcome, Introductions, Agenda Review/Bashing, News - Barry Leiba,
>>> Joshua Bell
>>> 10min - Open Issues in "Introduction and Goals"  - Meadhbh Hamrick
>>> 10min - Open Issues in "Foundation"  - Meadhbh Hamrick/Mark Lentczner
>>> 20min - Open Issues in "Abstract Type System"[2] - Meadhbh Hamrick/Mark
>>> Lentczner
>>> 5min - Status/Issues in "User Authentication"[3]  - Meadhbh Hamrick
>>> 5min - Status/Issues in"Client Application Launch Message"  - Meadhbh
>>> Hamrick
>>> 5min - Status/Issues in "Deployment and Trust Patterns" - David W Levine
>>> 5min - What's NOT in VWRAP (a dissection of the Linden "Legacy" Protocol)
>>>  - Joshua Bell
>>> [1] this is NOT to diagnose/fix issues; it's simply to confirm that a
>>> channel is functional or not, and redirect participants appropriately
>>> [2] Including implementation experiences, possibly by John Hurliman
>>> * Overall order (I have Meadhbh/Mark on the podium for a long period of
>>> time; break it up a bit?)
>>
>
>

---

From: Joshua Bell <[email-masked]>
Date: Thu, 4 Mar 2010 11:16:22 -0800

Thanks, folks. I did some agenda bashing after talking with several of
the topic owners, here's the latest:

2min - Mixed Reality Status Check  - Joshua Bell

10min - Welcome, Introductions, Agenda Review/Bashing, News - Barry
Leiba, Joshua Bell (chairs)

25min - Open Issues in "Foundation"  -  Mark Lentczner
* Including transport (EventQueue, HyBi, WebSockets, ...), road map

25min - Open Issues in "Abstract Type System" - Mark Lentczner
* Including implementation experiences (Mark Lentczner, John Hurliman)

5min - Client-Side Capabilities - David W Levine

5min - Status/Issues in "User Authentication"  - Meadhbh Hamrick
* Including OAuth

15min - Cable Beach and VWRAP  - John Hurliman

5min - Status/Issues in"Client Application Launch Message"  - Meadhbh Hamrick

15min - What's NOT in VWRAP (a dissection of the Linden "Legacy"
Protocol)  - Joshua Bell

15min - Virtual World Accessibility - Katherine Mancuso
* NOTE: I don't have confirmation that Katherine will be attending;
pinging via email
* Including "making metadata accessible"

10min - Next Steps - Barry Leiba, Joshua Bell (chairs)

Reminders:
* Internet Draft final submission cut-off due 3/8 (i.e. stop revising
drafts prior to IETF77 at this point)
* Draft WG session agenda is due by 3/10 (i.e. Barry and I will submit
the above)
* Final WG session agenda is due by 3/15 (although we will bash at the
start of the session)

(See http://www.ietf.org/meeting/cutoff-dates-2010.html for the
down-to-the-minute-in-what-time-zone cut-offs.)

As always, feedback appreciated - we can still adjust the schedule to
squeeze in additional topics. Where possible, I'd like to discuss
things within the scope of the drafts (thus letting the draft editors
lead the discussion), but identifying specific sub-topics that we
should budget time for is a good thing (IMHO).

---

From: David W Levine <[email-masked]>
Date: Thu, 4 Mar 2010 14:25:50 -0500

That looks super Josh. The first item raises a couple of quick logistical 
questions. Do we have a site in world which we
expect to use? I'm assuming we're going to be using voice, I'm also 
assuming we'll stick with 1.23.X compatible clients,
as much as it might be nice to have the 2.0 media in world. I'm looking 
forward to seeing us pull of the mixed reality
meeting. I'm also expecting some wide eyes when we take questions/comments 
from a virtual mike line. Given the
9:00 am, are we first up in the room? If so, have we looked at getting 
access to the room prior to 9:00?  And.. finally
do we have dry run plans a) pre IETF and b) before the session, in the 
actual space. (I'm willing to be there any time on
Monday we need to test stuff)

- David
~ Zha

From:
Joshua Bell <[email-masked]>
To:
ogpx <[email-masked]>
Date:
03/04/2010 02:16 PM
Subject:
Re: [ogpx] Draft Agenda for VWRAP WG Session at IETF77
Sent by:
[email-masked]

Reminders:

ogpx mailing list (VWRAP working group)

---

From: Joshua Bell <[email-masked]>
Date: Thu, 4 Mar 2010 11:59:14 -0800

All excellent questions, and a great time to ask for help in this area. I've
reached out to a few folks with experience in orchestrating these
mixed-reality events but haven't heard back. I need to beat the drum more
loudly, and dedicate serious time over the next few weeks to getting this
prepped.

On Thu, Mar 4, 2010 at 11:25 AM, David W Levine <[email-masked]> wrote:

> as much as it might be nice to have the 2.0 media in world.

I'll check with Lisa about using "IETF Island" in Second Life (
http://www.ietf.org/mail-archive/web/vmeet/current/msg00223.html), and make
sure we have permissions sorted.

What I've experienced working well for mixed-reality meetings is to have the
virtual meeting space projected on screen, and slide content displayed
in-world. We can do this with both "old" in-world media and "new" shared
media (where links are shared); the latter is snazzier but would require
users of older clients to follow along manually, unless we uniformly use
Google Docs and use the present/follow tools. Definitely something we should
dry-run.

We should definitely support voice in- and out of world at the meeting. Of
course, many virtual attendees prefer to stick with text (in meetings, I
tend to be a back-channel "typer" myself), so we'll need to relay.

I'm looking forward to seeing us pull of the mixed reality
> from a virtual mike line.

Minimally we will take questions from:
* Physical session attendees
* Jabber room
* In-World in Second Life

Other virtual locations are welcome, but I'll need volunteers ASAP to host
them and work on relays.

Traditionally, the on-the-fly nominated Jabber scribe relays those questions
to the physical room. If we get a good Jabber/In-World relay hopefully this
can be unified. Otherwise, we'll have to maintain three queues
(round-robin?)

Unless we have another volunteer, I'll attempt to play "MC" (but NOT scribe)
during the meeting to ensure the various modalities get represented at the
mics. (And I'll need backup if/when I'm talking.)

> Given the
> access to the room prior to 9:00?

We are up first in the room. I'll look into getting early access.

>  And.. finally

We don't have such plans, but we should!

People who wish to participate in the mixed-reality planning can email me
directly, and I'll coordinate.

> To: ogpx <[email-masked]> Date: 03/04/2010 02:16 PM Subject:
> Sent by: [email-masked]
> ------------------------------
>
>
>
> 2 min - Mixed Reality Status Check  - Joshua Bell
>
> 10 min - Welcome, Introductions, Agenda Review/Bashing, News - Barry

---

From: Barry Leiba <[email-masked]>
Date: Thu, 4 Mar 2010 16:36:56 -0500

> We are up first in the room. I'll look into getting early access.

Breakfast is served in the hallways at 8:00, and we'll have access to
the room at least as early as that.  If we need to get in earlier, we
can just ask Marcia on Sunday or Monday.  But I think 8 should be
early enough.

>> Monday we need to test stuff)

We can easily use the room for testing on Monday during lunch (11:30 to 1 PST).

Barry

---

From: Joshua Bell <[email-masked]>
Date: Thu, 4 Mar 2010 14:03:56 -0800

One more deadline, this one coming from your friendly neighborhood co-chairs:

Presentation slides MUST be submitted to Barry by noon Pacific time on
Friday March 19th, to ensure they are available to remote participants
in advance of the meeting. Preferred format is PDF, but PPT and ODP
are acceptable. Get them to Barry by the cut-off and they'll be posted
by EOD on Friday.

If you don't have your slides in by the the cut-off, you will be
removed from the agenda.