Subject: [ogpx] user agents vs client apps

From: Katherine Mancuso <[email-masked]>
Date: Sat, 6 Mar 2010 17:57:13 -0500

Hi Carlo and Meadhbh,

I believe we may have a conflation between user-as-end user (human who
is controlling a program at the moment) and user-as-programmer (who
may or may not be directly operating the program) which is an older
sense of the word user.  I do think it might be useful to use
vocabulary that teases out the distinction between
user-agent-as-automated-program (bots, data parsers, intermediaries,
etc) and user-agent-as-human-computer-interface (what we typically
call a viewer) before we deploy the term.

I don't know about IETF protocols, but I'd like to point out that the
W3C uses user agent to include both your "client applications
category"  of browsers, media rendering plugins, mobile browsers and
other programs that display content directly to humans AND bots, web
spiders, and other automated crawlers.

I would be curious to have citations for user agent in the IETF
literature so we can establish how the term is used for other
protocols.  I know that SIP refers to both its endpoints as user
agents.  Anyone?

Katherine

> ---------- Forwarded message ----------
> From: Carlo Wood <[email-masked]>
> To: "Infinity Linden (Meadhbh Hamrick)" <[email-masked]>
> Date: Sat, 6 Mar 2010 14:25:08 +0100
> Subject: Re: [ogpx] Updated deployment and trust draft posted
> Sorry for the late reply, but I couldn't find much time lately,
>
> On Wed, Feb 24, 2010 at 11:15:02AM -0800, Infinity Linden (Meadhbh Hamrick) wrote:
>> in a related issue. we use the term "client application" for an app that
>> accesses services. the most visible client application is the one that renders
>> the virtual world for the user. i think this kind of application is
>> traditionally called a "user agent" in other IETF protocols. so...
>>
>> question : does it make sense to introduce the concept of a "user agent" as the
>> client application that is intended to have direct interaction with the user?
>> i think it would be good to explain that "clients" or "client applications" do
>> not always have to be "user agents." if so, lemme modify the intro doc to
>> reflect it.
>
> I don't think rendering or having interaction with a human has anything to do
> with VWRAP, I'd define a "user agent" as "end point"; in theory, such an end
> point could be not the application that renders, it could be bot that has
> no rendering or human interaction at all.
>
> I'm ok with still using the word "user" in "user agent", but some clarification
> is indeed necessary then. On the other hand, I have no problem understanding
> "client application" at all. The use of "user agent" in it's place seems
> only confusing to me.
>
> --
> Carlo Wood <[email-masked]>

-- 
---------------------------------------------------------------------------------------------
Katherine Mancuso: crusader of community art, social technology, & disability

Research:
Center for Assistive Technology & Environmental Access (http://www.catea.org)
Georgia Tech, Digital Media (http://dm.gatech.edu)

Community:
The Vesuvius Group: metaverse community builders
(http://www.thevesuviusgroup.com)
Gimp Girl Community Liaison/Research Fellow (http://www.gimpgirl.com)
Alternate ROOTS: arts*community*activism (http://www.alternateroots.org)
Students Working Against Negative Stereotypes of Autism, Georgia Tech.
([email-masked])

Contact in the web, the metaverse, the world:
http://twitter.com/musingvirtual
http://muse.dreamwidth.org
http://www.linkedin.com/in/kathymancuso
SL: Muse Carmona
----------------------------------------------------------------------------------------------

---

From: Carlo Wood <[email-masked]>
Date: Sun, 7 Mar 2010 01:44:38 +0100

> protocols.  I know that SIP refers to both its endpoints as user

Perhaps the 'user' in 'user agent' refers to the trust model.
So, a user agent would be a program under the control of John Joe,
while a server is usually an application run by a company, or
administrator with responsibility.

In that light I can understand why 'user agent' would be broader
than the term 'client application' or visa versa: a user application
that also allows others to connect to it is also a server. While
a client application can in theory also be a service running
on a secure company network.

---

From: SM <[email-masked]>
Date: Tue, 09 Mar 2010 23:20:58 -0800

Hi Katherine,
>spiders, and other automated crawlers.

 From RFC 2616:

  "user agent - the client which initiates a request. These are often browsers,
   editors, spiders (web-traversing robots), or other end user tools."

>protocols.  I know that SIP refers to both its endpoints as user

Variants of the term are used in several specifications (mail, 
calendering, XMPP, HTTP, etc).  A user agent is an application.  It 
might be software acting on behalf of a human.

Is the distinction necessary in a virtual world? :-)

Regards,
-sm