Subject: Re: [OPSAWG] VMM-MIB: question about vmAdminState values

From: SHIMA Keiichi <[email-masked]>
Date: Tue, 3 Sep 2013 13:54:03 +0900

On 2013/08/30, at 0:06, Joe Marcus Clarke <[email-masked]> wrote:

> This reminds me of another problem I had initially noticed, but forgot
> to raise.  That is, the use of the state name to define the state.  I
> think what you have written here is good, but is there another way to
> say "blocked" that would define it more clearly?
> 
> I have the same comment for just about all states.  Their definition
> contains the state name.  If those descriptions were more descriptive,
> it might short-circuit emails like this in the future.

I agree that we need more explanation on the text describing the states.

By the way, VirtualMachineAdminState has more detailed explanation, which is nice :)  Maybe we should do the similar work for VirtualMachineOperState too?

---
Keiichi SHIMA (島 慶一)
WIDE project <[email-masked]>
Research Laboratory, IIJ Innovation Institute, Inc <[email-masked]>

On 2013/08/30, at 0:06, Joe Marcus Clarke <[email-masked]> wrote:

> On 8/26/13 6:59 AM, Juergen Schoenwaelder wrote:
>> Would this clarification help:
>> 
>>             blocked(5)     The virtual machine is currently blocked
>> 	     		    waiting for example for some action of 
>>                            the hypervisor to finish.
> 
> This reminds me of another problem I had initially noticed, but forgot
> to raise.  That is, the use of the state name to define the state.  I
> think what you have written here is good, but is there another way to
> say "blocked" that would define it more clearly?
> 
> I have the same comment for just about all states.  Their definition
> contains the state name.  If those descriptions were more descriptive,
> it might short-circuit emails like this in the future.
> 
> Joe
> 
> -- 
> Joe Marcus Clarke, CCIE #5384,         |          |
> SCJP, SCSA, SCNA, SCSECA, VCP        |||||      |||||
> Distinguished Services Engineer ..:|||||||||::|||||||||:..
> Phone: +1 (919) 392-2867         c i s c o  S y s t e m s
> Email: [email-masked]
> 
> ----------------------------------------------------------------------------
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: Joe Marcus Clarke <[email-masked]>
Date: Tue, 03 Sep 2013 11:00:53 -0400

> By the way, VirtualMachineAdminState has more detailed explanation, which is nice :)  Maybe we should do the similar work for VirtualMachineOperState too?

Yes, AdminState is much better, but still has one issue.  The
shutdown(4) state is described as "...should be taken shuttingdown."  I
don't think think this is right :-).

Joe