Subject: [OPSAWG] "Support" in working group last calls

From: Melinda Shore <[email-masked]>
Date: Mon, 09 Sep 2013 13:50:51 -0800

Over the past year or so there's been an increase in
the number of people responding to working group last
calls with "I support as a co-author."  This is a
request to stop.

By the time a document enters working group last call,
presumably the authors are familiar with its contents
and don't have serious disagreements with them.  Because
"I support as a co-author" introduces little-to-no
new information it's difficult to conclude that the
reason that it's being posted has something to do with
voting.  We don't vote.  (One hopes the reason isn't
that the co-author has just read the document for the
first time and finds it agreeable).

The IETF makes decisions through a process of rough
consensus, and this doesn't mean counting a show of
hands, counting "yes" postings, or counting "I support
this as a co-author" posts.  Decisions are made on
the basis of technical discussion and agreement with
the technical contents of a document.  This decision-
making process can be confusing to people who haven't
worked in consensus-oriented environments before, and
if you haven't already read Pete Resnick's internet draft
on consensus processes in the IETF, you may want to take
a look at it.  It's well-written and does a good job
of capturing what it is that we're doing when we have
last call on a document or ask other questions of
working group participants.  That document is here:
http://datatracker.ietf.org/doc/draft-resnick-on-consensus/

In the meantime, when we have last call on a document,
the co-authors should avoid posting their opinion on
whether or not they support publication unless they take
the probably surprising position of not supporting
publishing the document.  In that case they should definitely
speak up.

Many thanks,

Melinda

---

From: Randy Bush <[email-masked]>
Date: Tue, 10 Sep 2013 09:55:33 +0900

> calls with "I support as a co-author."  This is a

thank you

---

From: "ietfdbh" <[email-masked]>
Date: Tue, 10 Sep 2013 00:36:23 -0400

Hi Melinda,

You are the chair for this WG, and to a degree you can set the rules for how
WGLC works in your WG.
I respectfully disagree with your position.

Having been an editor for documents where my opinion about technical choices
was in the rough, I still stated support for publication of the document
because I felt it represented WG consensus, and wasn't "broken".
Having been a co-author for documents where I did not do the final editing
passes on the document, I read the updated document and supported the
document as ready for publication.
Having been a co-author where I did do the final editing passes because the
other editors were called away for day-job responsibilities, I appreciated
that they read the document and expressed support for the latest version as
named co-authors (even if they might have felt they were in the rough).
Having been a chair, one of the biggest problems can sometimes be getting
any responses at all to WGLC. I appreciated getting responses, even if they
were from co-authors of the documents.

I think it *does* have meaningful content to say that one supports the
document as a co-author/editor.

I agree that such statements would be MUCH more useful if they stated "I
read the document and believe it represents WG consensus" or "I read the
document and believe it is ready for publication".
I think we should educate people that that type of statement of support is
far more valuable than one that just says "I support the document".
I think we should NOT educate people that "if you are a co-author, then a
statement of your opinion is worthless".

Chairs are in the unenviable position of determining whether a co-author's
statement of support is based on actual support for the reviewed document or
some type of (inappropriate) political statement of support, and chairs have
ti decide whether to consider such statement as part of determining
consensus.
I do not think chairs should abdicate those responsibilities by simply
deciding all co-authors' statements of support should be ignored - ask for a
more detailed statement if "I support the document" does not seem
informative enough.

But, as I said, you are chairing this WG, and if that's your preference
about how this WG should operate, then so be it.

David Harrington
[email-masked]
+1-603-828-1401

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Melinda Shore
> Sent: Monday, September 09, 2013 5:51 PM
> To: [email-masked]
> Subject: [OPSAWG] "Support" in working group last calls
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: Melinda Shore <[email-masked]>
Date: Tue, 10 Sep 2013 03:15:09 -0800

> document as a co-author/editor.

I really don't think so.  It's meaningful to say that one
is a co-author and doesn't support the draft moving forward.

We don't vote, and I tend to think these "I support as co-
author" posts do take the form of voting.

Melinda

---

From: Loa Andersson <[email-masked]>
Date: Tue, 10 Sep 2013 13:29:49 +0200

Melinda,

in general I agree with you - but I would say that the "support
as co-author" is in a group of mails that could be called
"unnecessary but not forbidden".

Actually from the mpls wg there are a few expereiences.

Since starting to add "the co-authors of draft-xxx-
has told the wg chairs that the document is ready for working
group last call" to mails that tells what the wg chairs do
with the documents - the "support as co-author" has dropped.

Telling the wg during the wg status report at meeting that if
you are a co-author you don't need to speak up during wglc
in support of a document.

Also telling people that do that anyway offline also has effect.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Melinda Shore <[email-masked]>
Date: Tue, 10 Sep 2013 03:39:43 -0800

> "unnecessary but not forbidden".

Right, that's my feeling as well.  But I do think that
consensus processes are not well-understood, to the
detriment of the IETF, and that misunderstanding can be
expressed in a variety of ways, including responding
to working group last calls with a vote.  As the
organization has grown and changed over the years this
has become more of an issue.  It's a very good thing
that the IETF has grown and changed, and having a broader
set of participants both improves our documents and improves
the uptake of our documents, but it does mean
that from time to time we need to remind ourselves that
we do business a little (or a lot) differently from
other standards bodies.

One response I've never seen but that would indicate that
the person "gets it" would be a response along the lines
of "I don't agree with the contents of this document but
I made my case during its development, and while I'd
like my disagreement noted I will not object to it moving
forward."

Melinda

---

From: Loa Andersson <[email-masked]>
Date: Tue, 10 Sep 2013 15:26:36 +0200

Melinda,

again I agree that this is an issue, but I'm not sure about the
magnitude. The "support as co-author" often happens when a new
author has her/his first draft progressed through a wglc.

This is a good opportunity to reply with an off-line mail as
say "yes we understand that you supports the document - after
all you are  co-author; but please note that the IETF consensus
process does not work by voting". And maybe a pointer to the
Tao of IETF.

/Loa

--