Subject: Re: [OPSAWG] 🔔 WG Adoption Call for draft-claise-opsawg-service-assurance-yang-07

From: Greg Mirsky <[email-masked]>
Date: Tue, 4 May 2021 18:33:13 -0700

Dear All,
I've read the draft and support its adoption by the OPSAWG.

Regards,
Greg

>
>
> -----Original Message-----
> From: OPSAWG <[email-masked]> on behalf of Henk Birkholz <
> [email-masked]>
> Date: Tuesday, 27 April 2021 at 20:02
> To: opsawg <[email-masked]>
> Subject: [OPSAWG] 🔔 WG Adoption Call for
> draft-claise-opsawg-service-assurance-yang-07
>
>     Dear OPSAWG members,
>
>     this starts a call for Working Group Adoption for
>
>     >
> https://datatracker.ietf.org/doc/html/draft-claise-opsawg-service-assurance-yang-07
>
>     ending on Tuesday, May 18th.
>
>     As a reminder, this I-D describes YANG modules intended to facilitate
>     the aggregation of an assurance graph about the health of services and
>     sub-services in a system of interconnected network devices. To achieve
>     that, the I-D defines modules for graph updates about (sub-)services
> and
>     corresponding health and symptom knowledge acquired via assurance
> telemetry.
>
>     Please reply with your support and especially any substantive comments
>     you may have.
>
>
>     For the OPSAWG co-chairs,
>
>     Henk
>
>     _______________________________________________
>     OPSAWG mailing list
>     [email-masked]
>     https://www.ietf.org/mailman/listinfo/opsawg
>
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>

---

From: Giuseppe Fioccola <[email-masked]>
Date: Thu, 6 May 2021 14:10:42 +0000

Dear All,
I support the adoption of this related document too.

Regards,

Giuseppe

-----Original Message-----
From: OPSAWG [mailto:[email-masked]] On Behalf Of Henk Birkholz
Sent: Tuesday, April 27, 2021 8:02 PM
To: opsawg <[email-masked]>
Subject: [OPSAWG] 🔔 WG Adoption Call for draft-claise-opsawg-service-assurance-yang-07

Dear OPSAWG members,

As a reminder, this I-D describes YANG modules intended to facilitate the aggregation of an assurance graph about the health of services and sub-services in a system of interconnected network devices. To achieve that, the I-D defines modules for graph updates about (sub-)services and corresponding health and symptom knowledge acquired via assurance telemetry.

Please reply with your support and especially any substantive comments you may have.

Henk

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 6 May 2021 19:46:20 -0400

I support WG adoption.

Thanks

Gyan

On Thu, May 6, 2021 at 10:10 AM Giuseppe Fioccola <
[email-masked]> wrote:

> As a reminder, this I-D describes YANG modules intended to facilitate the
> aggregation of an assurance graph about the health of services and
> that, the I-D defines modules for graph updates about (sub-)services and
> corresponding health and symptom knowledge acquired via assurance telemetry.
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: Chongfeng Xie <[email-masked]>
Date: Sat, 8 May 2021 17:04:13 +0800

The definition of YANG modules is an indispensable job to implement service assurance in Intent-based network architecture, so I support this work,  

Best regards
Chongfeng

> 2021年4月28日 上午2:01，Henk Birkholz <[email-masked]> 写道：
> 
> Dear OPSAWG members,
>

---

From: Benoit Claise <[email-masked]>
Date: Mon, 10 May 2021 21:56:40 +0200

Hi Vladimir,

Thanks for your message.
There are a couple of service YANG models already worked on and also 
redefined, L2SM and L3SM. Those are service model defined in 
orchestrators/controllers.
I understand that you mean systemd type of service here.
Can you elaborate how you would see the enhancement here?

Regards, Benoit

On 4/30/2021 11:32 AM, Vladimir Vassilev wrote:
> I support the adoption of this draft.
>
> IMO there is need for a standard YANG model allowing configuration and 
> monitoring of services. In practical terms (taking the case where the 
> model is implemented on the device side) service managers like systemd 
> can be mapped to and managed according to a standard YANG model which 
> potentially can be provided by this draft.
>
> I am aware that configuration of the services is currently not in the 
> scope but I would like to propose the model to be enhanced in this 
> direction. IMO the model should at least allow for external 
> augmentation for such purpose if the configuration model functionality 
> is not considered to be in scope. The configuration part of the model 
> can be made dependent on feature for implementations that prefer other 
> means to configure the services and use the model only for monitoring.
>
> /Vladimir
>
> On 27/04/2021 20.01, Henk Birkholz wrote:
>> Dear OPSAWG members,
>>
>> the aggregation of an assurance graph about the health of services 
>> and sub-services in a system of interconnected network devices. To 
>> achieve that, the I-D defines modules for graph updates about 
>> (sub-)services and corresponding health and symptom knowledge 
>> acquired via assurance telemetry.
>>
> .

---

From: Paolo Lucente <[email-masked]>
Date: Tue, 11 May 2021 22:43:22 +0200

Dear OPSAWG'ers,

As a believer in draft-claise-opsawg-service-assurance-yang (read also 
co-author) and OPSAWG enthusiast, I do support the adoption of both 
draft-claise-opsawg-service-assurance-architecture and 
draft-claise-opsawg-service-assurance-yang.

Paolo

---

From: "Thangam Arumugam (tarumuga)" <[email-masked]>
Date: Fri, 14 May 2021 16:41:23 +0000

I support the adoption of this document by the OPSAWG. As a co-author, I am committed to working more on this document with the co-authors and the WG reviews

-----Original Message-----
From: Henk Birkholz <[email-masked]> 
Sent: Tuesday, April 27, 2021 11:02 AM
To: opsawg <[email-masked]>
Subject: [OPSAWG] 🔔 WG Adoption Call for draft-claise-opsawg-service-assurance-yang-07

Henk

---

From: "Thangam Arumugam (tarumuga)" <[email-masked]>
Date: Fri, 14 May 2021 17:36:00 +0000

Regards,
Thangavelu

-----Original Message-----
From: Henk Birkholz <[email-masked]> 
Sent: Tuesday, April 27, 2021 11:02 AM
To: opsawg <[email-masked]>
Subject: [OPSAWG] 🔔 WG Adoption Call for draft-claise-opsawg-service-assurance-yang-07

Henk

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 19 May 2021 21:03:40 +0200

Dear OPSAWG members,

this email concludes the call for Working Group Adoption on 
https://datatracker.ietf.org/doc/html/draft-claise-opsawg-service-assurance-yang-07.

We received a large number of positive replies, no objections, and 
various significant comments.

The chairs believe this I-D is ready for adoption and for the working 
group to work on.

Authors, please rename the I-D to 
draft-ietf-opsawg-service-assurance-yang-00, keeping the content as is, 
and resubmit.

Henk

---

From: Benoit Claise <[email-masked]>
Date: Fri, 21 May 2021 18:10:06 +0200

Thanks Henk.

Done.

Regards, Benoit

On 5/19/2021 9:03 PM, Henk Birkholz wrote:
> draft-ietf-opsawg-service-assurance-yang-00, keeping the content as 
> is, and resubmit.
>
>