Subject: Re: [OPSAWG] Source attribution in MUD files (RFC 8520)

From: Carsten Bormann <[email-masked]>
Date: Sat, 22 May 2021 09:17:24 +0200

Hi Hassan,

maybe not in every file, but I think it should be RECOMMENDED to put them in.

With the UNSW MUD files, we actually wanted to put them, possibly modified, into a repository of user-contributed MUD files.
Unfortunately, it is not clear that we are legally allowed to do that, and that prompted me to make the suggestion.

Grüße, Carsten

> On 22. May 2021, at 03:00, Hassan Habibi Gharakheili <[email-masked]> wrote:
> 
> Hi Eliot,
> 
> I find myself a bit out of context here. 
> 
> If I understood correctly, the two statements (you mentioned below) are expected to be included in every published MUD profile. Right?
> 
> That makes sense to me -- happy to help.
> 
> Regards,
> Hassan
> 
> From: Eliot Lear
> Sent: Friday, May 21, 2021 6:55 PM
> To: Carsten Bormann
> Cc: [email-masked] <mailto:[email-masked]>; Hassan Habibi Gharakheili
> Subject: Re: [OPSAWG] Source attribution in MUD files (RFC 8520)
> 
> Ok, I'm copying Hassan.  I can write a very quick draft to cover this.  I think what we are talking about are two statements:
> Copyright: [who, when]
> License pointer: URL or "unlimited use by anyone for any reason"
> The default would be the latter.
> This would be an UPDATE to 8520, with a SHOULD for its use.
> Sound about right?
> Eliot
> On 21.05.21 09:45, Carsten Bormann wrote:
>>> On 2021-05-21, at 09:25, Eliot Lear <[email-masked]> <mailto:[email-masked]> wrote:
>>> 
>>> Hi Carson,
>>> 
>>> How about sticking it in the documentation the file is linked to?  
>> We thought about that, too.
>> However, this requires the URI to be very stable, because you wouldn’t fulfill the CC-BY otherwise.
>> Putting the attribution right inside sounds less brittle.
>> 
>>> Otherwise we should do a very short extension.  
>> I don’t know what process this WG wants for this.
>> It would also be interesting to hear whether other people have run into the issue.
>> (For one data point, the MUD profiles at https://iotanalytics.unsw.edu.au/mudprofiles <https://iotanalytics.unsw.edu.au/mudprofiles> don’t seem to have a license at all so it is a bit illegal to use them.)
>> 
>>> The issue about sticking it in the mfg-name is that it'll have UX consequences.
>> (This suggestion was more of an application of https://meta.wikimedia.org/wiki/Cunningham%27s_Law <https://meta.wikimedia.org/wiki/Cunningham%27s_Law> .)
>> 
>> Grüße, Carsten
>> 
>> 
>

---

From: Hassan Habibi Gharakheili <[email-masked]>
Date: Sat, 22 May 2021 01:00:21 +0000

Hi Eliot,

Regards,
Hassan

________________________________
From: Eliot Lear
Sent: Friday, May 21, 2021 6:55 PM
To: Carsten Bormann
Cc: [email-masked]; Hassan Habibi Gharakheili
Subject: Re: [OPSAWG] Source attribution in MUD files (RFC 8520)

  *   Copyright: [who, when]
  *   License pointer: URL or "unlimited use by anyone for any reason"
  *   The default would be the latter.

Sound about right?

Eliot

On 2021-05-21, at 09:25, Eliot Lear <[email-masked]><mailto:[email-masked]> wrote:

Hi Carson,

I don’t know what process this WG wants for this.
It would also be interesting to hear whether other people have run into the issue.
(For one data point, the MUD profiles at https://iotanalytics.unsw.edu.au/mudprofiles don’t seem to have a license at all so it is a bit illegal to use them.)

(This suggestion was more of an application of https://meta.wikimedia.org/wiki/Cunningham%27s_Law .)

Grüße, Carsten