Subject: [OPSAWG] Source attribution in MUD files (RFC 8520)

From: Carsten Bormann <[email-masked]>
Date: Fri, 21 May 2021 09:19:13 +0200

We just had a discussion under what license we will publish our MUD files, so people using them don’t all go to jail.

The suggestion here was to go for CC-BY.  
But where would people publishing derived works then put in the attribution?

Jam it into the mfg-name?

Maybe CC-BY isn’t such a bright idea.

Grüße, Carsten

---

From: Eliot Lear <[email-masked]>
Date: Fri, 21 May 2021 09:25:32 +0200

Hi Carson,

How about sticking it in the documentation the file is linked to?  
Otherwise we should do a very short extension.  The issue about sticking 
it in the mfg-name is that it'll have UX consequences.

Eliot

On 21.05.21 09:19, Carsten Bormann wrote:
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 21 May 2021 09:45:17 +0200

> On 2021-05-21, at 09:25, Eliot Lear <[email-masked]> wrote:
> 
> Hi Carson,
> 

We thought about that, too.
However, this requires the URI to be very stable, because you wouldn’t fulfill the CC-BY otherwise.
Putting the attribution right inside sounds less brittle.

> Otherwise we should do a very short extension.  

I don’t know what process this WG wants for this.
It would also be interesting to hear whether other people have run into the issue.
(For one data point, the MUD profiles at https://iotanalytics.unsw.edu.au/mudprofiles don’t seem to have a license at all so it is a bit illegal to use them.)

> The issue about sticking it in the mfg-name is that it'll have UX consequences.

(This suggestion was more of an application of https://meta.wikimedia.org/wiki/Cunningham%27s_Law .)

Grüße, Carsten

---

From: Eliot Lear <[email-masked]>
Date: Fri, 21 May 2021 10:55:27 +0200

Ok, I'm copying Hassan.  I can write a very quick draft to cover this.  
I think what we are talking about are two statements:

  * Copyright: [who, when]
  * License pointer: URL or "unlimited use by anyone for any reason"
  * The default would be the latter.

This would be an UPDATE to 8520, with a SHOULD for its use.

Sound about right?

Eliot

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 21 May 2021 11:14:28 +0200

On 2021-05-21, at 10:55, Eliot Lear <[email-masked]> wrote:
> 
> Ok, I'm copying Hassan.  I can write a very quick draft to cover this.  I think what we are talking about are two statements:
> 
> 	• Copyright: [who, when]

Note that there may be multiple copyright holders.

> 	• License pointer: URL or "unlimited use by anyone for any reason"

An SPDX Identifier would be optimal.  Then there is no need to special-case the latter; there is an SPDX Identifier 0BSD that is pretty much that (and that probably should be called out in the document).

> 	• The default would be the latter.

“Default” as in the statement that a MUD file without all this makes?
Not sure our legal types would like retroactively slapping a permissive license on all MUD files.

> This would be an UPDATE to 8520, with a SHOULD for its use.

Sounds good to me.

Grüße, Carsten

---

From: Eliot Lear <[email-masked]>
Date: Fri, 21 May 2021 11:19:12 +0200

> Note that there may be multiple copyright holders.

Ok, a list/array.

> An SPDX Identifier would be optimal.

Ok, a CHOICE (SPDX ur URL).

>    Then there is no need to special-case the latter; there is an SPDX Identifier 0BSD that is pretty much that (and that probably should be called out in the document).
>
I was thinking more for mudmaker here.

---

From: Michael Richardson <[email-masked]>
Date: Fri, 21 May 2021 18:56:17 -0400

>  * Copyright: [who, when] * License pointer: URL or "unlimited use by
    > anyone for any reason" * The default would be the latter.

    > Sound about right?

It sounds great to me.
Please let's do this and get it adopted.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [