Subject: Re: [OPSAWG] New Version Notification for draft-ietf-opsawg-vpn-common-08.txt

From: <[email-masked]>
Date: Wed, 19 May 2021 13:55:25 +0000

Hi all, 

This version addresses the recent comments from Tom (add some reference, update some descriptions).

Cheers,
Med

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]]
> Envoyé : mercredi 19 mai 2021 15:50
> À : BOUCADAIR Mohamed TGI/OLN <[email-masked]>; Oscar
> Gonzalez de Dios <[email-masked]>; Oscar de Dios
> <[email-masked]>; Qin WU <[email-masked]>;
> Qin Wu <[email-masked]>; Samier Barguil
> <[email-masked]>; samier barguil
> <[email-masked]>
> Objet : New Version Notification for draft-ietf-opsawg-vpn-common-
> 08.txt
> 
> 
> A new version of I-D, draft-ietf-opsawg-vpn-common-08.txt
> has been successfully submitted by Mohamed Boucadair and posted to
> the IETF repository.
> 
> Name:		draft-ietf-opsawg-vpn-common
> Revision:	08
> Title:		A Layer 2/3 VPN Common YANG Model
> Document date:	2021-05-19
> Group:		opsawg
> Pages:		68
> URL:            https://www.ietf.org/archive/id/draft-ietf-opsawg-
> vpn-common-08.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-opsawg-
> vpn-common/
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-
> opsawg-vpn-common
> Htmlized:       https://tools.ietf.org/html/draft-ietf-opsawg-vpn-
> common-08
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-
> vpn-common-08
> 
> Abstract:
>    This document defines a common YANG module that is meant to be
> reused
>    by various VPN-related modules such as Layer 3 VPN and Layer 2 VPN
>    network models.
> 
> Editorial Note (To be removed by RFC Editor)
> 
>    Please update these statements within the document with the RFC
>    number to be assigned to this document:
> 
>    o  "This version of this YANG module is part of RFC XXXX;"
> 
>    o  "RFC XXXX: A Layer 2/3 VPN Common YANG Model";
> 
>    o  reference: RFC XXXX
> 
>    Also, please update the "revision" date of the YANG module.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> The IETF Secretariat
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Wed, 19 May 2021 14:08:40 +0000

Thanks, med (and Tom for the review).

A few comments on the diff.  For your ipv4 and ipv6 feature additions, What about saying:

"IPvX traffic can be _carried_ in the VPN..." (or transported, perhaps)

The text "can be assigned to an access" reads odd to me.  With respect to the rest of the document, maybe network access is more consistent.

For the input-bw and output-bw, the use of the words upload and download read odd to me.  What about "upstream" and "downstream" instead?

Finally, you removed ccm-priority-type.  You had borrowed this, but I wonder if removing this from common causes some other ripples in L2NM.  Ultimately, I don't have a problem with this typedef being pulled from its canonical source as long as the downstream ramifications are addressed.

Joe

On 5/19/21 09:56, [email-masked]<mailto:[email-masked]> wrote:

Hi all,

Cheers,
Med

-----Message d'origine-----
De : [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Envoyé : mercredi 19 mai 2021 15:50
À : BOUCADAIR Mohamed TGI/OLN <[email-masked]><mailto:[email-masked]>; Oscar
Gonzalez de Dios <[email-masked]><mailto:[email-masked]>; Oscar de Dios
<[email-masked]><mailto:[email-masked]>; Qin WU <[email-masked]><mailto:[email-masked]>;
Qin Wu <[email-masked]><mailto:[email-masked]>; Samier Barguil
<[email-masked]><mailto:[email-masked]>; samier barguil
<[email-masked]><mailto:[email-masked]>
Objet : New Version Notification for draft-ietf-opsawg-vpn-common-
08.txt

Abstract:

   o  reference: RFC XXXX

The IETF Secretariat

---

From: <[email-masked]>
Date: Wed, 19 May 2021 14:33:11 +0000

Hi Joe,

Thank you for the comments.

Please see inline.

Cheers,
Med

De : Joe Clarke (jclarke) [mailto:[email-masked]]
Envoyé : mercredi 19 mai 2021 16:09
À : BOUCADAIR Mohamed TGI/OLN <[email-masked]>; [email-masked]
Cc : [email-masked]
Objet : Re: New Version Notification for draft-ietf-opsawg-vpn-common-08.txt

[Med] Sure. Fixed.

The text "can be assigned to an access" reads odd to me.  With respect to the rest of the document, maybe network access is more consistent.
[Med] changed to "VPN network access" for better clarity.

For the input-bw and output-bw, the use of the words upload and download read odd to me.
[Med] For me as well, but this is inherited from RFC8299 and RFC8466. I prefer to maintain those to ease mapping when RFC8299bis and RFC8466bis are considered.
What about "upstream" and "downstream" instead?

Finally, you removed ccm-priority-type.  You had borrowed this, but I wonder if removing this from common causes some other ripples in L2NM.
[Med] This was moved back to the L2NM as we use it there.
  Ultimately, I don't have a problem with this typedef being pulled from its canonical source as long as the downstream ramifications are addressed.

Joe
[Med] The changes can be tracked: https://github.com/IETF-OPSAWG-WG/lxnm/commit/ab10294cdb24cb147ee0789f76b26395457639a8.
On 5/19/21 09:56, [email-masked]<mailto:[email-masked]> wrote:

Hi all,

Cheers,

Med

-----Message d'origine-----

08.txt

the IETF repository.

Revision: 08

Group:            opsawg

Pages:            68

vpn-common-08.txt

vpn-common/

opsawg-vpn-common

common-08

vpn-common-08

Abstract:

reused

   network models.

   o  reference: RFC XXXX

tools.ietf.org.

The IETF Secretariat

Thank you.