Subject: [OPSAWG] I-D Action: draft-ietf-opsawg-l2nm-03.txt

From: [email-masked]
Date: Fri, 09 Jul 2021 03:18:43 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Operations and Management Area Working Group WG of the IETF.

        Title           : A Layer 2 VPN Network YANG Model
        Authors         : Samier Barguil
                          Oscar Gonzalez de Dios
                          Mohamed Boucadair
                          Luis Angel Munoz
	Filename        : draft-ietf-opsawg-l2nm-03.txt
	Pages           : 149
	Date            : 2021-07-09

Abstract:
   This document defines an L2VPN Network YANG Model (L2NM) that can be
   used to manage the provisioning of Layer 2 Virtual Private Network
   (VPN) services within a network (e.g., service provider network).
   The L2NM complements the Layer 2 Service Model (L2SM) by providing a
   network-centric view of the service that is internal to a service
   providers.  As such, the L2NM is meant to be used by a network
   controller to derive the configuration information that will be sent
   to relevant network devices.

   Also, the document defines the initial versions of two IANA-
   maintained modules that defines a set of identities of BGP Layer 2
   encapsulation types and pseudowire types.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-opsawg-l2nm/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-l2nm-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-l2nm-03

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Fri, 9 Jul 2021 10:34:19 +0000

Hi all, 

We are pleased to share this major revision of the L2NM. Some of the main changes are: 
* Rewrite of Section 6 + restructure it to better reflect the content and rationale of the L2NM design. 
* Clarify the relationship between some nodes: signaling types, VPN types, etc. 
* Rather than defining L2 encap types and pw types as part of the L2MN, we defined two IANA-maintained modules to echo existing registries. 
* Many examples to illustrate the use of the module: LDP-signaled, BGP used for both auto-discovery and signaling, mutli-homing, EVPN, auto-assignment of ESI, redundancy, etc.

Please use the diff to track all the changes: https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-l2nm-03. 

The full set of closed issues can be tracked at: https://github.com/IETF-OPSAWG-WG/lxnm/issues?q=is%3Aissue+is%3Aclosed+label%3AL2NM. Majors issues were reported to the mailing list (Thanks, Samier). 

We don't have any pending issue (https://github.com/IETF-OPSAWG-WG/lxnm/issues).

We think that the document is ready for the WGLC. We defer to the Chairs whether to launch it before or after the IETF meeting.

Reviews and comments are welcome. 

Cheers,
Med

> -----Message d'origine-----
> De : I-D-Announce [mailto:[email-masked]] De la part
> de [email-masked]
> Envoyé : vendredi 9 juillet 2021 12:19
> À : [email-masked]
> Cc : [email-masked]
> Objet : I-D Action: draft-ietf-opsawg-l2nm-03.txt
> 
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Sat, 10 Jul 2021 18:53:15 +0000

I've been following your minutes updates, and I didn't think you'd make
this much progress so soon (with new issues being opened).  Very nice. 
Thanks to the authors and contributors for continuing to iterate on this
work.

We'd prefer to hold on LC until after 111 as we're already in that
gravity, and people have much to read and review.  Additionally, with
this being the summer, an extended LC is likely warranted to ensure
people get a chance to read it.

I've briefly looked through the diffs, but I'll try and get a more
thorough review in before our meeting myself.

Joe

---

From: <[email-masked]>
Date: Mon, 12 Jul 2021 08:08:07 +0000

Hi Joe, 

Having the WGLC right after IETF#111 is a good plan. Thanks. 

Looking forward to receive your comments.

Cheers,
Med

> De : Joe Clarke (jclarke) [mailto:[email-masked]]
> Envoyé : samedi 10 juillet 2021 20:53
> À : BOUCADAIR Mohamed INNOV/NET <[email-masked]>;
> [email-masked]; [email-masked]
> Cc : [email-masked]
> Objet : Re: I-D Action: draft-ietf-opsawg-l2nm-03.txt
> 
> I've been following your minutes updates, and I didn't think you'd
> make this much progress so soon (with new issues being opened).
> Very nice.
> Thanks to the authors and contributors for continuing to iterate on
> this work.
> 
> gravity, and people have much to read and review.  Additionally,
> with this being the summer, an extended LC is likely warranted to
> ensure people get a chance to read it.
> 
> > * Rewrite of Section 6 + restructure it to better reflect the
> content and rationale of the L2NM design.
> > * Rather than defining L2 encap types and pw types as part of the
> L2MN, we defined two IANA-maintained modules to echo existing
> registries.
> > * Many examples to illustrate the use of the module: LDP-signaled,
> BGP used for both auto-discovery and signaling, mutli-homing, EVPN,
> auto-assignment of ESI, redundancy, etc.
> >
> > Please use the diff to track all the changes:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-l2nm-03.
> >
> > The full set of closed issues can be tracked at:
> https://github.com/IETF-OPSAWG-
> WG/lxnm/issues?q=is%3Aissue+is%3Aclosed+label%3AL2NM. Majors issues
> were reported to the mailing list (Thanks, Samier).
> >
> > We think that the document is ready for the WGLC. We defer to the
> Chairs whether to launch it before or after the IETF meeting.
> >
> >> de [email-masked] Envoyé : vendredi 9 juillet 2021
> 12:19 À
> >> : [email-masked] Cc : [email-masked] Objet : I-D Action:
> >> draft-ietf-opsawg-l2nm-03.txt
> >>
> >>
> >> A New Internet-Draft is available from the on-line Internet-
> Drafts
> >> directories.
> >>    This document defines an L2VPN Network YANG Model (L2NM) that
> can
> >> be
> >>    controller to derive the configuration information that will
> be
> >> sent
> >>    maintained modules that defines a set of identities of BGP
> Layer
> >> 2
> ____________________________________________________________________
> _____________________________________________________
> >
> > Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> > pas etre diffuses, exploites ou copies sans autorisation. Si vous
> avez recu ce message par erreur, veuillez le signaler
> > a l'expediteur et le detruire ainsi que les pieces jointes. Les
> messages electroniques etant susceptibles d'alteration,
> > This message and its attachments may contain confidential or
> privileged information that may be protected by law;
> > If you have received this email in error, please notify the sender
> and delete this message and its attachments.
> > As emails may be altered, Orange is not liable for messages that
> have been modified, changed or falsified.
> > Thank you.
> >
> >