Subject: Re: [p2pi] WG Review: Application-Layer Traffic Optimization (alto)

From: "Woundy, Richard" <[email-masked]>
Date: Thu, 23 Oct 2008 15:32:41 -0400

>The question is the simpler coordinate: "who's MY resolver and who else uses it".

This is an interesting idea.

One perhaps obvious thought. I wouldn't use the IP address as the sole identifier of the DNS resolver. Lots of hosts on different networks are likely to use 192.168.x.1 as their DNS resolver, eg their home gateway. :)

-- Rich

----- Original Message -----
From: [email-masked] <[email-masked]>
To: Vijay K. Gurbani <[email-masked]>
Cc: [email-masked] <[email-masked]>; Nicholas Weaver <[email-masked]>
Sent: Tue Oct 21 17:09:07 2008
Subject: Re: [p2pi] WG Review: Application-Layer Traffic Optimization (alto)

Ono is leveraging off Akamai's DNS information:  You do a few queries  
to akamai'ed (and other CDN'ed) domains, and use the results as a  
coordinate space.

The question is the simpler coordinate: "who's MY resolver and who  
else uses it".

On Oct 21, 2008, at 2:05 PM, Vijay K. Gurbani wrote:

> Nicholas Weaver wrote:
>> Hey, stupid thought...
>> Could you do proximity based on "who's your DNS resolver"?  Do a  
>> few name lookups: one to register YOU as using YOUR DNS resolver to  
>> the remote coordinator, and one to get "who are other peers using  
>> the same resolver"?
>> An ugly, UGLY hack, but it might be interesting to think about.
>> Has anyone done this already?
>
> Doesn't Ono [1] do that?  Or am I missing something?  CDNs also
> use DNS redirects to redirect clients to nearest servers.
>
> [1] David R. Choffnes and Fabián E. Bustamante. Taming the Torrent:
>    A practical approach to reducing cross-ISP traffic in P2P
>    systems, Proc. of ACM SIGCOMM 2008, August 2008.
>
> Thanks,
>
> - vijay
> -- 
> Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
> 1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
> Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
> WWW:   http://www.alcatel-lucent.com/bell-labs
> _______________________________________________
> p2pi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2pi
>

_______________________________________________
p2pi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2pi
_______________________________________________
p2pi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2pi

---

From: Nicholas Weaver <[email-masked]>
Date: Thu, 23 Oct 2008 12:43:04 -0700

On Oct 23, 2008, at 12:32 PM, Woundy, Richard wrote:

> One perhaps obvious thought. I wouldn't use the IP address as the  
> sole identifier of the DNS resolver. Lots of hosts on different  
> networks are likely to use 192.168.x.1 as their DNS resolver, eg  
> their home gateway. :)

Well, you use the last-hop resolver, by looking at the address from  
the authoritative server side, not from the client side.

eg, query
server.nettest.icir.org

The answer is the recursive resolver which contacted our DNS server.   
(well, when our experimental server is running that is)