Subject: Re: [P2PSIP] New draft on requirements for Peer protocol

From: "Eric Cooper" <[email-masked]>
Date: Thu, 8 Mar 2007 11:34:36 -0500

Hi Jiang,

I like the idea of collecting all these requirements into a draft for the WG.

I had one comment for section 4.2:

It may also be a characteristic of peers that they are connected by relatively low-bandwidth connections.  

This property could have implications for the efficiency of routing lookups and the NAT traversal mechanism.

Best Regards,

Eric.

----- Original Message ----- 
From: "JiangXingFeng" <[email-masked]>
To: <[email-masked]>
Sent: Monday, February 26, 2007 8:49 PM
Subject: [P2PSIP] New draft on requirements for Peer protocol

> Hi, all:
> 
> I have written a draft to describe the requirements for P2PSIP Peer
> protocol. I hope this contribution could be helpful to get a successful Peer
> protocol finally.
> 
> Any comments are appreciated!
> 
> Thanks!
> 
> ----- Original Message -----
> From: <[email-masked]>
> To: <[email-masked]>
> Sent: Monday, February 26, 2007 2:50 PM
> Subject: I-D ACTION:draft-jiang-p2psip-peer-protocol-requirement-00.txt 
> 
> 
>>A New Internet-Draft is available from the on-line Internet-Drafts 
>> directories.
>> 
>> 
>> Title : The requirement of P2PSIP Peer protocol
>> Author(s(Zèš©²*[¢éÜzÈžµú+8n1ªôó]·óŽ6ÓNÑzÛ«ž–†©²*[¢éÜzÈžµú+œz+Þuúè›]»ÓMazZ,¶'¦¹¦j}ojw®²Ö«r‰›Êg jÚèž'~ŠàÂ+azÉ­¤Lb›Ž7‰ÝG<ÆRÓM:}@N´ðÆ«ÛM;×müßM9ÓD^qè¯y×ë¢mt÷]øãˆ^–ˆžµù±‰ë_¢¸Êg jÚèž'~ŠàÂ+azÉ­¤Lb›Ž7‰ÝG<ÆPÓM:|d~ŠéÚ›"¦'~ŠàN´ðÆ«ÛM;×müÛÍ9ÓD^qè¯y×ë¢fÚËJ&s{8Õ¶²Ò-™¨¥r‰ºçž6ã­¸Õ¼¢z×æÆ'~ŠàÂ+azÉ­¤Lb›Ž7‰ÝG<ÆNÓM7œ’:~ŠéÚ›"¦'~ŠàN´ðÆ«ÛM;×müÛ½9ÓD^qè¯y×ë¢fÚÉÍijÉ­§MÛk'5†‹fj)\¢n¹ç}×^·o&ÚËJ&s{8Õ¶²Ò-™¨¥r‰°ŠØL‰Êè²‡íHÄÏIPºÓ~ýÓnºñ8nðÆ«ÛM;ÓÝüÛ­<ÓEÎ®("«bžÛ^µßºñs«Š§jØ§€IšŠW«‰Ç\¢Š^®Ì¦¥«br‡EçŠ÷~º&®‰âŸmz×~6ëÆòm¬œÖ–¬šÚtÝ¶²sXh¶f¢•Ê&¢÷«L´¬yË«y×!jyÞ—„Èœ®‹(~ÔŒLô•7ïÝ5ó}†ïj½´Ó½=ßÍ¹ÓÍ41ë,jˆM»ÛM\ïZóÝo}¹Ó®yÓF´jº'Šqk¢a+‰À¨¢—«z¸œuÊ(¥êìÊjZ¶'(q¤è&&§x§€W§‚8šž_†æ°z'(š©²*bz×è®^}êÞÇ¬ÓM^ÓW;åuíÿ]tïm9kr§jšÁèœ¢d®n7œµØôˆ<×°v¶Ÿ¶‰ëz«¢éžžÛ¢³Þzºk¢Ú¢PÚµäá»Ã¯m4ï]wã~´çM Áz»"¢}t\úâ¢¸ËuÌHÆ¢”úâ¢¸ÈÚ+™©W1¨¥z³"rº,¡ûNºÙh¢A1¦·¬³4ÛÝ4ßM¼\È¦xâÄ>º¹Ç#"rº,¡ûLŠgŽ,EzÓM½ÓMôÛÅÎ®("©@®¸¯jTâ™í<1ªöÓNõï6çMöõDÂ‚ÄLƒ÷}wmtÓP»ëP<]*Z™'(í¶ûåÒq©ÒŠ	Ú¶êÞëÖ»áí6m·žã†›áÿi÷[qç]÷†µ	ÅÁyéÓ…êÞ§jlŠ˜žµú+sŠYšW«²*'Û^OçuéÜzX¬´¸¬´‡Oyêí ÷ž"ÂŠäŠx ®‹©v+ºË"¢yb²Úv¦È©‰ë_¢¸ŠËTžË›±Êâmèm¶›?ÿ0Ö'~Šàþf¢–f§þX¬¶)ß£úv¦È©™¨¥¶Šv¦È©ê®zËbz×è®.n7œ¶éì¹»®&Þ.+-·!Š÷¡¶Úÿ0Ö'~Šàþ˜©z¹šŠ_éÚ›"¤¸¬´ú,¶f¢–Ú)Ú›"¦'~Šà.+-éi™¨¥¶Šv¦È©ê®zËbz×è®.n7œ¶¥¤¸¬µ+›±Êâmèm¶›?ÿ0Ö'~Šàþf¢–f§þX¬¶)ß£úv¦È©™¨¥¶Šv¦È©ê®zËbz×è®.n7œ¶Ë›±Êâmà¨ž×§µ<©zk¥¶*Z®ßæ‹n‹§uªò×ŽxëÏ;ïÑ+®ŠìNŠv¦È©n‹§që"z×è®

Hi Jiang,

I like the idea of collecting all these requirements into a draft for the WG.

I had one comment for section 4.2:

It may also be a characteristic of peers that they are connected by relatively low-bandwidth connections.  

This property could have implications for the efficiency of routing lookups and the NAT traversal mechanism.

Best Regards,

Eric.

----- Original Message ----- 
From: "JiangXingFeng" <[email-masked]>
To: <[email-masked]>
Sent: Monday, February 26, 2007 8:49 PM
Subject: [P2PSIP] New draft on requirements for Peer protocol

> Hi, all:
> 
> I have written a draft to describe the requirements for P2PSIP Peer
> protocol. I hope this contribution could be helpful to get a successful Peer
> protocol finally.
> 
> Any comments are appreciated!
> 
> Thanks!
> 
> ----- Original Message -----
> From: <[email-masked]>
> To: <[email-masked]>
> Sent: Monday, February 26, 2007 2:50 PM
> Subject: I-D ACTION:draft-jiang-p2psip-peer-protocol-requirement-00.txt 
> 
> 
>>A New Internet-Draft is available from the on-line Internet-Drafts 
>> directories.
>> 
>> 
>> Title : The requirement of P2PSIP Peer protocol
>> Author(s) : X. Jiang
>> Filename : draft-jiang-p2psip-peer-protocol-requirement-00.txt
>> Pages : 18
>> Date : 2007-2-26
>> 
>>   In this draft, we present what P2PSIP should achieve - a distributed
>>   location service.  Then we compare the differences between C/S SIP
>>   and P2P SIP and point out that some features which are not
>>   standardized in C/S SIP should be addressed in the P2P SIP case.
>>   After analyzing some problems, some requirements of Peer protocol are
>>   proposed.
>> 
>> 
>> 
>> A URL for this Internet-Draft is:
>>
> http://www.ietf.org/internet-drafts/draft-jiang-p2psip-peer-protocol-require
> ment-00.txt
> --
> Jiang XingFeng
> 
> 
> 
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/p2psip
>

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: JiangXingFeng <[email-masked]>
Date: Fri, 09 Mar 2007 09:07:36 +0800

Hi, Eric:

Thanks for your comments. 

I agree with you that bandwidth which a peer has will influence the
efficiency of routing lookup and NAT traversal, because peers could not
serve requests dropped due to low-bandwidth connections.

Maybe we should modify the characteristic "Limited processing power" to
"limited capability", which means that a peer is short of enough processing
power, bandwidth, and so on. 

Eric, do I address your concern? 
Regards!

--
Jiang XingFeng
> -----Original Message-----
> From: Eric Cooper [mailto:[email-masked]]
> Sent: Friday, March 09, 2007 12:35 AM
> To: JiangXingFeng; [email-masked]
> Subject: Re: [P2PSIP] New draft on requirements for Peer protocol
> 
> Hi Jiang,
> 
> It may also be a characteristic of peers that they are connected by
relatively
> low-bandwidth connections.
> 
> This property could have implications for the efficiency of routing
lookups and the
> NAT traversal mechanism.

---

From: "Bruce Lowekamp" <[email-masked]>
Date: Fri, 9 Mar 2007 07:19:08 -0500

> power, bandwidth, and so on.

I would separate that into two characteristics, one of which is
limited resources, encompassing both processing power and storage
capacity.  The second is limited bandwidth, which is also a factor,
but it's a per-pair factor, not a per-node factor, i.e. within an AS
any pair of peers may have high bandwidth, but between the AS the
bandwidth may be quite low.  Some of the DHT algorithms (such as
Bamboo and Pastry) allow a peer to choose members of its routing table
that have lower latency/higher bandwidth than other peers that fit the
routing requirement but are harder to reach.

Bruce

---

From: "Henry Sinnreich" <[email-masked]>
Date: Fri, 9 Mar 2007 06:51:44 -0800

Bruce Lowenkamp wrote:

> The second is limited bandwidth, which is also a factor,

Yes, exactly! This is especially true for mobile devices and I believe
some wording should be added to <willis-p2psip-concepts-04> along these
lines: 

In the definition of the client, an important usage scenario is a mobile
phone connected to the base station and feeder network, where peer nodes
may be located.
I have cc:'d the authors - sorry for the duplicate mail for them. 

Q1: What would the client protocol look like for mobile devices?

Q2: Different usage scenarios may require different DHTs. 

A2: Requirement (xyz) is the peer protocol must be flexible to
accommodate different DHTs as outlined in
<draft-baset-sipping-p2pcommon-01> for different usage scenarios and
should also be flexible to the introduction to new types and versions of
DHTs.

Thanks, Henry

-----Original Message-----
From: Bruce Lowekamp [mailto:[email-masked]] 
Sent: Friday, March 09, 2007 6:19 AM
To: JiangXingFeng
Cc: [email-masked]
Subject: Re: [P2PSIP] New draft on requirements for Peer protocol

Bruce

---

From: Philip Matthews <[email-masked]>
Date: Fri, 9 Mar 2007 11:21:26 -0500

Personally, I would like the Peer Protocol to be designed so that
mobile devices could be _peers_ in the overlay if they desired,
and not just clients.

I think the Peer Protocol and the Distributed Database algorithm
needs to be able to accommodate peers of different processing power
and bandwidth.

- Philip

---

From: "Charlie Eunsoo Shim" <[email-masked]>
Date: Fri, 9 Mar 2007 11:30:50 -0500

When the P2P and DHT concept was explained to some folks developing mobile
devices, one immediate comment was about battery consumption to maintain the
DHT.
There is no need to prevent mobile devices from becoming a Peer but there
should be a way for those devices to use the P2P SIP network without being a
Peer and sharing the load of maintaining the DHT.
Thanks.

Eunsoo

---

From: JiangXingFeng <[email-masked]>
Date: Sat, 10 Mar 2007 09:25:55 +0800

HI, Bruce:

> bandwidth may be quite low. 

Bruce, I agree with you that link bandwidth between two peers is a per-pair
factor. It is used in some existing DHT algorithms to provide network
locality property. We should consider this characteristic because it will
influence routing efficiency and NAT traversal. 

But from literally, "limited bandwidth" is not exact for expressing the
per-pair meaning. So I suggest that we use "limited link bandwidth between
peers" as an additional peer's characteristic instead, not .use "limited
bandwidth".

Comments are welcome! 

Regards!

--
Jiang XingFeng