Subject: RE: [P2PSIP] Concepts draft and P2PSIP clients

From: <[email-masked]>
Date: Thu, 1 Mar 2007 14:29:03 +0200

Hi,

I somehow got a feeling that you are trying to distinguish peers from
clients based on their storage capacity.

Mobile terminals are mostly limited by their processing power and
battery life. Besides they are intermittently connected to the network.
While this is less common in fixed networks, it is a typical
characteristic of IP mobile terminlas who connect to the network via
GPRS or WLAN. The fact is that these terminals are not permanently
online, so a P2PSIP network has to be designed so that terminals can
come in and out easily with minimum overhead signaling for the whole
network. 

I could imagine a use case where mobile terminals act as peers, e.g. in
limited connectivity scenarios. In this situation it is not reasonable
to treat all of the peers as equal.

Besides, what do you mean by this: "clients associated with (usually
just one) peer" Does "associated" mean connected? How can the clients be
associated with one peer if they can move from one place to another. Or
you meant that their data is stored in one peer? 

Br,

Marcin

>-----Original Message-----
>From: ext Philip Matthews [mailto:[email-masked]] 
>Sent: 28 February, 2007 23:05
>To: Brian Rosen
>Cc: [email-masked]
>Subject: Re: [P2PSIP] Concepts draft and P2PSIP clients
>
>Brian:
>
>Your brief description below happens to match exactly the 
>description of a "peer" in Concepts-03.
>
>What I think you might be referring to is the  super-peer / 
>ordinary- peer approach to NAT Traversal. I will mention this 
>approach in Concepts-04, but it is my impression that we 
>agreed to the alternative approach of treating all peers as 
>equal for NAT Traversal.
>
>- Philip
>
>
>On 28-Feb-07, at 15:18 , Brian Rosen wrote:
>
>> Where in this is my model, where clients are all in the overlay, all 
>> have an id, all store data, but some of them need to relay messages 
>> through another peer?
>>
>> Brian
>>
>>> -----Original Message-----
>>> From: Philip Matthews [mailto:[email-masked]]
>>> Sent: Wednesday, February 28, 2007 2:38 PM
>>> To: [email-masked]
>>> Subject: [P2PSIP] Concepts draft and P2PSIP clients
>>>
>>> There have been various discussions and proposals for clients over 
>>> the past few months.
>>>
>>> First of all, there was the original proposal that was put forth in 
>>> the -00 version of the Concepts document.
>>> In this version, clients associated with (usually just one) peer, 
>>> with the client acting in a way similar to a SIP UA, and the peer 
>>> acting in a way similar to a SIP proxy/registrar.
>>> In this proposal, clients did not store data for the 
>overlay, nor did 
>>> they participate in message routing.
>>> In this view, clients do not have a "Client ID".
>>>
>>> Second, there was a proposal by Eric Rescorla.
>>> As I understand this proposal, clients are fully meshed into the 
>>> overlay, but still do not store data for the overlay.
>>> However, presumably they do participate in message routing.
>>> In this view, clients have a "Peer ID", since they are involved in 
>>> the DHT. This view has been described as "a peer with bad memory".
>>>
>>>
>>> Third, there has been some private  discussion of a model somewhat 
>>> similar to the first, but where clients DO store data. In 
>essence, a 
>>> peer can elect to store data on one of its associated 
>clients, rather 
>>> than in its own memory.
>>> In this view, clients do not have a "Client ID" and do not 
>>> participate in the DHT.
>>>
>>>
>>> I think all three of these views are interesting, albeit 
>>> contradictory.
>>> So I am proposing to include a section in the next revision of the 
>>> Concepts document that describes these three views.
>>> This would mean that the text elsewhere in the document 
>would become 
>>> somewhat more vague on what a client's role really is.
>>>
>>>
>>> Comments?
>>>
>>> - Philip
>>>
>>>
>>>
>>>
>>> _______________________________________________
>>> P2PSIP mailing list
>>> [email-masked]
>>> https://www1.ietf.org/mailman/listinfo/p2psip
>>
>
>
>_______________________________________________
>P2PSIP mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/p2psip
>

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: "Henry Sinnreich" <[email-masked]>
Date: Thu, 1 Mar 2007 04:37:46 -0800

>P2PSIP network has to be designed so that terminals can come in and out
>easily with minimum overhead signaling for the whole network.

This is an interesting issue and I can only report that Skype mobile
works on my PDA, both on WiFi (excellent) and EVDO (usable). So there
must be a way...

Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]

Sent: Thursday, March 01, 2007 6:29 AM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [P2PSIP] Concepts draft and P2PSIP clients

Hi,

Br,

Marcin