Subject: RE: [P2PSIP] What is a Service?

From: JiangXingFeng <[email-masked]>
Date: Thu, 01 Mar 2007 15:17:06 +0800

Hi, Henry and Dean:

In my opinion, the design criteria for OpenDHT system arises from that
OpenDHT want to make developing application built on DHT overlay more
simple, so it make the interface independent of the various applications.

In addition, OpenDHT runs on a collection of 200 - 300 nodes on PlanetLab.
These nodes are more stable than peers. So the precondition of OpenDHT is
different from that in P2PSIP case. The resultant P2PSIP system will be
different from applications built on OpenDHT. 

Maybe there are some mistakes in my understanding, please remind me. Please
keep discussing this topic.  

Regards!
--
Jiang XingFeng
> -----Original Message-----
> From: Henry Sinnreich [mailto:[email-masked]]
> Sent: Wednesday, February 28, 2007 7:54 AM
> To: Dean Willis; P2PSIP Mailing List
> Subject: RE: [P2PSIP] What is a Service?
> 
> Dean,
> 
> Thanks for keeping the topic alive (the interface to the DHT)!
> 
> Actually, going right to the original source would be better.
> Please see:
> 
> OpenDHT: "A Public DHT Service and Its Uses" by S. Rhea et al.,
> 
> http://www.intel-research.net/Publications/Pittsburgh/092620050725_326.p
> df
> 
> Section 3 on the Interface (to the DHT) says it all.
> 
> The 3rd interface, the one that provides access to the DHT routing is
> also very interesting, for example to provide large scale application
> layer multicast for very large conferences.
> 
> Thanks again,
> 
> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]]
> Sent: Tuesday, February 27, 2007 4:10 PM
> To: P2PSIP Mailing List
> Subject: [P2PSIP] What is a Service?
> 
> 
> Starting from Henry's request that P2PSIP differentiate between
> "service" and "data" models, we seem to have gotten a bit tangled up
> on the concept of "service".
> 
> An excellent discussion of the term, from the economic perspective,
> can be found at:
> 
> http://en.wikipedia.org/wiki/Service
> 
> 
> A closer-to-home definition is that of a "Web Service":
> 
> http://en.wikipedia.org/wiki/Web_service
> 
> 
> Henry, I believe, was attempting to use the term in a similar vein to
> "Web Service". He was proposing that the P2P lookup and routing
> functionality could be provided independently of the real-time call
> setup functionality. In other words, a "P2P service provider" would
> provide the distributed database, and we would just use the
> distributed database as-is to set up calls. We might need to define
> some new building blocks, but we should make use of the existing
> blocks where possible.
> 
> This is an example of what one might call a "Service Oriented
> Architecture". In this approach, an application loosely-couples
> various services, possibly adding new services to existing ones, in
> order to achieve the goal of the application. This application might
> then be exported as a "service".
> 
> But this raises questions. Does there need to be a standardized set
> of "services"? If so, which ones?
> 
> For example, is "voice mail" a service, and if so, does it need to be
> standardized?
> 
> I'd argue that the answer to both of the above is "probably not, at
> least for now". I'd much rather concentrate on the really reusable
> prices of functionality we've discussed -- like inserting a peer into
> an overlay and or routing a request between peers, as the "services"
> of interest.
> 
> --
> Dean
> 
> 
> 
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/p2psip
> 
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/p2psip

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: "Henry Sinnreich" <[email-masked]>
Date: Thu, 1 Mar 2007 07:11:26 -0800

Jiang XingFeng wrote

> Please keep discussing this topic.  

Your understanding is correct, and I see no reason not to use
openDHT-like networks (maybe even commercial as intended by its
developers) either:

1. A multipurpose global "Internet at the application layer", and/or
2. A bootstrap mechanism for P2PSIP.

A discussion would be very interesting and welcome indeed.

Thanks, Henry

-----Original Message-----
From: JiangXingFeng [mailto:[email-masked]] 
Sent: Thursday, March 01, 2007 1:17 AM
To: Henry Sinnreich; 'Dean Willis'; 'P2PSIP Mailing List'
Subject: RE: [P2PSIP] What is a Service?

Hi, Henry and Dean:

In my opinion, the design criteria for OpenDHT system arises from that
OpenDHT want to make developing application built on DHT overlay more
simple, so it make the interface independent of the various
applications.

In addition, OpenDHT runs on a collection of 200 - 300 nodes on
PlanetLab.
These nodes are more stable than peers. So the precondition of OpenDHT
is
different from that in P2PSIP case. The resultant P2PSIP system will be
different from applications built on OpenDHT. 

Maybe there are some mistakes in my understanding, please remind me.
Please
keep discussing this topic.  

Regards!
--
Jiang XingFeng