Subject: Re: [P2PSIP] where does a peer get the Master Key

From: Konstantinos Birkos <[email-masked]>
Date: Tue, 02 Mar 2010 16:45:05 +0200

The Master Key can either be provided during Enrollment and 
Authentication or the participating peers can be pre-configured with it.

---

From: jc <[email-masked]>
Date: Tue, 2 Mar 2010 10:28:54 -0500

The shared certificate is provided by the enrollment server, disk or memory. There is no master key.

On Mar 2, 2010, at 9:45 AM, Konstantinos Birkos wrote:

> The Master Key can either be provided during Enrollment and Authentication or the participating peers can be pre-configured with it.
> 
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip

---

From: Konstantinos Birkos <[email-masked]>
Date: Tue, 02 Mar 2010 17:58:02 +0200

Actually in our draft, some of the described extensions are based on the 
use of a shared secret key. We introduced the term "Master Key" to refer 
to this key. Of course, the shared key used in RELOAD to authenticate 
connections via TLS-PSK/TLS-SRP can serve as the Master Key (according 
to our notion of the term). 

-- 

Konstantinos Birkos
PhD Student
Wireless Telecommunication Laboratory
Department of Electrical and Computer Engineering
University of Patras
Patras, Greece
Tel.: +30 2610 996465