Subject: Re: [P2PSIP] Estimate sharing in draft-ietf-p2psip-self-tuning

From: Cullen Jennings <[email-masked]>
Date: Sat, 6 Mar 2010 17:35:34 -0700

On Feb 18, 2010, at 3:42 AM, Jouni Mäenpää wrote:

> Hi,
> 
>> A) Doing 2 should be easy using the new MessageExtensions in a PING or 
>> PROBE. 
> 
> Yes, this should be pretty straightforward.
> 
>> B) I think that 1 might run into serious problems as the messages 
>> growing and all the fragmentation issues around something in the 
>> forwarding header growing.
> 
> Perhaps this problem could be avoided if one placed a limit for the
> maximum number of ForwardingOption entries (containing shared estimates)
> that can be included in the message.
> 

Yah, that would probably work. But I still prefer A

> Cheers,
> Jouni

Cullen Jennings
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Jouni Mäenpää <[email-masked]>
Date: Mon, 08 Mar 2010 08:53:36 +0200

Hi,

> Yah, that would probably work. But I still prefer A

In the new version of the draft
(http://www.ietf.org/id/draft-ietf-p2psip-self-tuning-01.txt), which was
submitted last week, we specify only alternative A.

Cheers,
Jouni