Subject: Re: [P2PSIP] Key refresh for P2PSIP overlays

From: Sun Chongwei <[email-masked]>
Date: Mon, 1 Mar 2010 16:17:27 +0800

Dear Konstantinos Birkos

I feel interest about your thoughts.

Key refreshment  is an important issue to promise security of P2P overlay
network as well as other types of networks. Cost of key refreshment
mechanism, the architecture of key management, etc, lots of work should be
done.

2010/2/25 Konstantinos Birkos <[email-masked]>

> Dear all,
>
> I would like to discuss the possibility of periodically refreshing the
> keying material of the participating peers in the overlay as well as
> certificate revocation in case malicious activity is detected.
> I am talking about each peer periodically creating new public/private key
> pairs and producing or receiving new certificates that bind its NodeID to
> the new public keys. A key refresh mechanism would put a barrier to
> attackers who could have compromised certain peers and would make attacks
> based on cryptanalysis tools even  more difficult.
> We are actually developing  a mechanism and we would like to discuss its
> applicability and its importance with the WG.
>
> Kind Regards,
> Konstantinos Birkos
> --
> Konstantinos Birkos
> PhD Candidate
> Wireless Telecommunication Laboratory
> Department of Electrical and Computer Engineering
> University of Patras
> Patras, Greece
> Tel.: +30 2610 996465
>
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip
>

-- 
Sun Chongwei
Mobile LIfe and New Media Lab
Beijing University of Posts and Telecommunications

---

From: Konstantinos Birkos <[email-masked]>
Date: Mon, 01 Mar 2010 20:09:47 +0200

Dear Sun Chongwei,

Thank you for your interest. In our I-D "Security Mechanisms and Key 
Refresh for P2PSIP Overlays" we propose a refresh mechanism suitable for 
RELOAD. Each peer periodically generates new public/private key pairs. 
The peer's ID is bound to its new public key via certificates that are 
signed by trusted online super peers or via self-signed certificates. We 
can discuss any issue regarding the details of the proposed extensions.

BR,
Konstantinos Birkos

Sun Chongwei wrote:
> Key refreshment  is an important issue to promise security of P2P 
> overlay network as well as other types of networks. Cost of key 
> refreshment mechanism, the architecture of key management, etc, lots 
> of work should be done.
>
> 2010/2/25 Konstantinos Birkos <[email-masked] 
> <mailto:[email-masked]>>
>
>     Dear all,
>
>     I would like to discuss the possibility of periodically refreshing
>     the keying material of the participating peers in the overlay as
>     well as certificate revocation in case malicious activity is detected.
>     I am talking about each peer periodically creating new
>     public/private key pairs and producing or receiving new
>     certificates that bind its NodeID to the new public keys. A key
>     refresh mechanism would put a barrier to attackers who could have
>     compromised certain peers and would make attacks based on
>     cryptanalysis tools even  more difficult.
>     We are actually developing  a mechanism and we would like to
>     discuss its applicability and its importance with the WG.
>
>     Kind Regards,
>     Konstantinos Birkos
>     -- 
>     Konstantinos Birkos
>     PhD Candidate
>     [email-masked] <mailto:[email-masked]>

---

From: Cullen Jennings <[email-masked]>
Date: Sat, 6 Mar 2010 18:26:51 -0700

I Agree, I think it's important to be able to do key refresh although there are some cases that won't need it. 

Cullen

On Feb 25, 2010, at 4:56 AM, Konstantinos Birkos wrote:

> Dear all,
> 
> I would like to discuss the possibility of periodically refreshing the keying material of the participating peers in the overlay as well as certificate revocation in case malicious activity is detected.
> I am talking about each peer periodically creating new public/private key pairs and producing or receiving new certificates that bind its NodeID to the new public keys. A key refresh mechanism would put a barrier to attackers who could have compromised certain peers and would make attacks based on cryptanalysis tools even  more difficult.
> We are actually developing  a mechanism and we would like to discuss its applicability and its importance with the WG.
> 
> Kind Regards,
> Konstantinos Birkos 
> -- 
> Konstantinos Birkos
> PhD Candidate

Cullen Jennings
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Konstantinos Birkos <[email-masked]>
Date: Wed, 10 Mar 2010 15:51:45 +0200

I believe that the main issue regarding key refresh is which entity is 
going to sign the new certificates that bind peers' IDs with their new 
keys, given the fact that P2PSIP does not necessitate the existence of 
online trusted parties. In our draft, we have included two options. 
According to the first option which is a hierarchical approach, super 
peers (trusted peers or peers directly related to an IDS) sign the new 
certificates. The second option defines that each peer creates a 
self-signed certificate.

Konstantinos Birkos