Subject: [P2PSIP] New draft notification: draft-song-p2psip-bootstrap-status-maintenance-00

From: Song Haibin <[email-masked]>
Date: Tue, 02 Mar 2010 14:38:57 +0800

Dear all,

I have submitted a new I-D, which can be accessed at:
http://tools.ietf.org/id/draft-song-p2psip-bootstrap-status-maintenance-00.t
xt

Abstract:
In order to join the overlay, a joining peer/client has to find the
enrollment server first, and then acquire the configuration file from the
enrollment server where it can find the bootstrap peers' information, and
after that it contact a bootstrap node to route the join request message to
join the overlay.  However, nodes in P2PSIP overlay network are dynamic.
They can leave gracefully or abruptly at any time.  This document focuses on
the bootstrap server mechanism and proposes a mechanism to select proper
bootstrap peers and improve the availability of bootstrap nodes through
bootstrap peer status maintenance.

BR,
Haibin

---

From: jc <[email-masked]>
Date: Tue, 2 Mar 2010 10:34:43 -0500

Hi,
Are you building some new type of enrollment server? What I've read thus far is fairly impossible to do with the current drafted enrollment server which is simply an HTTP server that isn't connected to the Overlay.

Regards,
Julian

On Mar 2, 2010, at 1:38 AM, Song Haibin wrote:

> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip

---

From: Song Haibin <[email-masked]>
Date: Wed, 03 Mar 2010 14:38:27 +0800

Hi Julian,

The enrollment server mentioned in this draft is required to support the
communication messages between an overlay peer and itself. We don't define
the exact message formats yet, but reusing the existing messages(whatever
they are) are preferred.

Xie Xie,
Haibin

> -----Original Message-----
> From: jc [mailto:[email-masked]] 
> Sent: Tuesday, March 02, 2010 11:35 PM
> To: Song Haibin
> Cc: 'P2PSIP WG'
> Subject: Re: [P2PSIP] New draft notification: 
> draft-song-p2psip-bootstrap-status-maintenance-00
> 
> Hi,
> Are you building some new type of enrollment server? What 
> I've read thus far is fairly impossible to do with the 
> current drafted enrollment server which is simply an HTTP 
> server that isn't connected to the Overlay.
> 
> Regards,
> Julian
> 
> > enrollment server first, and then acquire the configuration 
> file from 
> > the enrollment server where it can find the bootstrap peers' 
> > information, and after that it contact a bootstrap node to 
> route the 
> > join request message to join the overlay.  However, nodes 
> in P2PSIP overlay network are dynamic.
> > They can leave gracefully or abruptly at any time.  This document 
> > focuses on the bootstrap server mechanism and proposes a 
> mechanism to 
> > select proper bootstrap peers and improve the availability of 
> > bootstrap nodes through bootstrap peer status maintenance.
> > 
> > 
> > BR,
> > Haibin
> > 
> >

---

From: Brian Rosen <[email-masked]>
Date: Wed, 03 Mar 2010 10:07:13 -0500

<as individual>
Right, but you see the problem here, right?  Until now, the enrollment
server wasn't needed after you got your credentials.  So, it's reliability
wasn't important.  If you put it in an active role as part of bootstrapping,
it now has to be much more reliable and available.

It may be better to have a different way that doesn't require the enrollment
server to be on line and available when you want to boot.

Is this a problem worth solving?  We have lots of experience with bootstrap
nodes in various guises.  Is it really hard to have a relatively fixed set
of nodes, one or more of which have to be on line and available when you
want to join the overlay?

Are there alternatives that have worked?  Something like anycast and
(relatively slow) updates to a DNS hostname A/AAAA record?

Brian