Subject: [P2PSIP] Section 1.2 Architecture is incomplete

From: "Michael Chen" <[email-masked]>
Date: Sun, 07 Mar 2010 12:28:09 -0700

Hi,

For the base draft, at least two messages are sent without TLS/DTLS: ATTACH and PING (multi-cast or broadcast use case). The two diagrams in section 1.2 should reflect these two usages.

Also, to be clear and explicit, the overlay link layer should depict the frame header and its relation to TLS/DTLS. I suggest the following:

-------------------------------------- Overlay Link API
+------+  +------+  +------+
|<none>|  |TLS   |  |DTLS  |  ...
+------+  +------+  +------+
+---------------------------------+

|      Framing Header             |

+---------------------------------+

The <none> box accounts for the ATTACH and PING without TLS/DTLS.

Thanks

--Michael

---

From: Eric Rescorla <[email-masked]>
Date: Sun, 7 Mar 2010 11:43:01 -0800

I had thought we got rid of those since they are underapecified. If  
not we should.

Ekr

On Mar 7, 2010, at 11:28, "Michael Chen" <[email-masked]>  
wrote:

> Hi,
>
> For the base draft, at least two messages are sent without TLS/DTLS:  
> ATTACH and PING (multi-cast or broadcast use case). The two diagrams  
> in section 1.2 should reflect these two usages.
>
> Also, to be clear and explicit, the overlay link layer should depict  
> the frame header and its relation to TLS/DTLS. I suggest the  
> following:
>
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip