Subject: Re: [P2PSIP] Section 1.2 Architecture is incomplete

From: "Michael Chen" <[email-masked]>
Date: Sun, 07 Mar 2010 12:49:50 -0700

Eric,

Do you mean PING with multicast and broadcast? Please elaborate. The case for ATTACH is demonstrated in section 11.

--Michael

-------- Original Message --------

Subject: Re: [P2PSIP] Section 1.2 Architecture is incomplete

From: Eric Rescorla <[email-masked]>

Date: Sun, March 07, 2010 11:43 am

To: Michael Chen <[email-masked]>

Cc: "[email-masked]" <[email-masked]>

I had thought we got rid of those since they are underapecified. If not we should.

Ekr

On Mar 7, 2010, at 11:28, "Michael Chen" <[email-masked]> wrote:

Hi,

For the base draft, at least two messages are sent without TLS/DTLS: ATTACH and PING (multi-cast or broadcast use case). The two diagrams in section 1.2 should reflect these two usages.

Also, to be clear and explicit, the overlay link layer should depict the frame header and its relation to TLS/DTLS. I suggest the following:

-------------------------------------- Overlay Link API
+------+  +------+  +------+
|<none>|  |TLS   |  |DTLS  |  ...
+------+  +------+  +------+
+---------------------------------+

|      Framing Header             |

+---------------------------------+

The <none> box accounts for the ATTACH and PING without TLS/DTLS.

Thanks

--Michael

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip

---

From: Eric Rescorla <[email-masked]>
Date: Sun, 7 Mar 2010 13:22:21 -0800

On Mar 7, 2010, at 11:49, "Michael Chen" <[email-masked]>  
wrote:

> Eric,
>
> Do you mean PING with multicast and broadcast? Please elaborate.

Yes. I'm not sure it's fully specified

> The case for ATTACH is demonstrated in section 11.

I don't see that. Afaict all the examples in s 11 are compatible with  
tls. Which one do you think is not?

Ekr
>> For the base draft, at least two messages are sent without TLS/ 
>> DTLS: ATTACH and PING (multi-cast or broadcast use case). The two  
>> diagrams in section 1.2 should reflect these two usages.
>>
>> Also, to be clear and explicit, the overlay link layer should  
>> depict the frame header and its relation to TLS/DTLS. I suggest the  
>> following:
>>