Subject: [P2PSIP] Is P2PSIP RELOAD not suitable to be leverage for both P2P Live Streaming and VoD Service?

From: World <[email-masked]>
Date: Mon, 15 Mar 2010 16:55:09 +0800 (CST)

Dear all,
 
I am thinking what P2P Live Streaming and VoD Service can leverage P2PSIP RELOAD. According to some research or proposal report, it seems that P2PSIP RELOAD can be used in P2P-based Tracker and/or chunk description distribution (chunk discovery) at the full distributed deployment. Both P2P-based Tracker and chunk description distribution over P2PSIP overlay were evaluated in performance referred to draft-chen-ppsp-dht-chunk-discovery-evaluation-00.txt and draft-hu-ppsp-tracker-dht-performance-comparison-01.txt. The result showed the performance of DHT-based Tracker and chunk description distribution is worse, even not acceptable for P2P Live Streaming and VoD Service.

So can we make such conclusion that P2PSIP RELOAD is not suitable to be leverage for both P2P Live Streaming and VoD Service in case a full distributed deployment is not mandatory? What do you think?
 
Any comments are welcome. Thanks.
 
BR,
Jeffrey

---

From: "Roy, Radhika R Dr CIV USA USAMC" <[email-masked]>
Date: Mon, 15 Mar 2010 08:54:14 -0400

Hi, Jeffrey:

My assumption has been that SIP signaling schemes have not been optimized for Live streaming or VOD.

In the same token, P2PSIP may not be scalable for Live streaming or VOD.

The question is this: Do we need still to make this statement in RELOAD of P2PSIP?

Best regards,
Radhika

----- Original Message -----
From: World <[email-masked]>
Date: Monday, March 15, 2010 5:03
Subject: [P2PSIP] Is P2PSIP RELOAD not suitable to be leverage for both P2P Live Streaming and VoD Service?
To: [email-masked]

> Dear all,
>  
> I am thinking what P2P Live Streaming and VoD Service can leverage 
> P2PSIP RELOAD. According to some research or proposal report, it 
> seems that P2PSIP RELOAD can be used in P2P-based Tracker and/or 
> chunk description distribution (chunk discovery) at the full 
> distributed deployment. Both P2P-based Tracker and chunk 
> description distribution over P2PSIP overlay were evaluated in 
> performance referred to draft-chen-ppsp-dht-chunk-discovery-
> evaluation-00.txt and draft-hu-ppsp-tracker-dht-performance-
> comparison-01.txt. The result showed the performance of DHT-based 
> Tracker and chunk description distribution is worse, even not 
> acceptable for P2P Live Streaming and VoD Service.
> 
> So can we make such conclusion that P2PSIP RELOAD is not suitable 
> to be leverage for both P2P Live Streaming and VoD Service in case 
> a full distributed deployment is not mandatory? What do you think?
>  
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip

---

From: EdPimentl <[email-masked]>
Date: Mon, 15 Mar 2010 09:47:21 -0400

Has the group considered the methods used by P2PLive, CoolStreaming and or
PPStream

-E
http://vCardCloud.com

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 15 Mar 2010 06:53:47 -0700

I don't think soi. It's an explicit non-goal.

-Ekr

---

From: jc <[email-masked]>
Date: Mon, 15 Mar 2010 14:18:16 -0400

My implementor experience suggests RELOAD would not work well in this scenario. An ad-hoc non KBR style overlay network is more suitable for this application. 

Julian Cain

---

From: Bruce Lowekamp <[email-masked]>
Date: Mon, 15 Mar 2010 11:32:50 -0800

The performance comparison draft compares the performance of a centralized
lookup server with a P2P DHT system with 10M peers.  Since those address
entirely different use cases, and no one would ever deploy a 10M peer
distributed tracker, it's not clear what the point of the comparison is.
 This has nothing to do with RELOAD.

Bruce

On Mon, Mar 15, 2010 at 12:55 AM, World <[email-masked]> wrote:

> Dear all,
>
> I am thinking what P2P Live Streaming and VoD Service can leverage P2PSIP
> RELOAD. According to some research or proposal report, it seems that P2PSIP
> RELOAD can be used in P2P-based Tracker and/or chunk description
> distribution (chunk discovery) at the full distributed deployment. Both
> P2P-based Tracker and chunk description distribution over P2PSIP overlay
> were evaluated in performance referred to
> draft-chen-ppsp-dht-chunk-discovery-evaluation-00.txt and
> draft-hu-ppsp-tracker-dht-performance-comparison-01.txt. The result showed
> the performance of DHT-based Tracker and chunk description distribution is
> worse, even not acceptable for P2P Live Streaming and VoD Service.
>
> So can we make such conclusion that P2PSIP RELOAD is not suitable to be
> leverage for both P2P Live Streaming and VoD Service in case a full
> distributed deployment is not mandatory? What do you think?
>

---

From: jc <[email-masked]>
Date: Mon, 15 Mar 2010 15:55:08 -0400

On Mar 15, 2010, at 3:32 PM, Bruce Lowekamp wrote:

> The performance comparison draft compares the performance of a centralized lookup server with a P2P DHT system with 10M peers.  Since those address entirely different use cases, and no one would ever deploy a 10M peer distributed tracker, it's not clear what the point of the comparison is.  This has nothing to do with RELOAD.

There are active distributed trackers w/ > 1M peers. Why would you not deploy a 10M user distributed tracker? They do inherently scale infinitely by nature.

---

From: Bruce Lowekamp <[email-masked]>
Date: Mon, 15 Mar 2010 14:32:40 -0800

They scale fine, but there is a point beyond which adding additional peers
to the overlay routing merely adds latency.  Don't have time to look up the
references now, but there are a number of papers discussing the advantages
of different numbers of peers (superpeers in a lot of systems) needed for
overlay routing.  You don't need 10M.

Bruce

On Mon, Mar 15, 2010 at 11:55 AM, jc <[email-masked]> wrote:

> There are active distributed trackers w/ > 1M peers. Why would you not
> deploy a 10M user distributed tracker? They do inherently scale infinitely
> by nature.
>
>
> Bruce
>
>
>

---

From: jc <[email-masked]>
Date: Mon, 15 Mar 2010 19:27:45 -0400

You need 57,142.857 nodes to route 20M of peer traffic. This is the  
algorithm we used in fasttrack and is the same as in skype. This is a  
maximum capacity scenario.

Sent from my iPhone

On Mar 15, 2010, at 6:32 PM, Bruce Lowekamp <[email-masked]> wrote:

> They scale fine, but there is a point beyond which adding additional  
> peers to the overlay routing merely adds latency.  Don't have time  
> to look up the references now, but there are a number of papers  
> discussing the advantages of different numbers of peers (superpeers  
> in a lot of systems) needed for overlay routing.  You don't need 10M.
>
> Bruce
>
>
>> The performance comparison draft compares the performance of a  
>> centralized lookup server with a P2P DHT system with 10M peers.   
>> Since those address entirely different use cases, and no one would  
>> ever deploy a 10M peer distributed tracker, it's not clear what the  
>> point of the comparison is.  This has nothing to do with RELOAD.
>
> There are active distributed trackers w/ > 1M peers. Why would you  
> not deploy a 10M user distributed tracker? They do inherently scale  
> infinitely by nature.
>
>>
>> Bruce
>>
>>
>>

---

From: Bruce Lowekamp <[email-masked]>
Date: Mon, 15 Mar 2010 16:10:27 -0800

So substituting the terms used in RELOAD, this is exactly my point.
 draft-hu-ppsp-tracker-dht-performance-comparison assumes 20M peers, i.e.
nodes used in routing, and bases latency calculations on that number.  Not
57K.  The draft further works out that with 20M peers storing data, each
needs to store 0.01 of a resource.

Even if you do the calculations with a reasonable number of peers (routing
nodes), the dht overlay will still obviously have higher latency than a
single-server based solution.  You select a dht overlay for different
reasons than you would select a central server-based solution.

Bruce

On Mon, Mar 15, 2010 at 3:27 PM, jc <[email-masked]> wrote:

> On Mon, Mar 15, 2010 at 11:55 AM, jc < <[email-masked]>
> [email-masked]> wrote:
>
>>
>> On Mon, Mar 15, 2010 at 12:55 AM, World < <[email-masked]>
>> [email-masked]> wrote:
>>
>>> Dear all,
>>>
>>>  <[email-masked]>[email-masked]
>>>  <https://www.ietf.org/mailman/listinfo/p2psip>
>> <[email-masked]>[email-masked]
>> <https://www.ietf.org/mailman/listinfo/p2psip>

---

From: jc <[email-masked]>
Date: Mon, 15 Mar 2010 20:58:18 -0400

The largest overlay i've seen where every node participated in storage and routing was ~1.6M. They operate best under ~650K. At about 1M the routing times get into the minutes. You would need to create and ad-hoc overlay for every stream. I've implemented a multicast layer that does this over a DHT. The DHT is the signaling layer used to setup these ad-hoc overlays(groups). RELOAD could perform the signaling, rendezvous setup, multicast grouping storage but not too much more.

On Mar 15, 2010, at 8:10 PM, Bruce Lowekamp wrote:

> So substituting the terms used in RELOAD, this is exactly my point.  draft-hu-ppsp-tracker-dht-performance-comparison assumes 20M peers, i.e. nodes used in routing, and bases latency calculations on that number.  Not 57K.  The draft further works out that with 20M peers storing data, each needs to store 0.01 of a resource.
> 
> Even if you do the calculations with a reasonable number of peers (routing nodes), the dht overlay will still obviously have higher latency than a single-server based solution.  You select a dht overlay for different reasons than you would select a central server-based solution.
> 
> Bruce
> 
> 
> You need 57,142.857 nodes to route 20M of peer traffic. This is the algorithm we used in fasttrack and is the same as in skype. This is a maximum capacity scenario.
> 
> Sent from my iPhone
> 
>> They scale fine, but there is a point beyond which adding additional peers to the overlay routing merely adds latency.  Don't have time to look up the references now, but there are a number of papers discussing the advantages of different numbers of peers (superpeers in a lot of systems) needed for overlay routing.  You don't need 10M.
>> 
>> Bruce
>> 
>>

---

From: [email-masked]
Date: Tue, 16 Mar 2010 10:35:26 +0800

I think DHT can be used to build tracker server farm in some scenarios. 
DHT server farm has better scalability and reliability compared with a 
single server. DHT server farm's latency is still acceptable, because DHT 
node number is small and one-hop DHT can be used.

BR
Lichun

Bruce Lowekamp <[email-masked]> 
发件人:  [email-masked]
2010-03-16 08:10

收件人
jc <[email-masked]>
抄送
"[email-masked]" <[email-masked]>
主题
Re: [P2PSIP] Is P2PSIP RELOAD not suitable to be leverage for both P2P 
Live Streaming and VoD Service?

Bruce

Sent from my iPhone

They scale fine, but there is a point beyond which adding additional peers 
to the overlay routing merely adds latency.  Don't have time to look up 
the references now, but there are a number of papers discussing the 
advantages of different numbers of peers (superpeers in a lot of systems) 
needed for overlay routing.  You don't need 10M.

Bruce

Bruce

RELOAD. According to some research or proposal report, it seems that 
P2PSIP RELOAD can be used in P2P-based Tracker and/or chunk description 

 
BR,
Jeffrey

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: [email-masked]
Date: Tue, 16 Mar 2010 10:49:27 +0800

Hi, Julian

I'm curious on how to calculate the DHT node number. What DHT algorithm is 
used? The routing hop count is O(log N)?
Are these 57,142.857 nodes super user nodes? If the DHT overlay is formed 
by servers, how many servers are required? 

By the way, I have a draft about P2P CDN using PPSP and RELOAD. In the 
proposed P2P CDN, trackers (servers) form a DHT overlay.
http://www.ietf.org/internet-drafts/draft-li-ppsp-p2p-cdn-00.txt

BR
Lichun

2010-03-16 07:27

收件人

Sent from my iPhone

Bruce

Bruce

 
 
BR,
Jeffrey

---

From: [email-masked]
Date: Wed, 17 Mar 2010 18:58:35 +0800

I think whatever the centralized or distributed tracker you chose, 
if you must deal with billions of users's access, they're the same. The 
centralized tracker must be deployed in distributed or so-called 'cluster' 
mode, DHT is just one kind of distributed algorithm, not so special...
      And futhermore, the DHT algorithm does not always mean 'poor 
performance', we have implemented one kind of DHT algorithm suitable for 
stable network, its lookup cost is one hop(thousands nodes) or two 
hop(millions nodes), and the algorithm released as a plug-in of RELOAD 
protocol.
      The similar algorithm you can found in amazon's dynamo or the 
memcahce project, and there's also some other constant complexity DHT 
algorithm.

Russell Wang

2010-03-16 08:58

收件人

The largest overlay i've seen where every node participated in storage and 
routing was ~1.6M. They operate best under ~650K. At about 1M the routing 
times get into the minutes. You would need to create and ad-hoc overlay 
for every stream. I've implemented a multicast layer that does this over a 
DHT. The DHT is the signaling layer used to setup these ad-hoc 
overlays(groups). RELOAD could perform the signaling, rendezvous setup, 
multicast grouping storage but not too much more.

Bruce

Sent from my iPhone

Bruce

Bruce

 
 
BR,
Jeffrey

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 17 Mar 2010 07:12:44 -0700

This all seems really off topic for this WG. The charter of P2PSIP
explicitly excludes
any work on this kind of media sharing:

1. Issues specific to applications other than locating users and
resources for SIP-based communications and presence.

-Ekr

2010/3/17 <[email-masked]>

>  *jc <[email-masked]>*
> Re: [P2PSIP] Is P2PSIP RELOAD not suitable to be leverage for both
>  P2P Live Streaming and VoD Service?
>
>
>
>
> times get into the minutes. You would need to create and ad-hoc overlay for
> every stream. I've implemented a multicast layer that does this over a DHT.
> The DHT is the signaling layer used to setup these ad-hoc overlays(groups).
> RELOAD could perform the signaling, rendezvous setup, multicast grouping
> storage but not too much more.
>
> On Mon, Mar 15, 2010 at 3:27 PM, jc <[email-masked]*<[email-masked]>>
> wrote:
> On Mar 15, 2010, at 6:32 PM, Bruce Lowekamp <[email-masked]*<[email-masked]>>
> wrote:
>
> On Mon, Mar 15, 2010 at 11:55 AM, jc < <[email-masked]>*
> [email-masked]* <[email-masked]>> wrote:
>
> On Mon, Mar 15, 2010 at 12:55 AM, World < <[email-masked]>*
> [email-masked]* <[email-masked]>> wrote:  Dear all,
>
> P2PSIP mailing list*
> * <[email-masked]>[email-masked]* <[email-masked]>*
> * <https://www.ietf.org/mailman/listinfo/p2psip>*
> https://www.ietf.org/mailman/listinfo/p2psip*<https://www.ietf.org/mailman/listinfo/p2psip>
>
>
> P2PSIP mailing list*
> * <[email-masked]>[email-masked]* <[email-masked]>*
> * <https://www.ietf.org/mailman/listinfo/p2psip>*
> https://www.ietf.org/mailman/listinfo/p2psip*<https://www.ietf.org/mailman/listinfo/p2psip>
>
>
>

---

From: [email-masked]
Date: Thu, 18 Mar 2010 09:31:03 +0800

DHT/reload discussed here are used for build trackers of a streaming 
system, where the resources are chunk/piece of data other than users.

Wang Russell

Eric Rescorla <[email-masked]> 
2010-03-17 22:12

收件人
[email-masked]
抄送
jc <[email-masked]>, "[email-masked]" <[email-masked]>, 
[email-masked]
主题
Re: [P2PSIP] 答复: Re: Is P2PSIP RELOAD not suitable to be leverage for 
both P2P Live Streaming and VoD Service?

-Ekr

Russell Wang

收件人

Bruce 

Sent from my iPhone 

Bruce 

Bruce 

 
 
BR,
Jeffrey

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is 
solely property of the sender's organization. This mail communication is 
confidential. Recipients named above are obligated to maintain secrecy and 
are not permitted to disclose the contents of this communication to 
others.
This email and any files transmitted with it are confidential and intended 
solely for the use of the individual or entity to whom they are addressed. 
If you have received this email in error please notify the originator of 
the message. Any views expressed in this message are those of the 
individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam 
system.

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 17 Mar 2010 19:06:35 -0700

Yes, this is also out of scope for the WG.

-Ekr

>  *Eric Rescorla <[email-masked]>*
>
> 2010-03-17 22:12
>   收件人
> [email-masked]
>  抄送
> Re: [P2PSIP] 答复: Re: Is P2PSIP RELOAD not suitable to be leverage for both
> 2010/3/17 <[email-masked]* <[email-masked]>>
>
>      The similar algorithm you can found in amazon's dynamo or the memcahce
> project, and there's also some other constant complexity DHT algorithm.
>
>
>
> Russell Wang
>
>
>
>   *jc <[email-masked]* <[email-masked]>*>*
> 发件人:  [email-masked]* <[email-masked]>
>
> 2010-03-16 08:58
>
>   收件人
> Bruce Lowekamp <[email-masked]* <[email-masked]>>
> 抄送
> "[email-masked]* <[email-masked]>" <[email-masked]* <[email-masked]>
> >
> 主题
> [email-masked]* <[email-masked]>*
> **https://www.ietf.org/mailman/listinfo/p2psip*<https://www.ietf.org/mailman/listinfo/p2psip>
>
>
> are not permitted to disclose the contents of this communication to others.
> If you have received this email in error please notify the originator of the
> message. Any views expressed in this message are those of the individual
> sender.
> [email-masked]* <[email-masked]>*
> **https://www.ietf.org/mailman/listinfo/p2psip*<https://www.ietf.org/mailman/listinfo/p2psip>
>
>
>

---

From: "David A. Bryan" <[email-masked]>
Date: Wed, 17 Mar 2010 22:14:51 -0400

This isn't really the best list for a discussion about these topics, since
the P2PSIP group isn't chartered right now to work on streaming or trackers.
The best place is probably over on the PPSP list, rather than here. That is
the group that is looking building streaming systems and trackers, and can
certainly discuss if RELOAD is a good protocol choice for that application,
while this group is currently only chartered to look at a protocol for DHTs
for use with SIP. You are more likely to get the right folks for this
discussion on that list (and of course there is a good bit of overlap of
participants between the lists).

David (as chair)

2010/3/17 Eric Rescorla <[email-masked]>

>> "[email-masked]* <[email-masked]>" <[email-masked]*<[email-masked]>
>> >
>> 主题

---

From: [email-masked]
Date: Thu, 18 Mar 2010 10:28:17 +0800

Hi David,

But there is a situation really hard for us.

RELOAD is a nice platform for P2P Live Streaming and VoD Service. So, it 
is nature to enhance RELOAD for such usage.

So, if we can divide RELOAD base and RELOAD usage as two aspect and make 
RELOAD base open for usage other than p2psip might better.

I think define new RELOAD base like platform for every new p2p usage is 
not a proper way :)

Thanks,

Gao

===================================
 Zip    : 210012
 Tel    : 87211
 Tel2   :(+86)-025-52877211
 e_mail : [email-masked]
===================================

"David A. Bryan" <[email-masked]> 
发件人:  [email-masked]
2010-03-18 10:14

收件人
[email-masked]
抄送

This isn't really the best list for a discussion about these topics, since 
the P2PSIP group isn't chartered right now to work on streaming or 
trackers. The best place is probably over on the PPSP list, rather than 
here. That is the group that is looking building streaming systems and 
trackers, and can certainly discuss if RELOAD is a good protocol choice 
for that application, while this group is currently only chartered to look 
at a protocol for DHTs for use with SIP. You are more likely to get the 
right folks for this discussion on that list (and of course there is a 
good bit of overlap of participants between the lists).

David (as chair)

-Ekr

Wang Russell

收件人
[email-masked] 
抄送

-Ekr 

Russell Wang

收件人

Bruce 

Sent from my iPhone 

Bruce 

Bruce 

 
 
BR,
Jeffrey

---

From: JeffreyHo <[email-masked]>
Date: Thu, 18 Mar 2010 11:44:31 +0800

Subject: RE: [P2PSIP] Is P2PSIP RELOAD not suitable to be leverage for bothP2P Live Streaming and VoD Service?
From: JeffreyHo <[email-masked]>
To: "'David A. Bryan'" <[email-masked]>
Cc: <[email-masked]>, <[email-masked]>
Date: Thu, 18 Mar 2010 11:44:31 +0800

Actually, there is the same topic posted in the PPSP group. Please see
http://www.ietf.org/mail-archive/web/ppsp/current/msg00552.html
But there is not any discussion there. I think there is indeed a good bits
of overlay of participants between P2PSIP and PPSP lists.
Thanks.

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
David A. Bryan
Sent: Thursday, March 18, 2010 10:15 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [P2PSIP] Is P2PSIP RELOAD not suitable to be leverage for
bothP2P Live Streaming and VoD Service?

David (as chair)

-Ekr

DHT/reload discussed here are used for build trackers of a streaming system,
where the resources are chunk/piece of data other than users. 

Wang Russell

2010-03-17 22:12 

收件人
[email-masked] 

抄送

主题

-Ekr 

2010/3/17 < <mailto:[email-masked]> [email-masked]> 

       I think whatever the centralized or distributed tracker you chose, if
you must deal with billions of users's access, they're the same. The

Russell Wang

jc < <mailto:[email-masked]> [email-masked]> 
发件人:   <mailto:[email-masked]> [email-masked] 

2010-03-16 08:58 

收件人
Bruce Lowekamp < <mailto:[email-masked]> [email-masked]> 	

抄送
" <mailto:[email-masked]> [email-masked]" < <mailto:[email-masked]>
[email-masked]> 	

主题

Bruce 

On Mon, Mar 15, 2010 at 3:27 PM, jc < <mailto:[email-masked]>

Sent from my iPhone 

On Mar 15, 2010, at 6:32 PM, Bruce Lowekamp < <mailto:[email-masked]>
[email-masked]> wrote:

Bruce 

On Mon, Mar 15, 2010 at 11:55 AM, jc < <mailto:[email-masked]>
<mailto:[email-masked]> [email-masked]> wrote: 

Bruce 

On Mon, Mar 15, 2010 at 12:55 AM, World < <mailto:[email-masked]>
<mailto:[email-masked]> [email-masked]> wrote: 
Dear all, 

 
 
BR,
Jeffrey	

_______________________________________________
P2PSIP mailing list
 <mailto:[email-masked]>  <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/p2psip>
<https://www.ietf.org/mailman/listinfo/p2psip>
https://www.ietf.org/mailman/listinfo/p2psip

_______________________________________________
P2PSIP mailing list
 <mailto:[email-masked]>  <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/p2psip>
<https://www.ietf.org/mailman/listinfo/p2psip>
https://www.ietf.org/mailman/listinfo/p2psip 

_______________________________________________
P2PSIP mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/p2psip>
https://www.ietf.org/mailman/listinfo/p2psip

_______________________________________________
P2PSIP mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/p2psip>
https://www.ietf.org/mailman/listinfo/p2psip

本信件可能包含工研院機密資訊，非指定之收件者，請勿使用或揭露本信件內容，並請銷毀此信件。
This email may contain confidential information. Please do not use or disclose it in any way and delete it if you are not the intended recipient.

---

From: [email-masked]
Date: Thu, 18 Mar 2010 11:48:39 +0800

Please see my previous mail in 
http://www.ietf.org/mail-archive/web/p2psip/current/msg05558.html

my key point here is RELOAD base and RELOAD usage are two aspects and make 
RELOAD base open for usage other than p2psip might better.

Thanks,

Gao

JeffreyHo <[email-masked]> 
发件人:  [email-masked]
2010-03-18 11:44

收件人
"'David A. Bryan'" <[email-masked]>
抄送
[email-masked], [email-masked]
主题
Re: [P2PSIP] Is P2PSIP RELOAD not suitable to be leverage for   bothP2P 
Live Streaming and VoD Service?

-----来自 JeffreyHo <[email-masked]> 的消息，在 Thu, 18 Mar 2010 
11:44:31 +0800 -----
收件人:
"'David A. Bryan'" <[email-masked]>
抄送:
<[email-masked]>, <[email-masked]>
主题:
RE: [P2PSIP] Is P2PSIP RELOAD not suitable to be leverage for bothP2P Live 
Streaming and VoD Service?
Actually, there is the same topic posted in the PPSP group. Please see 
http://www.ietf.org/mail-archive/web/ppsp/current/msg00552.html
But there is not any discussion there. I think there is indeed a good bits 
of overlay of participants between P2PSIP and PPSP lists.
Thanks.

From: [email-masked] [mailto:[email-masked]] On Behalf 
Of David A. Bryan

David (as chair)

-Ekr

Wang Russell

收件人
[email-masked] 
抄送

-Ekr 

Russell Wang

收件人

Bruce 

Sent from my iPhone 

Bruce 

Bruce 

 
 
BR,
Jeffrey

本信件可能包含工研院機密資訊，非指定之收件者，請勿使用或揭露本信件內容，並
請銷毀此信件。
This email may contain confidential information. Please do not use or 
disclose it in any way and delete it if you are not the intended 
recipient._______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip