Subject: Re: [P2PSIP] WGLC for draft-ietf-p2psip-sip-09

From: "Michael Chen" <[email-masked]>
Date: Mon, 15 Jul 2013 10:43:11 -0700

Hi Thomas,
 
The change in sip-10 is not appropriate. Please refer to my Feb 14, 2012 comment:
 
  http://www.ietf.org/mail-archive/web/p2psip/current/msg06176.html
 
The keep-alive needed is for the application channel created from AppAttach, in this case should only carry SIP traffics. Therefore, RELOAD Ping is not appropriate.
 
Instead, p2psip-sip should simply mention these two techniques or select one of:
 
  http://tools.ietf.org/html/rfc5626#section-3.5
 
Thanks
 
--Michael
--------- Original Message --------- Subject: Re: [P2PSIP] WGLC for draft-ietf-p2psip-sip-09
From: "Thomas C. Schmidt" <[email-masked]>
Date: 7/15/13 12:21 am
To: "Michael Chen" <[email-masked]>
Cc: [email-masked]

Hi Michael, all,
 
 it's updated now ... as this doc is on last call, it would be good to 
 hear about all other comments/remarks by the Berlin meeting.
 
 Cheers,
 
 Thomas

 On 12.07.2013 18:32, Thomas C. Schmidt wrote:
 > Hi Michael,
 >
 > sorry for having missed your mail: we'll address in an update.
 >
 > Best,
 >
 > Thomas
 >
 > On 09.06.2013 17:36, Michael Chen wrote:
 >> Hi,
 >> Has the issue of keep-alive been addressed?
 >> http://www.ietf.org/mail-archive/web/p2psip/current/msg06176.html
 >> Thanks
 >> --Michael
 >>

---

From: "Thomas C. Schmidt" <[email-masked]>
Date: Tue, 16 Jul 2013 18:17:04 +0200

Hi Michael,

thanks for the pointer and sorry to have missed this point.

Currently I'm on travel and rather intermittently connected: We'll fix 
next week.

Best,

Thomas

On 15.07.2013 19:43, Michael Chen wrote:
> The keep-alive needed is for the application channel created from
> AppAttach, in this case should only carry SIP traffics. Therefore,
> RELOAD Ping is not appropriate.
>     --------- Original Message ---------
>     Subject: Re: [P2PSIP] WGLC for draft-ietf-p2psip-sip-09

-- 

Prof. Dr. Thomas C. Schmidt
° Hamburg University of Applied Sciences                   Berliner Tor 7 °
° Dept. Informatik, Internet Technologies Group    20099 Hamburg, Germany °
° http://www.haw-hamburg.de/inet                   Fon: +49-40-42875-8452 °
° http://www.informatik.haw-hamburg.de/~schmidt    Fax: +49-40-42875-8409 °

---

From: "Thomas C. Schmidt" <[email-masked]>
Date: Sun, 21 Jul 2013 23:56:38 +0200

Hi Michael,

thanks again for the pointer - please see inline.

> RELOAD Ping is not appropriate.

Yup - sorry, I was too quick. A new version of the draft can be 
provisionally obtained from 
http://inet.cpt.haw-hamburg.de/papers/draft-ietf-p2psip-sip-11.txt until 
the submission re-opens.

However, as we are talking about plain SIP connectivity, there is just a 
reference pointer useful ... nothing new here.

>    http://tools.ietf.org/html/rfc5626#section-3.5

We've added the reference - a selection of the techniques depends on the 
transport choice.

Cheers,

Thomas

--

---

From: "Thomas C. Schmidt" <[email-masked]>
Date: Mon, 29 Jul 2013 09:41:48 +0200

Hi,

in the previous discussion we have overlooked that ICE includes 
keepalives of data channels. This has now been added to the submission.

Cheers,

Thomas

--