Subject: [P2PSIP] storage_time check wording inconsistency

From: "Michael Chen" <[email-masked]>
Date: Thu, 04 Jul 2013 10:52:24 -0700

Hi,
 
In the current p2psip-base-26, all descriptions of storage_time check (e.g 7.4.1.1 and 13.5.3) states that a Store request must satisfy condition:

    new_item->storage_time > existing_item->storage_time
 
However, these two places have wordings to the contrary in terms of equality in the above comparison:
 
Section 7. Data Storage Protocol
storage_time
  ... Any attempt to store a data value with a storage
 time before that of a value already stored at this location MUST
 generate a Error_Data_Too_Old error. 
Section 6.3.3.1
Error_Data_Too_Old: A store cannot be completed because the
 storage_time precedes the existing value.
 
The word "before" must be changed to "older than or equal to", and
the word "precedes" must be changed to "is older than or equal to".
 
Thanks
 
--Michael

---

From: 邓灵莉/Lingli Deng <[email-masked]>
Date: Fri, 5 Jul 2013 06:46:28 +0800

Hi Michael,

I agree with you that there is a hole when subsequent store requests have the same storage_time value.

But should every equality case be responded with a TOO-OLD error?

If there is  only one writer to the data object, it seems like a repetition, and it makes sense to discard it like you said.

Whereas if there are more than one writers to the data object, I am not sure what is expected. 

Do we have to consider the multi-writer case?

BR

Lingli

发件人: [email-masked] [mailto:[email-masked]] 代表 Michael Chen
发送时间: 2013年7月5日 1:52
收件人: [email-masked]
主题: [P2PSIP] storage_time check wording inconsistency

Hi,

   storage_time

Section 6.3.3.1

Thanks

--Michael

---

From: "Michael Chen" <[email-masked]>
Date: Sun, 07 Jul 2013 08:33:55 -0700

Hi Lingli,
 
"Writer" is a vague term. Section 7.3 Access Control describes validation around the "signer" of the stored data. A storage data can be stored (or written) by the signer and by the responsible peer as replica to its successors.
 
The problem is not as simple as it may seem. During replication, successors will receive identical copies of the same StoredDataValue with a storage_time equals to the one it already has (previously received). Therefore, for replicas, storage_time equality is expected and must be allowed.
 
This topic needs more discussions. Please add it to the Berlin agendas if none of the principal authors are able to respond before then.
 
Thanks
 
--Michael
--------- Original Message --------- Subject: 答复: [P2PSIP] storage_time check wording inconsistency
From: "邓灵莉/Lingli Deng" <[email-masked]>
Date: 7/4/13 3:46 pm
To: "'Michael Chen'" <[email-masked]>, [email-masked]

  Hi Michael,

  
  
 BR
 Lingli