Subject: [P2PSIP] time synchronization?

From: "Songhaibin (A)" <[email-masked]>
Date: Wed, 14 Aug 2013 01:31:08 +0000

Hi Guys,

In -diagnostics draft, we have timestamp that is used by the intermediate nodes to check if the message is expired or not. It raises a problem of time synchronization. I think we need a decision from the WG. We need careful consideration on how to use the timestamp because time synchronization is a barrier in open Internet environment, while in a managed environment, it may be less of a problem. Do we want to enforce the time synchronization or do we want to lose the feature to check the message expiration (and one-way-delay)? Please tell what you are thinking about.

BR,
-Haibin

---

From: Roland Bless <[email-masked]>
Date: Tue, 27 Aug 2013 11:44:17 +0200

Hi,

On 14.08.2013 03:31, Songhaibin (A) wrote:
> In –diagnostics draft, we have timestamp that is used by the
> intermediate nodes to check if the message is expired or not. It raises
> a problem of time synchronization. I think we need a decision from the
> WG. We need careful consideration on how to use the timestamp because
> time synchronization is a barrier in open Internet environment, while in
> a managed environment, it may be less of a problem. Do we want to
> enforce the time synchronization or do we want to lose the feature to
> check the message expiration (and one-way-delay)? Please tell what you
> are thinking about.

As the base (RELOAD) draft doesn't require any time synchronization
mechanism, I think, it's not useful to enforce the use of
time synchronization in any other draft. IMHO it's obvious
that you may have advantages if time synch is available;
more important is how you could distinguish from the protocol
if it's used or not.

Regards,
 Roland

---

From: "Songhaibin (A)" <[email-masked]>
Date: Wed, 28 Aug 2013 01:22:10 +0000

Hi Roland,

Thanks for your point.

In -base document, the last paragraph of section 13.6.3 mentions a little about time synchronization for preventing replay attack.

By the way, I guess time synchronization can be overlay specific. So the overlay configuration file can include some parameters to say whether there is synchronization or not. For the overlays which do not enforce it, overlay nodes can just ignore the related fields.

BR,
-Haibin

-----Original Message-----
From: Roland Bless [mailto:[email-masked]] 
Sent: Tuesday, August 27, 2013 5:44 PM
To: Songhaibin (A)
Cc: [email-masked]
Subject: Re: [P2PSIP] time synchronization?

Hi,

On 14.08.2013 03:31, Songhaibin (A) wrote:
> In -diagnostics draft, we have timestamp that is used by the

Regards,
 Roland