Subject: [Pals] Fwd: I-D Action: draft-andersson-mpls-miad-fwk-01.txt

From: Loa Andersson <[email-masked]>
Date: Fri, 4 Mar 2022 14:05:55 +0800

Working Groups,

We have posted an early version of the MIAD Framework.

Version -01 does nothing but correct a few embarrassing typos.

In its current version the document is posted to attract review and 
comments. Please read and send nits to the authors and technical 
comments to the mpls mailing list.

Take a careful look at section 3 and 8, where we started to fill on some 
content.

/Loa

-------- Forwarded Message --------
Subject: I-D Action: draft-andersson-mpls-miad-fwk-01.txt
Date: Thu, 03 Mar 2022 19:49:50 -0800
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.

         Title           : MPLS MIAD Framework
         Authors         : Loa Andersson
                           Stewart Bryant
                           Matthew Bocci
	Filename        : draft-andersson-mpls-miad-fwk-01.txt
	Pages           : 13
	Date            : 2022-03-03

Abstract:
    This document specifies an architectural framework for the
    application of the MPLS Indicator and Ancillary Data (MIAD)
    technologies.  MIAD techmologies are used to indicate actions (I) for
    LSPs and/or packets and to transfer data needed for these actions
    (AD).

    The document describes a common set of protocol functions and
    information elements - the MPLS Indicartor and Ancillary Data -
    supporting additional operational models and capabilities of MPLS
    netwroks that support these functions.  Some of these functions are
    defined in existing MPLS specifications, while others require
    extensions to existing specifications to meet the requirements in the
    MIAD requirement specification.

    This document is the result of work started in MPLS Open Desgign
    Team, with participation by the MPLS, PALS and DETNET working groups.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-andersson-mpls-miad-fwk/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-andersson-mpls-miad-fwk-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-andersson-mpls-miad-fwk-01

Internet-Drafts are also available by rsync at 
rsync.ietf.org::internet-drafts

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Haoyu Song <[email-masked]>
Date: Fri, 4 Mar 2022 17:55:32 +0000

Hi Loa,

One suggestion: E2E may also be renamed as EO (Edges Only) to remove ambiguity. 

Best regards,
Haoyu

-----Original Message-----
From: mpls <[email-masked]> On Behalf Of Loa Andersson
Sent: Thursday, March 3, 2022 10:06 PM
To: [email-masked]; [email-masked]; DetNet WG <[email-masked]>
Subject: [mpls] Fwd: I-D Action: draft-andersson-mpls-miad-fwk-01.txt

Working Groups,

In its current version the document is posted to attract review and comments. Please read and send nits to the authors and technical comments to the mpls mailing list.

Take a careful look at section 3 and 8, where we started to fill on some content.

/Loa

-------- Forwarded Message --------
Subject: I-D Action: draft-andersson-mpls-miad-fwk-01.txt
Date: Thu, 03 Mar 2022 19:49:50 -0800
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

Abstract:

The IETF datatracker status page for this draft is:
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-andersson-mpls-miad-fwk%2F&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C854d6cb869644049053208d9fda56ccb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637819709269354452%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=jDfPnFmeYTqTBqwQwQlBBE7NGwXjA0ShIcf3Uf3qMns%3D&amp;reserved=0

There is also an htmlized version available at:
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-andersson-mpls-miad-fwk-01&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C854d6cb869644049053208d9fda56ccb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637819709269354452%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=fZkAG9af34KVswpGTWiFVZTjsLbdBPT6DON2XSV0Ja8%3D&amp;reserved=0

A diff from the previous version is available at:
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-andersson-mpls-miad-fwk-01&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C854d6cb869644049053208d9fda56ccb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637819709269354452%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=XD2KLCuNb6RiPbYwzc3TboiO%2FBNTz6eepapSF4xUv5c%3D&amp;reserved=0

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fi-d-announce&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C854d6cb869644049053208d9fda56ccb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637819709269354452%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=VW3v1vZTBCmfAOPic5vzKK%2Bqr%2Bv5EVHqRqWSctqP1GM%3D&amp;reserved=0
Internet-Draft directories: https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.ietf.org%2Fshadow.html&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C854d6cb869644049053208d9fda56ccb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637819709269354452%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=PTRCC0Z44hvmpOgltvSmQ%2BIC6mCrf5MRFr6UIEvkdOQ%3D&amp;reserved=0
or https://nam11.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org%2Fietf%2F1shadow-sites.txt&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C854d6cb869644049053208d9fda56ccb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637819709269354452%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=D79H%2BQB49X7QlJfRITXKegsXzxnPPFSMqx2fugAECMc%3D&amp;reserved=0

_______________________________________________
mpls mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fmpls&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C854d6cb869644049053208d9fda56ccb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637819709269354452%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=kAlnOFAAnz1AaJGS1NKuRf1glgutEThtovhnvBcMOmU%3D&amp;reserved=0