Subject: Re: [proto-team] Re: Russ's Discuss on the doc shepherding draft

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 22 Nov 2006 00:53:54 +0100

Hi Allison,

on 2006-11-22 00:37 Allison Mankin said the following:
> Hi, Henrik,
> 
> Here's something I also suggested in a side message to Brian.
> 
>   - txt for some users
> 
>   - an html presentation for other users
> 
>   - a form for still other users.  The output of this form would
>     be the Write-Up as txt email to the ADs and the WG Chairs.
>     If the only mandatory input to the form was the document
>     string, the ADs/Chairs email addresses could be derived from
>     parsing the WG.

Right, good point.

> It would be easy enough to display a small link representing each
> choice of format.

Yes, agreed.

> I thought (similar to what you say) it's do-able to generate all 
> the formats from the content in one form updated by the maintainer(s).
> I'd start with xml because I'm getting used to it :)

Right, understood.  Although I've personally backed off from the idea
of using XML as an *internal* format after getting somewhat used to it
in that capacity - if you don't benefit a lot from the self-documenting
generic format that XML (ideally) provides, it's really a much heavier
thing to parse and extract information from than a well-chosen text format.

Best,

	Henrik

_______________________________________________
proto-team mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/proto-team

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 22 Nov 2006 10:06:00 +0100

OK, here's what I propose to get us started, so that we
can stay flexible:

http://www.ietf.org/IESG/content/Doc-Writeup.html

is now an elementary HTML file with the raw text
(or will be, as soon as the directory synchronizes; the
preview is http://utgard.ietf.org/iesgcontent/Doc-Writeup.html).
If we want to post multiple versions later, we can
replace it with an index page.

This should be a stable URL.

    Brian

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 22 Nov 2006 11:05:01 +0100

Hi Brian,

> This should be a stable URL.

Yup.  Works for me.

	Henrik