Subject: [proto-team] Fwd: COMMENT: draft-ietf-proto-wgchair-doc-shepherding

From: Lars Eggert <[email-masked]>
Date: Tue, 14 Nov 2006 13:46:49 +0100

Begin forwarded message:

> From: Ted Hardie <[email-masked]>
> Date: November 14, 2006 12:57:44 AM GMT+01:00
> To: [email-masked]
> Cc: [email-masked], [email-masked], [email-masked]
> Subject: COMMENT: draft-ietf-proto-wgchair-doc-shepherding
>
> Comment:
> Nit:
>
> This parenthetical expression is not closed:
>
> (because it was created by the "PROcess
>    and TOols" or PROTO [PROTO] team,
>
> The document consistently says that the document
> shepherd should be a single person (see section 3.
> especially).  I have personally run PROTO with both
> working group chairs taking joint responsibility.  I
> think it works.  Softening the language on that to
> allow WG chairs to work in double harness would
> be valuable, in my opinion.
>
> Section 3.1 adds this section to the common write-up:
>
> Personnel
>              Who is the Document Shepherd for this document?  Who  
> is the
>              Responsible Area Director?
>
> above that, the document says:
>
>  A final sentence of the Document Announcement Write-Up, simply placed
>    as a line at the end of the "Document Quality" section, can  
> state the
>    names of the Document Shepherd and the Responsible Area Director,
>    because the announcement will not otherwise acknowledge them.  The
>    Document Shepherd SHOULD add this information and the Responsible
>    Area Director SHOULD add it if it is not already there.
>
> That seems to indicate that the same information goes in the  
> Document quality
> section, rather than in its own heading.  Resolving that seems to  
> me useful.
>
> On IANA actions, the document says:
>
>    In summary, the task of shepherding the IANA actions is overlooked
>    but is as important to coordinate and manage as all the other
>    document reviews the Document Shepherd has managed.  As with those,
>    the Document Shepherd contributes greatly to quality and timeliness
>    of the document by effective and responsive shepherding of the IANA
>    requests.
>
> Does this mean to say "is often overlooked"?
>
> In Section 6, the document says:
>
> 1.  Cases, where the Document Shepherd is the primary author or
>        editor of a large percentage of the documents produced by the
>        working group.
> 2.  Cases, where the Responsible Area Director expects communication
>        difficulties with the Document Shepherd (either due to
>        experience, strong views stated by the Document Shepherd, or
>        other issues).
>
>    3.  Cases, where the working group itself is either very old,  
> losing
>        energy, or winding down, i.e., cases, where it would not be
>        productive to initiate new processes or procedures.
>
> The syntax of these is hard to parse. I think the last of them applies
> only to working groups that pre-date PROTO (it would not introduce
> a new procedure to tired WGs that post-date PROTO).  As something
> that is either already dated or soon will be, should it be struck?
>
> Frankly, I would recommend cutting that whole section, and replacing
> it with "When the responsible area director or proposed PROTO shepherd
> feel that the process is not appropriate, the responsible area  
> director
> may server as document shepherd, as she or he does for non-WG
> documents."
>
>

Lars
-- 
Lars Eggert                                     NEC Network Laboratories

_______________________________________________
proto-team mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/proto-team

---

From: Lars Eggert <[email-masked]>
Date: Tue, 14 Nov 2006 13:48:26 +0100

Begin forwarded message:

> From: Henrik Levkowetz <[email-masked]>
> Date: November 14, 2006 3:52:20 AM GMT+01:00
> To: Ted Hardie <[email-masked]>
> Cc: [email-masked], [email-masked], [email-masked]
> Subject: Re: COMMENT: draft-ietf-proto-wgchair-doc-shepherding
>
> Hi,
>
> (Lars Eggert is the current editor of this document, but I'm not  
> adding
> an explicit Cc: as I assume he sees this on the [email-masked] list...)
>
> My responses inline.
>
> on 2006-11-14 00:57 Ted Hardie said the following:
>> Comment:
>> Nit:
>>
> Ack.
> Works for me.
> Umm.  I'm not sure if you propose to remove the duplication, or if you
> seek a clearer statement of the fact that if the optional  
> acknowledgement
> is added, it is indeed duplicating the previous mandatory personnel
> information?  I guess either would be fine with me.
>
> (The best would maybe to have the information explicitly only once  
> under
> "Personnel" and have it automatically added to the announcement as  
> part
> of automated processing, if such exists.)
>
> I believe so.  s/is overlooked/is often overlooked/ seems indicated.
>
> Makes sense, yes.
> I think this would be ok, but note that while the enumerated cases are
> probably very real to an AD, this may not be the case for a newly
> appointed chair, and it is easier to read a document which provides a
> clear connection to real cases, rather than only the abstract  
> principles
> which would cover them.  I think there is some merit in keeping  
> Section
> 6 except for case 3, and try to re-word cases 1 and 2 to be more
> easily parsed.
>
> I don't feel strongly about this though, so if the other authors would
> like to adjust the text according to the proposal, I'm ok with that.
>
>
> Regards,
>
> 	Henrik
>
>
>

Lars

---

From: Lars Eggert <[email-masked]>
Date: Tue, 14 Nov 2006 13:48:41 +0100

Begin forwarded message:

> Date: November 14, 2006 5:12:07 AM GMT+01:00
> To: Henrik Levkowetz <[email-masked]>
> At 3:52 AM +0100 11/14/06, Henrik Levkowetz wrote:
>>
> I guess my real motive here is to find out whether we are asking
> the secretariat to add a Personnel section, or asking the ADs to
> include the information in the Document quality section.  I am
> fine either way.  I do think it would be easier to set out which
> is expected.  If folks want to go with a mandatory Personnel,
> as you suggest below, in other words, that's fine by me.
>
>
>>
> I also did not feel strongly about it; none of my comments is meant
> to be blocking.  If you prefer to drop 3 and reword 1 &2, that's fine
> by me.  Doing nothing is also okay, if the authors feel it is valuable
> to retain even section 3.
> 			
> Thanks for your quick response,
> 				regards,
> 					Ted
>

Lars

---

From: Lars Eggert <[email-masked]>
Date: Tue, 14 Nov 2006 13:49:12 +0100

Begin forwarded message:

> From: Brian E Carpenter <[email-masked]>
> Date: November 14, 2006 8:39:42 AM GMT+01:00
> Cc: [email-masked], [email-masked], Henrik Levkowetz  
> <[email-masked]>, [email-masked]
> Since there's already a pretty complex RFC Editor note,
> I may end up asking for one more respin of the draft,
> even if there are no Discusses. All Ted's points are worthy
> of attention.
>
>     Brian
>
> Ted Hardie wrote:
>>>> section, rather than in its own heading.  Resolving that seems  
>>>> to me useful.
>>>

Lars

---

From: Allison Mankin <[email-masked]>
Date: Tue, 14 Nov 2006 06:52:40 -0800

------- Forwarded Message

To: Ted Hardie <[email-masked]>
cc: Henrik Levkowetz <[email-masked]>, [email-masked],
    [email-masked], [email-masked]
Subject: Re: COMMENT: draft-ietf-proto-wgchair-doc-shepherding 
Date: Tue, 14 Nov 2006 06:15:33 -0800
From: Allison Mankin <[email-masked]>

Hi, Ted,

I myself would like the Secretariat to add a Personnel section to
the ballot.  I would like this to be there to cue the author
of the writeup to include the names (and also to add the
name of any appointed Expert, because this is also often
left out of the announcement).

It would be good for the IESG to decide if this is acceptable
and let the Secretariat know if that's the decision.  If it
is not desired, then I'll take it out at re-spin time.

I should remind everyone that there are several chunky-ish
Notes to the RFC Editor - we didn't go the revision route before
giving you the doc for IESG Eval.

Allison

------- End of Forwarded Message

---

From: Lars Eggert <[email-masked]>
Date: Wed, 15 Nov 2006 08:35:47 +0100

Begin forwarded message:

> From: Dan Romascanu <[email-masked]>
> Date: November 15, 2006 4:10:19 AM GMT+01:00
> To: [email-masked]
> 1. Section 3
> During IESG evaluation, following up on all IESG feedback  
> ("DISCUSS" and "COMMENT" items) related to the shepherded document,  
> as described in Section 3.3.
>
> Any reason not to include "ABSTAIN" contents as feedback?
>
> 2. Is there any reference for who is the Responsible Area Director?  
> Is this the same as WG Area Advisor?
>
> 3. In 2e I am slightly confused by the use of the construct  
> 'strongly RECOMMENDED'. I believe that we should not allow usage of  
> intermediate constructs between 2119 keywords and would recommend  
> to pick one of RECOMMENDED (with no strength marking) or MUST.
>
> 4. Section 6 - 'If the document shepherding process is not used,  
> the Responsible Area Director acts as Document Shepherd, just as he  
> or she did in the past.' - better say '... just as per the existing  
> procedures of shepherding by Area Directors.' (he or she may not  
> have been an AD in the past)
>
>

Lars