Subject: Network Interworking Only in PWE3 (was: RE: Proposed chang es to draft kamapabhava-01)

From: Sasha Vainshtein <[email-masked]>
Date: Thu, 25 Apr 2002 15:06:52 +0200

Danny, Neil and all,
Please see just one simple question inline below.

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, April 25, 2002 1:15 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: RE: [PWE3] Proposed changes to draft kamapabhava-01
> 
> 
... snipped ...
> One further more general point on all this stuff:
> There are essentially 2 extremes of interworking various L2 protocols:
> -	true client/server layer relationhip, ie the client layer PDU is
> fully/transparently encapsulated within the server layer PDU payload 
> -	true peer-layer relationship, ie use protocol 
> conversion to pass PDU
> payloads across transparently but map PDU O/H functions (as a 
> best fit)
> 
> The former has no impact on the trail termination points of 
> the client layer
> network, though the server layer trail termination points 
> must start/end at
> the IWF. Whereas in the peer-layer case we have 3 peer trails 
> in the case of
> X<=>MPLS<=>X....one at each end for layer network X 
> (say ATM,  FR trails) and
> one in the middle for the MPLS LSP.
> 
> Why is this important?
> 
> -	Well, in the client/server case the client layer 
> networks exists for all future practical time, ie this architecture does
not 
> permit migration of end systems to MPLS nor does it allow X<=>MPLS<=>Y 
> interworking...where X and Y are different L2 technologies.  In the
peer-layer case 
> however, this does allow X<=>MPLS<=>Y, and even MPLS<=>XorYorZ.....
>
Isn't the PWE3 work explicitly limited (by its charter) to the case of 
X<===>PSN<===>X (where PSN may be IP or MPLS)
(or what the PWE3 FW document calls "network interworking")?
This has been my default assumption until now... and I do not remember
the opposite ever being discussed on the list or at the face-to-face
WG meetings.
IMHO a clear-cut answer to this question would be beneficial for the 
discussion.
... snipped ...
> 
> regards, Neil  
> 
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: [email-masked]
Date: Thu, 25 Apr 2002 13:59:27 +0100

Fair question Sasha.  But if you actually look at the ATMoverMPLS stuff its
actually not black & white like this at all.

If we are sending a true ATM level trail (at either VP or VC) across the
server MPLS fabric then I agree its true client/server (or 'network I/W' if
you prefer).

If however we are stripping the ATM header at the IWF and essentially only
coveying the AAL5  transparently (but even this has BW sqeezing variants)
the the ATM VP(VC) trails are architecurally peers of the MPLS trail, whilst
the AAL5 trail is a client of both.  It's not quite as clean-cut as this
however, and has a more hybrid behaviour;  this can be seen clearly when
considering how to handle ATM trail OAM cells.  One may have to suspend the
AAL5 trail data and insert the ATM layer OAM cell (though exact behaviour,
eg OAM cell positioning, depends on which particular AAL mode is chosen).
Put another way, the behaviour flips from a hybrid peer-I/W case to true
client/server when an OAM cell has to be conveyed.

The defect handling behaviour required is quite different between cell mode
(client/server) and various AAL5 modes (hybrid).

So whether its in the charter or not seems a moot point to me.....you have
to get the right behaviour for whatever it is you are specifying.  Its not
clear to me all the issues have been considered.  The defect handling point
I have raised just exposes this.

regards, Neil

> From: Sasha Vainshtein [mailto:[email-masked]]
> Sent: 25 April 2002 14:07
> To: Danny McPherson (E-mail); [email-masked]'
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Network Interworking Only in PWE3 (was: RE: [PWE3] Proposed
> chang es to draft kamapabhava-01)
> 
> 
> Danny, Neil and all,

---

From: Giles Heron <[email-masked]>
Date: 25 Apr 2002 14:04:56 +0000

On Thu, 2002-04-25 at 13:06, Sasha Vainshtein wrote:
[snip]
> IMHO a clear-cut answer to this question would be beneficial for the 

I think yes, the PWE3 assumption is that you have the same L2 at either
side.

But of course this doesn't preclude the use of an IWF at either side (so
e.g. ATM<===>FR<===>PW<===>FR is possible).

And of course there is a draft or two in PPVPN on X<===>PW<===>Y for the
case where X and Y both carry IP.

Giles

-- 
=================================================================
Giles Heron    Principal Network Architect    PacketExchange Ltd.
ph: +44 7880 506185              "if you build it they will yawn"
=================================================================