Subject: IETF-54 PLD questions

From: Stewart Bryant <[email-masked]>
Date: Mon, 12 Aug 2002 20:06:40 +0100

At IETF-54 I asked a few questions, which need wider review
before we can close on the protocol layering document (which
it has been agreed will merge with the framework doc to become
the arch doc).

Following on from the meeting Danny suggested posting the 
questions to the list with the default (no response) actions.

Here are the questions again. 

1) Should the PSN stack diagrams Fig10 and Fig 11 be retained 
in the text, or should they be relegated to appendixes 
(follows from question to list)?

I will assume that no response means retain the diagrams.

2) Is the MPLS CW sufficiently generic for this text (it hails 
from Martini, but does not specify bit allocations or sizes)?

I will assume that no response means that it is sufficiently 
generic.

If you think that it is not sufficiently generic, please supply
alternative text.

3) Do we need to retain GRE and IPSEC as tunnel types?
Is anyone using/planning to use them for PW? 
Can they be dropped from the PW design? (Note that L2TP 
and GRE/MPLS could run over IPSec with no impact on the PW)

At the meeting someone said that they were planning to run
PW over GRE. Please could that person confirm that their
stack is IP/GRE/PWE3 and not IP/GRE/MPLS/PWE3 as that
is already covered in the MPLS text. Can I also remind
that person that they agreed to provide me with some text
for the PWE3 arch doc. 

I will assume that no response means that no one is planning
to implement IP/GRE/PWE3 and will delete that stack from the 
text.

Also I have not heard that anyone is implementing PWE3
over IPSec. I will again assume that no response means that
it is safe to delete IPSec from the stack. Please accompany
any response with any necessary text changes.

4) I requested that the TDM and cell specialists look at
those sections of the PLD and give me some feedback. Please
can I repeat that request.

5) We agree that there would be a single terminology dictionary
that all documents would reference. I asked at the meeting if this
should be within the arch doc or freestanding. Scott suggested
that it should be freestanding. Before I split this out
can I just do a consensus check.

I will assume that no response means leave it in the doc.

If we descide to take it out, I suggest using the dictionary from 
arch draft (which is a combination of framework and PLD) as 
the starting point and the PLD/arch authors will get this out 
by early September.

Regards

Stewart

---

From: Shahram Davari <[email-masked]>
Date: Mon, 12 Aug 2002 13:06:34 -0700

Hi,

Please find my comments in-line.

-Shahram

> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]]
> Sent: Monday, August 12, 2002 3:07 PM
> To: [email-masked]
> Subject: [PWE3] IETF-54 PLD questions
> 
> 
> 

Figure 10 seems to be fairly general, so it could stay. Figure 11
is tied to some specific solution, which should move to the appendix.

> from Martini, but does not specify bit allocations or sizes)?

No it is not generic. So I think it is better to make it generic, such
as:

          +---------------------+
          |      Payload        |
          /=====================\
          H Payload Convergence H-----------------+
          H---------------------H                 |
          H       Timing        H                 |
          H---------------------H                 |
          H     Sequencing      H-----------------|
          \=====================/                 |                  
          |  PW Demultiplexer   |---+             |                  
          +---------------------+   |             |                  
          |  PSN Convergence    |-----------------|
          +---------------------+   |             |      
          |        PSN          |-+ |             v       
          +---------------------+ | |  +--------------------------------+
          |    MAC/Data-link    | | |  | Flags, Frag, Len, Seq #, etc   |
          +---------------------+ | |  +--------------------------------+
          |       Physical      | | +->|          Inner Label           |
          +---------------------+ |    +--------------------------------+
                                  +--->| Outer Label or MPLS-in-IP encap|
                                       +--------------------------------+

> to implement IP/GRE/PWE3 and will delete that stack from the 

What if some one in future does want to implement it?

> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: Jeremy Brayley <[email-masked]>
Date: Mon, 12 Aug 2002 17:02:03 -0400

Stewart,

> to implement IP/GRE/PWE3 and will delete that stack from the 

I was one of the people (out of 3 I believe) that indicated interest in PWE3
over GRE. 

However, the IP/GRE/MPLS/PWE3 stack is sufficient for my application.  So
deleting IP/GRE/PWE3 is OK by me.

Thanks,

Jeremy

---

From: Shahram Davari <[email-masked]>
Date: Tue, 13 Aug 2002 08:59:31 -0700

Stewart,

Why isn't UDP mentioned as a possible Demuxing layer for PWE3 over IP PSN?
You could use the source port# for demuxing.

-Shahram

---

From: Sasha Vainshtein <[email-masked]>
Date: Tue, 13 Aug 2002 19:00:29 +0200

Shahram and all,
IMHO if you use UDP, then the *destination* port
is the standard option for demuxing (which happens
at *egress*). 

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> From: Shahram Davari [mailto:[email-masked]]
> Sent: Tuesday, August 13, 2002 6:00 PM
> To: [email-masked]'; [email-masked]
> Subject: RE: [PWE3] IETF-54 PLD questions
> 
> 
> Stewart,
>

---

From: Shahram Davari <[email-masked]>
Date: Tue, 13 Aug 2002 09:12:33 -0700

Sasha,

I meant demuxing between PWs not demuxing between protocols.
The dest port #s are IANA assigned.

-Shahram

> From: Sasha Vainshtein [mailto:[email-masked]]
> Sent: Tuesday, August 13, 2002 1:00 PM
> To: Shahram Davari; [email-masked]'; [email-masked]

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 13 Aug 2002 17:59:16 +0100

> You could use the source port# for demuxing.

The IETF standard method of carrying level 2 payloads over UDP is
IP/UDP/L2TP, so UDP is there by default.

What advantages do you see for IP/UDP/PWE3 vis a vis IP/L2TPv3/PWE3?

Stewart

---

From: Shahram Davari <[email-masked]>
Date: Tue, 13 Aug 2002 10:25:48 -0700

Stewart,

> What advantages do you see for IP/UDP/PWE3 vis a vis IP/L2TPv3/PWE3?

UDP has CRC, and is available on all routers.

-Shahram

---

From: "tom k. johnson" <[email-masked]>
Date: Wed, 14 Aug 2002 22:31:36 -0400

> deleting IP/GRE/PWE3 is OK by me.

I thought there was some discussion of resurrecting Tom W's draft for carrying MPLS directly over IP.  Is that actually going anywhere?

If so, couldn't you cut down IP/GRE/MPLS/PWE3 to IP/MPLS/PWE3 (?)

Thanks!

-Tom

---

From: "W. Mark Townsley" <[email-masked]>
Date: Thu, 15 Aug 2002 10:56:57 +0200

> UDP has CRC, and is available on all routers.

...and causing many of them to take a drastically slower path for processing.

---

From: "W. Mark Townsley" <[email-masked]>
Date: Thu, 15 Aug 2002 11:14:19 +0200

UDP is certainly possible, but suffers from:

- A relatively small number of demux values (compared to 2^20 or 2^32 for MPLS 
and L2TP)

- If all protocols that required demuxing streams used UDP, then would this 
scale well on a multiprotocol/multiservice box?

- Forces the PW demuxing to be on the same path as protocol demuxing. This might 
be better for PW lookup, but potentially slows down other UDP paths in the process.

- You are hitting well-worn UDP protocol demuxing code with new PW lookup code, 
adding new code in this area and potentially new requirements for a larger, 
faster, lookup table in the process. A bug in PW lookup could more likely cause 
a bug in the existing UDP protocol service demux lookup which could be 
detrimental to the overall operation of a router.

- Manual configuration of UDP ports required on either end of the tunnel (unless 
you adapt or create a standard mechanism for this).

- Explosion of Port address translation tables when operated through a NAT/PAT

- Operating across a large number of UDP ports (unless operated within a 
standardized range) is less deterministic for traffic analysis, common IP 
filters, IPsec SA negotiation, etc.

- Mark

---

From: "tom k. johnson" <[email-masked]>
Date: Thu, 15 Aug 2002 14:24:14 -0400

Lloyd.

Great, I didn't see that one go by.

Jeremy - I'm a bit behind on my reading, so please excuse me if this is dumb question... 
Are you considering that IP/MPLS/PWE3 encapsulation as well (or instead of) the IP/GRE/MPLS/PWE3 encapsulation?

Thanks.

-Tom

> From: Lloyd Wood [mailto:[email-masked]]
> Sent: Thursday, August 15, 2002 7:10 AM
> To: tom k. johnson
> Cc: Jeremy Brayley; [email-masked]; [email-masked]
> On Wed, 14 Aug 2002, tom k. johnson wrote:
> 
> > I thought there was some discussion of resurrecting Tom W's 
> draft for carrying MPLS directly over IP.  Is that actually 
> going anywhere?
> >
> You need to read ietf-announce.
> 
> Below.
> 
> L.
> 
> <http://www.ee.surrey.ac.uk/Personal/L.Wood/><[email-masked]>
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> 
> 
>         Title           : Encapsulating MPLS in IP or GRE
>         Author(s)       : T. Worster, Y. Rekhter, E. Rosen
>         Filename        : draft-rosen-mpls-in-ip-or-gre-00.txt
>         Pages           : 7
>         Date            : 13-Aug-02
> 
> In various applications of MPLS, label stacks with multiple entries
> are used.  In some cases, it is possible to replace the top label of
> the stack with an IP-based encapsulation, thereby enabling the
> application to run over networks which do not have MPLS enabled in
> their core routers.  This draft specifies two IP-based
> encapsulations, MPLS-in-IP, and MPLS-in-GRE.  Each of these is
> applicable in some circumstances.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-rosen-mpls-in-ip-or-
gre-00.txt

---

From: Jeremy Brayley <[email-masked]>
Date: Thu, 15 Aug 2002 15:14:28 -0400

Tom,

> From: tom k. johnson [mailto:[email-masked]]
> Sent: Thursday, August 15, 2002 2:24 PM
> To: Lloyd Wood
> Are you considering that IP/MPLS/PWE3 encapsulation as well 
> (or instead of) the IP/GRE/MPLS/PWE3 encapsulation?

I like the GRE layer in here because it has a protocol type field.  So I can
use the same GRE tunnel to carry MPLS and IP.  A GRE tunnel can appear as an
IP interface on a router.

I have not yet considered doing IP/MPLS/PWE3.

Thanks,

Jeremy

---

From: tom worster <[email-masked]>
Date: Thu, 15 Aug 2002 15:45:47 -0400

on 8/15/02 7:09 AM, "Lloyd Wood" <[email-masked]> wrote:

>> I thought there was some discussion of resurrecting Tom W's draft for
>> carrying MPLS directly over IP.  Is that actually going anywhere?
>> 

i would like to see that draft proceed on the standards track as a pwe3 wg
draft. my impression is that eric and yakov feel the same way.

c u
fsb

---

From: "Matt Squire" <[email-masked]>
Date: Thu, 15 Aug 2002 16:49:57 -0400

> draft. my impression is that eric and yakov feel the same way.

Here's another vote for moving that draft to the standards track.  Its short, sweet, and makes sense.  

- Matt