Subject: JtrBfrUnderruns in CEP MIB

From: "Ron Cohen" <[email-masked]>
Date: Thu, 12 Sep 2002 17:06:51 +0200

Hi,

According to the MIB, the jitter buffer underrun counter reads:

pwVcCepPerfCurrentJtrBfrUnderruns OBJECT-TYPE 
      SYNTAX        Counter32 
      MAX-ACCESS    read-only 
      STATUS        current 
      DESCRIPTION 
          "Number of times a packet needed to be played 
           out and the jitter buffer was empty." 

It is not clear to me what is the benefit in this counter. Why is it
important to count the packets that were dropped when the jitter buffer
is empty? We already have a counter for missing packets - which count
all missing packets. Eventually, if too many packets will be missing the
buffer will become empty. Why count these missing packets additionally
in a different counter?

Thanks
Ron

Ron Cohen
Lycium Networks
Tel: +972-9-9717794
Mobile: +972-55-245104
Fax: +972-9-9717798
email: [email-masked]
home email: [email-masked]
9 Hamanofim st., P.O.Box 12256
Herzliya 46733 Israel

---

From: "Dave Danenberg" <[email-masked]>
Date: Thu, 12 Sep 2002 11:35:58 -0400

Ron,

There is a difference between missing packets and underruns. It could be that the packet is not missing. It could be that a packet (or several packets) is too late based on the size/buildout of the jitter buffer. In other words, after a long gap between consecutive packets, the jitter buffer may become empty. So a few "fill" packets need to be played out. Later, when the good/consecutive packets come in, they will be dropped (naturally) as the play out mechanism knows those sequence number were already played out (though as a "fill" packets). 

(Btw, late packets will also be counted as "out of range". However, "out of range" may include other types of jitter buffer errors, so the "underrun" is still needed.)

So because "underrun" and "missing" are different, we think both are useful. The underrun count helps the operator when a jitter buffer is configured to be too small - or the engineered tunnel is not meeting the "packet delay variation" aspect of an SLA. The missing packet count helps the operator if the engineered tunnel is not meeting the "error rate" aspect of an SLA.

-Dave

> -----Original Message-----
> From: Ron Cohen [mailto:[email-masked]]
> Sent: Thursday, September 12, 2002 11:07 AM
> To: PWE3 (IETF); Dave Danenberg; David Zelig
> Subject: JtrBfrUnderruns in CEP MIB
> 
> Hi,
>