Subject: RE: (no subject) TDM implementation

From: [email-masked] (Amnon Ilan)
Date: Thu, 12 Sep 2002 11:06:20 +0200

Tim,

AFAIK the most common link is a voice connection (PBX-PBX or PBX-PSTN).
In such a connection the required solution is AAL2 (mainly in order to
support
silence-suppression and per-voice-channel muxing/switching).
Processing using TDMoIP takes (TDM->PSN):
       TDM + AAL2 + TDMoIP
Processing using CESoPSN is problematic here:
       TDM + AAL2 + ...
How do you go from AAL1/2 packets to CESoPSN (it can only take TDM), so you
need:
       TDM + AAL2 + restructured-TDM + CESoPSN

These extra steps may also add delay, since you are actually sampling the
TDM twice.

Amnon.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Wed 11 September 2002 16:46
To: Shahram Davari
Cc: [email-masked]; [email-masked]; Sasha Vainshtein
Subject: RE: [PWE3] (no subject) TDM implementation

Shahram,

> Depending on the network on both sides of the PSN, there are
> 6 possible cases:
>
> TDM   ---- TDM
> SONET ---- SONET
> ATM   ---- ATM
> TDM   ---- SONET
> TDM   ---- ATM
> ATM   ---- SONET
>
> Assume if the CESoPSN is selected rather than TDMoIP.
> In that case the functions that are needed on each side are:
>
>          (CESoPSN)   TDM ---- TDM   (CESoPSN)
>         (SONET-VT) SONET ---- SONET (SONET-VT)
> (AAL1/2 + CESoPSN)   ATM ---- ATM   (CESoPSN + AAL1/2)
>          (CESoPSN)   TDM ---- SONET (CESoPSN + SONET)
>          (CESoPSN)   TDM ---- ATM   (CESoPSN + AAL1/2)
> (AAL1/2 + CESoSPN)   ATM ---- SONET (CESoPSN + SONET)
>
> As you can see (in the 3rd, 4th, 5th and 6th case) you need a total
> of 6 interworking functions.
>
> Now assume the TDMoIP (AAL1/2) is selected rather than CESoPSN.
> In that case the functions that are needed on each side are:
>
>        (TDMoIP)   TDM ---- TDM   (TDMoIP)
>      (SONET-VT) SONET ---- SONET (SONET-VT)
>        (TDMoIP)   ATM ---- ATM   (TDMoIP)
>        (TDMoIP)   TDM ---- SONET (TDMoIP + SONET)
>        (TDMoIP)   TDM ---- ATM   (TDMoIP)
>        (TDMoIP)   ATM ---- SONET (TDMoIP + SONET)
>
> As you can see (in the 4th and 6th case) you need a total of
> 2 interworking functions.
>
> Does that answer your question?

To be honest, no. TDMoIP is not a single interworking function, it is a
double. TDM->AAL1/2, followed by AAL1/2->TDMoIP. Hence I would restate
your table as follows:

(AAL1/2 + TDMoIP)   TDM ---- TDM   (TDMoIP + AAL1/2)
       (SONET-VT) SONET ---- SONET (SONET-VT)
         (TDMoIP)   ATM ---- ATM   (TDMoIP)
(AAL1/2 + TDMoIP)   TDM ---- SONET (TDMoIP + AAL1/2 + SONET)
(AAL1/2 + TDMoIP)   TDM ---- ATM   (TDMoIP)
         (TDMoIP)   ATM ---- SONET (TDMoIP + AAL1/2 + SONET)

This gives 8 interworking functions, including at least two multiple stage
conversions (TDMoIP into AAL1/2 into TDM into SONET).

The nice part about CESoPSN is that if you don't want to handoff into ATM,
you don't need to pay for the ATM function. If you don't want to handoff
into SONET, you don't need to pay for the SONET function.
If you do, either of these handoffs can be achieved with truly
off-the-shelf existing offerings, connected as an NSP function in the PE.
And nobody needs to do a triple conversion, since there is at most a
single intermediate format.

Regards,
Tim

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Bob Barrett" <[email-masked]>
Date: Thu, 12 Sep 2002 13:27:08 +0100

Tim

I am 100% in agreement with your last paragraph.

This is pseudo wire after all, and therefore imho functions for optimising
things at sub-wire level e.g. silence suppression etc., and payload hand-off
mappings / NSP functions are out of scope within PWE3.

It is self evident that the standards for the protocol conversions /
mappings required aleady exist in other documents, so it is not necessary to
include them other than by reference in the PWE3 work (within an informative
/ tutorial annex regarding PWE3 inter-working with NSP functions).

That still leaves us with at least two choices for PWE3. I don't see a
problem with having an SP centric draft (Pate) and an Enterprise centric
draft.

Best regards

Bob

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: 11 September 2002 15:46
To: Shahram Davari
Cc: [email-masked]; [email-masked]; Sasha Vainshtein
Subject: RE: [PWE3] (no subject) TDM implementation

Shahram,

Regards,
Tim