Subject: Re: Definition of PSN

From: "W. Mark Townsley" <[email-masked]>
Date: Tue, 18 Jun 2002 13:33:17 +0200

Sasha Vainshtein wrote:
> 
> Mark and Walter,
> IMHO:
> 1. An ATM network can be hardly considered a PSN because
>    it switches fixed-size cells (and hence requires say,
>    AAL5 to carry variable-size PDUs).

Right. I was assuming that. (As an aside, in the DSL world L2TP over AAL5 is
often erroneously referred to as "L2TP over ATM.")

> 2. A FR network cannot meet one of the important PWE3 goals,
>    namely leaving the state of core devices (routers or switches)
>    intact with creation/deletion of new PWs betwwen edge devices
>    (an ATM network can do that).

Assuming your FR network already gives reachability to all PEs between which you
plan to establish PWs, simply run L2TP on top of the existing FR PE-PE circuit
(e.g. RFC3070). I don't see why this should affect P router state any more than
LDP and a second pair of MPLS labels over an existing MPLS PE-PE LSP would.

All this aside, again I will stress my own sincere desire and hope that we will
stick with IP and run that over FR, AAL5, etc. if need be. To me, removing a
couple of IP addresses and 20 bytes of header just doesn't seem like it is worth
the complexity of Yet Another PSN (but, if it were up to me alone, RFC3070
wouldn't exist either!).

- Mark

> 
> My 2 cents.
> With best regards,
>                                    Sasha Vainshtein
> email:     [email-masked] <mailto:[email-masked]>
> tel:       +972-3-7659993 (office)
>            +972-8-9254948 (res.)
>            +972-58-674833 (cell.)
> 
> 
> > -----Original Message-----
> > From: W. Mark Townsley [mailto:[email-masked]]
> > Sent: Monday, June 17, 2002 11:45 PM
> > To: Klausberger Walter
> > Cc: [email-masked]'
> > Subject: Re: [PWE3] Definition of PSN
> >
> >
> >
> >
> > > Klausberger Walter wrote:
> > >
> > > Hi everybody,
> > >
> > > I'm relatively new to this list, so my question may have
> > been answered already
> > > before. In PWE3 framework draft PSN is defined as IP or MPLS.
> > > Is this the focus of the working group, because I'm missing
> > other options like
> > > Frame Relay or ATM?
> >
> > Or IPv6?
> >
> > Theoretically, you can stick in any packet switched network
> > for your PSN in
> > PWE3. Practically, I don't think anyone is working on
> > anything other than MPLS
> > and IP right now. Once you have PWE3 over IP, you can always
> > run IP over FR and
> > ATM. Hopefully, this will be good enough and we won't need to
> > introduce
> > additional native PSN support.
> >
> > > PWE3 seems to me quite generic and it should not be a big
> > > problem to introduce other PSN(like) networks later, or am I wrong?
> > >
> > > regards
> > > - walter
> >
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> >

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 19 Jun 2002 15:02:47 +0100

The IETF is the design authority for IP and MPLS. It has
no responsibility for other network types.

The definition of PSN is therefore deliberately set to 
cover the IETF areas of responsibility, no more and no less.

Stewart