Subject: RE: Network Interworking Only in PWE3 (was: RE: Proposed c hang es to draft kamapabhava-01)

From: Sasha Vainshtein <[email-masked]>
Date: Thu, 25 Apr 2002 17:13:27 +0200

Giles and Neil,
Thank you for prompt responses
Please see some comments inline (in Giles' text).
With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> -----Original Message-----
> From: Giles Heron [mailto:[email-masked]]
> Sent: Thursday, April 25, 2002 4:05 PM
> To: Sasha Vainshtein
> Cc: Danny "McPherson (E-mail); [email-masked]'; 
> [email-masked]; [email-masked]; Andy 
> Malis; [email-masked]; [email-masked]; [email-masked]
> Subject: Re: Network Interworking Only in PWE3 (was: RE: 
> [PWE3] Proposed chang es to draft kamapabhava-01)
> 
> 
> On Thu, 2002-04-25 at 13:06, Sasha Vainshtein wrote:
> [snip]
> > > -	Well, in the client/server case the client layer 
> > > networks exists for all future practical time, ie this 
> architecture does
> > not 
> > > permit migration of end systems to MPLS nor does it allow 
> X<=>MPLS<=>Y 
> > > interworking...where X and Y are different L2 
> technologies.  In the
> > peer-layer case 
> > > however, this does allow X<=>MPLS<=>Y, and even 
> MPLS<=>XorYorZ.....
> > >
> > Isn't the PWE3 work explicitly limited (by its charter) to 
> the case of 
> > X<===>PSN<===>X (where PSN may be IP or MPLS)
> > (or what the PWE3 FW document calls "network interworking")?
> > This has been my default assumption until now... and I do 
> not remember
> > the opposite ever being discussed on the list or at the face-to-face
> > WG meetings.
> > IMHO a clear-cut answer to this question would be 
> beneficial for the 
> > discussion.
> >
> 
> I think yes, the PWE3 assumption is that you have the same L2 
> at either
> side.
> 
> But of course this doesn't preclude the use of an IWF at 
> either side (so
> e.g. ATM<===>FR<===>PW<===>FR is possible).
> 
Sure. But should the fact that you have FR over AAL5 over ATM 
at one end of the PW affect behavior of a FR-carrying PW in any way?
I would say not; and, luckily, none of the FR-related drafts does not
say anything else.

Not all the services are that lucky, though. I would say that many
problems with ATM AAL5 mentioned by Neil stem from its interpretation as 
inherently related to ATM instead  a (more or less generic) frame-carrying 
service. The latter approach would result in emulation that is far from
perfect
from the ATM point of view but, hopefully, very simple and sufficient for
lots of applications, while the former (the hybrid one) is (to my taste)
results in a lot of complications - and the simplest way to avoid them would
be to switch to a true Cell Relay (= AAL0) PW. 
>
> And of course there is a draft or two in PPVPN on 
> X<===>PW<===>Y for the
> case where X and Y both carry IP.
>
I can only say that one such draft (on ARP mediation) has been
explicitly rejected at the PPVPN WG meeting in MPLS because
the subject was declared "not in the charter". (Personally I think
that this is a very useful document provoding a nice solution of
a highly relevant problem, and I hope that the PPVPN WG will
reconsider). 
I do not have anything against "service interworking" or "peer-to-peer"
trail relationships. I just am not sure that the PWE3 WG is a
suitable place for these discussions and that service interworking
considerations are valid arguments in these discussions.
>
> Giles
> 
> > ... snipped ...
> > > 
> > > regards, Neil  
> > > 
> > > 
> > > 
> > > _______________________________________________
> > > pwe3 mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/pwe3
> > > 
> > 
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> > 
> -- 
> =================================================================
> Giles Heron    Principal Network Architect    PacketExchange Ltd.
> ph: +44 7880 506185              "if you build it they will yawn"
> =================================================================
>

---

From: Eric Rosen <[email-masked]>
Date: Thu, 25 Apr 2002 15:13:54 -0400

Luca> Yes,  I think that  draft [ARP  Mediation] did  not really  define any
Luca> protocols.  

It specified how to  modify the pw signaling to carry the  IP address of the
CE at the other end, and  specified how the results of that signaling impact
the  CE/PE interactions.   I think  this  counts as  "defining a  protocol",
though I'd agree with the other  correspondents that the proper venue for it
is PPVPN not PWE3.