Subject: question regarding draft-kamapabhava-fr-pwe3-01.txt

From: Akiva Sadovski <[email-masked]>
Date: Sun, 2 Jun 2002 15:27:56 +0200

Hi, pwe3,

In draft-kamapabhava-fr-pwe3-01:
  1. the FRoPW header (control word) contains F and B bits;
  2. the F-bit (FECN) definition is " FECN is copied as follows into the
FRFoPW header: If it was set to one in the incoming frame relay frame, it
must be copied unchanged in the FRoPW header. Otherwise if it was set to
zero, it may be set to zero or one, depending on the congestion state of the
PE device in the forward direction" (6.2.1)
  3. it is stated in B-bit definition that the processing is as for F-bit,
but ... it's applied in backward direction.
  4. now the question: what direction in PW is considered to be backward:
PSN-bound? CE-bound?
i'm sure this issue was extensively discussed on this mail list, so how can
i found any pointers ?

thanks,
   Akiva

---

From: Shahram Davari <[email-masked]>
Date: Sun, 2 Jun 2002 13:54:26 -0700

Backward here means P-> PE direction. The B-bit in the header of FRoPW in the PE->P direction is derived from F-bit in the FRoPW in the P->PE direction of the same connection. 

-Shahram

> -----Original Message-----
> From: Akiva Sadovski [mailto:[email-masked]]
> Sent: Sunday, June 02, 2002 9:28 AM
> To: [email-masked]
> Subject: [PWE3] question regarding draft-kamapabhava-fr-pwe3-01.txt
> 
> 
> Hi, pwe3,
> 
>   
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: Akiva Sadovski <[email-masked]>
Date: Mon, 3 Jun 2002 12:05:07 +0200

> From: Shahram Davari [mailto:[email-masked]]
> Sent: Sunday, June 02, 2002 10:54 PM
> To: 'Akiva Sadovski'; [email-masked]
> Subject: RE: [PWE3] question regarding 
> draft-kamapabhava-fr-pwe3-01.txt
> 
> 
> Backward here means P-> PE direction. The B-bit in the header 
> of FRoPW in the PE->P direction is derived from F-bit in the 
> FRoPW in the P->PE direction of the same connection. 
> 

   But it means that "backward" direction mentioned in the draft is actually
P->PE, isn't
it ? And is it possible to incorporate your explanation into the draft ?

Thanks,
   Akiva

---

From: "Claude Kawa" <[email-masked]>
Date: Tue, 18 Jun 2002 08:31:02 -0400

In frame relay the reference used to determine whether the direction of the
traffic is the forward or backward direction is the frame being forwarded.
The forward direction is the direction taken by the frame being forwarded. 

The backward direction is the direction opposite to the direction taken by a
frame being forwarded.

So if a frame is traveled from East to West, relative to this frame, the
forward direction  is the East-West direction and the backward direction is
the West-East direction.

We added these clarifications in the new FR/PWE3 draft to be available soon.

About the processing of the different frame relay control bits (F, B, C, D)
we copied almost  verbatim  the relevant text from ITU-T Recommendation
Q.922 on frame relay data transfer protocol to avoid any misalignment.

Claude Kawa

-----Original Message-----
From: Akiva Sadovski [mailto:[email-masked]]
Sent: Sunday, June 02, 2002 9:28 AM
To: [email-masked]
Subject: [PWE3] question regarding draft-kamapabhava-fr-pwe3-01.txt

Hi, pwe3,

thanks,
   Akiva