Subject: Re: Ethernet Circuit Types

From: Giles Heron <[email-masked]>
Date: 26 Jul 2002 16:35:25 +0000

On Fri, 2002-07-26 at 15:06, Eric Rosen wrote:
> 
> Giles> The alternative appears to be to have one VC type and then to either:
> 
> Giles> 1) rely on configuration to get things right (which SPs, or at least
> Giles> this SP, won't accept)
> 
> Giles> 2) signal optional parameters instead of a different VC type (i.e.
> Giles> change the syntax but retain the semantics?)
> 
> Giles> which are you proposing?
> 
> 
> Well, I would say 3: 
> 
>         Where a PW won't operate unless the two endpoints have 
>         compatible configuration parameters, the signaling may
>         carry those parameters, and the PW may be kept down if
>         the parameters are incompatible.  Signaling may also be
>         used to negotiate parameters, if appropriate.

so you're saying "let's give people a choice of whether or not to
signal" - i.e. options 1 + 2 (==3?)  That probably makes sense - as long
as we ensure that an end which wants to signal can interoperate with one
that doesn't know how to (or isn't configured to do so).  But I think we
should probably change your statement to say that if the signalling
carries the parameters then the PW MUST be kept down if they are
incompatible (otherwise it all becomes a bit too non-deterministic?)

> I don't agree that this "changes  the syntax but retains the semantics", I'd
> say rather that it provides the semantics you hoped you would get but didn't
> really get ;-)

I'm not sure how different the semantics between a VC type of "Ethernet
VPLS" and an optional parameter saying "this Ethernet circuit is being
used for VPLS" are?
 
> By carrying  these configuration checks as parameters  rather than embedding
> them  into  the  circuit  type,  we  get  a  more  flexible  and  extensible
> configuration checking  mechanism, with less  impact on the  basic signaling
> procedures. Conceptually, we  might say that the parameters  just get passed
> to the NSP, which may decide whether to accept or reject the circuit. 

agreed that this would be more flexible and extensible.

Giles

-- 
=================================================================
Giles Heron    Principal Network Architect    PacketExchange Ltd.
ph: +44 7880 506185              "if you build it they will yawn"
=================================================================

---

From: Luca Martini <[email-masked]>
Date: Fri, 26 Jul 2002 17:51:39 -0600

> to the NSP, which may decide whether to accept or reject the circuit. 

well, yes I can agree with this. Which means we would have only one ethernet PW type ,

but a parameter somewhere that signals the presence of a tag.

Luca