Subject: RE: about draft-martini-frame-encap-mpls-00.txt

From: "Danny McPherson" <[email-masked]>
Date: Wed, 17 Apr 2002 08:53:04 -0600

> Lastly  if we do fragmentation outside the PW, we can use FRF.12
between PEs. Let us see what others think about this change of the
fragmentation capability.
More to the point, is there a compelling reason NOT to do this, and if
so, should we define something more generic as Eric suggested?
-danny

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 17 Apr 2002 18:47:25 -0400

The biggest reason is efficiency - two bits vs. 6 octets (FRF.12) in every 
frame.

Cheers,
Andy

At 4/17/2002 08:53 AM -0600, Danny McPherson wrote:

>More to the point, is there a compelling reason NOT to do this, and if so, 
>should we define something more generic as Eric suggested?
>
>-danny
>
>

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 18 Apr 2002 12:06:27 +0100

> Claude Kawa wrote:
> 
> George
> 
> About the control word for other PSN, in particular IP and L2TPv3 the draft is not fully
> developed. I would like to solicit additional help. I know Mark has a draft on FR/L2TPv3.

Mark described the control plane, and the revised draft that I submitted before
teh last IETF described the data plane.

> 
>  One question is whether we always include the control word for the different PSN even if we do
> not use some of the fields.

I see no reason to include it in the IP case.

> 
> About keeping the DLCI we have the port mode doing that. It keeps the whole frame as it is.

So my vote is that on an IP network we only support the port mode.

> 
> Lastly  if we do fragmentation outside the PW, we can use FRF.12 between PEs. Let us see what
> others think about this change of the fragmentation capability.
> 
> Claude
> 
> 
> -----Original Message-----
> From: George Wilkie [mailto:[email-masked]]
> Sent: Wednesday, April 17, 2002 9:49 AM
> To: Kawa, Claude [CAR:CS49:EXCH]
> Cc: 'Andrew G. Malis'; W. Mark Townsley; [email-masked]
> Subject: RE: [PWE3] about draft-martini-frame-encap-mpls-00.txt
> 
> Hi Claude,
> 
> A question on the FRoPW control word.
> The doc appears to require the use of the FRoPW control word for all types of
> PSN.
> I understand the need for MPLS, not clear to me for other PSNs, e.g. L2TPv3.
> L2TPv3 can do without the control word since it has its own sequencing
> capability and IP has no need for length field.
> The DLCI can remain on the frame to carry the FBDC bits and avoid inefficient
> copy out/in.
> Pure FRF.12 can be used for fragmentation.
> 
> Cheers.