Subject: RE: Network Interworking Only in PWE3 (was: RE: Proposed c hang es to draft kamapabhava-01)

From: Giles Heron <[email-masked]>
Date: 25 Apr 2002 16:13:40 +0000

On Thu, 2002-04-25 at 15:13, Sasha Vainshtein wrote:
[snip]
> > I think yes, the PWE3 assumption is that you have the same L2 
> > at either
> > side.
> > 
> > But of course this doesn't preclude the use of an IWF at 
> > either side (so
> > e.g. ATM<===>FR<===>PW<===>FR is possible).
> > 
> Sure. But should the fact that you have FR over AAL5 over ATM 
> at one end of the PW affect behavior of a FR-carrying PW in any way?
> I would say not; and, luckily, none of the FR-related drafts does not
> say anything else.

The PW should be unaware of any service interworking.  Or another way of
putting it is that the far end PWES should be unaware of it...

> Not all the services are that lucky, though. I would say that many
> problems with ATM AAL5 mentioned by Neil stem from its interpretation as 
> inherently related to ATM instead  a (more or less generic) frame-carrying 
> service. The latter approach would result in emulation that is far from
> perfect
> from the ATM point of view but, hopefully, very simple and sufficient for
> lots of applications, while the former (the hybrid one) is (to my taste)
> results in a lot of complications - and the simplest way to avoid them would
> be to switch to a true Cell Relay (= AAL0) PW. 

To me the AAL5 mode is just an optimisation that you can make if you
know you will be carrying AAL5 traffic only.

It also interoperates with existing SAR chips (or at least the SDU mode
does - personally I don't see much benefit in the PDU mode).

> > And of course there is a draft or two in PPVPN on 
> > X<===>PW<===>Y for the
> > case where X and Y both carry IP.
> >
> I can only say that one such draft (on ARP mediation) has been
> explicitly rejected at the PPVPN WG meeting in MPLS because
> the subject was declared "not in the charter". (Personally I think
> that this is a very useful document provoding a nice solution of
> a highly relevant problem, and I hope that the PPVPN WG will
> reconsider). 

I wasn't there, but from my reading of the minutes Scott said it was out
of scope of the current charter and should be discussed on the list.  Is
that the same as "explicitly rejected"?  I suppose it may be!

I'm not entirely sure why ARP mediation is out of scope.  It isn't FR to
ATM interworking, it is IP interworking.  Surely IP VPNs are in scope
for PPVPN?

> I do not have anything against "service interworking" or "peer-to-peer"
> trail relationships. I just am not sure that the PWE3 WG is a
> suitable place for these discussions and that service interworking
> considerations are valid arguments in these discussions.

agreed.  Service interworking is outside the PWE3 scope (and may or may
not be out of scope for PPVPN).

Giles

> >
> > Giles
> > 
> > > ... snipped ...
> > > > 
> > > > regards, Neil  
> > > > 
> > > > 
> > > > 
> > > > _______________________________________________
> > > > pwe3 mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/pwe3
> > > > 
> > > 
> > > _______________________________________________
> > > pwe3 mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/pwe3
> > > 
> > -- 
> > =================================================================
> > Giles Heron    Principal Network Architect    PacketExchange Ltd.
> > ph: +44 7880 506185              "if you build it they will yawn"
> > =================================================================
> > 
> 
-- 
=================================================================
Giles Heron    Principal Network Architect    PacketExchange Ltd.
ph: +44 7880 506185              "if you build it they will yawn"
=================================================================

---

From: Luca Martini <[email-masked]>
Date: Thu, 25 Apr 2002 11:16:06 -0600

Comments inline.
Luca

Sasha Vainshtein wrote:

> Giles and Neil,
> Thank you for prompt responses
> Please see some comments inline (in Giles' text).
> With best regards,

>>On Thu, 2002-04-25 at 13:06, Sasha Vainshtein wrote:
>>[snip]
>>
>>>>-	Well, in the client/server case the client layer 
>>>>networks exists for all future practical time, ie this 
>>architecture does
>>>not 
>>>>permit migration of end systems to MPLS nor does it allow 
>>X<=>MPLS<=>Y 
>>>>interworking...where X and Y are different L2 
>>technologies.  In the
>>>peer-layer case 
>>>>however, this does allow X<=>MPLS<=>Y, and even 
>>MPLS<=>XorYorZ.....
>>>Isn't the PWE3 work explicitly limited (by its charter) to 
>>the case of 
>>>X<===>PSN<===>X (where PSN may be IP or MPLS)
>>>(or what the PWE3 FW document calls "network interworking")?
>>>This has been my default assumption until now... and I do 
>>not remember
>>>the opposite ever being discussed on the list or at the face-to-face
>>>WG meetings.
>>>IMHO a clear-cut answer to this question would be 
>>beneficial for the 
>>>discussion.

The latter approach is the only one in the PWE3 charter.

"PWE3 will not strive for pseudo wires to perfectly emulate the
characteristics of the native service. "

> be to switch to a true Cell Relay (= AAL0) PW. 

yes , and after further consideration of the AAL5 modes one could say that they 
are unnecessary , and ATM cell ( with concatenation ) is the only mode needed. 
The AAL5 modes are nice for devices that are mainly built to forward IP, and 
would have trouble accessing cells directly.
As a service provider I want protocols that are useful , and if possible , 
implementable in existing hardware.

> considerations are valid arguments in these discussions.

Yes, I think that draft did not really define any protocols .

It defined a nice vendor feature, but that it not for IETF consideration.