Subject: Re: Question on Martini AAL-5 SDU mode

From: Stewart Bryant <[email-masked]>
Date: Tue, 13 Aug 2002 08:23:10 +0100

Jim Harford wrote:
> 
> Shahram,
> One of the major benefits of AAL-5 PDU mode over SDU mode is the fact that
> AAL-5 CRC is carried end-to-end.  This was one of the reasons that the ATM
> Forum specs use PDU mode.
> 
> Jim Harford
> 

Agreed, but what is the systematic advantage of this?

Why is ATM special vis a vis the other framing modes that do not do this?

The Internet is built on systems that do not preserve end-to-end CRC
what is the incidence of problems, and how do they manifest themselves?

Little, deployed hardware can run PDU mode. Is this a problem?

See also below

Stewart

> At 07:46 AM 8/12/2002 -0700, Shahram Davari wrote:
> >Hi,
> >
> >Since in SDU mode the CRC is removed at the ingress PE and added at
> >the egress PE, it is possible for a bit error in the MPLS network
> >not to be detected (MPLS doesn't have CRC)

But the underlying links do, so the only causes of corruption are
memory error and software error. How much of a problem is this.

> and to get
> >rubber stamped by the egress PE. Has any remedy been proposed,
> >to prevent this from happening?
> >
> >Note: The errors might not even be detectable by the link layer,
> >such as errors inside the routers.

How significant a problem is this compared to error in the end-systems?

Does anyone have any measured results?

> >
> >Yours,
> >Shahram Davari
> >Senior Product Research Engineer
> >R&D Research Ottawa
> >PMC-Sierra, Inc.
> >Phone: (613) 271-4018
> >Fax:   (613) 271-6468
> >
> >_______________________________________________
> >pwe3 mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/pwe3
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Bob Barrett" <[email-masked]>
Date: Tue, 13 Aug 2002 11:05:48 +0100

Hi Shahram

Isn't the key point here that the payload in AAL5 format is inter-operable
with some existing ATM based switch front ends, even though those systems
may be out of scope for the ietf, and to a degree implementation specific?
Using an ATM AAL layer two format (cells with the ATM construct) makes the
adaptation from packet transport of a circuit back to layer two ATM
transport of a circuit a pretty simple piece of logic.

Having said that I am in favour of SDU mode as it is simple and effective,
and I don't have any legacy of ATM expertise to leverage. But I can
understand and accept that a significant proportion of the PWE3 contributors
do have that ATM legacy and expertise, and that carriers have an installed
base of ATM based Class5 front ends that they need to leverage.

Best regards

Bob Barrett

BTW - just rejoined the reflector as I am not travelling for a few weeks,
apologies if this is re-stating a point already made.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Stewart Bryant
Sent: 13 August 2002 08:23
Cc: [email-masked]
Subject: Re: [PWE3] Question on Martini AAL-5 SDU mode

See also below

Stewart

---

From: Jim Harford <[email-masked]>
Date: Tue, 13 Aug 2002 11:53:30 -0400

Stewart,
Most of the layer-2 technologies I am aware of have a mechanism (e.g. CRC) 
to protect the data integrity of a delivered message from one end of the 
link to the other.  If you want to emulate a layer-2 technology, then one 
should strive to preserve as many layer-2 characteristics as possible.  In 
the area of data integrity, this would mean carrying the original link's 
protection (e.g. ATM AAL-5 CRC, Ethernet CRC, HDLC CRC, etc) across the 
pseudo-wire.

But we keep running into the design tradeoff of emulating a service that 
people are buying today from their carrier, versus inventing a new service 
that just happens to run on an installed base of hardware.

Jim Harford