Subject: Re: RE: Is IP Layer 2 Interworking useful?

From: "W. Mark Townsley" <[email-masked]>
Date: Thu, 25 Apr 2002 23:05:01 +0200

"Shah, Himanshu" wrote:
> 
> IP L2 interworking is where IP packets from the
> CE device are propagated by ingress PE over
> Layer 2 VPN infrastructure (Martini, Kompella) using
> circuit information (such as VLAN, DLCI, ATM PVC, etc).
> 
> In Interworking case, ingress PE decapsulates data link
> header and dispatches the IP packet as payload across
> PSTN. Egress PE, in turn re-encapsulates the appropriate
> data link header before dispatching to CE. This decap - encap
> on the edges allows heterogenous circuits to cross-connect.
> Note again, that packet forwarding is strictly based on circuit info
> and NOT destination IP address (hence "L2")

I believe this may be thought of as essentially compressing away the L2 framing
before transit, leaving just the interior L3 header and data for transport
across the PW. It does not "allow" heterogenous circuits to cross-connect, as
translation from one circuit type to another could occur within the NSP without
the PW ever even knowing about it -- and with no new encapsulations defined. 

>From an encapsulation perspective, what this really looks like to the PW is a
new pseudowire type, one which reflects the least common denominator for sending
IP packets arriving on any given circuit type. This of course may be done only
under the assumption that the information carried in the L2 framing of each
packet is not needed by the other end of the tunnel.

In this way, the specific conversion from the various circuit types (conversion
which in this case is essentially the extraction of an IP packet and throwing
everything else away) may then simply be punted to the NSP function, without
affecting the PW per se.

- Mark

> 
> hope this clears up,
> himanshu
> 
> > -----Original Message-----
> > From: Lars Eggert [mailto:[email-masked]]
> > Sent: Thursday, April 25, 2002 1:18 PM
> > To: Shah, Himanshu
> > Cc: 'Giles Heron'; Sasha Vainshtein; [email-masked];
> > [email-masked]; Joe Touch; [email-masked]
> > Subject: Re: Is IP Layer 2 Interworking useful?
> >
> >
> > Hi,
> >
> > Shah, Himanshu wrote:
> > > I am not entirely sure if IP L2 interworking is out of scope for
> > > PPVPN working group charter. At last IETF, we had one or
> > two opinions
> > > that claimed that heterogeneous configurations are not useful.
> >
> > could you explain a bit more what you mean by "IP L2 internetworking"?
> >
> > Since IP is layer 3, do you mean "an IP overlay deployed on an L2
> > infrastructure"? Isn't that just provisioning? Or do you mean "an L2
> > overlay deployed over IP"?
> >
> > Thanks,
> > Lars
> > --
> > Lars Eggert <[email-masked]>           USC Information
> > Sciences Institute
> >
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Yu-Shun Wang <[email-masked]>
Date: Thu, 25 Apr 2002 14:57:41 -0700

Hi,

Please see comments & questions inline.

Shah, Himanshu wrote:

<snip>

> and NOT destination IP address (hence "L2")

I am confused. Your description above matches exactly how an IP pkt was
sent from one host to another host EXCEPT the ARP part was replaced with
the "cross-connect heterogeneous circuit encap-decap" stuff.

My question is, when you have different L2 protocols at the ends, isn't
it time to try L3 solutions? I just don't see going through all this
troubles and inventing new protocols justify what you can simply do
with L3 (i.e., IP).

Thanks,

yushun.

-- 
____________________________________________________________________________
Yu-Shun Wang <[email-masked]>               Information Sciences Institute
                                            University of Southern California