Subject: Number of Authors

From: Danny McPherson <[email-masked]>
Date: Thu, 25 Jul 2002 10:35:58 -0600

Folks, 
As most of you are aware, the number of authors in many
of the drafts posted here and in other working groups is 
growing significantly.  This is causing formatting 
problems for the secretariat, as well as processing delays
when explicit responses are required from the authors
before action can be taken.

Most of the reasoning for the growing number of authors  
appears to be the result of demonstrating support for the 
work.

Based on my experience, however, only one or two, at 
most, actually "hold the pen" for the whole document.

In order to avoid this in PWE3 I'd like to propose
something and get your feedback.  In short, rather 
than listing all the authors on the title page list
only the editor, and have the first section following 
the abstract be the authors section (note that this 
is separate from the acknowledgements sections).  This 
would allow authors to be listed and acknowledged 
respectively, and allow the editor(s?) to provide a
single point of contact for the document.

So, comments?

-danny

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 25 Jul 2002 13:36:53 -0400

Sounds reasonable to me.

         --Tom

>_______________________________________________
>pwe3 mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/pwe3

------------------------------------------------------------------------
Mathematics is the supreme nostalgia of our time.

---

From: "W. Mark Townsley" <[email-masked]>
Date: Tue, 30 Jul 2002 10:00:33 +0200

Lloyd Wood wrote:
> 
> 
> (Oh, you can't have more than one designated editor per draft imo.
>  Doesn't work, since then editors can point fingers at each other
>  saying "His fault!" and there's no single information collation
>  point.)

Sure you can, all it takes is a good source tracking system (e.g. CVS).

With a good tracking system in place, I think it is perfectly reasonable to have
2 or 3 editors for large or broadly-scoped documents, particularly if "Authors"
are not directly involved in the final sign-off process and "Editors" are.

- Mark

> 
> It's worth pointing out draft-rfc-editor-rfc2223bis-02.txt section
> 2.12.
> 
> L.
> 
> <http://www.ee.surrey.ac.uk/Personal/L.Wood/><[email-masked]>
>

---

From: "W. Mark Townsley" <[email-masked]>
Date: Tue, 30 Jul 2002 18:30:32 +0200

Lloyd Wood wrote:
> 
> On Tue, 30 Jul 2002, W. Mark Townsley wrote:
> 
> > Lloyd Wood wrote:
> > >
> > >
> No, because there's _still_ no single (human) collation point.

Single points of contact are also single points of failure.

> If the draft is large enough or broadly-scoped enough to require two
> or three editors, the draft can be split into two or three
> documents.

The delegation of tasks and responsibilities to different humans may not
correlate well with organization of documents for presentation to the reader.

---

From: "W. Mark Townsley" <[email-masked]>
Date: Tue, 30 Jul 2002 19:06:59 +0200

Lloyd Wood wrote:
> and, in the single-point case, that failure is immediately detectable,
> allowing action to be taken.
> 
> Exactly. that's why you want a single editor, who fulfils the task of
> the single, critical, reader, and can ensure a reader-oriented
> presentation for the single document being edited.
> 
> (Mark, you might want to double-check what you're actually arguing
> for. I'm making the point that delegating/splitting the editing role
> within a single document doesn't work, and you've just agreed with
> me.)

We are obviously not hearing one another clearly.

I will have to give an example. Let's say I have two primary editors splitting
the task of writing a single document. You proposed that this is broken. That
you should split the document into two, with one editor tasked for each. What I
am saying, is that while this may in fact work in some cases, in others it might
lead to document organization based not on what would make most sense to the
readers reading the documents, but what makes most sense to the writers writing
the documents. The two may not always be the same.

Documents should be split based on the best presentation to the reader. In some
cases, this may require a small team of primary editors that trust one another
on a single document. Splitting the documents does not create any less work, or
magically ensure quality documents. In fact, it moves the burden of
responsibility for consistency checking among the dispirate primary editors
carefully taking care of their own world to the WG chair or IESG members that
must manage and approve multiple documents that might better be presented as
one.

In case anyone was wondering, I am in favor of short, concise, drafts. I just
don't think that there has to be a 1:1 ratio between an editor an a document.
Perhaps more than 3:1 is cumbersome, and dozens:1 is sheer nonsense, but this
small number is perfectly manageable (and has been for a while).

---

From: Scott Bradner <[email-masked]>
Date: Tue, 30 Jul 2002 17:04:23 -0400 (EDT)

> Does it really matter anyway Scott?

it seems to matter to some people - I was just pointing out
that there is noting in the IETF process that says how few
editors there should be

> What I really don't like however, are the drafts
> with a cast of 10s of authors

it does matter along that end - current RFC Editor guidelines 
say that there should be a max of about 5 names at the top of the file

> where I perceive an intention to intimidate
> the reader that if A,B,C,D etc agree with this draft then who are you as an
> individual to dare disagree with such a cast?

successful intimidation seems rare in my observation of IETF lists  :-)

Scott

---

From: [email-masked]
Date: Tue, 30 Jul 2002 21:58:12 +0100

Does it really matter anyway Scott?.....if the 'masses' are allowed to
comment on such before approval this ought to provide a sanity check of its
technical correctness.  What I really don't like however, are the drafts
with a cast of 10s of authors, where I perceive an intention to intimidate
the reader that if A,B,C,D etc agree with this draft then who are you as an
individual to dare disagree with such a cast?

regards, Neil

> -----Original Message-----
> From: Scott Bradner [mailto:[email-masked]]
> Sent: 30 July 2002 18:13
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [PWE3] Number of Authors
> 
> 
> there is no IETF process requirement for only one editor per document
> 
> Scott
> 
>

---

From: Scott Bradner <[email-masked]>
Date: Tue, 30 Jul 2002 17:20:09 -0400 (EDT)

> it's "then please add my name to your ever-increasing author list."

in which case the document is tossed back to the working group
by teh IESG (which just happend to some ccamp documents)

adding names to show support works in some standards organizations - it is 
counter productive in the IETF

Scott

---

From: "Vach Kompella" <[email-masked]>
Date: Tue, 30 Jul 2002 14:17:18 -0700

It's not the intimidation.  It's the politicking that has increased - lobbying
is no longer to get an affirmative hum in a consensus check, it's "then please
add my name to your ever-increasing author list."

-Vach

> From: [email-masked] [mailto:[email-masked]]On Behalf Of Scott
> Bradner
> Sent: Tuesday, July 30, 2002 2:04 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: [PWE3] Number of Authors
>
>

---

From: Maarten Vissers <[email-masked]>
Date: Mon, 12 Aug 2002 12:00:24 +0200

Scott,

If we can not come to a conclusion on the number, then my proposal is to have
zero names on the final version of the RFC. The RFC is a result of the work in
IETF, and the IETF is responsible for its content and its maintenance, not one
or more individuals (or companies of those individuals).

During the creation of the draft document, it is helpful to have the name (or
names) of the editor(s) on the draft document (point of contact for status,
progress, etc during drafting period).

Regards,

Maarten

---

From: Scott Bradner <[email-masked]>
Date: Mon, 12 Aug 2002 07:14:55 -0400 (EDT)

there needs to be at least on name on the RFC because the RFC Editor
needs to have someone to check the final version with and so that
readers have someone to contact

Scott

---
>From [email-masked]  Mon Aug 12 06:00:43 2002
Cc: [email-masked]
Date: Mon, 12 Aug 2002 12:00:24 +0200
From: Maarten Vissers <[email-masked]>
Organization: Lucent Technologies
X-Mailer: Mozilla 4.76 [en]C-CCK-MCD EMS-1.5  (Windows NT 5.0; U)
X-Accept-Language: en
MIME-Version: 1.0
To: Scott Bradner <[email-masked]>
Original-CC: [email-masked]
Subject: Re: [PWE3] Number of Authors
References: <[email-masked]>
Content-Type: multipart/mixed;
 boundary="------------514C9C1AF8EC7D56D63385CD"

This is a multi-part message in MIME format.
--------------514C9C1AF8EC7D56D63385CD
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

Scott,

Regards,

Maarten

> counter productive in the IETF
--------------514C9C1AF8EC7D56D63385CD
Content-Type: text/x-vcard; charset=us-ascii;
 name="mvissers.vcf"
Content-Transfer-Encoding: 7bit
Content-Description: Card for Maarten Vissers
Content-Disposition: attachment;
 filename="mvissers.vcf"

begin:vcard 
n:Vissers;Maarten
tel;cell:+31 62 061 3945
tel;home:+31 35 526 5463
tel;work:+31 35 687 4270
x-mozilla-html:FALSE
org:Lucent Technologies;NA&CPSE
adr:;;Larenseweg 50;Hilversum;;1221 XL;Netherlands
version:2.1
email;internet:[email-masked]
title:Consulting Member of Technical Staff
fn:Maarten Vissers
end:vcard

--------------514C9C1AF8EC7D56D63385CD--

---

From: Scott Bradner <[email-masked]>
Date: Mon, 12 Aug 2002 10:06:32 -0400 (EDT)

> But since poisson/poised et al. have concluded, where would be the
> best place to do so?

two places I can think of
	1/ bring it up with the RFC Editor
	2/ in the ipr working group 

but there is no one clear place

Scott

---

From: "Don Fedyk" <[email-masked]>
Date: Mon, 12 Aug 2002 14:03:34 -0400

Loa

This thread seems to indicate to the contrary that something is broke. If
the people on the front of the draft/RFC were "RFC points of contact" and
the authors list was a section in the document perhaps some ambiguity would
be removed. The "RFC points of contact" would typically be authors/editors
but the purpose of the names on the first page would be more in line with
the goals of the RFC editor. While a practice of having true authors section
would allow authors who contributed be recognized. 

What is broke in the process is that some are implying many things from the
authors list that go on drafts/RFCs. While I don't think this addresses all
issues, I think calling the contacts list what it is, so an some RFC with
large lists of authors can move forward might help.

Don 

-----Original Message-----
From: Loa Andersson [mailto:[email-masked]] 
Sent: Monday, August 12, 2002 10:01 AM
To: Maarten Vissers
Cc: Scott Bradner; [email-masked]
Subject: Re: [PWE3] Number of Authors

why mend something that is not broken? authors/editors are responsible (even
it is not legal) for answering questions on the rfc, no authors can't do
that, to may creates confusion. 1-3 authors seems to about right

/Loa

Maarten Vissers wrote:

> Scott,
> 
> The RFC Editor has that name on the draft document (proposed standard, 
> draft standard). When the RFC get officially published (standards 
> track) a WG within the IETF is responsible for its maintenance. The 
> name of that WG can be on the document, or (as WGs come and go) the 
> name of the responsible WG can be on the IETF web page.
> 
> Readers can contact the experts via the WG mailing list or the WG 
> management.
> 
> Regards,
> 
> Maarten
> 
> Scott Bradner wrote:
> 
>>If we can not come to a conclusion on the number, then my proposal is 
>>to have zero names on the final version of the RFC. The RFC is a 
>>result of the work in IETF, and the IETF is responsible for its 
>>content and its maintenance, not one or more individuals (or companies 
>>of those individuals).
>>
>>>in which case the document is tossed back to the working group by teh 
>>>IESG (which just happend to some ccamp documents)
>>>
>>>adding names to show support works in some standards organizations - 
>>>it is counter productive in the IETF
>>>
>>>Scott
>>>
>>Content-Type: text/x-vcard; charset=us-ascii;  name="mvissers.vcf"
>>adr:;;Larenseweg 50;Hilversum;;1221 XL;Netherlands version:2.1

-- 
     Loa Andersson
     Chief Architect,
     Utfors Research, Architecture and Future Lab (URAX)
     Utfors AB
     Råsundavägen 12
     Box 525, 169 29 Solna
     Office          +46 8 5270 2000
     Office direct   +46 8 5270 5038
     Mobile          +46 70 848 5038
     Email           [email-masked]
     WWW             www.utfors.se