Subject: Re: about draft-martini-frame-encap-mpls-00.txt

From: Stewart Bryant <[email-masked]>
Date: Thu, 18 Apr 2002 12:03:35 +0100

> Claude Kawa wrote:
> 
> This is an en bloc reply to George, Mark and Stewart emails trying to summarize our understanding:
> 
> 1-It is suggested to do the fragmentation outside the PW, this means that the FR/PW header (Fig 3
> of draft kamapabhava.01) will not show the fragmentation bits.

Yes we should do fragmentation outside the PW, but when using the sompression mode that
the MPLS camp seem so keen on, you will need the frag bits to send a FRF12 link
fragmented frame received from the attached device. (or you will have to declare
this type as unsupported and justify why)

> 
> 2-The fragmentation can be done in the PE, this implies that we need protocol control information
> to keep track of the different fragments not visible in the FR/PW header but they will be
> carried/hidden in the payload of the FR/PW packet (Fig 2 of the draf kama...).

The fragmentation can certainly be done at the PE (however we do it). I don't think that
you have any problem with end-end fragmented frame, but as outlined above you
do have problems with link fragmented frames.

> 
> Is this a correct summary?
> 
> Thanks
> 
> Claude Kawa

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 18 Apr 2002 07:52:04 -0400

Stewart,

>this type as unsupported and justify why)

See my previous message on how you need to handle interface-local 
fragmentation.

Cheers,
Andy