Subject: RE: Ethernet Circuit Types

From: Giles Heron <[email-masked]>
Date: 25 Jul 2002 13:35:23 +0000

On Thu, 2002-07-25 at 11:42, Ali Sajassi wrote:
> At 10:57 AM 7/25/2002 +0200, David Zelig wrote:
> >Ali,
> >
> > >
> > > Yes, all we need is one circuit type - e.g., raw mode
> > > Ethernet VC type as
> > > defined in
> > > http://www.ietf.org/internet-drafts/draft-martini-ethernet-enc
> > >ap-mpls-01.txt
> > >with the rule of NOT sending service delimiting tags over the PW but
> > >sending customers' tags that are not service delimiting across the PW.
> >
> >What will you do if they are both? If the user want to connect to multiple
> >sites from a single Ethernet port, so it marks it with VLANs but want in the
> >same time that the VLAN to be transparent in provider networks since it is
> >depends on it's internal LAN scheme?. In this case you need to carry the
> >VLAN even if it used by one peer as service delineator.
> 
> Since in your example, the customer VLAN is used to select different PW for 
> connectivity to different sites, then the customer VLANs are not 
> transparent to the SP and thus they are used as service delimiters. And if 
> we are talking about VPLS, then customer VLANs are not used for site 
> selection and thus they are passed transparently via the PW.
[rest snipped]

Not necessarily true.  Customer VLANs may still be used to select
individual VPLS networks (or in fact a mixture of VPLS, PW, L3 VPNs, IP
transit, L2 switched services, etc. etc. etc.)

I would expect, and hope, that most VPLS services only carry a single
VLAN (but I lost this battle when it came to specifying VPLS...)

Giles

-- 
=================================================================
Giles Heron    Principal Network Architect    PacketExchange Ltd.
ph: +44 7880 506185              "if you build it they will yawn"
=================================================================

---

From: Luca Martini <[email-masked]>
Date: Thu, 25 Jul 2002 14:43:45 -0600

snip.

>> I think the following definition will cover all cases:
>> - use raw mode whenever more than one VLAN or the whole port 
>> independent of
>> the VLAN scheme is associated to the PW.
>> - The NSP can strip/add VLAN fields and may forward from the same 
>> physical
>> port to different PW on whatever scheme he wants.
>> - Use VLAN mode when you carry only one VLAN, and carry the VLAN field
>> inside. The internal value of the VLAN field may be dependant on the
>> capabilities of the peers.
>> (no one prevent you from using raw mode to carry one VLAN only, but it is
>> the provider selection if he want the extra configuration coordination
>> between the sites).
> 
> 
> Still all you need is just a raw mode since with the raw mode you can do 
> what ever you could do with VLAN mode. Lets remind ourselves that we are 
> talking about the VC type in here and not the operations performed at 
> the NSP.
> 
> -Ali
> 

I totally disagree. raw mode is not sufficient. On what grounds do you arbitrarily discard the 802.1P bits ?

Vlan mode makes the PW transparent, why would we reduce this transparency ?
I would have to change my network architecture, and reduce the service offered 
without the VLAN mode.

Luca