Subject: Fwd: I-D ACTION:draft-malis-pwe3-fragmentation-00.txt

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 27 Jun 2002 03:48:46 -0400

This is a draft on generalized PWE3 fragmentation and reassembly over both 
MPLS and L2TP PSNs.  It is going to be presented at Yokohama.

Thanks,
Andy

------- Begin of Forwarded Message -------
To: IETF-Announce: ;
From: [email-masked]
Reply-to: [email-masked]
Subject: I-D ACTION:draft-malis-pwe3-fragmentation-00.txt
Date: Tue, 25 Jun 2002 07:02:34 -0400
Sender: [email-masked]
X-OriginalArrivalTime: 25 Jun 2002 15:23:32.0037 (UTC) 
FILETIME=[43D49750:01C21C5C]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: PWE3 Fragmentation and Reassembly
	Author(s)	: A. Malis, W. Townsley
	Filename	: draft-malis-pwe3-fragmentation-00.txt
	Pages		: 11
	Date		: 24-Jun-02
	
This document defines a generalized method of performing
fragmentation for use by PWE3 protocols and services.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-malis-pwe3-fragmentation-00.txt

To remove yourself from the IETF Announcement list, send a message to
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-malis-pwe3-fragmentation-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-malis-pwe3-fragmentation-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
Content-Type: text/plain
Content-ID:	<[email-masked]>

ENCODING mime
FILE /internet-drafts/draft-malis-pwe3-fragmentation-00.txt

<ftp://ftp.ietf.org/internet-drafts/draft-malis-pwe3-fragmentation-00.txt>

------- End of Forwarded Message -------

---

From: Akiva Sadovski <[email-masked]>
Date: Wed, 17 Jul 2002 16:31:36 +0200

Andy,
  in Section 5. Security Considerations of
draft-malis-pwe3-fragmentation-00.txt written:
"To circumvent any possible attacks in
    either case, all filtering and access controls should be applied to
    the resulting reconstructed frame rather than any PW fragments."
Te question is: by what layer (according to
draft-bryant-pwe3-protocol-layering) reconstruction is performed ? If it is
performed by layers above PSN (PSN Convergence, etc), does it mean that all
PW implementations that use suggested fragmentation scheme have to implement
filtering and
access control ?

Best,
  Akiva

> -----Original Message-----
> From: Andrew G. Malis [mailto:[email-masked]]
> Sent: Thursday, June 27, 2002 9:49 AM
> To: [email-masked]
> Subject: [PWE3] Fwd: I-D ACTION:draft-malis-pwe3-fragmentation-00.txt
> 
> 

Send a message to:
	[email-masked].
In the body type:

ENCODING mime

------- End of Forwarded Message ------- 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 18 Jul 2002 03:19:34 -0400

Akiva,

>PW implementations that use suggested fragmentation scheme have to implement

No, the only point is that if filtering and access control are used at all, 
they should be applied to complete PW frames (as if fragmentation were not 
in use) and not the fragments themselves.  This is really just common 
sense.  To answer your first question, fragmentation and reassembly form a 
thin layer between the emulated service and the pseudo wire in figure 5 of 
draft-bryant.  Also see figure 2 in my draft.

Regards,
Andy

---

From: Akiva Sadovski <[email-masked]>
Date: Thu, 18 Jul 2002 14:17:56 +0200

Thanks for clarifications, Andy. 

But, if filtering and access control are applied to complete frames between
the emulated service and the pseudo wire, then these functions should be
defined as part of pseudo wire. 
In other words, we cannot use filtering/access control of PSN or PSN Tunnel,
but are going
to augment the PW with such functionality if required. Is that so ?

Akiva.

> Sent: Thursday, July 18, 2002 9:20 AM
> To: Akiva Sadovski
> Cc: 'Andrew G. Malis'; [email-masked]
> Subject: RE: [PWE3] Fwd: I-D 
> ACTION:draft-malis-pwe3-fragmentation-00.txt
> 
> 
> Akiva,
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 18 Jul 2002 08:16:30 -0400

Akiva,

Yes, that's correct.

Cheers,
Andy

-------