Subject: comments to draft-ietf-pwe3-ethernet-encap-01

From: Akiva Sadovski <[email-masked]>
Date: Mon, 2 Dec 2002 13:14:09 +0200

Luca and all,

1) the draft (draft-ietf-pwe3-ethernet-encap-01) states that 
"The entire Ethernet frame without any preamble or FCS 
is transported as a single packet over the Pseudowire";  
and it also requires that 
"The network MUST be configured with an MTU that is sufficient to
transport the largest encapsulation frames (3.7. MTU requirements)".

I probably misunderstand something but that looks like there is no ability
to run 
ETHoL2TPv3 PW over Ethernet unless jumbo frames are allowed or you agree 
to drop "large" Eth frames. The last option is rather unlikely in the access
networks...

2) "3.1.5. Frame Error Processing" states : "As described in [PWE3-
   REQ], packet-loss, corruption, and out-of-order delivery is
   considered to be a "generalized bit error" of the psuedo-wire." It's OK, 
but subsequent statement "therefore, if
   a PE device receives an Ethernet frame containing hardware level CRC
   errors, framing errors, or a runt condition, the frame MUST be discarded
on input"
seems to be out-of-context here since packet-loss, corruption etc should be
monitored
in the CE-bound direction, while CRC errors, framing errors, runts etc are
detected by NSP, in the PSN-bound direction

Can you, please, clarify these issues

thanks,
  Akiva Sadovski,
 Axerra Networks

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 02 Dec 2002 11:50:05 +0000

> to drop "large" Eth frames. The last option is rather unlikely in the access

The prefered approach would be a cascading ageement on MTU sizes, so that
the originating traffic confined itself to an MTU that worked.

Failing that Ethernet over L2TPv3 calls up a fragmentation strategy that
can be applied, if necessary at the intermediate IP layer.

> detected by NSP, in the PSN-bound direction

Surely you are not advocating forwarding corrupt packets over the PSN?
I assume not, in which case the issue is one of how to report the
errors back from the PE to the CE, which I imagine would be via some
out of band exposure of elements of the PE MIB.

Stewart

---

From: Sasha Vainshtein <[email-masked]>
Date: Mon, 2 Dec 2002 14:18:03 +0200

Stewart, Akiva and all,
Please see some comments inline.

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]]
> Sent: Monday, December 02, 2002 1:50 PM
> To: Akiva Sadovski
> Cc: [email-masked]'; [email-masked]; Alik Shimelmits; Sasha 
> Vainshtein
> Subject: Re: [PWE3] comments to draft-ietf-pwe3-ethernet-encap-01
> 
> 
> 
> 
> Akiva Sadovski wrote:
> > Luca and all,
> > 
There is also a PW-specific fragmentation document that would be equally
applicable both to L2TPv3 and MPLS PSN - the price being usage of the 
control word and sequence numbers with an Ethernet PW.
IMHO, this would be preferable to IP fragmentation.
> out of band exposure of elements of the PE MIB.
I may be mistaken, but I think that the problem is not with forwarding
corrupt packets but with the linkage (seemingly introduced in this clause)
between PW errors and AC errors. E.g., if my Eth PHY receives 90% of 
frames with errors and, as a consequence, only 10% of packets are forwarded,
but all the forwarded packets are safely delivered to the remote PE, I
would claim that the PW operates OK.