Subject: PWE3 requirements draft, version 5

From: "Xipeng Xiao" <[email-masked]>
Date: Mon, 17 Mar 2003 21:34:09 -0800

A new version of the PWE3 requirements draft is available for review at:
http://www.cse.msu.edu/~xiaoxipe/pwe3/draft-ietf-pwe3-requirements-05.txt
 
Comments from the last last-call are all considered.  Changes made in this version are:
 
1. The Fragmentation section is re-worded. The original term "SAR" is replaced.
2. The Maintenance section is rewritten.  
   i. How to handle control messages of the native service is now clearly specified;
   ii.  The need for PE-generated maintenance messages, when they are needed, and how to generate and process them at the PEs, are discussed.
3. The Inter-domain section is re-worded.
 
Comments are welcome!
 
XiPeng

---

From: Akiva Sadovski <[email-masked]>
Date: Sun, 23 Mar 2003 10:55:47 +0200

Mustapha, Xipeng and all,

About:

> >  > Section 5.3: paragraph 8, last sentence says: "If a PE needs to
> >  > generate and send a maintenance message to a remote PE, the
> >  > maintenance message MUST be sent via the control plane, 
> not via the
> >  > PW"
 
  IMHO maintenance information may be passed from PE to PE not only in
separate messages
but also via CW bits (f.ex. N and P bits in draft-ietf-pwe3-sonet-01).
Should this kind of
communication be restricted or prohibited ? I doubt...

Have i missed something ?

> -----Original Message-----
> From: Mustapha Aissaoui [mailto:[email-masked]]
> Sent: Wednesday, March 19, 2003 8:26 PM
> To: Xipeng Xiao
> Cc: [email-masked]; Thomas D. Nadeau
> Subject: Re: [PWE3] PWE3 requirements draft, version 5
> 
> 
> Xipeng,
> when OAM messages are sent inband, they travel within the PW. You
> are referring to out-of-band maintenance. We should allow both
> inband and out-of-band maintenance messages.
> 
> Mustapha.
> -----------
> Xipeng Xiao wrote:
> > 
> > Mustapha,
> > 
> > Thank you for your comments!  One response below.
> > 
> >  > Section 5.3: paragraph 8, last sentence says: "If a PE needs to
> >  > generate and send a maintenance message to a remote PE, the
> >  > maintenance message MUST be sent via the control plane, 
> not via the
> >  > PW"
> >  > Where does this requirement come from? This is too 
> restrictive. We
> >  > should allow the option to send a maintenance message 
> over the PW.
> > 
> > A maintenance message is a control plane thing.  It has to 
> stay inside the control plane.
> > 
> > We will consider your other suggestions.
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>