Subject: I-D ACTION:draft-ietf-pwe3-control-protocol-12.txt

From: [email-masked]
Date: Mon, 25 Oct 2004 16:06:11 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Pseudo Wire Emulation Edge to Edge Working Group of the IETF.

	Title		: Pseudowire Setup and Maintenance using LDP
	Author(s)	: L. Martini, et al.
	Filename	: draft-ietf-pwe3-control-protocol-12.txt
	Pages		: 41
	Date		: 2004-10-25
	
Layer 2 services (such as Frame Relay, ATM, ethernet) can be
   "emulated" over an IP and/or MPLS backbone by encapsulating the layer
   2 PDUs and then transmitting them over "pseudowires". It is also
   possible to use pseudowires to provide low-rate TDM and SONET circuit
   emulation over an IP and/or MPLS network. This document specifies a
   protocol for establishing and maintaining the pseudowires, using
   extensions to LDP. Procedures for encapsulating layer 2 PDUs are
   specified in a set of companion documents.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-pwe3-control-protocol-12.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-pwe3-control-protocol-12.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-pwe3-control-protocol-12.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Singh, Hardeep (Hardeep)" <[email-masked]>
Date: Mon, 25 Oct 2004 20:19:27 -0400

Is there an easy way to see the revision history for the draft (For eg.
the nature of changes made - a short synopsis on areas touched, etc)

Thanks

Hardeep

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Monday, October 25, 2004 4:06 PM
To: [email-masked]
Cc: [email-masked]
Subject: [PWE3] I-D ACTION:draft-ietf-pwe3-control-protocol-12.txt

	

Send a message to:
	[email-masked].
In the body type:

---

From: Luca Martini <[email-masked]>
Date: Fri, 29 Oct 2004 17:33:45 -0600

Here is the diff.
Basically :

- added generic misconfiguration error ( per sasha )
- Clarification on pSN tunnel text.
- removed redundant status tlv secion
- fixed grouping tlv note

That's it.

Luca

------- control.nroff -------
1c1
< .\"   %A% %D% %T% %R%.%S%
---
 > .\" @(#) control.nroff 12.3@(#) 04/10/22 18:38:00 12.0
6c6
< .Id 11 "ietf-pwe3-control-protocol"
---
 > .Id 12 "ietf-pwe3-control-protocol"
9c9
< .Dd 2004 10 05
---
 > .Dd 2004 10 22
196,202c196,202
< pseudowire to the other are MPLS packets. Unless the pseudowire endpoints
< are immediately adjacent, these MPLS packets must be transmitted through a
< PSN tunnel. Any sort of PSN tunnel can be used, as long as it is 
possible to
< transmit MPLS packets through it. The PSN tunnel can itself be an LSP, or
< any other sort of tunnel which can carry MPLS packets. Procedures for
< setting up and maintaining the PSN tunnels are outside the scope of this
< document.
---
 > pseudowire to the other are MPLS packets must be transmitted through 
a PSN
 > tunnel, however if the pseudowire endpoints are immediately adjacent, the
 > PSN tunnel may not be necessary. Any sort of PSN tunnel can be used, 
as long
 > as it is possible to transmit MPLS packets through it. The PSN tunnel can
 > itself be an LSP, or any other sort of tunnel which can carry MPLS 
packets.
 > Procedures for setting up and maintaining the PSN tunnels are outside the
 > scope of this document.
923c923
< A more detailed diagram is shown in Appendix B.
---
 > .\A more detailed diagram is shown in Appendix B.
1200c1200,1202
< accept such withdrawn message, but are not required to send it.
---
 > accept such withdrawn message, but are not required to send it. Note that
 > the PW Grouping ID TLV only applies to PW using the Generalized ID FEC
 > element, while the Group ID only applies to PWid FEC element.
1204,1205c1206,1207
< include only the group ID. A Label Release message initiated from the
< imposition router must always include the PW ID.
---
 > include only the group ID, or Grouping ID TLV. A Label Release message
 > initiated from the imposition router must always include the PW ID.
1269a1272,1273
 >    0x0000002A "Generic Misconfiguration Error"
 >
1318,1323d1321
< .Pb "Status codes"
< RFC 3036 has a range of Status Code values which are assigned by IANA on a
< First Come, First Served basis. These additional status codes, and 
assigned
< Values are specified in "IANA Allocations for pseudo Wire Edge to Edge
< Emulation (PWE3)" [IANA].
<

Singh, Hardeep (Hardeep) wrote:

>_______________________________________________
>pwe3 mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/pwe3
>
>  
>