Subject: [PWE3] WG poll on draft-bryant-pwe3-packet-pw-04.txt

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Thu, 21 Oct 2010 18:09:44 +0200

The authors of draft-bryant-pwe3-packet-pw-04.txt have asked that this draft be made a PWE3 working group draft.

This email starts a two week poll, closing Friday 5th November, to help judge consensus on this.

I would ask that the working group participants take into consideration the fact that this draft is intended as a BCP. It is not intended to define new protocol. If this document becomes a WG draft, it does not preclude other solutions to this problem that require protocol extensions to be adopted in the future, but the WG will need to be convinced that they should be adopted.

Regards

Matthew

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Thu, 21 Oct 2010 18:26:57 +0200

Support.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: donderdag 21 oktober 2010 18:10
To: [email-masked]
Subject: [PWE3] WG poll on draft-bryant-pwe3-packet-pw-04.txt

Regards

Matthew

_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Aissaoui, Mustapha (Mustapha)" <[email-masked]>
Date: Thu, 21 Oct 2010 11:31:09 -0500

Support.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Thursday, October 21, 2010 12:10 PM
To: [email-masked]
Subject: [PWE3] WG poll on draft-bryant-pwe3-packet-pw-04.txt

Regards

Matthew

---

From: "Shahram Davari" <[email-masked]>
Date: Thu, 21 Oct 2010 10:47:00 -0700

Support.

-Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Thursday, October 21, 2010 9:10 AM
To: [email-masked]
Subject: [PWE3] WG poll on draft-bryant-pwe3-packet-pw-04.txt

Regards

Matthew

---

From: "Mallette, Edwin" <[email-masked]>
Date: Mon, 25 Oct 2010 08:27:46 -0400

Support!

Ed

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Thursday, October 21, 2010 12:10 PM
To: [email-masked]
Subject: [PWE3] WG poll on draft-bryant-pwe3-packet-pw-04.txt

Regards

Matthew

CONFIDENTIALITY NOTICE: This e-mail may contain information that is privileged, confidential or otherwise protected from disclosure. If you are not the intended recipient of this e-mail, please notify the sender immediately by return e-mail, purge it and do not disseminate or copy it.

---

From: Yaakov Stein <[email-masked]>
Date: Mon, 25 Oct 2010 18:16:40 +0200

I support adopting, since that merely means that the WG is going to work on it.
However, I think the document needs serious editorial work.

The second line of the Abstract already has a problem
This document describes a pseudowire mechanism that is used to
transport a packet service over an MPLS PSN <<<is>>> the case where the
I guess that should be <<<in>>>, or even better <<<for>>>.

But more importantly, I found both the problem and solution descriptions hard to parse.

The problem description starts with talk about the client LSR and server PE being collocated,
rather than describing the real purpose - to carry a generic packet without
trying to DPI out the protocols.

It is not clear to me what Figure 2 clarifies.
If this is a PW it should conform to the corresponding figure of RFC 3985.
All PEs take in a client network and place it on a server network,
in fact all "non peer-peer" IWFs do that.

I don't recall other RFCs detailing all the approaches that were rejected as in Section 6 here.
Is this section going to remain, or is it for discussion ? 

I find Figure 4 baffling. The way it looks to me is that after the CW there are 2 bytes,
then 2 "missing" bytes of air, then the rest of the Ethernet header.
How this is compatible with 4448 is as unclear as "missing" bytes,
and the "clarification" text that there is no 32-bit alignment is even more confusing 
(when did we ever introduce alignment in PW headers?).

This whole ID could be written in 2 pages: 
  1. Problem - how to transport anything Ethernet can transport.
  2. Solution - introduce a fake Ethernet interface and use an Ethernet PW.

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Thursday, October 21, 2010 18:10
To: [email-masked]
Subject: [PWE3] WG poll on draft-bryant-pwe3-packet-pw-04.txt

Regards

Matthew

---

From: Mach Chen <[email-masked]>
Date: Tue, 26 Oct 2010 16:57:24 +0800

Support.

Best regards,
Mach

--------------------------------------------------
From: "Bocci, Matthew (Matthew)" <[email-masked]>
Sent: Friday, October 22, 2010 12:09 AM
To: <[email-masked]>
Subject: [PWE3] WG poll on draft-bryant-pwe3-packet-pw-04.txt

> The authors of draft-bryant-pwe3-packet-pw-04.txt have asked that this 
> draft be made a PWE3 working group draft.
>
> I would ask that the working group participants take into consideration 
> the fact that this draft is intended as a BCP. It is not intended to 
> define new protocol. If this document becomes a WG draft, it does not 
> preclude other solutions to this problem that require protocol extensions 
> to be adopted in the future, but the WG will need to be convinced that 
> they should be adopted.
>
> Regards
>
> Matthew
>
>
>

---

From: <[email-masked]>
Date: Wed, 27 Oct 2010 16:22:39 +0200

Support.

Best regards,
Manuel 

> Sent: Thursday, October 21, 2010 6:10 PM
> To: [email-masked]