Subject: Re: [PWE3] VCCV usage

From: [email-masked]
Date: Mon, 15 Nov 2010 22:16:12 +0800

Hi all,
For MS-PW trace route, I agree TTL expiry is required. But does the MS-PW 
need to support VCCV type3 during VCCV negotiation? I consider the S-PE 
TTL expiry function as a normal label switching behavior, is that right?

IMO, MS-PW trace route can not be performed with only VCCV type3 enabled. 
Because the S-PE can not send the Ping-reply with appropriete TTL value. 
VCCV Type 1 + TTL expiry is the only mode MS-PW trace route can use.

Lizhong

> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Mon, 15 Nov 2010 14:39:58 +0200
> From: Alexander Vainshtein <[email-masked]>
> Subject: Re: [PWE3] VCCV usage
> To: Greg Mirsky <[email-masked]>, Sriganesh Kini
>    <[email-masked]>, Yaakov Stein <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Message-ID:
>    <[email-masked]>
> Content-Type: text/plain; charset="windows-1255"
> 
> Hi all,
> I present for your consideration the following use case.
> 
> 1.       An MS-PW uses CW in encapsulation.
> 
> 2.       End-to-end LSP Ping  in VCCV is used to check its 
> continuity. Since encapsulation uses CW, VCCV Type 1 is used (as 
> required by 5086).
> 
> 3.       Loss of end-to-end continuity has been detected by end-to-
> end LSP-Ping, and the operator wants to localize the fault. In order
> to do that the operator employs LSP-Ping in the trace route mode.
> How, in your opinion, would look LSP-PIng packets in this case? IMO
> 
> ?         They would still use CW with 0b0001 in the first nibble 
> and 21 as the Channel Type (because this is what the remote T-PE 
expects).
> 
> ?         They would use TTL expiration in order to be terminated by
> S-PEs because there is no other way to do that.
> Did I miss something?
> Do you think that this use case is not relevant for MS-PW 
> deployments (assuming there are ? or will be ? such)?
> 
> Regards,
>      Sasha
> 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 15 Nov 2010 16:45:26 +0200

Lizhong,
If a combination of VCCV Type 1 and TTL expiration is used, S-PE does not really have to send replies with the correct TTL: it should just set TTL to some max. value and rely on VCCV Type 1 to be employed in T-PE to intercept LCP-Ping Echo message.
Alternatively, we can follow draft-boutros<https://datatracker.ietf.org/doc/draft-boutros-mpls-lsp-ping-ttl-tlv> and include a TTL TLV in the body of the LSP-Ping request. This is definitely required if we want to initiate LSP-Ping from S-PE.

What should be advertized during negotiation of VCCV types is a somewhat different question. One could argue that VCCV Type 3 does not have to be advertized since it should always work; but my reading of RFC 5085<http://datatracker.ietf.org/doc/rfc5085> does not say so. At the same time, it states that, for PWs using CW, VCCV packets MUST also include CW after the bottom of the label stack and that encapsulation must use PW-ACH.

IMO this means that if CW is set up for the PW and if both VCCV Type 1 and VCCV Type 3 are advertized:

1.       The PW-ACH header MUST be included in all VCCV packets regardless of where we expect them to be intercepted

2.       T-PE will always intercept a VCCV Packet based on the 1st nibble of the CW

3.       S-PE can intercept a VCCV Packet based on TTL expiration (if this happens) but it will process the packet based on the ACH Type in the CW.
Di I miss something?
Regards,
     Sasha

From: [email-masked] [mailto:[email-masked]]
Sent: Monday, November 15, 2010 4:16 PM
To: [email-masked]; [email-masked]; [email-masked]; Alexander Vainshtein
Cc: [email-masked]
Subject: Re: [PWE3] VCCV usage

Hi all,
For MS-PW trace route, I agree TTL expiry is required. But does the MS-PW need to support VCCV type3 during VCCV negotiation? I consider the S-PE TTL expiry function as a normal label switching behavior, is that right?

IMO, MS-PW trace route can not be performed with only VCCV type3 enabled. Because the S-PE can not send the Ping-reply with appropriete TTL value. VCCV Type 1 + TTL expiry is the only mode MS-PW trace route can use.

Lizhong

> and 21 as the Channel Type (because this is what the remote T-PE expects).
>