Subject: [PWE3] Standards for Serial Transport over Pseudowire

From: "Tim Lyon (tlyon)" <[email-masked]>
Date: Mon, 17 Oct 2011 09:58:13 -0500

Which key standards are relevant for transport of serial (i.e. RS-232,
RS-422, RS-485) over Pseudowire?

Thanks,

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 17 Oct 2011 13:15:39 -0400

TIm,

The closest is RFC 4618, PPP and HDLC pseudowires. You can check it out at
https://tools.ietf.org/html/rfc4618 .

Cheers,
Andy

On Mon, Oct 17, 2011 at 10:58 AM, Tim Lyon (tlyon) <[email-masked]> wrote:

> RS-422, RS-485) over Pseudowire?****
>
> ** **
>
> Thanks,****
>
> ****
>
>  ****
>
>
> ****
>
> ** **
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>
>

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 18 Oct 2011 15:25:03 +0000

Tim,

I agree with Andy that the HDLC PW is the closest standard encap we have, but it is still pretty far off.
I doubt that you want to send a packet for each character, which is what a straightforward extension of 4618 would do.

Another possibility is a TDM PW carrying all the idle bits as well.
This may be BW inefficient, but if the bandwidth is low you can get by with it, and it will probably generate fewer pps.

If the bandwidth is high or you have multiple links to transport, then you should look into non-standard encaps.
I have done a few of these in the past, and would be happy to share details.
I considered bringing them to the IETF at some point,
but didn't believe that many PWE participants would be interested.

Y(J)S

From: [email-masked] [mailto:[email-masked]] On Behalf Of Tim Lyon (tlyon)
Sent: Monday, October 17, 2011 16:58
To: [email-masked]
Subject: [PWE3] Standards for Serial Transport over Pseudowire
Importance: High

Which key standards are relevant for transport of serial (i.e. RS-232, RS-422, RS-485) over Pseudowire?

Thanks,