Subject: Re: [PWE3] WG adoption of draft-nadeau-pwe3-vccv-2-02.txt

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Thu, 20 Oct 2011 00:19:00 +0200

Greg

The intention is as follows.

If you support the CW then type 1 must be supported. If the CW is in use, then type 1 must be used.

If you do not support the CW, then type 4 must be supported and type 2 or 3 may be supported.

So if you support a particular PW both with and without a CW then you have to implement both type 1 and type 4 to claim conformance to vccv 2.

Regards

Matthew

________________________________
From: Greg Mirsky <[email-masked]>
To: Bocci, Matthew (Matthew)
Cc: [email-masked] <[email-masked]>
Sent: Wed Oct 19 23:58:01 2011
Subject: Re: [PWE3] WG adoption of draft-nadeau-pwe3-vccv-2-02.txt

Dear Chairs and Authors,
which VCCV Type of Control Channel is mandatory according to proposed changes for a PW with optional CW? Is that support of VCCV Type 4 now mandatory and Types 1, 2, and 3 are optional?

Regards,
Greg

On Wed, Oct 19, 2011 at 2:42 PM, Bocci, Matthew (Matthew) <[email-masked]<mailto:[email-masked]>> wrote:
Folks,

It is about time we closed the poll for WG adoption of draft-nadeau-pwe3-vccv-2-02.txt. We had left this open for longer than originally intended due to the ongoing discussion about the use of the GAL in PWs, which has moved forward now that the GAL-in-PW draft is in the RFC editor's queue.

There was a lot of support for adopting VCCV 2 given the clear need to support VCCV negotiation of a channel type for the GAL. However, these seemed to be some concerns around mandating the new VCCV Type 4 (for the GAL) for PWs without a CW,  particularly given the previous decision to move VCCV towards Internet Standard status.

We have discussed how to proceed with the draft authors, and propose the following:

 *   The WG should adopt VCCV 2, with VCCV Type 1 mandatory for PWs with a CW and Type 4 mandatory for Pws without a CW. VCCV Type 2 and 3 will be optional.
 *   We will not progress RFC5085 towards Internet Standard status at this time. At some point in the future, we will pursue this with an RFC5085bis that reflects the updates resulting from VCCV 2, as and when implementation and deployments allow.
 *   The authors of VCCV 2 should upload a new version of the draft as a PWE3 WG draft, but ensure that they remove any text suggesting that the draft actually rationalises or simplifies the number of modes.

Regards

Matthew & Andy

_______________________________________________
pwe3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Shahram Davari" <[email-masked]>
Date: Wed, 19 Oct 2011 15:48:29 -0700

Matthew,

Can we change the name to VCCV-v2 (for version 2). Since it may be confused with VCCV Type 2.

Thx
Shahram

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Wednesday, October 19, 2011 3:19 PM
To: [email-masked]'
Cc: [email-masked]'
Subject: Re: [PWE3] WG adoption of draft-nadeau-pwe3-vccv-2-02.txt

Greg

Regards

Matthew

Regards,
Greg

Matthew & Andy

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 19 Oct 2011 15:57:49 -0700

Hi Matthew,
thank you for most expedient response, much appreciated.
I think that if CW is supported for a PW with optional use of CW, i.e.
Ethernet PW, then requirement to support Type 4 VCCV CC is artificial. I
think that for such type of PW implementations support of Type 4 VCCV CC
should be optional as well.

Regards,
Greg

On Wed, Oct 19, 2011 at 3:19 PM, Bocci, Matthew (Matthew) <
[email-masked]> wrote:

> So if you support a particular PW both with and without a CW then you have
> to implement both type 1 and type 4 to claim conformance to vccv 2.
>
> Regards
>
> Matthew
>
> ------------------------------
>  *From*: Greg Mirsky <[email-masked]>
> *To*: Bocci, Matthew (Matthew)
> *Cc*: [email-masked] <[email-masked]>
> *Sent*: Wed Oct 19 23:58:01 2011
> *Subject*: Re: [PWE3] WG adoption of draft-nadeau-pwe3-vccv-2-02.txt
>
> Dear Chairs and Authors,
> which VCCV Type of Control Channel is mandatory according to proposed
> changes for a PW with optional CW? Is that support of VCCV Type 4 now
> mandatory and Types 1, 2, and 3 are optional?
>
> Regards,
> Greg
>
> On Wed, Oct 19, 2011 at 2:42 PM, Bocci, Matthew (Matthew) <
> [email-masked]> wrote:
>
>> Folks,
>>
>> It is about time we closed the poll for WG adoption of
>> draft-nadeau-pwe3-vccv-2-02.txt. We had left this open for longer than
>> originally intended due to the ongoing discussion about the use of the GAL
>> in PWs, which has moved forward now that the GAL-in-PW draft is in the RFC
>> editor's queue.
>>
>> There was a lot of support for adopting VCCV 2 given the clear need to
>> support VCCV negotiation of a channel type for the GAL. However, these
>> seemed to be some concerns around mandating the new VCCV Type 4 (for the
>> GAL) for PWs without a CW,  particularly given the previous decision to move
>> VCCV towards Internet Standard status.
>>
>>    - The WG should adopt VCCV 2, with VCCV Type 1 mandatory for PWs with
>>    a CW and Type 4 mandatory for Pws without a CW. VCCV Type 2 and 3 will be
>>    optional.
>>    - We will not progress RFC5085 towards Internet Standard status at
>>    this time. At some point in the future, we will pursue this with an
>>    RFC5085bis that reflects the updates resulting from VCCV 2, as and when
>>    implementation and deployments allow.
>>    - The authors of VCCV 2 should upload a new version of the draft as a
>>    PWE3 WG draft, but ensure that they remove any text suggesting that the
>>    draft actually rationalises or simplifies the number of modes.
>>
>> Regards
>>
>> Matthew & Andy
>>
>> [email-masked]

---

From: Thomas Nadeau <[email-masked]>
Date: Thu, 20 Oct 2011 08:31:57 -0400

Sounds reasonable to me. 

	--Tom

On Oct 19, 2011, at 6:48 PM, Shahram Davari wrote:

> On Wed, Oct 19, 2011 at 2:42 PM, Bocci, Matthew (Matthew) <[email-masked]> wrote:
> Folks,
>  
> The WG should adopt VCCV 2, with VCCV Type 1 mandatory for PWs with a CW and Type 4 mandatory for Pws without a CW. VCCV Type 2 and 3 will be optional.
> We will not progress RFC5085 towards Internet Standard status at this time. At some point in the future, we will pursue this with an RFC5085bis that reflects the updates resulting from VCCV 2, as and when implementation and deployments allow.
> The authors of VCCV 2 should upload a new version of the draft as a PWE3 WG draft, but ensure that they remove any text suggesting that the draft actually rationalises or simplifies the number of modes.
> Regards
>  
> Matthew & Andy
>