Subject: [PWE3] Pseudowire Sequence Number in draft-ietf-mpls-forwarding: a minor comment

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 20 Nov 2013 14:35:41 +0000

Hi all,
I would like to comment on the text in Section 2.1.8.1 "Pseudowire Sequence Number" in
draft-ietf-mpls-forwarding-03 - MPLS Forwarding Compliance and Performance Requirements<http://tools.ietf.org/html/draft-ietf-mpls-forwarding-03>.

This section states, in short, that the main drive for using the sequence number in the PW Control Word is handling of packet reordering events. TDM PWs are presented as a major example, with CBR ATM services as another example.

In fact, this statement is not accurate.

The main drive for mandating the use of sequence number in TM PWs is the need to detect and count lost packets because the egress PE MUST compensate the lost payload bit for bit.

Ability to compensate reordering of PW packets at egress is a side effect of (a) sequence number usage and (b) usage of the de-jitter buffer in the egress PW. It is not mandatory and in any case is limited by the depth of the de-jitter buffer: re-ordered packets that cannot be accommodated within this buffer are treated as lost.

Additional details can be found, e.g., in section 6.2.2 of RFC 4553<http://tools.ietf.org/html/rfc4553>. Ability to re-order mis-ordered PW packets is defined there as OPTIONAL, while replacement of the payload of lost PW packets is defined as MANDATORY.

Hopefully these notes will be useful.

Regards,
     Sasha

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 26 Nov 2013 16:26:43 +0000

Curtis,
Lots of thanks for a prompt and very detailed response.
May I suggest an alternative version of the following text fragment?

<Curtis>
>   Identifying the position of any lost packets is important
>    for PW services which are attempting to reconstruct a bit stream
>    which maintains bit timing, such as time division multiplexing (TDM)
>    services.  TDM and other PW services which require strict ordering
>    also require that misordered packets be either dropped or reordered. 
 <Sasha>
Identifying lost PW packets and exact amount of lost payload is critical for PW services
which maintain bit timing, such as Time Division Multiplexing (TDM) services since
these services MUST compensate lost payload on a bit-for-bit basis. 

With these services PW packets that have been received out of order also MUST also be identified and may be either re-ordered or dropped. 
Reordering requires, in addition to sequence numbering, a "de-jitter buffer" in the egress PE, and ability to reorder is limited by the depth of this buffer. The down side of maintaining a de-jitter buffer is 
added end-to-end service delay.
</Sasha>

Hopefully this will be useful.

Regards,
     Sasha

> -----Original Message-----
> From: Curtis Villamizar [mailto:[email-masked]]
> Sent: Monday, November 25, 2013 8:30 PM
> To: Alexander Vainshtein
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]; Yaakov Stein
> ([email-masked]); pwe3 ([email-masked])
> Subject: Re: [PWE3] Pseudowire Sequence Number in draft-ietf-mpls-
> forwarding: a minor comment
> 
> 
> In message
> <[email-masked]
> om>
> Alexander Vainshtein writes:
> >
> > Hi all,
> >
> > I would like to comment on the text in Section 2.1.8.1 "Pseudowire
> > Sequence Number" in draft-ietf-mpls-forwarding-03 - MPLS Forwarding
> > Compliance and Performance Requirements
> > <http://tools.ietf.org/html/draft-ietf-mpls-forwarding-03>.
> >
> > This section states, in short, that the main drive for using the
> > sequence number in the PW Control Word is handling of packet
> > reordering events. TDM PWs are presented as a major example, with CBR
> > ATM services as another example.
> >
> Yes.  You are correct in pointing this out as inaccurate by omitting
> the other important function of identifying drops for the purpose of
> recunstructing TDM bit streams.
> 
> Andy brought up resequencing being a strong provider request.
> Reordering is far more common than loss particularly for high priority
> services on provider networks and without resequencing reorder results
> in PW loss in what could otherwise be lossless service.
> 
> So we should get the base requirements right but still reflect this,
> but strictly as advice with no normative wording.  We had used the
> phrase "is beneficial" and will retain that.
> 
> Andy brought up the topic.  The incorrect wording in the existing
> draft is my fault.  This text went in fairly early with a lot of other
> changes and it appears that no one had since given it a careful enough
> read and review until you came along.
> 
> > The main drive for mandating the use of sequence number in TM PWs is
> > the need to detect and count lost packets because the egress PE MUST
> > compensate the lost payload bit for bit.
> >
> > Ability to compensate reordering of PW packets at egress is a side
> > effect of (a) sequence number usage and (b) usage of the de-jitter
> > buffer in the egress PW. It is not mandatory and in any case is
> > limited by the depth of the de-jitter buffer: re-ordered packets that
> > cannot be accommodated within this buffer are treated as lost.
> >
> > Additional details can be found, e.g., in section 6.2.2 of RFC
> > 4553<http://tools.ietf.org/html/rfc4553>. Ability to re-order
> > mis-ordered PW packets is defined there as OPTIONAL, while replacement
> > of the payload of lost PW packets is defined as MANDATORY.
> 
> The change below at the top of the section more accurately reflects
> requirements in the RFCs but still states that resequencing can be
> beneficial.  The comments about EPD and PPD are dropped and therefore
> also the informative reference.
> 
>  Context:
> 
>  2.1.8.1.  Pseudowire Sequence Number
> 
>  OLD
> 
>    Pseudowire (PW) sequence number support is most important for PW
>    payload types with a high expectation of in-order delivery.
>    Resequencing support, rather than dropping at egress on out of order
>    arrival, is most important for PW payload types with a high
>    expectation of lossless delivery.  For example, TDM payloads require
>    sequence number support and require resequencing support.  The same
>    is true of ATM CBR service.  ATM VBR or ABR may have somewhat relaxed
>    requirements, but generally require ATM Early Packet Discard (EPD) or
>    ATM Partial Packet Discard (PPD) [ATM-EPD-and-PPD].  Though sequence
>    number support and resequencing support are beneficial to PW packet
>    oriented payloads such as FR and Ethernet, they are highly desirable
>    but not as strongly required.
> 
> NEW
> 
>    Pseudowire (PW) sequence number support is most important for PW
>    payload types with a high expectation of lossless and/or in-order
>    delivery.  Identifying the position of any lost packets is important
>    for PW services which are attempting to reconstruct a bit stream
>    which maintains bit timing, such as time division multiplexing (TDM)
>    services.  TDM and other PW services which require strict ordering
>    also require that misordered packets be either dropped or reordered.
> 
>    PW services which are not timing critical bit streams in nature are
>    cell oriented or frame oriented.  Though resequencing support is
>    beneficial to PW cell and frame oriented payloads such as ATM, FR and
>    Ethernet, they are highly desirable but not required.
> 
> NEW (end of subsection after list of possible reording causes)
> 
>    In provider networks which use multipath techniques and which may
>    occassionally rebalance traffic or which may change PW paths
>    occasionally for other reasons, reordering may be far more common
>    than loss.  Where reordering is more common than loss, resequencing
>    packets is beneficial, rather than dropping packets at egress when
>    out of order arrival occus.  Resequencing is most important for PW
>    payload types with a high expectation of lossless delivery since in
>    such cases out of order delivery within the network results in PW
>    loss.
> 
> The final paragraph sums up the motivation for highlighting
> resequencing as beneficial and desirable.  It does so without any
> normative wording.
> 
> These notes are very useful.  Thank you.
> 
> Please let us know if you (and the WG) are OK with the rewording
> proposed above.
> 
> Curtis