Subject: [Rats] Comments on draft-birkholz-rats-basic-yang-module-01

From: Thomas Hardjono <[email-masked]>
Date: Mon, 23 Sep 2019 12:48:57 +0000

Folks,

Here are some of my comments regarding the Yang draft (draft-birkholz-rats-basic-yang-module-01).

-- The draft needs could benefit from opening text to describe the purpose of Yang and the broader background context (e.g. maybe a couple of paragraphs explaining the use cases of the composite-device, such as constrained environments like IoT).

-- It would be useful to provide a basic definition of a “composite-device” as the reader may not be familiar with this.  The terminology draft (draft-birkholz-attestation-terminology-02) does not actually define it, unless I missed it.

-- Would it be useful to provide a paragraph that explains to the reader that some matching reference values (i.e. matching the tree) are expected to be possessed by the Verifier for each client composite-device that seeks to be verified.

-- thomas --

---

From: Thomas Hardjono <[email-masked]>
Date: Mon, 23 Sep 2019 20:48:28 +0000

I forgot to add that I support this draft being adopted by the RATS working group (assuming the first two easy items have been added).

The third item, which involves reference measurements can be added later, once the Architecture document settles down and explains reference measurements.

-- thomas --

________________________________________
From: RATS [[email-masked]] on behalf of Thomas Hardjono [[email-masked]]
Sent: Monday, September 23, 2019 8:48 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Rats] Comments on draft-birkholz-rats-basic-yang-module-01

Folks,

-- thomas --

_______________________________________________
RATS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rats