Subject: [rddp] DDP draft specification

From: "Sanjay Goyal" <[email-masked]>
Date: Fri, 19 Aug 2005 13:28:40 -0400

Hi,

The below 2 sentences are from draft-ietf-rddp-ddp-05.txt

1. DDP provides enough information in each DDP Segment to allow the ULP Payload in each inbound DDP Segment payloads to be directly Placed into the correct ULP Buffer, even when the DDP Segments arrive out-of-order. 
2. This specification requires reliable, in order Delivery LLPs.

First sentence says that DDP segments which are MPA FPDUs in TCP case can arrive out-of-order and second sentence says that LLP (MPA layer) needs to provide ordered delivery. Isn't it contradictory?

Regards,

Sanjay

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Sukanta ganguly <[email-masked]>
Date: Sun, 21 Aug 2005 18:09:22 -0700 (PDT)

Hi,
  The first sentence clearly specifies that their is
enough information for the payload to be placed
appropriately. With TCP an out-of-order arrival is a
strong possibility. The implementation will help the
ordered delivery.
  Did I read the question wrong or am I missing
something

SG

--- Sanjay Goyal <[email-masked]> wrote:

> 1. DDP provides enough information in each DDP
> Segment to allow the ULP Payload in each inbound DDP
> Segment payloads to be directly Placed into the
> correct ULP Buffer, even when the DDP Segments
> arrive out-of-order. 
> First sentence says that DDP segments which are MPA
> FPDUs in TCP case can arrive out-of-order and second
> sentence says that LLP (MPA layer) needs to provide
> ordered delivery. Isn't it contradictory?
> 
> Regards,
> 
> Sanjay
> 

____________________________________________________
Start your day with Yahoo! - make it your home page 
http://www.yahoo.com/r/hs

---

From: Caitlin Bestler <[email-masked]>
Date: Sun, 21 Aug 2005 19:15:15 -0700

On Aug 19, 2005, at 10:28 AM, Sanjay Goyal wrote:

> 1. DDP provides enough information in each DDP Segment to allow the  
> ULP Payload in each inbound
>     DDP Segment payloads to be directly Placed into the correct ULP  
> Buffer, even when the DDP Segments
>     arrive out-of-order.
> First sentence says that DDP segments which are MPA FPDUs in TCP  
> case can arrive out-of-order and
> second sentence says that LLP (MPA layer) needs to provide ordered  
> delivery. Isn't it contradictory?
>

The same distinction between placement and delivery that applies for  
RDMAP and DDP
MAY apply to the DDP/LLP interface.

The DDP/LLP interface is not standardized, but the essence is that:

1) the LLP MAY supply DDP Segments in the order received (some might  
even say SHOULD).
     The adaptation layers for TCP and SCTP are specifically designed  
to enable this by providing
     sufficient data to enable placement even when LLP re-ordering  
has occurred.
2) The LLP MUST still indicate in-order delivery to DDP. DDP needs  
this because it MUST NOT
      deliver anything to RDMAP that was not fully delivered by the LLP.

One of the review criteria that the IETF RDDP work group insisted on  
was that DDP must
be implementable over a standards socket interface. DDP in fact  
allows this, but that interface
does not provide optimization for out-of-order placement.

An implementation can define its own DDP/LLP interface that  
distinguishes between
placement and delivery. Such an interface can even be described as  
"cleanly layered",
it just isn't using the classic sockets interface to define the clean  
layering.

Caitlin Bestler
Principal Software Scientist
Broadcom
[email-masked]

---

From: Michael Krause <[email-masked]>
Date: Mon, 22 Aug 2005 07:01:04 -0700

>it just isn't using the classic sockets interface to define the clean

Side note: There is also a new Sockets Extension API that adds memory 
management, event management, async comms, etc. that people should take a 
look at since it is a Unix standard.  It will work well for RDMA / SDP.

Mike