Subject: [re-ECN] ConEx and MPLS (WAS RE: re-ECN Digest, Vol 14, Issue 18)

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 29 Apr 2010 10:34:04 +0200

Hi

I am too a bit curious about this as I belive that this is probably an important matter. 
MPLS was (briefly) discussed on the list earlier
http://www.ietf.org/mail-archive/web/re-ecn/current/msg00580.html
As I understand it MPLS is out of scope because there is some pressure to prove that it is useful before attempts are made to adapt other protocols (like MPLS) to work with ConEx.

/Ingemar
 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Thu, 29 Apr 2010 09:17:18 +0100
> From: Stewart Bryant <[email-masked]>
> Subject: Re: [re-ECN] Conex charter - now in External Review
> To: John Leslie <[email-masked]>
> Cc: "Woundy, Richard" <[email-masked]>,
> 	[email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> 
> 
> >     (I also note that Stewart asked about MPLS forwarding: that's a 
> > quite separate question which may deserve more of an answer than I 
> > have already given...)
> Let me explain why I keep asking about MPLS.
> 
> The stated purpose of CONEX is to provide visibility of 
> congestion state within the network.
> 
> A very large fraction of provider networks use MPLS as their 
> primary forwarding mechanism.
> 
> In those networks there will only be visibility of the 
> congestion state at the network ingress and egress unless an 
> MPLS solution is designed.
> 
> If the intent is to design a mechanism that works under the 
> assumption that congestion state will normally only be 
> visible at network boundaries, then that should be in the 
> charter. If the intent is not to make that assumtion, then we 
> should have a very high degree of confidence that we can find 
> a viable MPLS solution.
> 
> Bob's answer to MPLS in Anaheim was to take it out of scope, 
> but that does not address  the central of whether the 
> technology is viable for deployment without MPLS support.
> 
> - Stewart
> 
> 
> ------------------------------
> 
> _______________________________________________
> re-ECN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/re-ecn
> 
> 
> End of re-ECN Digest, Vol 14, Issue 18
> **************************************
>

---

From: ken carlberg <[email-masked]>
Date: Thu, 29 Apr 2010 05:23:11 -0400

Hi Ingemar,

> As I understand it MPLS is out of scope because there is some pressure to prove that it is useful before attempts are made to adapt other protocols (like MPLS) to work with ConEx.

this last part is what concerns me about how the issue is brought up.  While I agree with the point that Stewart brings up in that MPLS is an integral part in a significant number of ISPs, a proper response to Stewart's question really requires a solution first.  

Stewart, I'm going by memory here, so please  correct me if I'm wrong, but the crux of re-ecn is the use of the evil bit as a means of distinguishing it from ECN.  So, wouldn't it be the case that transits that don't want to add any additional attribute to the LSP would just choose to disregard IP packets that have that bit set -- at least with respect to IPv4.  So, while it would eventually be constructive to address the MPLS case, the group and transits can by-pass that topic for the time being.

And if I recall correctly, it was stated and agreed at the Anaheim meeting that Conex needs to make sure its doesn't adversely affect MPLS.  At the very least, the IESG can look at the drafts and make the determination then if Conex adversely affects MPLS....but this is done after work/solutions  have been worked on instead of design-on-the-fly.

-ken