Subject: [re-ECN] Fwd: WG Action: Congestion Exposure (conex)

From: Lars Eggert <[email-masked]>
Date: Fri, 4 Jun 2010 10:30:10 +0300

Hi,

you have probably seen that the CONEX WG has been chartered. The WG mailing list is [email-masked]. I have requested that the secretariat subscribe everyone who is currently on the [email-masked] list to the new CONEX WG list.

I leave it up to Bob to decide if he wants to keep the [email-masked] list around; but any CONEX-related discussion should move to [email-masked].

Lars

Begin forwarded message:

> From: IESG Secretary <[email-masked]>
> Date: June 3, 2010 23:48:40 GMT+03:00
> To: IETF Announcement list <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
> Subject: WG Action: Congestion Exposure (conex) 
> 
> A new IETF working group has been formed in the Transport Area.  For
> additional information, please contact the Area Directors or the WG
> Chairs.
> 
> Congestion Exposure (conex) 
> ---------------------------------------------------
> Current Status: Active Working Group
> 
> Chairs:
>  Nandita Dukkipati <[email-masked]>
>  Marcelo Bagnulo <[email-masked]>
> 
> Transport Area Director(s):
>  Lars Eggert <[email-masked]>
>  David Harrington <[email-masked]>
> 
> Transport Area Advisor:
>  Lars Eggert <[email-masked]> 
> 
> Mailing Lists:
>  General Discussion: [email-masked]
>  To Subscribe: https://www.ietf.org/mailman/listinfo/conex
>  Archive: http://www.ietf.org/mail-archive/web/conex/
> 
> Description of Working Group:
> 
> The purpose of the CONEX working group is to develop a mechanism
> by which senders inform the network about the congestion encountered
> by previous packets on the same flow. Today, the network may signal
> congestion by ECN markings or by dropping packets, and the receiver
> passes this information back to the sender in transport-layer
> acknowledgements. The mechanism to be developed by the CONEX WG
> will enable the sender to also relay the congestion information
> back into the network in-band at the IP layer, such that the total
> level of congestion is visible to all IP devices along the path,
> from where it could, for example, be provided as input to traffic
> management.
> 
> The primary goal of the CONEX WG is to develop experimental
> specifications to achieve the above in IPv6 networks. The WG will
> also develop an abstract, higher-level description of the congestion
> exposure mechanism.
> 
> Primary work items are:
> 
> * An Informational document containing an abstract description of
> the congestion exposure mechanism that is independent of specific
> transport protocols and congestion information encoding techniques
> needed for different IP protocol versions.
> 
> * An Experimental specification of an IPv6 packet structure that
> encapsulates CONEX information, defining a packet format and an
> interpretation.
> 
> * An Experimental specification of a modification to TCP, for the
> timely transport of congestion information from the destination to
> the sender.
> 
> It is believed that the CONEX mechanism will be useful as a generative
> technology that can be applied as a key element of congestion
> management solutions in a wide variety of use cases. However, the
> CONEX WG will initially focus on one use case, where the end hosts
> and the network that contains the destination end host are CONEX-enabled
> but other networks need not be. CONEX information can assist the
> network operator's traffic management and, for example, incentivize
> LEDBAT-like applications. Congestion-based billing is not within the
> scope of the WG.
> 
> Experiments on use cases are encouraged and the WG will solicit
> feedback from such deployments. The WG may decide to document the
> experience from such use cases in Informational documents, covering:
> 
> * Assumptions made
> 
> * Deployment considerations
> 
> * Advice on how to use the CONEX mechanism as an element of a
> congestion management solution
> 
> * Security threats and advice on mitigation approaches (detailed
> specifications of threat mitigation techniques are out of scope)
> 
> * Descriptions of results from experiments with the use case
> 
> The CONEX WG is only chartered to work on a congestion exposure mechanism
> for IPv6 networks. When the output of the WG has seen adoption and
> has proven to be useful, the WG may propose to the IESG that it
> should be rechartered to extend this effort. The first result of
> the WG is the usage scenarios document. Other documents will not
> be considered for publication before this first document has seen
> IETF consensus (but may be worked on in the WG).
> 
> Goals and Milestones:
> 
> Mar 2011 Submit use case description to IESG as Informational
> 
> Jul 2011 Submit abstract specification for the congestion exposure
> mechanism to IESG as Informational
> 
> Nov 2011 Submit specification of IPv6 packet structure to IESG as
> Experimental
> 
> Nov 2011 Submit specification for modification to TCP to IESG as
> Experimental
> 
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: Bob Briscoe <[email-masked]>
Date: Fri, 04 Jun 2010 12:49:10 +0100

Lars,

At 08:30 04/06/2010, Lars Eggert wrote:
>I leave it up to Bob to decide if he wants to keep the 
>[email-masked] list around; but any CONEX-related discussion should 
>move to [email-masked].

Unless anyone objects, I intend to shut down the re-ECN list (in a 
few days once traffic in response to ongoing threads has died).

If there starts to be too much discussion on re-ECN details that are 
beyond the ConEx charter, I'm sure the chairs will let those 
responsible know, then we can consider reopening a separate re-ECN 
list. But I don't think we'll get to that bridge and we can cross it if we do.

Cheers

Bob

________________________________________________________________
Bob Briscoe,                                BT Innovate & Design

---

From: "David Harrington" <[email-masked]>
Date: Fri, 4 Jun 2010 08:51:56 -0400

Hi,

When we moved discussion from the BRIDGE MIB WG to an IEEE ML, we
automated the WG ML to respond to posters with a message that
discusion should be taken to <IEEE-ML>, and here are the instructions
for joining that list. 

I recommend a similar approach here.

dbh

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Bob Briscoe
> Sent: Friday, June 04, 2010 7:49 AM
> To: [email-masked]
> Cc: [email-masked] list; [email-masked]
> Subject: Re: [conex] [re-ECN] Fwd: WG Action: Congestion 
> Exposure (conex)
> 
> Lars,
> 

> conex mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/conex
>

---

From: Bob Briscoe <[email-masked]>
Date: Fri, 04 Jun 2010 16:15:26 +0100

David,

OK, Will do.

Even if we eventually shut down the re-ECN list, I will ask the IETF 
tools folks to make sure the archive remains accessible.

On Web pages I can edit, I've also changed links advising how to 
post/subscribe to the re-ECN list to point to the new ConEx list.

Cheers

Bob