Subject: [regext] I-D Action: draft-ietf-regext-epp-fees-01.txt

From: [email-masked]
Date: Fri, 03 Mar 2017 14:13:57 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Registration Protocols Extensions of the IETF.

        Title           : Registry Fee Extension for the Extensible Provisioning Protocol (EPP)
        Authors         : Roger Carney
                          Gavin Brown
                          Jothan Frakes
	Filename        : draft-ietf-regext-epp-fees-01.txt
	Pages           : 34
	Date            : 2017-03-03

Abstract:
   This document describes an Extensible Provisioning Protocol (EPP)
   extension mapping for registry fees.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-regext-epp-fees/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-regext-epp-fees-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-regext-epp-fees-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Thomas Corte <[email-masked]>
Date: Mon, 6 Mar 2017 18:02:55 +0100

Hello,

>    extension mapping for registry fees.

In addition to the XML schema problem I reported earlier today, I also
noticed a discrepancy between the description of the transfer response
elements and the ones allowed by the schema
(see ttps://tools.ietf.org/html/draft-ietf-regext-epp-fees-01#page-22):

The description text says:

  the server MAY include in the <extension> section of the EPP response a
  <fee:trnData> element, which contains the following child elements:

   o  A <fee:currency> element;
   o  Zero or more <fee:fee> elements;
   o  Zero or more <fee:credit> elements;
   o  An OPTIONAL <fee:balance> element;
   o  An OPTIONAL <fee:creditLimit> element.

However, transferResultType is defined as:

 <!-- transfer result -->
  <complexType name="transferResultType">
    <sequence>
      <element name="currency" type="fee:currencyType" />

      <!-- only used op="query" responses -->
      <element name="period" type="domain:periodType"
        minOccurs="0" />

      <element name="fee" type="fee:feeType"
        maxOccurs="unbounded" />
      <element name="credit" type="fee:creditType"
        minOccurs="0" maxOccurs="unbounded" />
    </sequence>
  </complexType>

"period" is missing in the text, while "balance" and "creditLimit" are
missing in the schema.

Best regards,

Thomas

-- 
____________________________________________________________________
     |       |
     | knipp |            Knipp  Medien und Kommunikation GmbH
      -------                    Technologiepark
                                 Martin-Schmeißer-Weg 9
                                 44227 Dortmund
                                 Deutschland

     Dipl.-Informatiker          Tel:    +49 231 9703-0
     Thomas Corte                Fax:    +49 231 9703-200
     Stellvertretender Leiter    SIP:    [email-masked]
     Software-Entwicklung        E-Mail: [email-masked]

                                 Registereintrag:
                                 Amtsgericht Dortmund, HRB 13728

                                 Geschäftsführer:
                                 Dietmar Knipp, Elmar Knipp

---

From: Roger D Carney <[email-masked]>
Date: Mon, 6 Mar 2017 23:19:36 +0000

Good Afternoon,

Thanks for catching these issues Thomas, these will be corrected in the next version. We have found that there were a few scheme issues, looks like an older scheme got published with this update.

We are running through all the examples and scheme and will take a look at any notes anyone has (thanks for sending notes Jim) and we will plan to publish an update Tuesday or Wednesday this week.

Please keep the comments coming and we will get this draft over the hump and on the final stretch soon.

Thanks
Roger

-----Original Message-----
From: TANGO Support [mailto:[email-masked]] 
Sent: Monday, March 06, 2017 6:11 AM
To: [email-masked]
Cc: [email-masked]; Roger D Carney <[email-masked]>
Subject: Re: [regext] I-D Action: draft-ietf-regext-epp-fees-01.txt

Hello,

On 03/03/2017 23:13, [email-masked] wrote:
> ...

It seems that there is an issue with the XML schema included in this new version. This type definition is defective:

  <complexType name="commandType">
    <sequence>
      <element name="currency" type="fee:currencyType" />
      <element name="period" type="domain:periodType"
        minOccurs="0" maxOccurs="1" />
      <element name="fee" type="fee:feeType"
        minOccurs="0" maxOccurs="unbounded" />
      <element name="credit" type="fee:creditType"
        minOccurs="0" maxOccurs="unbounded" />
      <element name="class" type="token" minOccurs="0" />
      <element name="reason" type="token" minOccurs="0" />
    </sequence>
    <simpleContent>
      <attribute name="name" type=extension base="fee:commandTypeValue"/>
        <attribute name="phase" type="token" />
        <attribute name="subphase" type="token" />
      </extension>
    </simpleContent>
    <attribute name="avail" type="boolean" default="1" />
  </complexType>

XML validator says:

cvc-complex-type.2.4.a: Invalid content was found starting with element 'simpleContent'. One of '{"http://www.w3.org/2001/XMLSchema":attribute,
"http://www.w3.org/2001/XMLSchema":attributeGroup,
"http://www.w3.org/2001/XMLSchema":anyAttribute}' is expected. [132] Open quote is expected for attribute "type" associated with an  element type  "attribute". [133]

Looks like a fix is needed here.

Best regards,

Thomas

--
TANGO REGISTRY SERVICES(r) is a product of:
Knipp Medien und Kommunikation GmbH
Technologiepark                             Phone: +49 231 9703-222
Martin-Schmeisser-Weg 9                       Fax: +49 231 9703-200
D-44227 Dortmund                       E-Mail: [email-masked]
Germany