Subject: Re: [regext] Working Session @ IETF 98

From: "Gould, James" <[email-masked]>
Date: Fri, 3 Mar 2017 13:36:19 +0000

Antoin,

I’m willing to help facilitate or participate in the reseller drafts (draft-ietf-regext-reseller and draft-ietf-regext-reseller-ext) sub-group; although the draft-ietf-regext-epp-fees sub-group is a high priority for me.  You may be able to split it based on EPP based sub-groups and RDAP based sub-groups.  

For the draft-ietf-regext-epp-fees sub-group, I particularly would like to discuss the policies around the handling of premium domain names.  The specific policies that I would like to discuss include:

1. Should a create fail if the client does not pass a fee that is greater than or equal to the premium domain name fee?
2. Should a premium domain name be returned as unavailable in the check if the fee extension is not passed, since the create would most likely fail later in the purchase flow?
3. Should we have text in the draft with guidance around these and other policies?   
  
—
 
JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com <http://verisigninc.com/> 

On 3/3/17, 5:23 AM, "regext on behalf of Antoin Verschuren" <[email-masked] on behalf of [email-masked]> wrote:

    Dear WG,
    
    Important questions below.
    As you may have seen, we have requested 2 meeting slots in Chicago.
    The first slot will be an experimental working session.
    It will be similar to this experiment: https://trac.ietf.org/trac/iesg/wiki/MeetingExperiments
    
    For this experiment to succeed, it will be vital that the participants have prepared.
    It will not be a session to sit in the back of the room reading email.
    This means:
    
    -You must have read and have an opinion or questions about at least one of the documents discussed here.
    -Prepare your questions or text and choose a subgroup from the listing below beforehand.
    
    The setup of this session will be as followed:
    -We will have a short introduction with a sum-up of the sub-groups and documents that will be discussed.
    -We may split up the group in sub-groups, and ask participants to close laptops and join a sub-group of their choice.
    -We have asked for a room setup where each sub-group will have at least a table to sit around.
    -We ask each sub-group to appoint a "facilitator” that will lead the discussion and summarize the results of the discussion afterwards.
    -If there are remote participants for your sub-group, we may ask on-site participants to assist in Skype or similar conferencing tools.
    -We expect a small presentation by the facilitator with the results of the sub-group discusion in the regular session later in the week.
    -You will have an opportunity in the regular session to ask questions to the whole working group if necessary.
    
    So far we have the following documents for this session:
    
    Facilitator:	Document:
    Scott 		draft-hollenbeck-regext-rdap-openid
    Scott		draft-hollenbeck-regext-rdap-object-tag
    Scott		draft-fregly-regext-rdap-search-regex
    Roger		draft-ietf-regext-epp-fees-01
    
    We are considering, but didn’t get confirmation from one of these authors yet:
    
    Facilitator:	Document:
    Jacques?		draft-ietf-regext-dnsoperator-to-rrr-protocol-02
    Linlin/James?	draft-ietf-regext-reseller-ext-01
    
    Please let us know if you want to work on these documents during the working session.
    Perhaps people other than the authors may have an interest to discuss.
    
    Not all documents will have the same interest or expertise.
    Questions we have for the WG now:
    
    -Do you think we should treat the documents in parallel or serial ?
    
    We want to give enough time to each document to discuss and do actual work like writing text.
    Since Scott is leading 3 document discussions, it will be hard to treat them in parallel, but how about the others?
    
    -If you are a remote participant and want to join one of the discussions, please identify yourself on the mailinglist so on-site participants that will join the same sub-discussion can offer to assist in remote participation when we decide to treat them in parallel. It will also allow for the facilitator to get a sense of interest and prepare discussions.

    The preliminary agenda and call for agenda items for our regular meeting session will follow later today.
    
    Regards,
    
    Antoin and Jim.
    
    - --
    Antoin Verschuren
    
    Tweevoren 6, 5672 SB Nuenen, NL
    M: +31 6 37682392

---

From: Roger D Carney <[email-masked]>
Date: Fri, 3 Mar 2017 16:42:23 +0000

Good Morning,

I am a bit confused on the reseller drafts. I thought in Seoul we decided to review and comment but to not dedicate WG effort to these drafts?

Thanks

Roger

-----Original Message-----
From: regext [mailto:[email-masked]] On Behalf Of Gould, James
Sent: Friday, March 03, 2017 7:36 AM
To: Antoin Verschuren <[email-masked]>; regext <[email-masked]>
Subject: Re: [regext] Working Session @ IETF 98

Antoin,

—

JG

James Gould

Distinguished Engineer

[email-masked]<mailto:[email-masked]>

703-948-3271

12061 Bluemont Way

Reston, VA 20190

On 3/3/17, 5:23 AM, "regext on behalf of Antoin Verschuren" <[email-masked] on behalf of [email-masked]<mailto:[email-masked][email-masked]>> wrote:

    Dear WG,

    This means:

    Facilitator:       Document:

    Facilitator:       Document:

    Regards,

    Antoin and Jim.

    - --

    Antoin Verschuren

    M: +31 6 37682392

_______________________________________________

regext mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/regext

---

From: "Linlin Zhou" <[email-masked]>
Date: Mon, 6 Mar 2017 13:43:02 +0800

Thanks James.
I am interested and will participate in the reseller sub group. Hope we can have extensions to fulfill most people's requirements.

Regards,

Linlin Zhou
 
From: Gould, James
Date: 2017-03-03 21:36
To: Antoin Verschuren; regext
Subject: Re: [regext] Working Session @ IETF 98
Antoin,

 
  
—
JG

James Gould
Distinguished Engineer
[email-masked]
 
703-948-3271
12061 Bluemont Way
Reston, VA 20190

 
    Dear WG,

    

    
    Facilitator: Document:

    Facilitator: Document:

    

    
    
    Regards,
    
    Antoin and Jim.
    
    - --
    Antoin Verschuren

    

[email-masked]

---

From: Antoin Verschuren <[email-masked]>
Date: Fri, 10 Mar 2017 14:11:32 +0100

> I’m willing to help facilitate or participate in the reseller drafts (draft-ietf-regext-reseller and draft-ietf-regext-reseller-ext) sub-group; although the draft-ietf-regext-epp-fees sub-group is…

Hi James,

We like this idea of splitting up in a parallel RDAP and EPP track, and then handle documents in serial.
I have put you on the draft agenda for the reseller discussion that will be published later today.
I’m happy to clarify my personal thoughts on these documents and take part in the discussion remotely.
We will have one meetecho setup in the room, and Jim and I will schedule the work session as to accommodate the remote participation for this discussion.

- --
Antoin Verschuren

---

From: Bernhard Reutner-Fischer <[email-masked]>
Date: Sun, 19 Mar 2017 16:49:42 +0100

> 1. Should a create fail if the client does not pass a fee that is greater than or equal to the premium domain name fee?

I always saw it as a (customer-friendly) "bid". As such the command
succeeds if the bid is equal to or greater than the associated price
(regardless if the price stems from a non-default amount -- i.e. a fee
-- or not).

So to answer your question above, of course the create should fail if
the registrar is not willing to pay the required amount, i.e. if the
bid is below the price.

OTOH for
1b) Should a create fail if the client does pass a fee that is greater
than the [premium] domain name fee?
I think no, it should not fail but just deduct the domain name fee
(and of course not more than that). But IIRC that's already in the
text somewhere (?).

> 2. Should a premium domain name be returned as unavailable in the check if the fee extension is not passed, since the create would most likely fail later in the purchase flow?

Yes.
We have a response-data extension where in this case the reason 'Fee
extension required' is returned along the avail=0 to eventually help
registrars that do not use the fee-extension understand the situation.

> 3. Should we have text in the draft with guidance around these and other policies?

Maybe. I think everybody who implements this extension should strive
to make the registrar's life not unnecessarily complex. Remember we
want them to succeed with as little effort as possible from their
side.

cheers,