Subject: [Revampers] www.ietf.org website revamp community review committee - 20170627 - notes

From: Greg Wood <[email-masked]>
Date: Tue, 27 Jun 2017 15:35:24 -0400

Hi,

Here is a link to folder with the recording (MP4 of the video) from the conversation last week:

https://isoc.box.com/v/IETF-Website-CRC-201706

Notes are also below. Please let me know if I have missed anything or there are any questions.

Here are a few highlights:

• Send notes from the call around (and the recording) to spark input/questions <—THIS NOTE
• Suggestions about specific individuals to review the beta site<—ENCOURAGED!
• Plan to release beta.ietf.org ~8 July (before IETF 99)
• Check-in with Revampers after IETF 99/before production <—LIKELY FIRST WEEK OF AUGUST

Thanks!

-Greg

NOTES

0. Agenda bash

1. Introduction
Community Review Committee == Revampers

2. Review of project process and progress
	• So far...
	• SOW development
	• Input from interviews with audiences (participants, potential participants, non-participants)
	• Review by CRC and community 
	• Preview for community at IETF 98 (including update at the WG Chairs meeting)

     b) Currently.
	• finishing content, working with content review groups (EMO Directorate (nee EDU-Team), IESG, Secretariat
	• Fixing bugs and implementing features with Torchbox
	• Testing with groups (non-participants, potential participants)

    c) Upcoming
	• Review by IESG and IAB
	• Planning for community “beta” preview to be released around 8 July--in advance of IETF99
	• “Office hours” to be held at IETF 99 (similar to IETF 98) and update at the WG Chairs meeting
	• Public release on the schedule for early August

3. Review/tour of revamped website
https://beta.ietf.org 
ietfwagtail / ietfshowme

	• Responsive mode
	• Blog posts
	• Meetings
	• Quick links for current IETF participants

4. Discussion

Requesting CRC input:
	• How to test/confirm technical requirements from SOW including:
		• HTML/Open standards
		• Plug-ins and Javascript
		• Accessibility
		• Responsive design
		• SOW: https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf 

	• Suggestions about IETF community review process
		• Including suggestions about specific individuals to review

	• Next steps on website review development

Comment: Need a new name for the Tools “quick links” tab
	• Suggestion “Popular” instead of “Tools” for the name

5. AOB/Next steps
	• Send notes from the call around (and the recording) to spark further input
	• Check-in with Revampers after IETF 99/before production

---

From: Robert Sparks <[email-masked]>
Date: Tue, 27 Jun 2017 15:48:41 -0500

I'm listening to the recording and playing with the site in parallel.

One thing I noticed right away on the home page is that the "What's new" 
section is showing very old articles from the blog - it looks like its 
sorting things in oldest to newest and showing the oldest perhaps? 
Newest to oldest would work better.

Similarly, it's making IETF100 more important than IETF99 - I suspect it 
should make the next upcoming meeting more prominent.

RjS

On 6/27/17 2:35 PM, Greg Wood wrote:
> _______________________________________________
> Revampers mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/revampers

---

From: Robert Sparks <[email-masked]>
Date: Tue, 27 Jun 2017 16:03:58 -0500

Other small content things (is it time to critique content things?)

There are two pages named WG pages, one under "Groups" and one under 
"How we work". Should probably reconcile that to one page.

On the upcoming/99 page, there's a link labelled "Reporting Problems" 
that goes to the "Reporting Potential Harassment" page (which has its 
own link on the upcoming/99 page). That should probably go to a page 
about how to report bugs or meeting trouble or something else.

RjS

On 6/27/17 3:48 PM, Robert Sparks wrote:
> One thing I noticed right away on the home page is that the "What's 
> new" section is showing very old articles from the blog - it looks 
> like its sorting things in oldest to newest and showing the oldest 
> perhaps? Newest to oldest would work better.
>
> Similarly, it's making IETF100 more important than IETF99 - I suspect 
> it should make the next upcoming meeting more prominent.
>
> RjS
>
>
>
>> 		• SOW:https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf  
>>

---

From: Greg Wood <[email-masked]>
Date: Tue, 27 Jun 2017 17:19:02 -0400

Hi Robert,

Thanks for the close review!

At this point the big items for this group (in my mind) are suggestions about how to be sure the site meets the SOW requirements and specific reviews for the non-IETF participant audiences. That said, any and all input and feedback is welcome, particularly general site functionality.

A caveat: Torchbox has been diligently working through tickets and many that have been fixed on staging haven’t yet been deployed on https://beta.ietf.org . I expect/hope that to happen in the next day or so.

Some notes inline:

> On Jun 27, 2017, at 5:03 PM, Robert Sparks <[email-masked]> wrote:
> 
Input is definitely appreciated, though the top-100 pages each will get a close review in the next few weeks, ideally by the groups/folks directly connected to the content, so things will be fine-tuned. For example, the “Hot topics” pages still need to be sorted.
> There are two pages named WG pages, one under "Groups" and one under "How we work". Should probably reconcile that to one page.
> 
Yes. Thanks for pointing that out.

> On the upcoming/99 page, there's a link labelled "Reporting Problems" that goes to the "Reporting Potential Harassment" page (which has its own link on the upcoming/99 page). That should probably go to a page about how to report bugs or meeting trouble or something else. 
> 

I agree. This is a page the secretariat ‘owns’ (as they own the meeting pages on the current site). So I will flag that for them.

>> One thing I noticed right away on the home page is that the "What's new" section is showing very old articles from the blog - it looks like its sorting things in oldest to newest and showing the oldest perhaps? Newest to oldest would work better.
>> 
Indeed. This seems to be a bug in the page template. I’ve filed a ticket with Torchbox.

>> Similarly, it's making IETF100 more important than IETF99 - I suspect it should make the next upcoming meeting more prominent.
>> 
Agree. I’ve filed a ticket with Torchbox to adjust.

Thanks again,
-Greg

>>> https://isoc.box.com/v/IETF-Website-CRC-201706 <https://isoc.box.com/v/IETF-Website-CRC-201706>
>>> 
>>> https://beta.ietf.org <https://beta.ietf.org/> 
>>> ietfwagtail / ietfshowme
>>> 
>>> 	• Responsive mode
>>> 	• Blog posts
>>> 	• Meetings
>>> 		• SOW: https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf <https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf> 
>>> 
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/revampers <https://www.ietf.org/mailman/listinfo/revampers>
>> 
>> 
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/revampers <https://www.ietf.org/mailman/listinfo/revampers>
>

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 28 Jun 2017 12:01:01 +1000

Regarding the "tools" / "sidebar" issue -- I think that it's likely that active IETF participants are going to migrate to using datatracker as their "home" page, and that's fine.

It does mean that datatracker needs to be improved to suit that purpose; adding a few links in appropriate places should do the trick (and I note that there's a LOT of whitespace on the datatracker front page :).

If that's coordinated with the tools folks, it could be ready by 99, and doing so might reduce the amount of concern / complaints about the new site. We could also drop the extra "tools" menu.

Otherwise, just a few nits:

* "Understanding our documents" on the front page should probably be something like "Understanding the IETF"

* The IETF logo looks out of place in a white box on the banner; can we get a transparent-background version with the type reversed? It might require using a different background colour for the banner.

* The top navigation doesn't seem particularly well organised; there seems to be some duplication and awkward categorisations. E.g., many of the entries under "Internet Standards" would fit equally well under "How we work" as well as "about" -- this is confusing.

* There seems to be a non-existant "Making the Internet work better" page in the bread crumbs.

Cheers,

> On 28 Jun 2017, at 5:35 am, Greg Wood <[email-masked]> wrote:
> 
> Hi,
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Greg Wood <[email-masked]>
Date: Wed, 28 Jun 2017 08:52:58 -0400

Hi Mark,

Thank you very much for the review. A few notes below:

> On Jun 27, 2017, at 10:01 PM, Mark Nottingham <[email-masked]> wrote:
> 

This aligns with the in-person feedback we got at IETF 98, though it would require work that is out of scope for this project. 

However, some did indicate that losing the left side bar would interrupt some folks’ current workflow. Most of them indicated that a set of links that was one-step away form the home page (or which could be bookmarked directly), would be acceptable.

I should stress we received overwhelmingly positive feedback on the new site, and that this was the most consistent piece of feedback I received.

> * "Understanding our documents" on the front page should probably be something like "Understanding the IETF”

Agree this needs to be clarified.

> * The IETF logo looks out of place in a white box on the banner; can we get a transparent-background version with the type reversed? It might require using a different background colour for the ban…

Yes, I think this would require design changes. This is exactly the design we reviewed previously, though that was a while ago! And, others have noted it. I’ve filed a ticket as a feature request.

> * The top navigation doesn't seem particularly well organised; there seems to be some duplication and awkward categorisations. E.g., many of the entries under "Internet Standards" would fit equally…

Thanks for this feedback. There is an intended logic behind the structure based on the initial audience research.. I can provide the gory details if you’d like. It is something I will test and tease out in the follow-up conversations with audiences over the next few weeks.

> * There seems to be a non-existant "Making the Internet work better" page in the bread crumbs.

Yes—there is bug in some templates that show the home page twice, once as a home icon and once with the title of the page. I’ve filed a ticket.

Thanks again!

-Greg

---

From: Russ Housley <[email-masked]>
Date: Wed, 28 Jun 2017 15:14:02 -0400

Mark:

Are you suggesting things for the datatracker sidebar or for the items across the top?

Russ

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 29 Jun 2017 16:10:15 +1000

Hi Russ,

Sorry, not sure what that's in reference to.

Cheers,

> On 29 Jun 2017, at 5:14 am, Russ Housley <[email-masked]> wrote:
> 
> Mark:
>

---

From: Russ Housley <[email-masked]>
Date: Thu, 29 Jun 2017 10:47:29 -0400

Mark:

You believe that many IETFers will make the datatracker page their starting point for the IETF site.  So, what from the current from page ought to be added to the datatracker sidebar or the things across the top of the datatracker page to make their life easier?

Russ

> On Jun 29, 2017, at 2:10 AM, Mark Nottingham <[email-masked]> wrote:
> 
> Hi Russ,
>

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 30 Jun 2017 11:59:36 +1000

Ah.

Looking at the two pages, the following are missing:

- Link to the "home" page for the upcoming meeting
- Links to the various mailing list directories
- E-mail list archive search

And a few other bits and bobs. Really, just having a prominent link to the upcoming meeting "home" page should do the trick.

Cheers,

P.S. I think the datatracker sidebar is an abomination, and have turned it off; I only use the top links.

> On 30 Jun 2017, at 12:47 am, Russ Housley <[email-masked]> wrote:
> 
> Mark:
>