Subject: [rohc] [Editorial Errata Reported] RFC5225 (3185)

From: RFC Errata System <[email-masked]>
Date: Wed, 11 Apr 2012 02:17:03 -0700 (PDT)

The following errata report has been submitted for RFC5225,
"RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5225&eid=3185

--------------------------------------
Type: Editorial
Reported by: FWX <[email-masked]>

Section: page 64

Original Text
-------------
rtp(profile_value, ts_stride_value, time_stride_value,
    reorder_ratio_value)
{
  UNCOMPRESSED {
    ENFORCE((profile_value == PROFILE_RTP_0101) ||
            (profile_value == PROFILE_RTP_0107));
    rtp_version =:= uncompressed_value(2, 0) [  2 ];

Corrected Text
--------------
rtp(profile_value, ts_stride_value, time_stride_value,
    reorder_ratio_value)
{
  UNCOMPRESSED {
    ENFORCE((profile_value == PROFILE_RTP_0101) ||
            (profile_value == PROFILE_RTP_0107));
    rtp_version =:= uncompressed_value(2, 2) [  2 ];

Notes
-----
rtp_version is set to 2, not to zero.

See RTP Header Fields page 115 :

Version

      This field is expected to have the value two and the field is
      therefore classified as STATIC-KNOWN.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5225 (draft-ietf-rohc-rfc3095bis-rohcv2-profiles-06)
--------------------------------------
Title               : RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite
Publication Date    : April 2008
Author(s)           : G. Pelletier, K. Sandlund
Category            : PROPOSED STANDARD
Source              : Robust Header Compression
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: Kristofer Sandlund <[email-masked]>
Date: Wed, 11 Apr 2012 11:57:27 +0200

Hi,

I agree with this errata. That's an evil typo that I must have made
in the draft that went undetected through the reviews. 
I'd recommend setting the errata as "Verified", whoever has permission
to edit that one.

/Kristofer

at den 11 april 2012 11:17, RFC Errata System wrote :
> The following errata report has been submitted for
> RFC5225, "RObust Header Compression Version 2 (ROHCv2):
> Profiles for 
> RTP, UDP, IP, ESP and UDP-Lite".
> 
> reorder_ratio_value) {   UNCOMPRESSED {
> (profile_value == PROFILE_RTP_0107));     rtp_version =:=
> uncompressed_value(2, 0) [  2 ];
> 
> Corrected Text
> --------------
> reorder_ratio_value) {   UNCOMPRESSED {
> (profile_value == PROFILE_RTP_0107));     rtp_version =:=
> uncompressed_value(2, 2) [  2 ];
> 
> Notes
> -----
> rtp_version is set to 2, not to zero.  See RTP Header
> Fields 
> page 115 :  Version        This field is expected to have
> the 
> value two and the field is       therefore classified as
> STATIC-KNOWN. 
> 
> Instructions:
> -------------
> This errata is currently posted as "Reported". If
> necessary, please use "Reply All" to discuss whether it
> should be verified or 
> Title               : RObust Header Compression Version 2
> (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite

---

From: RoHC Team <[email-masked]>
Date: Wed, 11 Apr 2012 12:48:47 +0200

Hi Christopher,

  Thank you for your quick reply.
  Best regards,

               FWX.

Le 11/04/2012 11:57, Kristofer Sandlund a écrit :
>> Reported by: FWX<[email-masked]>
>>
>> Section: page 64
>>
>> Original Text
>> -------------

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 11 Apr 2012 14:20:06 +0200

> I'd recommend setting the errata as "Verified", whoever has permission

Indeed.  To corroborate (grepping for rtp_version):

rfc5225.txt:3570:    rtp_version =:= uncompressed_value(2, 0) [  2 ];
rfc5225.txt:4354:    rtp_version =:= uncompressed_value(2, 2)           [  2 ];
rfc5225.txt:4391:    rtp_version    =:= uncompressed_value(2, 2)        [   2 ];
rfc5225.txt:5137:    rtp_version    =:= uncompressed_value(2, 2)        [  2 ];
rfc5225.txt:5173:    rtp_version =:= uncompressed_value(2, 2)           [   2 ];

Very clearly, line 3570 is the odd one out here and needs to be fixed, as RTP Version 0 is neither defined nor in use.

rohc_team: 
Thanks for finding this!
(If I still were rohc WG chair, I would ask you for your common name at this point, as it is customary to use wallet names on IETF lists.)

Grüße, Carsten

---

From: Klaus Warnke <[email-masked]>
Date: Thu, 12 Apr 2012 18:13:29 +0200

Hello!

I could not determine, where the attribute

    ip_id_behavior_innermost.UVALUE

is bound in this format (ipv4 encoding method):

   COMPRESSED ipv4_innermost_irregular {
     ENFORCE(is_innermost == 1);
     ip_id =:=
       ip_id_enc_irreg(ip_id_behavior_innermost.UVALUE)  [ 0, 16 ];
   }

In the  ipv4_outer_irregular format the ip id behavior is defined in 
DEFAULT as static.
I understand here, that the irregular chain (and therefore CO formats)
could not be used, if the ip-id behavior of an outer IP header has changed.
Then I need a co_repair/IR with dynamic chain.

But if the innermost ip id behavior changes, I can use co_common.
Then the ip id is either send within co_common (in seq/seq swapped case)
or within irregular chain (in rand/zero) case.

Therefore maybe the line
     ENFORCE(ip_id_behavior_innermost.UVALUE == ip_id_behavior_value);
is missed here, to bind the attribute with the parameter value?

If not, could please someone explain, where the binding works?

Thanks and Regards,
Klaus

-- 
Klaus Warnke		[email-masked]
http://www.acticom.de
Tel +49-30-4849.6891

acticom GmbH
Schwedter Str. 9b, 10119 Berlin, Germany
Managing Directors:  Olaf Kehrer, Gerrit Schulte
Commercial Register: Berlin-Charlottenburg HRB 73245
VAT-ID DE205131766