Subject: Motivation of IPFRR

From: András Császár <[email-masked]>
Date: Tue, 5 Aug 2008 16:41:00 +0200

Hi All!

I really like the idea of having an FRR solution for native IP networks and so I have been following the evolution of IPFRR solutions for quite some time now (LFA, not-via, MRC, FIR & co.), and I think I know quite well what are the different proposals about.

Yet, the other day I was asked a question, for which I couldn't and still can't give a profound answer. The question was something like this:

Why do we need a separate IP-FRR solution, why is it not enough to use an MPLS detour to a (next-)next-hop to protect links?

The motivation behind it was that basically all major router vendors (C*, J*, R*) support it, why do we need a dedicated native IP solution?

Up to know I thought that there is MPLS-FRR for MPLS networks, there is IP-FRR for IP networks. But now I think that node/link protection of MPLS-FRR is straightforward to apply to IP networks as well. I mean, you don't have to bother about managing a full fledged MPLS network, although there will be some protection LSPs for FRR purposes but these are quite automatic.

Are there scenarios out there which require the extreme high resilience provided by FRR but which do not afford having even a little MPLS only for protection? Under normal conditions, the network is basically still a pure IP network...

I went through the intro of all major IPFRR publications out there, but each motivated IPFRR with the need of an IP-only solution, but what is the motivation for having a native IP-only solution?

Do I miss something, or is the answer only something like management-overhead of MPLS?

Any answers would very appreciated!

BR,
András
_______________________________________________
rtgwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtgwg

---

From: "Alia Atlas" <[email-masked]>
Date: Tue, 5 Aug 2008 11:09:23 -0400

Hi Andras,

One advantage that I see for an IP-FRR solution is that it enables a
solution that offers end-to-end protection, regardless of multiple routing
areas.  It is possible to protect against the failure of an ABR, for
instance.

Another thing is that while we talk about IP-FRR, it works just as well for
LDP.  There are a number of MPLS networks that are running just LDP and do
not need/want the complication of running RSVP as well on top just for FRR.

LFA, in particular, is much lower for operational complexity than RSVP-TE
FRR.

Hopefully this gives you some ideas,

Alia

2008/8/5 András Császár <[email-masked]>

> Hi All!
>
> I really like the idea of having an FRR solution for native IP networks and
> so I have been following the evolution of IPFRR solutions for quite some
> time now (LFA, not-via, MRC, FIR & co.), and I think I know quite well what
> are the different proposals about.
>
> Yet, the other day I was asked a question, for which I couldn't and still
> can't give a profound answer. The question was something like this:
>
> Why do we need a separate IP-FRR solution, why is it not enough to use an
> MPLS detour to a (next-)next-hop to protect links?
>
> The motivation behind it was that basically all major router vendors (C*,
> J*, R*) support it, why do we need a dedicated native IP solution?
>
> Up to know I thought that there is MPLS-FRR for MPLS networks, there is
> IP-FRR for IP networks. But now I think that node/link protection of
> MPLS-FRR is straightforward to apply to IP networks as well. I mean, you
> don't have to bother about managing a full fledged MPLS network, although
> there will be some protection LSPs for FRR purposes but these are quite
> automatic.
>
> Are there scenarios out there which require the extreme high resilience
> provided by FRR but which do not afford having even a little MPLS only for
> protection? Under normal conditions, the network is basically still a pure
> IP network...
>
> I went through the intro of all major IPFRR publications out there, but
> each motivated IPFRR with the need of an IP-only solution, but what is the
> motivation for having a native IP-only solution?
>

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 05 Aug 2008 17:02:48 +0100

András
> Why do we need a separate IP-FRR solution, why is it not enough to use an MPLS detour to a (next-)next-hop to protect links?
One application is in IP networks. Although many service providers have 
deployed MPLS, there are some that have not, and many non-SP networks 
are IP.

LFA is much simpler to deploy on MPLS than MPLS-TE, and there are those 
that feel that a solution directly integrated in to the IGP is simpler 
when you want universal coverage that a scheme based on universal 
coverage delivered via RSVP.
> I went through the intro of all major IPFRR publications out there, but each motivated IPFRR with the need of an IP-only solution, but what is the motivation for having a native IP-only solution?
That was an initial restriction imposed in RTGWG, but since MPLS-LDP 
inherits paths from the IGP, there is an obvious pullthrough. Work of 
the adaptation to MPLS, should however be done MPLS-WG.

Stewart