Subject: draft-bashandy-idr-bgp-repair-label-01

From: Ahmed Bashandy <[email-masked]>
Date: Wed, 23 Mar 2011 18:47:02 +0200

Hi,

This is a draft that proposes rerouting traffic, without waiting for BGP to re-converge, to another PE in a BGP-free core when a PE detects that the NH is no longer reachable. Because traffic coming from the core is redirected back to the core, we propose using a specially advertised label to make sure that the traffic does not get re-routed multiple times into the core, thus avoiding loops.

The draft was sent to IDR. But of course RTGWG has historically been the FRR discussion arena. Unfortunately, non of the authors will be able to attend the next RTGWG meeting in Prague. But I am planning to present the draft during the IDR meeting.

I am attaching a newer version of the draft based on the comments that I got so far. I'll upload it to the ID database once ID submission is re-opened

All comments now or during the IDR meeting are highly appreciated.

Ahmed

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Wed, 23 Mar 2011 19:49:10 +0100

Ahmed, do you believe this should also work for LBL per NH and LBL per service in a VRF ?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ahmed Bashandy
Sent: woensdag 23 maart 2011 17:47
To: [email-masked]
Cc: Burjiz Pithawala (bpithaw)
Subject: draft-bashandy-idr-bgp-repair-label-01

Hi,

Ahmed

---

From: Ahmed Bashandy <[email-masked]>
Date: Thu, 24 Mar 2011 11:24:07 +0200

Both the primary and repair label allocation can be anything (at least this is our intention). However, as pointed out near the end of page 9, per NH (we call it per-CE) repair label allocation is preferred in the sense that optimizes both control and forwarding planes.

Thanks

Ahmed

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Thu, 24 Mar 2011 12:34:50 +0100

Ahmed, in case of LBL per VRF when an IP lookup is done, how are you going to deal with this when also a repair LBL is used. In this case when a CE link fails you have to do a NH re-write for the prefix using either the repair LBL or a different NH advertized by BGP with a different RD.

You should clarify this case I believe.

-----Original Message-----
From: Ahmed Bashandy [mailto:[email-masked]] 
Sent: donderdag 24 maart 2011 10:24
To: Henderickx, Wim (Wim)
Cc: [email-masked]; Burjiz Pithawala (bpithaw)
Subject: Re: draft-bashandy-idr-bgp-repair-label-01

Thanks

Ahmed

---

From: Ahmed Bashandy <[email-masked]>
Date: Thu, 24 Mar 2011 16:21:38 +0200

I agree that this part is not clear in the draft.

Multiple lookups are needed to decide the primary NH for any aggregate label (e.g. per-VRF). Eventually there will either be a label lookup or an IP lookup that points to the primary NH.
If it is a label, then item 2.a in section 3.1.2 specifies how to handle the case of loosing the primary NH
If it is an IP lookup, then it is similar to the case where the repairing PE is an ingress PE. Item 2.b in Section 3.1.2 describes how to deal with loosing the primary NH in this case

Thanks for catching it :-) . I added item (2.c) in Section 3.1.2 to cover this case. The modified draft is attached

Thanks

Ahmed