Subject: Re: FW: Regarding cost based algorithm for finding Extended P-Space.

From: Stewart Bryant <[email-masked]>
Date: Mon, 03 Feb 2014 18:06:25 +0000

Mike and I did some work on this this afternoon

We propose the following algorithm for calculating
extend P space with avoids stub node problem
and also addresses a problem in the pseudocode
that excluded the use of a parallel link.

/////////////////////////////////////////////////////////////////
    //
    // Calculate extended P-space
    //
    // Note the strictly less than operator is needed to
    // avoid ECMP issues.

    Compute_Extended_P_Space(fail_intf)
        foreach node y in network
            y.in_extended_P_space = false
            // Extend P-space to the P-spaces of all reachable
            // neighbours
            foreach interface intf in self
                // Exclude failed interface, noting that
                // the node reachable via that interface may be
                // reachable  via another interface (parallel path)
                if (intf != fail_intf)
                    foreach neighbor n in intf.remote_node
                        // Apply RFC5286 Inequality 1
                        if ( D_opt(n, y) <
                                D_opt(n,self) + D_opt)(self, y)
                            y.in_extended_P_space = true

It might seem strange to run rlfa to a node via a parallel
link, but it would work and it seems strange to exclude it,
particularly as some would like to use only rlfa.

I have also extended the code to exclude the accidental
selection of a pseudonode as PQ and the use of a repair
first hop that is reachable through a pseudonode.

Note that RFC5286 does not seem to explicitly call
out the case where the first hop is a pseudonode.

Stewart

---

From: Uma Chunduri <[email-masked]>
Date: Mon, 3 Feb 2014 18:52:53 +0000

Also it might be important to align Admin checks for both LFA and rLFA by pointing the below in RFC 5286. In other words,  as it doesn't make sense to use the nexthop, which is administratively not allowed for LFA to be used for rLFA. Indication of this could be useful/important..

Page 16 - 5286
"   3.   If H_h.link is administratively allowed to be used as an
        alternate,

           and the cost of H_h.link is less than the maximum,
           and the reverse cost of H_h is less than the maximum,
           and H_h.neighbor is not overloaded (for IS-IS),
           and H_h.link is bidirectional,

        then H_h can be considered as an alternate.  Otherwise, skip it
        and continue to the next candidate next-hop."

--
Uma C.

-----Original Message-----
From: rtgwg [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Monday, February 03, 2014 10:06 AM
To: Bharath R; [email-masked]'; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: FW: Regarding cost based algorithm for finding Extended P-Space.

We propose the following algorithm for calculating extend P space with avoids stub node problem and also addresses a problem in the pseudocode that excluded the use of a parallel link.

It might seem strange to run rlfa to a node via a parallel link, but it would work and it seems strange to exclude it, particularly as some would like to use only rlfa.

I have also extended the code to exclude the accidental selection of a pseudonode as PQ and the use of a repair first hop that is reachable through a pseudonode.

Note that RFC5286 does not seem to explicitly call out the case where the first hop is a pseudonode.

Stewart
_______________________________________________
rtgwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtgwg