Subject: comments on draft-ietf-rtgwg-remote-lfa-05

From: Chris Bowers <[email-masked]>
Date: Fri, 23 May 2014 12:43:26 +0000

Authors,

Below are two comments on draft-ietf-rtgwg-remote-lfa-05.

1) A section should be added to the document clarifying what the expected behavior is for RLFA when routers advertise themselves as not desiring to carry transit traffic or links have been costed out.    RFC5286 has a useful section on this topic entitled "Interactions with IS-IS Overload, RFC 3137, and Costed Out Links".  The current document would benefit from additional clarity in this topic.

2) The current document doesn't appear to say anything about the expected behavior of RLFA when the IGP has multiple areas or levels.  It would be useful to either address this topic, or explicitly narrow the scope of the document to describing the behavior when the IGP has a single area or level.

Thanks,
Chris

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 23 May 2014 16:11:00 +0100

On 23/05/2014 13:43, Chris Bowers wrote:
> 1) A section should be added to the document clarifying what the 
> expected behavior is for RLFA when routers advertise themselves as not 
> desiring to carry transit traffic or links have been costed out.    
> RFC5286 has a useful section on this topic entitled "Interactions with 
> IS-IS Overload, RFC 3137, and Costed Out Links".  The current document 
> would benefit from additional clarity in this topic.
New section 4.4.

The consideration concerning interactions with IS-IS Overload, [RFC3137],
and costed out links as described in [RFC5286] apply. In selecting a PQ
node a PLR MUST exclude any candidate that is reachable (including via 
ECMP)
from the PLR via a path subject to one of the above exclusions.
The method of determining the exclusion is a local matter.
> 2) The current document doesn't appear to say anything about the 
> expected behavior of RLFA when the IGP has multiple areas or levels.  
> It would be useful to either address this topic, or explicitly narrow 
> the scope of the document to describing the behavior when the IGP has 
> a single area or level.
I have added to the bottom of the intro:

This document considers the case when the repair path is confined to 
either a
single area or to the level two routing domain. In all other cases, the 
chosen
PQ node should be regarded as a tunnel adjacency of the repairing node,
and the considerations  described in Section 6 of [RFC5286] taken
into account.

- Stewart

---

From: Chris Bowers <[email-masked]>
Date: Wed, 28 May 2014 18:54:58 +0000

See inline [CB] for comment on the new section 4.4.

Chris

From: Stewart Bryant [mailto:[email-masked]]
Sent: Friday, May 23, 2014 10:11 AM
To: Chris Bowers; [email-masked]
Subject: Re: comments on draft-ietf-rtgwg-remote-lfa-05

node a PLR MUST exclude any candidate that is reachable (including via ECMP)

[CB] I think the following text explains the expected behavior more clearly.

"Since normal IGP routing takes into account the IS-IS overload bit , RFC 3137, and costing out of links, the forward SPFs performed by the PLR rooted at neighbors of the PLR also need to take this into account.  Therefore a repair tunnel path from a neighbor of the PLR to a repair tunnel endpoint will generally avoid the nodes and links excluded by the IGP overload/costing out rules.  However, there are two situations where this behavior may result in a repair path traversing  a link or router that should be excluded.

1) The first hop on the repair tunnel path (from the PLR to a direct neighbor) does not necessarily follow the IGP shortest path.   Therefore, the PLR MUST NOT use a repair tunnel path whose first hop is along a link whose cost or reverse cost is LSInfinity (for OSPF) or the maximum cost (for IS-IS) or, has the overload bit set (for IS-IS).

2) The IS-IS overload bit and the mechanism of RFC 3137 only prevent transit traffic from traversing a node.  It does not prevent traffic destined to a node.  So the per-neighbor forwards SPFs using standard IGP overload rules will not prevent  a PLR from choosing a repair tunnel endpoint that is advertising a desire to not carry transit traffic.  Therefore, the PLR MUST NOT use a repair tunnel endpoint with the IS-IS overload bit set (or all outgoing interfaces with cost set to LSInfinity for OSPF).  "

This document considers the case when the repair path is confined to either a
single area or to the level two routing domain. In all other cases, the chosen
PQ node should be regarded as a tunnel adjacency of the repairing node,
and the considerations  described in Section 6 of [RFC5286] taken
into account.

- Stewart

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 30 May 2014 13:28:01 +0100

Chris

I would like to take this together with final review coments
from the WGCs

Stewart

On 28/05/2014 19:54, Chris Bowers wrote:
> *From:*Stewart Bryant [mailto:[email-masked]]
> *Sent:* Friday, May 23, 2014 10:11 AM
> *To:* Chris Bowers; [email-masked]
> *Subject:* Re: comments on draft-ietf-rtgwg-remote-lfa-05
>
>     expected behavior is for RLFA when routers advertise themselves as
>     not desiring to carry transit traffic or links have been costed
>     out.    RFC5286 has a useful section on this topic entitled
>     "Interactions with IS-IS Overload, RFC 3137, and Costed Out
>     Links".  The current document would benefit from additional
>     clarity in this topic.
>
> New section 4.4.
>
> "Since normal IGP routing takes into account the IS-IS overload bit , 
> RFC 3137, and costing out of links, the forward SPFs performed by the 
> PLR rooted at neighbors of the PLR also need to take this into 
> account.  Therefore a repair tunnel path from a neighbor of the PLR to 
> a repair tunnel endpoint will generally avoid the nodes and links 
> excluded by the IGP overload/costing out rules.  However, there are 
> two situations where this behavior may result in a repair path 
> traversing  a link or router that should be excluded.
>
> 1) The first hop on the repair tunnel path (from the PLR to a direct 
> neighbor) does not necessarily follow the IGP shortest path.   
> Therefore, the PLR MUST NOT use a repair tunnel path whose first hop 
> is along a link whose cost or reverse cost is LSInfinity (for OSPF) or 
> the maximum cost (for IS-IS) or, has the overload bit set (for IS-IS).
>
> 2) The IS-IS overload bit and the mechanism of RFC 3137 only prevent 
> transit traffic from traversing a node.  It does not prevent traffic 
> destined to a node.  So the per-neighbor forwards SPFs using standard 
> IGP overload rules will not prevent  a PLR from choosing a repair 
> tunnel endpoint that is advertising a desire to not carry transit 
> traffic. Therefore, the PLR MUST NOT use a repair tunnel endpoint with 
> the IS-IS overload bit set (or all outgoing interfaces with cost set 
> to LSInfinity for OSPF).  "
>
>     expected behavior of RLFA when the IGP has multiple areas or
>     levels.  It would be useful to either address this topic, or
>     explicitly narrow the scope of the document to describing the
>     behavior when the IGP has a single area or level.
>

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html