Subject: Re: I-D Action: draft-ietf-rtgwg-rlfa-node-protection-03.txt

From: Pushpasis Sarkar <[email-masked]>
Date: Tue, 13 Oct 2015 10:14:39 +0000

Hi Mike,

I thought I have already taken care of these in latest draft. I will go through them and if see that they have not been taken care of I will redo them and submit the next version.

Thanks
-Pushpasis

On 10/13/15, 3:39 PM, "Mike Shand" <[email-masked]> wrote:

>Pushpasis,
>
>That looks fine. Just a few trivial comments that don't seem to have 
>been addressed.
>
>I'll be interested to see how this progresses.
>
>
>para under figure 2 line 3
>
>I still think it should say Extended P-space of S and Q-space of E 
>(w.r.t. S-E link).
>
>i.e. make it clear that it is the extended P-space OF S  that we are 
>talking about.
>
>
>introduction para 1 line 2
>
>I still think guarantee is better than guarantees here.
>
>par 4 line 2
>
>"procedure is extended"
>
>
>2. Node protection with remote-LFA
>para 1 line 7
>
>a essential -> essential
>
>2.3. computing node-protecting R-LFA path
>para 2
>it's ->its
>
>and another one that seems to have crept in
>
>2.3.3 Limiting extra...
>para 3 line 4
>
>it's->its
>
>That's all
>
>Mike
>
>
>
>On 06/10/2015 16:52, Pushpasis Sarkar wrote:
>> Hi Mike,
>>
>> I have uploaded version 03 addressing all your comments. Please review and let me know if there any more comments.
>>
>> Thanks and Regards,
>> -Pushpasis
>>
>>
>>
>>
>> On 10/6/15, 9:18 PM, "rtgwg on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:
>>
>>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>>> This draft is a work item of the Routing Area Working Group Working Group of the IETF.
>>>
>>>         Title           : Remote-LFA Node Protection and Manageability
>>>         Authors         : Pushpasis Sarkar
>>>                           Shraddha Hegde
>>>                           Chris Bowers
>>>                           Hannes Gredler
>>>                           Stephane Litkowski
>>> 	Filename        : draft-ietf-rtgwg-rlfa-node-protection-03.txt
>>> 	Pages           : 16
>>> 	Date            : 2015-10-06
>>>
>>> Abstract:
>>>    The loop-free alternates computed following the current Remote-LFA
>>>    [RFC7490] specification guarantees only link-protection.  The
>>>    resulting Remote-LFA nexthops (also called PQ-nodes), may not
>>>    guarantee node-protection for all destinations being protected by it.
>>>
>>>    This document describes procedures for determining if a given PQ-node
>>>    provides node-protection for a specific destination or not.  The
>>>    document also shows how the same procedure can be utilised for
>>>    collection of complete characteristics for alternate paths.
>>>    Knowledge about the characteristics of all alternate path is
>>>    precursory to apply operator defined policy for eliminating paths not
>>>    fitting constraints.
>>>
>>>
>>>
>>> The IETF datatracker status page for this draft is:
>>> https://datatracker.ietf.org/doc/draft-ietf-rtgwg-rlfa-node-protection/
>>>
>>> There's also a htmlized version available at:
>>> https://tools.ietf.org/html/draft-ietf-rtgwg-rlfa-node-protection-03
>>>
>>> A diff from the previous version is available at:
>>> https://www.ietf.org/rfcdiff?url2=draft-ietf-rtgwg-rlfa-node-protection-03
>>>
>>>
>>> Please note that it may take a couple of minutes from the time of submission
>>> until the htmlized version and diff are available at tools.ietf.org.
>>>
>>> Internet-Drafts are also available by anonymous FTP at:
>>> ftp://ftp.ietf.org/internet-drafts/
>>>
>>> _______________________________________________
>>> rtgwg mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/rtgwg
>

---

From: Pushpasis Sarkar <[email-masked]>
Date: Wed, 14 Oct 2015 09:42:06 +0000

Hi Mike,

Thanks for the review again. Please see resolutions inline. 

Regards,
-Pushpasis

>I still think it should say Extended P-space of S and Q-space of E 
[Pushpasis] I see that this has been already addressed in 03 version. So I assume I don’t have to take care of it anymore. :)

>I still think guarantee is better than guarantees here.
[Pushpasis] Will rectify in next version.

>"procedure is extended"
[Pushpasis] Will rectify in next version.

>2. Node protection with remote-LFA
[Pushpasis] Will rectify in next version.

>and another one that seems to have crept in
[Pushpasis] Will rectify all in next version.