Subject: Request for WG adoption of draft-bashandy-rtgwg-bgp-pic-02.txt

From: "Ahmed Bashandy (bashandy)" <[email-masked]>
Date: Mon, 09 Nov 2015 16:25:27 -0800

Hi,

This is the latest version of the BGP-PIC draft that was presented on 
Nov/2/15 during the IETF-94 meeting in Yokohama
We have addressed the comments as follows:
- Added statements in multiple places, including the abstract, 
indicating the need for more than one BGP path
- Added example in Section 2.3.3 with illustrations in Figure 4,5,6 on 
how to handle a platform that does not support the required number of 
hierarchy levels.  Section 4.3 explains the gradual degradation of 
BGP-PIC benefit as a result of the reduced platform support
- For handling unlabeled traffic in case PE-CE failure, the last bullet 
in Section 4.2.2 indicates that an egress PE must always treat a core 
facing path as a backup path to avoid looping the packet in case of 
PE-CE link failure. The first statement in Section 5.1 indicates that 
the draft does not cover the failure of a CE node

We would like to request adoption of the draft.

Thanks

Ahmed

-------- Original Message --------
Subject: 	New Version Notification for draft-bashandy-rtgwg-bgp-pic-02.txt
Date: 	Mon, 9 Nov 2015 16:05:59 -0800
From: 	<[email-masked]>
To: 	Clarence Filsfils <[email-masked]>, Ahmed Bashandy 
<[email-masked]>, Prodosh Mohapatra <[email-masked]>, "Pradosh 
Mohapatra" <[email-masked]>

A new version of I-D, draft-bashandy-rtgwg-bgp-pic-02.txt
has been successfully submitted by Ahmed Bashandy and posted to the
IETF repository.

Name:		draft-bashandy-rtgwg-bgp-pic
Revision:	02
Title:		Abstract
Document date:	2015-11-09
Group:		Individual Submission
Pages:		26
URL:            https://www.ietf.org/internet-drafts/draft-bashandy-rtgwg-bgp-pic-02.txt
Status:         https://datatracker.ietf.org/doc/draft-bashandy-rtgwg-bgp-pic/
Htmlized:       https://tools.ietf.org/html/draft-bashandy-rtgwg-bgp-pic-02
Diff:           https://www.ietf.org/rfcdiff?url2=draft-bashandy-rtgwg-bgp-pic-02

Abstract:
In the network comprising thousands of iBGP peers exchanging millions
of routes, many routes are reachable via more than one path. Given
the large scaling targets, it is desirable to restore traffic after
failure in a time period that does not depend on the number of BGP
prefixes. In this document we proposed an architecture by which
traffic can be re-routed to ECMP or pre-calculated backup paths in a
timeframe that does not depend on the number of BGP prefixes. The
objective is achieved through organizing the forwarding chains in a
hierarchical manner and sharing forwarding elements among the maximum
possible number of routes. The proposed technique achieves prefix
independent convergence while ensuring incremental deployment,
complete transparency and automation, and zero management and
provisioning effort. It is noteworthy to mention that the benefits of
BGP-PIC are hinged on the existence of more than one path whether as
ECMP or primary-backup.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 10 Nov 2015 01:47:06 +0000

Dear RTGWG,

The authors have requested the RTGWG to adopt draft-bashandy-rtgwg-bgp-pic-02 as the working group document with Informational intended status.

WG expressed support during the last RTGWG meeting (94) in Yokohama.
Please indicate support or no-support by November 15, 2015.

If you are listed as a document author or contributor please respond to this email stating of whether or not you are aware of any relevant IPR. The response needs to be sent to the RTGWG mailing list. The document will not advance to the next stage until a response has been received from each author and each individual that has contributed to the document.

Cheers,
Jeff & Chris

From: "Ahmed Bashandy (bashandy)" <[email-masked]<mailto:[email-masked]>>
Date: Monday, November 9, 2015 at 16:25
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, Chris Bowers <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Clarence Filsfils <[email-masked]<mailto:[email-masked]>>, Pradosh Mohapatra <[email-masked]<mailto:[email-masked]>>
Subject: Request for WG adoption of draft-bashandy-rtgwg-bgp-pic-02.txt

Hi,

This is the latest version of the BGP-PIC draft that was presented on Nov/2/15 during the IETF-94 meeting in Yokohama
We have addressed the comments as follows:
- Added statements in multiple places, including the abstract, indicating the need for more than one BGP path
- Added example in Section 2.3.3 with illustrations in Figure 4,5,6 on how to handle a platform that does not support the required number of hierarchy levels.  Section 4.3 explains the gradual degradation of BGP-PIC benefit as a result of the reduced platform support
- For handling unlabeled traffic in case PE-CE failure, the last bullet in Section 4.2.2 indicates that an egress PE must always treat a core facing path as a backup path to avoid looping the packet in case of PE-CE link failure. The first statement in Section 5.1 indicates that the draft does not cover the failure of a CE node

Thanks

Ahmed

-------- Original Message --------
Subject:        New Version Notification for draft-bashandy-rtgwg-bgp-pic-02.txt
Date:   Mon, 9 Nov 2015 16:05:59 -0800
From:   <[email-masked]><mailto:[email-masked]>
To:     Clarence Filsfils <[email-masked]><mailto:[email-masked]>, Ahmed Bashandy <[email-masked]><mailto:[email-masked]>, Prodosh Mohapatra <[email-masked]><mailto:[email-masked]>, "Pradosh Mohapatra" <[email-masked]><mailto:[email-masked]>

Abstract:

The IETF Secretariat

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 10 Nov 2015 03:21:32 +0000

I support this document on the Informational track. BGP PIC is a useful mechanism for speeding convergence and this describes many of the use cases in the context of a conceptual forwarding plane implementation.
Thanks,
Acee

From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, November 10, 2015 at 10:47 AM
To: "Ahmed Bashandy (bashandy)" <[email-masked]<mailto:[email-masked]>>, Chris Bowers <[email-masked]<mailto:[email-masked]>>
Cc: Pradosh Mohapatra <[email-masked]<mailto:[email-masked]>>, Routing WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: Request for WG adoption of draft-bashandy-rtgwg-bgp-pic-02.txt

Dear RTGWG,

Cheers,
Jeff & Chris

Hi,

Thanks

Ahmed

-------- Original Message --------
Subject:        New Version Notification for draft-bashandy-rtgwg-bgp-pic-02.txt
Date:   Mon, 9 Nov 2015 16:05:59 -0800
From:   <[email-masked]><mailto:[email-masked]>
To:     Clarence Filsfils <[email-masked]><mailto:[email-masked]>, Ahmed Bashandy <[email-masked]><mailto:[email-masked]>, Prodosh Mohapatra <[email-masked]><mailto:[email-masked]>, "Pradosh Mohapatra" <[email-masked]><mailto:[email-masked]>

Abstract:

The IETF Secretariat

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Tue, 10 Nov 2015 05:09:26 +0000

I support adopting this draft

From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Date: Tuesday 10 November 2015 at 02:47
To: "Ahmed Bashandy (bashandy)" <[email-masked]<mailto:[email-masked]>>, Chris Bowers <[email-masked]<mailto:[email-masked]>>
Cc: Pradosh Mohapatra <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Request for WG adoption of draft-bashandy-rtgwg-bgp-pic-02.txt

Dear RTGWG,

Cheers,
Jeff & Chris

Hi,

Thanks

Ahmed

-------- Original Message --------
Subject:        New Version Notification for draft-bashandy-rtgwg-bgp-pic-02.txt
Date:   Mon, 9 Nov 2015 16:05:59 -0800
From:   <[email-masked]><mailto:[email-masked]>
To:     Clarence Filsfils <[email-masked]><mailto:[email-masked]>, Ahmed Bashandy <[email-masked]><mailto:[email-masked]>, Prodosh Mohapatra <[email-masked]><mailto:[email-masked]>, "Pradosh Mohapatra" <[email-masked]><mailto:[email-masked]>

Abstract:

The IETF Secretariat

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Tue, 10 Nov 2015 05:12:00 +0000

I agree I support the document as a WG doc. It is widely implemented and used in networks.

From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of "Acee Lindem (acee)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday 10 November 2015 at 04:21
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, "Ahmed Bashandy (bashandy)" <[email-masked]<mailto:[email-masked]>>, Chris Bowers <[email-masked]<mailto:[email-masked]>>
Cc: Pradosh Mohapatra <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Request for WG adoption of draft-bashandy-rtgwg-bgp-pic-02.txt

Dear RTGWG,

Cheers,
Jeff & Chris

Hi,

Thanks

Ahmed

-------- Original Message --------
Subject:        New Version Notification for draft-bashandy-rtgwg-bgp-pic-02.txt
Date:   Mon, 9 Nov 2015 16:05:59 -0800
From:   <[email-masked]><mailto:[email-masked]>
To:     Clarence Filsfils <[email-masked]><mailto:[email-masked]>, Ahmed Bashandy <[email-masked]><mailto:[email-masked]>, Prodosh Mohapatra <[email-masked]><mailto:[email-masked]>, "Pradosh Mohapatra" <[email-masked]><mailto:[email-masked]>

Abstract:

The IETF Secretariat

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Tue, 10 Nov 2015 05:48:19 +0000

Support.
Valuable description of a useful feature.

   Les

From: rtgwg [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Monday, November 09, 2015 5:47 PM
To: Ahmed Bashandy (bashandy); Chris Bowers
Cc: Pradosh Mohapatra; [email-masked]
Subject: Re: Request for WG adoption of draft-bashandy-rtgwg-bgp-pic-02.txt

Dear RTGWG,

Cheers,
Jeff & Chris

Hi,

Thanks

Ahmed

-------- Original Message --------
Subject:

New Version Notification for draft-bashandy-rtgwg-bgp-pic-02.txt

Date:

Mon, 9 Nov 2015 16:05:59 -0800

From:

<[email-masked]><mailto:[email-masked]>

To:

Clarence Filsfils <[email-masked]><mailto:[email-masked]>, Ahmed Bashandy <[email-masked]><mailto:[email-masked]>, Prodosh Mohapatra <[email-masked]><mailto:[email-masked]>, "Pradosh Mohapatra" <[email-masked]><mailto:[email-masked]>

IETF repository.

Revision:     02

Title:        Abstract

Pages:        26

Abstract:

ECMP or primary-backup.

The IETF Secretariat

---

From: <[email-masked]>
Date: Wed, 11 Nov 2015 00:06:40 +0000

Hi,

I support this document.

While this document does not describe “bytes on the wire”, IMO it’s useful to have a vendor independent description and terminology.
While this is old stuff, this is (really) good stuff.  (still, doing this 10 years ago would have been more valuable)

I had read it and commented the week before the IETF. Ahmed has already updated it. (some follow up may still be required).

Thanks
-- Bruno

Sent: Tuesday, November 10, 2015 2:47 AM

Dear RTGWG,

Cheers,
Jeff & Chris

Hi,

Thanks

Ahmed

-------- Original Message --------
Subject:

Date:

From:

To:

IETF repository.

Revision:     02

Title:        Abstract

Pages:        26

Abstract:

ECMP or primary-backup.

The IETF Secretariat

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Loa Andersson <[email-masked]>
Date: Wed, 11 Nov 2015 10:54:56 +0800

Folks,

Yes this is a useful document, we should go ahead and publish it.

/Loa

On 2015-11-10 11:21, Acee Lindem (acee) wrote:
> I support this document on the Informational track. BGP PIC is a useful
> mechanism for speeding convergence and this describes many of the use
> cases in the context of a conceptual forwarding plane implementation.
> Thanks,
> Acee
>
> From: rtgwg <[email-masked] <mailto:[email-masked]>> on
> behalf of Jeff Tantsura <[email-masked]
> <mailto:[email-masked]>>
> To: "Ahmed Bashandy (bashandy)" <[email-masked]
> <mailto:[email-masked]>>, Chris Bowers <[email-masked]
> <mailto:[email-masked]>>
> Cc: Pradosh Mohapatra <[email-masked] <mailto:[email-masked]>>,
> Routing WG <[email-masked] <mailto:[email-masked]>>
>     The authors have requested the RTGWG to adopt
>     draft-bashandy-rtgwg-bgp-pic-02 as the working group document with
>     Informational intended status.
>
>     If you are listed as a document author or contributor please respond
>     to this email stating of whether or not you are aware of any
>     relevant IPR. The response needs to be sent to the RTGWG mailing
>     list. The document will not advance to the next stage until a
>     response has been received from each author and each individual that
>     has contributed to the document.
>
>     Cheers,
>     Jeff & Chris
>
>     To: Jeff Tantsura <[email-masked]
>     <mailto:[email-masked]>>, Chris Bowers
>     <[email-masked] <mailto:[email-masked]>>
>     Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked]
>     <mailto:[email-masked]>>, Clarence Filsfils <[email-masked]
>     <mailto:[email-masked]>>, Pradosh Mohapatra <[email-masked]
>     <mailto:[email-masked]>>
>     This is the latest version of the BGP-PIC draft that was presented
>     on Nov/2/15 during the IETF-94 meeting in Yokohama
>     - Added example in Section 2.3.3 with illustrations in Figure 4,5,6
>     on how to handle a platform that does not support the required
>     number of hierarchy levels.  Section 4.3 explains the gradual
>     degradation of BGP-PIC benefit as a result of the reduced platform
>     support
>     - For handling unlabeled traffic in case PE-CE failure, the last
>     bullet in Section 4.2.2 indicates that an egress PE must always
>     treat a core facing path as a backup path to avoid looping the
>     packet in case of PE-CE link failure. The first statement in Section
>     5.1 indicates that the draft does not cover the failure of a CE node
>
>
>     <[email-masked]>, Prodosh Mohapatra <[email-masked]>,
>     "Pradosh Mohapatra" <[email-masked]>
>
>
>
>     URL:https://www.ietf.org/internet-drafts/draft-bashandy-rtgwg-bgp-pic-02.txt
>     Status:https://datatracker.ietf.org/doc/draft-bashandy-rtgwg-bgp-pic/
>     Htmlized:https://tools.ietf.org/html/draft-bashandy-rtgwg-bgp-pic-02
>     Diff:https://www.ietf.org/rfcdiff?url2=draft-bashandy-rtgwg-bgp-pic-02
>
>     Abstract:
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg
>

---

From: Jon Mitchell <[email-masked]>
Date: Tue, 10 Nov 2015 23:50:38 -0500

Support adoption.

-Jon

> On Nov 9, 2015, at 8:47 PM, Jeff Tantsura <[email-masked]> wrote:
> 
> Dear RTGWG,
> 
> From: "Ahmed Bashandy (bashandy)" <[email-masked]>
> To: Jeff Tantsura <[email-masked]>, Chris Bowers <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, Clarence Filsfils <[email-masked]>, Pradosh Mohapatra <[email-masked]>
> To:	Clarence Filsfils <[email-masked]>, Ahmed Bashandy <[email-masked]>, Prodosh Mohapatra <[email-masked]>, "Pradosh Mohapatra" <[email-masked]>
>

---

From: Shyam Sethuram <[email-masked]>
Date: Tue, 10 Nov 2015 23:04:53 -0800

Support adoption. There are mature implementations of this.

thanks--shyam

On Mon, Nov 9, 2015 at 4:25 PM, Ahmed Bashandy (bashandy) <
[email-masked]> wrote:

> - Added example in Section 2.3.3 with illustrations in Figure 4,5,6 on how
> to handle a platform that does not support the required number of hierarchy
> levels.  Section 4.3 explains the gradual degradation of BGP-PIC benefit as
> a result of the reduced platform support
> - For handling unlabeled traffic in case PE-CE failure, the last bullet in
> Section 4.2.2 indicates that an egress PE must always treat a core facing
> path as a backup path to avoid looping the packet in case of PE-CE link
> failure. The first statement in Section 5.1 indicates that the draft does
> not cover the failure of a CE node
>
>
> -------- Original Message -------- Subject: New Version Notification for
> draft-bashandy-rtgwg-bgp-pic-02.txt Date: Mon, 9 Nov 2015 16:05:59 -0800 From:
> <[email-masked]> <[email-masked]> To: Clarence
> Filsfils <[email-masked]> <[email-masked]>, Ahmed Bashandy
> <[email-masked]> <[email-masked]>, Prodosh Mohapatra
> <[email-masked]> <[email-masked]>, "Pradosh Mohapatra"
> <[email-masked]> <[email-masked]>
>

---

From: "Robert Hanzl (rhanzl)" <[email-masked]>
Date: Wed, 11 Nov 2015 07:44:17 +0000

Support adoption

Robert

On 11 Nov 2015, at 08:04, Shyam Sethuram <[email-masked]<mailto:[email-masked]>> wrote:

thanks--shyam

On Mon, Nov 9, 2015 at 4:25 PM, Ahmed Bashandy (bashandy) <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Thanks

Ahmed

-------- Original Message --------
Subject:        New Version Notification for draft-bashandy-rtgwg-bgp-pic-02.txt
Date:   Mon, 9 Nov 2015 16:05:59 -0800
From:   <[email-masked]><mailto:[email-masked]>
To:     Clarence Filsfils <[email-masked]><mailto:[email-masked]>, Ahmed Bashandy <[email-masked]><mailto:[email-masked]>, Prodosh Mohapatra <[email-masked]><mailto:[email-masked]>, "Pradosh Mohapatra" <[email-masked]><mailto:[email-masked]>

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

The IETF Secretariat

_______________________________________________
rtgwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtgwg

_______________________________________________
rtgwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtgwg

---

From: Antoni Przygienda <[email-masked]>
Date: Wed, 11 Nov 2015 17:09:02 +0000

Clear adoption … either as INFO or maybe even BCP makes good sense.

thanks

--- tony
_____________________________________________
“Simple, clear purpose and principles give rise to complex and intelligent behavior. Complex rules and regulations give rise to simple and stupid behavior.”
--- Dee Hock

From: rtgwg [mailto:[email-masked]] On Behalf Of Ahmed Bashandy (bashandy)
Sent: Monday, November 09, 2015 4:25 PM
To: Jeff Tantsura; Chris Bowers
Cc: Pradosh Mohapatra; [email-masked]
Subject: Request for WG adoption of draft-bashandy-rtgwg-bgp-pic-02.txt

Hi,

Thanks

Ahmed

-------- Original Message --------
Subject:

Date:

From:

To:

IETF repository.

Revision:      02

Title:         Abstract

Pages:         26

Abstract:

ECMP or primary-backup.

The IETF Secretariat

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Thu, 12 Nov 2015 10:57:25 +0000

I support this draft.

s.

> On Nov 10, 2015, at 2:47 AM, Jeff Tantsura <[email-masked]> wrote:
> 
> Dear RTGWG,
> 
> URL:            
> https://www.ietf.org/internet-drafts/draft-bashandy-rtgwg-bgp-pic-02.txt
> 
> Status:         
> https://datatracker.ietf.org/doc/draft-bashandy-rtgwg-bgp-pic/
> 
> Htmlized:       
> https://tools.ietf.org/html/draft-bashandy-rtgwg-bgp-pic-02
> 
> Diff:           
> https://www.ietf.org/rfcdiff?url2=draft-bashandy-rtgwg-bgp-pic-02
> 
> 
> Abstract:

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 17 Nov 2015 16:04:42 -0500

> Please indicate support or no-support by November 15, 2015.

I'm a few days late, but I support adoption.

-- Jeff

---

From: "Derek Man-Kit Yeung (myeung)" <[email-masked]>
Date: Tue, 17 Nov 2015 21:08:22 +0000

Supported.

- Derek