Subject: RE: WG adoption poll on draft-nitish-vrrp-bfd-04

From: Chris Bowers <[email-masked]>
Date: Thu, 20 Oct 2016 15:10:48 +0000

RTGWG,

At this point, I don't think that there is a consensus for the working group to adopt this draft
without more discussion of the issue raised by Loa Andersson and Adrian Farrel in the
following two emails.

https://www.ietf.org/mail-archive/web/rtgwg/current/msg05712.html
https://www.ietf.org/mail-archive/web/rtgwg/current/msg05718.html

The main objection raised in these two emails is that the working group should work on
solutions that are either unencumbered by IPR or that are available on free-to-implementers
terms.   Loa and Adrian also point out that the current lack of visibility to the patent
application covered by the IPR disclosure for this draft means that it is currently not possible to
evaluate this situation with respect to this draft.

The reason for the IPR disclosure process is to allow working groups to take into consideration
the potential licensing of IPR when evaluating alternative technical solutions.  At this point,
adopting draft-nitish-vrrp-bfd-04 as the basis for work on standardizing the use of VRRP
with BFD without more discussion of this issue would imply that there is consensus that
the working group should not take potential licensing of IPR into account for this work.
I don't think there is currently consensus for this.

I encourage further discussion of this issue. I think that there may be the potential to
reach a consensus if the working group can come to an explicit agreement about whether
or not potential licensing of IPR should be taken into account when evaluating alternative
technologies for this work.

Chris

_____________________________________________
From: Chris Bowers
Sent: Thursday, September 29, 2016 10:44 AM
To: [email-masked]' <[email-masked]>; [email-masked]
Subject: WG adoption poll on draft-nitish-vrrp-bfd-04

RTGWG,

This email starts a two week poll to gauge consensus on adopting draft-nitish-vrrp-bfd-04
as an RTGWG working group document.

The BFD working group is also copied on this adoption poll.  We encourage participants in
BFD working group to provide their input on the adoption poll.  And should this document
be adopted as an RTGWG document, we would plan to copy the BFD WG on emails
related to this document to benefit from the BFD expertise in that WG in the development
of this document.

Please send your comments to the RTGWG mailing list ([email-masked]<mailto:[email-masked]>) indicating support
or opposition to the adoption of this document, along with the reasoning for that support
or opposition.

If you are listed as a document author or contributor, please respond to this email stating
whether or not you are aware of any relevant IPR.   The response needs to be sent to the
RTGWG mailing list. The document will not advance to the next stage until a response has
been received from each author and each individual that has contributed to the document.

At this point, the document has the following IPR disclosure associated with it.
https://datatracker.ietf.org/ipr/2739/

This adoption poll will end on Friday October 14th.

Thanks,
Chris and Jeff

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 26 Oct 2016 15:20:11 +0100

It might (or might not :-) help if I give some clarification of my position on
this draft.
[I'm not trying to tell the chairs how to do their job!]
 
We are not in a position at the moment to make our own individual assessments of
whether or how the disclosed IPR covers the draft. This is because we cannot yet
see the content of the IPR filed in the disclosed application. That means we can
take one of two approaches:
 
1. Assume that the IPR covers a substantial portion of the draft
2. Wait and see
 
In the first case we have to decide whether we want to go ahead with this work
on that assumption and in the knowledge of the licensing terms. The alternatives
are:
a. Abandon the work
b. Re-invent the solution to avoid the IPR (which necessarily involves waiting
until we can read it)
c. Carry on regardless deciding that we are willing to live with the disclosure
 
In the second case we would delay progression until we can see the IPR and
decide what to do. The alternative would then be exactly the same a, b, and c as
above.
 
It might be pragmatic to continue to work on the current draft. That work could
happen without adoption (lack of adoption is not reason not to work on the
draft, and the unadopted draft can still be "under the care of the WG") or could
include adoption. If the draft is adopted, however, I would be very wary of the
implied momentum: that is, when the WG has been working on the draft for a while
it must not be taken to imply that any consensus was reached with respect to the
IPR and it must be understood that the discussion was deferred not concluded.
Future arguments that "we have invested so much time and effort" will not carry
water!
 
All that considered, I would be OK to see work continue on the document pending
availability of the IPR in the hope that when we can see the IPR we will attempt
to find a solution that avoids the IPR.
 
Cheers,
Adrian

From: rtgwg [mailto:[email-masked]] On Behalf Of Chris Bowers
Sent: 20 October 2016 16:11
To: [email-masked]; [email-masked]
Subject: RE: WG adoption poll on draft-nitish-vrrp-bfd-04
 
RTGWG,
 
At this point, I don't think that there is a consensus for the working group to
adopt this draft 
without more discussion of the issue raised by Loa Andersson and Adrian Farrel
in the
following two emails.

The main objection raised in these two emails is that the working group should
work on 
solutions that are either unencumbered by IPR or that are available on
free-to-implementers
terms.   Loa and Adrian also point out that the current lack of visibility to
the patent 
application covered by the IPR disclosure for this draft means that it is
currently not possible to 
evaluate this situation with respect to this draft.
 
The reason for the IPR disclosure process is to allow working groups to take
into consideration
the potential licensing of IPR when evaluating alternative technical solutions.
At this point, 
adopting draft-nitish-vrrp-bfd-04 as the basis for work on standardizing the use
of VRRP 
with BFD without more discussion of this issue would imply that there is
consensus that 
the working group should not take potential licensing of IPR into account for
this work.
I don't think there is currently consensus for this.
 
I encourage further discussion of this issue. I think that there may be the
potential to
reach a consensus if the working group can come to an explicit agreement about
whether
or not potential licensing of IPR should be taken into account when evaluating
alternative 
technologies for this work.
 
Chris

RTGWG,
 
This email starts a two week poll to gauge consensus on adopting
draft-nitish-vrrp-bfd-04
as an RTGWG working group document.
 
The BFD working group is also copied on this adoption poll.  We encourage
participants in 
BFD working group to provide their input on the adoption poll.  And should this
document
be adopted as an RTGWG document, we would plan to copy the BFD WG on emails 
related to this document to benefit from the BFD expertise in that WG in the
development 
of this document.
 
Please send your comments to the RTGWG mailing list ( <mailto:[email-masked]>
[email-masked]) indicating support 
or opposition to the adoption of this document, along with the reasoning for
that support
or opposition.  
 
If you are listed as a document author or contributor, please respond to this
email stating
whether or not you are aware of any relevant IPR.   The response needs to be
sent to the 
RTGWG mailing list. The document will not advance to the next stage until a
response has
been received from each author and each individual that has contributed to the
document.
 
At this point, the document has the following IPR disclosure associated with it.
 <https://datatracker.ietf.org/ipr/2739/> https://datatracker.ietf.org/ipr/2739/

Thanks,
Chris and Jeff

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 27 Oct 2016 11:25:31 -0700

Dear All,
to the best of my knowledge and understanding the disclosed IPR may be
relevant only to Section 4.

Regards,
Greg

On Wed, Oct 26, 2016 at 7:20 AM, Adrian Farrel <[email-masked]> wrote:

> It might (or might not :-) help if I give some clarification of my
> position on this draft.
>
> We are not in a position at the moment to make our own individual
> assessments of whether or how the disclosed IPR covers the draft. This is
> because we cannot yet see the content of the IPR filed in the disclosed
> application. That means we can take one of two approaches:
>
>
>
> In the first case we have to decide whether we want to go ahead with this
> work on that assumption and in the knowledge of the licensing terms. The
> alternatives are:
>
> a. Abandon the work
>
> b. Re-invent the solution to avoid the IPR (which necessarily involves
> waiting until we can read it)
>
> decide what to do. The alternative would then be exactly the same a, b, and
> c as above.
>
>
>
> It might be pragmatic to continue to work on the current draft. That work
> could happen without adoption (lack of adoption is not reason not to work
> on the draft, and the unadopted draft can still be "under the care of the
> WG") or could include adoption. If the draft is adopted, however, I would
> be very wary of the implied momentum: that is, when the WG has been working
> on the draft for a while it must not be taken to imply that any consensus
> was reached with respect to the IPR and it must be understood that the
> discussion was deferred not concluded. Future arguments that "we have
> invested so much time and effort" will not carry water!
>
>
>
> All that considered, I would be OK to see work continue on the document
> pending availability of the IPR in the hope that when we can see the IPR we
> will attempt to find a solution that avoids the IPR.
>
>
>
> Cheers,
>
> Adrian
>
>
>
>
>
> *From:* rtgwg [mailto:[email-masked]] *On Behalf Of *Chris Bowers
> *Sent:* 20 October 2016 16:11
> *To:* [email-masked]; [email-masked]
> *Subject:* RE: WG adoption poll on draft-nitish-vrrp-bfd-04
>
>
>
> RTGWG,
>
>
>
> At this point, I don’t think that there is a consensus for the working
> group to adopt this draft
>
> I don’t think there is currently consensus for this.
>
>
>
> *From:* Chris Bowers
> *Sent:* Thursday, September 29, 2016 10:44 AM
> *To:* [email-masked]' <[email-masked]>; [email-masked]
> *Subject:* WG adoption poll on draft-nitish-vrrp-bfd-04
>
>
>
>
>
> RTGWG,
>
>
>
> Please send your comments to the RTGWG mailing list ([email-masked])
> indicating support
>
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg
>
>

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 27 Oct 2016 15:02:00 -0400

Greg,

Section 4 (of version -04) only deals with p2mp BFD and section 3 provides a unicast solution.

If your employer can issue an appropriate clarification that section 3 is not covered, it's possible the draft might be able to proceed.  Procedures in section 4 can always be covered in a different document.

(For the WGs) It's worth noting that previously both of these solutions lived in separate documents prior to merge since they covered related solution spaces.  The authors merged the proposals at the request of the impacted working groups.

-- Jeff

> On Oct 27, 2016, at 2:25 PM, Greg Mirsky <[email-masked]> wrote:
> 
> Dear All,
> to the best of my knowledge and understanding the disclosed IPR may be relevant only to Section 4. 
> 
> Regards,
> Greg
> 
> On Wed, Oct 26, 2016 at 7:20 AM, Adrian Farrel <[email-masked] <mailto:[email-masked]>> wrote:
> It might (or might not :-) help if I give some clarification of my position on this draft.
> 
> We are not in a position at the moment to make our own individual assessments of whether or how the disclosed IPR covers the draft. This is because we cannot yet see the content of the IPR filed in the disclosed application. That means we can take one of two approaches:
> 
>  
> 
> In the first case we have to decide whether we want to go ahead with this work on that assumption and in the knowledge of the licensing terms. The alternatives are:
> 
> a. Abandon the work
> 
> b. Re-invent the solution to avoid the IPR (which necessarily involves waiting until we can read it)
> 
> In the second case we would delay progression until we can see the IPR and decide what to do. The alternative would then be exactly the same a, b, and c as above.
> 
>  
> 
> It might be pragmatic to continue to work on the current draft. That work could happen without adoption (lack of adoption is not reason not to work on the draft, and the unadopted draft can still be "under the care of the WG") or could include adoption. If the draft is adopted, however, I would be very wary of the implied momentum: that is, when the WG has been working on the draft for a while it must not be taken to imply that any consensus was reached with respect to the IPR and it must be understood that the discussion was deferred not concluded. Future arguments that "we have invested so much time and effort" will not carry water!
> 
>  
> 
> All that considered, I would be OK to see work continue on the document pending availability of the IPR in the hope that when we can see the IPR we will attempt to find a solution that avoids the IPR.
> 
>  
> 
> Cheers,
> 
> Adrian
> 
>  
> 
>  
> 
> From: rtgwg [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Chris Bowers
> To: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> At this point, I don’t think that there is a consensus for the working group to adopt this draft
> 
> https://www.ietf.org/mail-archive/web/rtgwg/current/msg05712.html <https://www.ietf.org/mail-archive/web/rtgwg/current/msg05712.html>
> https://www.ietf.org/mail-archive/web/rtgwg/current/msg05718.html <https://www.ietf.org/mail-archive/web/rtgwg/current/msg05718.html>
>  
> 
> To: [email-masked] <mailto:[email-masked]>' <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> Please send your comments to the RTGWG mailing list ([email-masked] <mailto:[email-masked]>) indicating support
> 
> https://datatracker.ietf.org/ipr/2739/ <https://datatracker.ietf.org/ipr/2739/>
>  
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rtgwg <https://www.ietf.org/mailman/listinfo/rtgwg>
> 
>