Subject: Re: WG adoption poll on draft-nitish-vrrp-bfd-04

From: Loa Andersson <[email-masked]>
Date: Sun, 9 Oct 2016 20:55:12 +0800

Folks,

When the mpls wg last called draft-ietf-mpls-bfd-directed we received
the following comment related the IPRs disclosed for this document:

   "Ross, thanks for this notice.
    I need to read the IPR referenced by the disclosure, but pending
    that, I do not support this document going forward in its current
    state.

    I think it is important for the working group to seek to develop
    solutions that either completely unencumbered by IPR or that is
    available on free-to-implementers terms. It may turn out that this
    is not possible with the disclosed IPR, but I think the WG should
    try.

    For the avoidance of doubt: I am not making any comment on the
    IPR-holder's rights to impose whatever license they want, and I am
    not asking them to vary their terms.

    I do note that it would be convenient if the IPR holder updated the
    disclosure to show that it applies to the current WG draft.

    Thanks,

    Adrian"

The document has since then been blocked by failure to reach a
consensus on the IPR. In the mean time there has also been new
technical comments that the authors tried to address.

The Patent application referred to in the disclosure is:

Appl no: US Serial No.: 14/512,259
Appl date: October 13, 2014

Later updated to:
Patent, Serial, Publication, Registration, or Application/File number(s)
US Serial No: 14/846580, filed Sept 4, 2015

This document has a very similar (not to say identical) IPR disclosure
referencing:

Appl.No: US Serial No: 14/512.259
Appl.date: October 13, 2014

(for some reason this has not been updated.

I note the same thing as Adrian, it would be convenient if the IPR
holder updated the disclosure to show that it applies to the current
WG draft(s).

For the time being and for the very same reason that apply to the mpls
wg document I do not support this document being adopted as a wg doc,
unless it is clearly stated that the goal is to create a standard that
is that the working group to seek to develop a solution that either is
completely unencumbered by IPR or that is available on free-to-
implement terms.

/Loa

On 29/09/2016 23:44, Chris Bowers wrote:
> RTGWG,
>
> This email starts a two week poll to gauge consensus on adopting
> draft-nitish-vrrp-bfd-04
> as an RTGWG working group document.
>
> The BFD working group is also copied on this adoption poll.  We
> encourage participants in
> BFD working group to provide their input on the adoption poll.  And
> should this document
> be adopted as an RTGWG document, we would plan to copy the BFD WG on emails
> related to this document to benefit from the BFD expertise in that WG in
> the development
> of this document.
>
> Please send your comments to the RTGWG mailing list ([email-masked]
> <mailto:[email-masked]>) indicating support
> or opposition to the adoption of this document, along with the reasoning
> for that support
> or opposition.
>
> If you are listed as a document author or contributor, please respond to
> this email stating
> whether or not you are aware of any relevant IPR.   The response needs
> to be sent to the
> RTGWG mailing list. The document will not advance to the next stage
> until a response has
> been received from each author and each individual that has contributed
> to the document.
>
> At this point, the document has the following IPR disclosure associated
> with it.
> _https://datatracker.ietf.org/ipr/2739/_
>
> This adoption poll will end on Friday October 14^th .
>
> Thanks,
> Chris and Jeff
>
>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 11 Oct 2016 14:48:23 +0000

While I originally didn’t think this was necessary, I can see the use case and support RTG WG adoption.
Thanks,
Acee

From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of Chris Bowers <[email-masked]<mailto:[email-masked]>>
Date: Thursday, September 29, 2016 at 11:44 AM
To: Routing WG <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: WG adoption poll on draft-nitish-vrrp-bfd-04

RTGWG,

This email starts a two week poll to gauge consensus on adopting draft-nitish-vrrp-bfd-04
as an RTGWG working group document.

The BFD working group is also copied on this adoption poll.  We encourage participants in
BFD working group to provide their input on the adoption poll.  And should this document
be adopted as an RTGWG document, we would plan to copy the BFD WG on emails
related to this document to benefit from the BFD expertise in that WG in the development
of this document.

Please send your comments to the RTGWG mailing list ([email-masked]<mailto:[email-masked]>) indicating support
or opposition to the adoption of this document, along with the reasoning for that support
or opposition.

If you are listed as a document author or contributor, please respond to this email stating
whether or not you are aware of any relevant IPR.   The response needs to be sent to the
RTGWG mailing list. The document will not advance to the next stage until a response has
been received from each author and each individual that has contributed to the document.

At this point, the document has the following IPR disclosure associated with it.
https://datatracker.ietf.org/ipr/2739/

This adoption poll will end on Friday October 14th.

Thanks,
Chris and Jeff

---

From: Pushpasis Sarkar <[email-masked]>
Date: Wed, 12 Oct 2016 11:30:48 +0530

Support.

Thanks
-Pushpasis

On Thu, Sep 29, 2016 at 9:14 PM, Chris Bowers <[email-masked]> wrote:

> Please send your comments to the RTGWG mailing list ([email-masked]*
> <[email-masked]>) indicating support
> *https://datatracker.ietf.org/ipr/2739/*
> <https://datatracker.ietf.org/ipr/2739/>
>
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg
>
>

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 12 Oct 2016 07:53:54 -0700

Yes/support as co-author

Regards, Greg

On Tue, Oct 11, 2016 at 11:00 PM, Pushpasis Sarkar <[email-masked]
> wrote:

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 12 Oct 2016 14:29:16 -0700

Support as co-author 

Cheers,

Jeff

RTGWG,

of this document.

Please send your comments to the RTGWG mailing list ([email-masked]) indicating support 

or opposition.  

Thanks,

Chris and Jeff

_______________________________________________ rtgwg mailing list [email-masked] https://www.ietf.org/mailman/listinfo/rtgwg

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 13 Oct 2016 20:41:51 +0100

Hi all,

Since Loa quotes me extensively from a thread about a completely different
draft, perhaps I had better state my opinion on this draft.

I hate to be standing in the way of progressing work that it is a clear a number
of people want to see move forward, but I find the IPR disclosure against this
draft to be inconvenient.

Since the reference is to an unpublished patent application we cannot look it up
to find out whether we (as individuals) think it applies to our implementations.
Furthermore, we can't try to work out a solution that is unencumbered because we
don't know what the patent application covers.

This might not be an issue except for the fact that the IPR disclosure seems to
include licensing terms that are different from the commonly used "Company will
not assert any patents owned or controlled by Company against any party for
making, using, selling, importing or offering for sale a product that implements
the standard, provided, however that Company retains the right to assert its
patents (including the right to claim past royalties) against any party that
asserts a patent it owns or controls (either directly or indirectly) against
Company."

I think it is important for the working group to seek to develop solutions that
either completely unencumbered by IPR or that are available on
free-to-implementers terms. It may turn out that this is not possible with the
disclosed IPR, but I think the WG should try.  In the current situation, I don't
see how the WG can make such an attempt until it has seen the IPR and so I do
not support the WG adopting the document at the moment. Circumstances may change
in the future.

To be clear, I am not asking IPR-holder to vary its commercial behaviour. I am
not making any comment on the IPR-holder's rights to impose whatever license
they want, and I am not asking them to vary their terms. 

Thanks,
Adrian

> -----Original Message-----
> From: rtgwg [mailto:[email-masked]] On Behalf Of Loa Andersson
> Sent: 09 October 2016 13:55
> To: [email-masked]; [email-masked]; [email-masked];
[email-masked];
> [email-masked]
> Subject: Re: WG adoption poll on draft-nitish-vrrp-bfd-04
> 
> Folks,
>

---

From: "Vengada Prasad Govindan (venggovi)" <[email-masked]>
Date: Fri, 14 Oct 2016 11:20:02 +0000

Have read the draft and think it is useful in addressing a valid use case. Hence I support its adoption.
Thanks
Prasad

From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Chris Bowers
Sent: Thursday, September 29, 2016 9:14 PM
To: [email-masked]; [email-masked]
Subject: WG adoption poll on draft-nitish-vrrp-bfd-04

RTGWG,

Thanks,
Chris and Jeff