Subject: Ben Campbell's No Objection on draft-ietf-rtgwg-uloop-delay-07: (with COMMENT)

From: Ben Campbell <[email-masked]>
Date: Wed, 11 Oct 2017 21:13:04 -0700

Ben Campbell has entered the following ballot position for
draft-ietf-rtgwg-uloop-delay-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-rtgwg-uloop-delay/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

(Oops, sorry, I entered the bit about addressing my comments for the wrong
draft.)

- General: Do I undertand correctly that this is a black-box implementation
detail? I note that section 4 explicitly says that it is a local-only feature
that does not require interoperability. If so, then standards track seems
inappropriate. BCP or informational seems to make more sense. Since there are
recommendations here, I think BCP is the right choice.  (I note Adam made a
similar comment.)

-11: Do you expect this section to stay in the RFC? It is likely to become
outdated rather quickly.

Editorial Comments:

- General: Please number the tables.

- sections 2 and 3 and their child sections have quite a few grammar errors.
Please proofread it again. I mention a few specifics below, but doubt I caught
everything.

- 2, first paragraph: " That means that all non-D neighbors of S on the
topology will send to S any traffic destined to D if a neighbor did not, then
that neighbor would be loop-free." I can't parse that sentence. Is it a run-on
sentence, or are there missing words? -- S / "can be work" / "can work"

-3: " may cause high damages for a network."
I suggest " may cause significant network damage".

-4, last paragraph: "This benefit comes at the expense of eliminating transient
forwarding loops involving the local router. " How is that an "expense"? Isn't
it the whole point?

-5.3, first paragraph and paragraph before figure 4:
The MUST is stated twice. Please avoid redundant normative statements. Even if
they agree now, they can cause maintenance issues down the road.

---

From: <[email-masked]>
Date: Thu, 12 Oct 2017 07:11:19 +0000

Hi Ben,

Thanks for your review, I will publish a revision soon addressing your comment.
The RFC type (BGP vs info vs STD) has been discussed in the WG, and we are following the way of LFA,rLFA... that are standard track RFCs. Please see the email attached.

Brgds,

-----Original Message-----
From: Ben Campbell [mailto:[email-masked]] 
Sent: Thursday, October 12, 2017 06:13
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Ben Campbell's No Objection on draft-ietf-rtgwg-uloop-delay-07: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

- General: Do I undertand correctly that this is a black-box implementation detail? I note that section 4 explicitly says that it is a local-only feature that does not require interoperability. If so, then standards track seems inappropriate. BCP or informational seems to make more sense. Since there are recommendations here, I think BCP is the right choice.  (I note Adam made a similar comment.)

-11: Do you expect this section to stay in the RFC? It is likely to become outdated rather quickly.

Editorial Comments:

- sections 2 and 3 and their child sections have quite a few grammar errors.
Please proofread it again. I mention a few specifics below, but doubt I caught everything.

- 2, first paragraph: " That means that all non-D neighbors of S on the topology will send to S any traffic destined to D if a neighbor did not, then that neighbor would be loop-free." I can't parse that sentence. Is it a run-on sentence, or are there missing words? -- S / "can be work" / "can work"

-4, last paragraph: "This benefit comes at the expense of eliminating transient forwarding loops involving the local router. " How is that an "expense"? Isn't it the whole point?

-5.3, first paragraph and paragraph before figure 4:
The MUST is stated twice. Please avoid redundant normative statements. Even if they agree now, they can cause maintenance issues down the road.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

Subject: Re: WG last call for draft-ietf-rtgwg-uloop-delay
From: Stewart Bryant <[email-masked]>
To: Chris Bowers <[email-masked]>, "Acee Lindem (acee)" <[email-masked]>, RTGWG <[email-masked]>
Date: Mon, 5 Jun 2017 15:34:14 +0000
List-Id: Routing Area Working Group <rtgwg.ietf.org>

I will accept whatever the consensus is.

- Stewart

On 05/06/2017 16:22, Chris Bowers wrote:

   Stewart,

   It seems to me that this document is not qualitatively different from the LFA, RLFA, and

   node-protecting LFA RFCs which were all published as standards track.  The behavior of the PLR

   in those documents is also a local matter, and in principle can be deployed on a single router without

   the knowledge of the rest of the network (except for allowing establishment of targeted LDP

   sessions in the case of remote LFA).

   Publishing this draft as standards track seems to be consistent with the decision made on those drafts.

   Chris

   From: Stewart Bryant [mailto:[email-masked]]
   Sent: Monday, June 5, 2017 4:48 AM
   To: Chris Bowers <[email-masked]><mailto:[email-masked]>; Acee Lindem (acee) <[email-masked]><mailto:[email-masked]>; RTGWG <[email-masked]><mailto:[email-masked]>
   Subject: Re: WG last call for draft-ietf-rtgwg-uloop-delay

   Hi Chris

   An RFC is surely sufficient to specify the behaviour of the router, and communicate to others the capability of a product.

   If multiple routers needed to act identically across the network I could see ST as better, but this is really a single router feature.

   - Stewart

   On 04/06/2017 17:47, Chris Bowers wrote:

      As a WG participant, I think standards track makes most sense, since it specifies a precise behavior for a router under certain conditions.  It is likely that network operators and software implementers will want to use the document as a means of communicating about whether or not a given implementation supports that precise behavior.  In my opinion, a standards track document is the best format to support that interaction.

      Chris

      From: Acee Lindem (acee) [mailto:[email-masked]]
      Sent: Saturday, June 3, 2017 6:05 PM
      To: Chris Bowers <[email-masked]><mailto:[email-masked]>; RTGWG <[email-masked]><mailto:[email-masked]>
      Subject: Re: WG last call for draft-ietf-rtgwg-uloop-delay

      I support advancement and publication of this draft.  I think we should have the discussion of whether or not it should be standards track, BCP, or informational as invariably this question will arise during all the reviews.

      Thanks,

      Acee

      From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of Chris Bowers <[email-masked]<mailto:[email-masked]>>
      Date: Friday, June 2, 2017 at 4:43 PM
      To: Routing WG <[email-masked]<mailto:[email-masked]>>
      Subject: WG last call for draft-ietf-rtgwg-uloop-delay

         RTGWG,

         This email starts the two week WG last call for draft-ietf-rtgwg-uloop-delay.

         Please indicate support for or opposition to the publication of this

         standards track document, along with the reasoning for that support or

         opposition.

         IPR:

         If you are listed as a document author or contributor, please respond to

         this email stating whether or not you are aware of any relevant IPR. The

         response needs to be sent to the RTGWG mailing list. The document will

         not advance to the next stage until a response has been received from

         each author and each individual that has contributed to the document.

         The document currently has the following IPR disclosure associated

         with it.

         https://datatracker.ietf.org/ipr/2565/

         This last call will end on Friday June 16th.

         Thanks,

         Chris and Jeff

      _______________________________________________
      rtgwg mailing list
      [email-masked]<mailto:[email-masked]>
      https://www.ietf.org/mailman/listinfo/rtgwg