Subject: Warren Kumari's No Objection on draft-ietf-rtgwg-uloop-delay-07: (with COMMENT)

From: Warren Kumari <[email-masked]>
Date: Wed, 11 Oct 2017 14:29:45 -0700

Warren Kumari has entered the following ballot position for
draft-ietf-rtgwg-uloop-delay-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-rtgwg-uloop-delay/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Section 1.  Introduction:
"That means that all non-D neighbors of S on the
   topology will send to S any traffic destined to D if a neighbor did
   not, then that neighbor would be loop-free."
 -- I was unable to parse the above. I may just be overtired, but it feels like
 there are some missing words.

Nits:
" When S-D fails, a transient forwarding loop may appear between S and
   B if S updates its forwarding entry to D before B."
 -- Perhaps "... entry to D before B does." or "... before B updates its
 forwarding entry"?

Section 2.1.  Fast reroute inefficiency
"On the  router C, the nexthop to D is the tunnel T thanks to the IGP 
shortcut." s/the//

"On C, the tail-end of the TE tunnel (router B) is no more on the shortest-path
tree (SPT) to D, ..." s/is no more on/is no longer on/ (related) "... so C does
not encapsulate anymore the traffic to D..." s/does not encapsulate anymore/no
longer encapsulates/

Section 3.  Overview of the solution
"This ordered convergence, is similar to the ordered FIB ..."
s/,/ (superfluous).

---

From: <[email-masked]>
Date: Thu, 12 Oct 2017 06:50:26 +0000

Hi Warren,

Thanks for your review.

I will fix it in the next revision.

Brgds,

-----Original Message-----
From: Warren Kumari [mailto:[email-masked]] 
Sent: Wednesday, October 11, 2017 23:30
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Warren Kumari's No Objection on draft-ietf-rtgwg-uloop-delay-07: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Section 1.  Introduction:
"That means that all non-D neighbors of S on the
   topology will send to S any traffic destined to D if a neighbor did
   not, then that neighbor would be loop-free."
 -- I was unable to parse the above. I may just be overtired, but it feels like  there are some missing words.

Nits:
" When S-D fails, a transient forwarding loop may appear between S and
   B if S updates its forwarding entry to D before B."
 -- Perhaps "... entry to D before B does." or "... before B updates its  forwarding entry"?

Section 2.1.  Fast reroute inefficiency
"On the  router C, the nexthop to D is the tunnel T thanks to the IGP shortcut." s/the//

"On C, the tail-end of the TE tunnel (router B) is no more on the shortest-path tree (SPT) to D, ..." s/is no more on/is no longer on/ (related) "... so C does not encapsulate anymore the traffic to D..." s/does not encapsulate anymore/no longer encapsulates/

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.