Subject: I-D Action: draft-ietf-rtgwg-yang-vrrp-06.txt

From: [email-masked]
Date: Thu, 26 Oct 2017 12:01:07 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Routing Area Working Group WG of the IETF.

        Title           : A YANG Data Model for Virtual Router Redundancy Protocol (VRRP)
        Authors         : Xufeng Liu
                          Athanasios Kyparlis
                          Ravi Parikh
                          Acee Lindem
                          Mingui Zhang
	Filename        : draft-ietf-rtgwg-yang-vrrp-06.txt
	Pages           : 42
	Date            : 2017-10-26

Abstract:
   This document describes a data model for Virtual Router Redundancy
   Protocol (VRRP).  Both version 2 and version 3 of VRRP are covered.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rtgwg-yang-vrrp/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-rtgwg-yang-vrrp-06
https://datatracker.ietf.org/doc/html/draft-ietf-rtgwg-yang-vrrp-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-rtgwg-yang-vrrp-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Robert Wilton <[email-masked]>
Date: Fri, 27 Oct 2017 10:11:38 +0100

Hi authors,

One minor nit, I think that you need to update the tree diagram to show 
that the top level "vrrp" container is config false.

E.g.

OLD:

    module: ietf-vrrp
       +--rw vrrp
          +--ro <global operational states>
          +--ro statistics
             +--ro discontinuity-datetime?   yang:date-and-time
             +--ro <global statistics>

NEW:

    module: ietf-vrrp
       +--ro vrrp
          +--ro <global operational states>
          +--ro statistics
             +--ro discontinuity-datetime?   yang:date-and-time
             +--ro <global statistics>

Otherwise, looks good to me!

Thanks,
Rob

On 26/10/2017 20:01, [email-masked] wrote:
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg
> .
>

---

From: Xufeng Liu <[email-masked]>
Date: Fri, 27 Oct 2017 15:28:48 +0000

Hi Rob,

Thanks. The error has been fixed.

Also, after the discussions with the implementers, it has been agreed to remove the non-NMDA appendix.

Regards,
- Xufeng

From: Robert Wilton [mailto:[email-masked]]
Sent: Friday, October 27, 2017 5:12 AM
To: [email-masked]; [email-masked]
Subject: Re: I-D Action: draft-ietf-rtgwg-yang-vrrp-06.txt

Hi authors,

One minor nit, I think that you need to update the tree diagram to show that the top level "vrrp" container is config false.

E.g.

OLD:

   module: ietf-vrrp

      +--rw vrrp

         +--ro statistics

NEW:

   module: ietf-vrrp

      +--ro vrrp

         +--ro statistics

Thanks,
Rob

On 26/10/2017 20:01, [email-masked]<mailto:[email-masked]> wrote:

        Authors         : Xufeng Liu

                          Athanasios Kyparlis

                          Ravi Parikh

                          Acee Lindem

                          Mingui Zhang

 Pages           : 42

 Date            : 2017-10-26

Abstract:

rtgwg mailing list

[email-masked]<mailto:[email-masked]>