Subject: Eric Rescorla's No Objection on draft-ietf-rtgwg-uloop-delay-07: (with COMMENT)

From: Eric Rescorla <[email-masked]>
Date: Wed, 11 Oct 2017 14:42:31 -0700

Eric Rescorla has entered the following ballot position for
draft-ietf-rtgwg-uloop-delay-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-rtgwg-uloop-delay/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Line 115
   Consider the case in Figure 1 where S does not have an LFA to protect
   its traffic to D.  That means that all non-D neighbors of S on the
You need to define LFA.

Line 118
   topology will send to S any traffic destined to D if a neighbor did
   not, then that neighbor would be loop-free.  Regardless of the
   advanced fast-reroute (FRR) technique used, when S converges to the
This is not a grammatical sentence.

Line 132
        S ------ B
             1
        Figure 1
What do the numbers in this box mean? I assume they are route metrics, but you
need to say so.

Line 136
   When S-D fails, a transient forwarding loop may appear between S and
   B if S updates its forwarding entry to D before B.
Something seems to have gone badly wrong with this paragraph. Are these lines
supposed to be in the previous paragraph.

Line 326
      unstable.  As an example, [I-D.ietf-rtgwg-backoff-algo] defines a
      standard SPF delay algorithm.
You need to define SPF here.

Line 338
   1.  The Up/Down event is notified to the IGP.
Usually, one would say that the IGP is notified of...

Line 552
           S

             Figure 7
Is this the same as the previous figure with T running CEAB?

---

From: <[email-masked]>
Date: Thu, 12 Oct 2017 07:04:28 +0000

Hi Eric,

Thanks for your review, I will take care of your comments.

" Line 136
   When S-D fails, a transient forwarding loop may appear between S and
   B if S updates its forwarding entry to D before B.
Something seems to have gone badly wrong with this paragraph. Are these lines supposed to be in the previous paragraph."

[SLI] This is the postamble of the figure and not really a paragraph.

"             Figure 7
"

[SLI] What figure are you talking about when saying "the previous" ?
I think there is a copy/paste issue. The tunnel T is not used here.

Brgds,

-----Original Message-----
From: Eric Rescorla [mailto:[email-masked]] 
Sent: Wednesday, October 11, 2017 23:43
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Eric Rescorla's No Objection on draft-ietf-rtgwg-uloop-delay-07: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Line 115
   Consider the case in Figure 1 where S does not have an LFA to protect
   its traffic to D.  That means that all non-D neighbors of S on the You need to define LFA.

Line 118
   topology will send to S any traffic destined to D if a neighbor did
   not, then that neighbor would be loop-free.  Regardless of the
   advanced fast-reroute (FRR) technique used, when S converges to the This is not a grammatical sentence.

Line 132
        S ------ B
             1
        Figure 1
What do the numbers in this box mean? I assume they are route metrics, but you need to say so.

Line 136
   When S-D fails, a transient forwarding loop may appear between S and
   B if S updates its forwarding entry to D before B.
Something seems to have gone badly wrong with this paragraph. Are these lines supposed to be in the previous paragraph.

Line 326

Line 338

Line 552
           S

             Figure 7

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 12 Oct 2017 06:36:39 -0700

On Thu, Oct 12, 2017 at 12:04 AM, <[email-masked]> wrote:

> Something seems to have gone badly wrong with this paragraph. Are these
> lines supposed to be in the previous paragraph."
>

It's also not really readable in the context of that paragraph.

"             Figure 7
> I think there is a copy/paste issue. The tunnel T is not used here.

Hmm...I seem to have reviewed -06.

> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Something seems to have gone badly wrong with this paragraph. Are these
> lines supposed to be in the previous paragraph.
>
> Line 326
> ____________________________________________________________
> _____________________________________________________________
>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;