Subject: WG adoption for draft-hu-rtgwg-srv6-egress-protection

From: Jeff Tantsura <[email-masked]>
Date: Thu, 20 Feb 2020 11:02:25 -0800

Dear RTGWG,

The authors have requested RTGWG to adopt draft-hu-rtgwg-srv6-egress-protection as the working group document.
The draft has received support during IETF106 meeting, authors have addressed all the comments received, I expect new version that addresses latest comments from Yimin to be uploaded within few days.

Please indicate support or no-support by April 5, 2020.

If you are listed as a document author or contributor please respond to this
email stating of whether or not you are aware of any relevant IPR.
The response needs to be sent to the RTGWG mailing list. The document will not
advance to the next stage until a response has been received from each
author and each individual that has contributed to the document.

Cheers,
Jeff & Chris

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 20 Feb 2020 11:48:48 -0800

Dear Authors,
I have got a question about the switchover procedure in the scenario
described in Section 3. As I understand, P1 monitors the path to PE3 using,
for example, BFD. Once it detects the failure, P1 starts using the
pre-computed and pre-signaled path towards PE4. In order to do that, P1
does, as described in the text:

P1 modifies the packet before sending it to PE4.

I've looked for what are these modifications and, as I understand it, think
that it is an update to SRH, P1 appends the Mirror SID A4:1::3 to the
segment list. Is that correct understanding? If it is, I'm not sure that it
is a valid operation for P1? Have we heard from 6man experts about this?
I'd greatly appreciate your clarification on this as this mechanism, in my
understanding of the document, is the foundation of the proposed solution
and without it it may not be feasible.

Regards,
Greg

On Thu, Feb 20, 2020 at 11:02 AM Jeff Tantsura <[email-masked]>
wrote:

> Dear RTGWG,
>
> The authors have requested RTGWG to adopt
> draft-hu-rtgwg-srv6-egress-protection as the working group document.
> The draft has received support during IETF106 meeting, authors have
> addressed all the comments received, I expect new version that addresses
> latest comments from Yimin to be uploaded within few days.
>
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg
>

---

From: Jim Guichard <[email-masked]>
Date: Thu, 20 Feb 2020 15:29:03 -0500

Support

---

From: Huzhibo <[email-masked]>
Date: Fri, 21 Feb 2020 06:29:58 +0000

Dear RTGWG,

Support as a co-author. There is a Patent application related to the draft and in the process of IPR disclosure.

Thanks

Zhibo Hu
From: rtgwg [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Friday, February 21, 2020 3:02 AM
To: RTGWG <[email-masked]>; Routing WG <[email-masked]>
Subject: WG adoption for draft-hu-rtgwg-srv6-egress-protection

Dear RTGWG,

Cheers,
Jeff & Chris

---

From: Zhuangshunwan <[email-masked]>
Date: Fri, 21 Feb 2020 06:43:06 +0000

Support.

Dear RTGWG,

Cheers,
Jeff & Chris

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Fri, 21 Feb 2020 06:50:34 +0000

Yes, support. The solution described in this document is useful for egress protection, and the comments have been addressed, so support to adopt it.

Cheng

Dear RTGWG,

Cheers,
Jeff & Chris

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 21 Feb 2020 15:10:17 +0800

Support. I am not aware of any relevant IPR.

BR.
HuaNan

From: Jeff Tantsura
Date: 2020-02-21 03:02
To: RTGWG; Routing WG

Cheers,
Jeff & Chris

---

From: "Xiejingrong (Jingrong)" <[email-masked]>
Date: Fri, 21 Feb 2020 07:25:10 +0000

+1 support.

Thanks
Jingrong

From: rtgwg [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, February 21, 2020 3:10 PM
To: Jeff Tantsura <[email-masked]>; RTGWG <[email-masked]>; Routing WG <[email-masked]>
Subject: Re: WG adoption for draft-hu-rtgwg-srv6-egress-protection

Support. I am not aware of any relevant IPR..

BR.
HuaNan

From: Jeff Tantsura<mailto:[email-masked]>
Date: 2020-02-21 03:02
To: RTGWG<mailto:[email-masked]>; Routing WG<mailto:[email-masked]>
Subject: WG adoption for draft-hu-rtgwg-srv6-egress-protection
Dear RTGWG,

Cheers,
Jeff & Chris

---

From: Tao He(联通集团联通网络技术研究院本部) <[email-masked]>
Date: Fri, 21 Feb 2020 07:38:04 +0000

发件人: rtgwg <[email-masked]> 代表 Jeff Tantsura
发送时间: 2020年2月21日 3:02
收件人: RTGWG <[email-masked]>; Routing WG <[email-masked]>
主题: WG adoption for draft-hu-rtgwg-srv6-egress-protection

Dear RTGWG,

Cheers,
Jeff & Chris
如果您错误接收了该邮件，请通过电子邮件立即通知我们。请回复邮件到 [email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] ,you can unsubscribe from this mail. We will immediately remove your information from send catalogue of our.

---

From: Lizhenbin <[email-masked]>
Date: Fri, 21 Feb 2020 08:43:01 +0000

I support the adoption. It is a useful solutions for reliability and after refining the draft is ready for adoption.

Best Regards,
Zhenbin (Robin)

From: rtgwg [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Friday, February 21, 2020 3:02 AM
To: RTGWG <[email-masked]<mailto:[email-masked]>>; Routing WG <[email-masked]<mailto:[email-masked]>>
Subject: WG adoption for draft-hu-rtgwg-srv6-egress-protection

Dear RTGWG,

Cheers,
Jeff & Chris

---

From: Huzhibo <[email-masked]>
Date: Fri, 21 Feb 2020 10:01:46 +0000

Hi Greg:

    The behavior of PLR encapsulating Mirror Sid is the same as that of SRv6 Ti-LFA。draft-ietf-spring-srv6-network-programming section 5.1 has been mentioned that H.Encap is used to encapsulate the TiLFA Repair List, so this behavior will not modify the original SRH header.

Thanks

Zhibo Hu
From: rtgwg [mailto:[email-masked]] On Behalf Of Greg Mirsky
Sent: Friday, February 21, 2020 3:49 AM
To: Jeff Tantsura <[email-masked]>
Cc: Routing WG <[email-masked]>; RTGWG <[email-masked]>
Subject: Re: WG adoption for draft-hu-rtgwg-srv6-egress-protection

Dear Authors,
I have got a question about the switchover procedure in the scenario described in Section 3. As I understand, P1 monitors the path to PE3 using, for example, BFD. Once it detects the failure, P1 starts using the pre-computed and pre-signaled path towards PE4. In order to do that, P1 does, as described in the text:
P1 modifies the packet before sending it to PE4.
I've looked for what are these modifications and, as I understand it, think that it is an update to SRH, P1 appends the Mirror SID A4:1::3 to the segment list. Is that correct understanding? If it is, I'm not sure that it is a valid operation for P1? Have we heard from 6man experts about this?
I'd greatly appreciate your clarification on this as this mechanism, in my understanding of the document, is the foundation of the proposed solution and without it it may not be feasible.

Regards,
Greg

On Thu, Feb 20, 2020 at 11:02 AM Jeff Tantsura <[email-masked]<mailto:[email-masked]>> wrote:
Dear RTGWG,

Cheers,
Jeff & Chris
_______________________________________________
rtgwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtgwg

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 21 Feb 2020 17:04:40 +0000

Support to be adopted to WG draft.

Linda Dunbar

Dear RTGWG,

Cheers,
Jeff & Chris

---

From: "Wupeng (Baggio, NOS MKT)" <[email-masked]>
Date: Mon, 24 Feb 2020 01:08:15 +0000

Hi,Jeff & RTGWG,

Best Regards,
Peng.Wu

发件人: rtgwg [mailto:[email-masked]] 代表 Jeff Tantsura
发送时间: 2020年2月21日 3:02
收件人: RTGWG <[email-masked]>; Routing WG <[email-masked]>
主题: WG adoption for draft-hu-rtgwg-srv6-egress-protection

Dear RTGWG,

Cheers,
Jeff & Chris

---

From: Aijun Wang <[email-masked]>
Date: Mon, 24 Feb 2020 09:33:04 +0800

Hi, Folks: 
Support for the adoption.
The proposed protection mechanism and extension to the IGP protocol can mitigate effectively the failure influence of the SR path, is an interesting topic and need to be further studied.

Best Regards.

Aijun Wang
China Telecom

---

From: Xufeng Liu <[email-masked]>
Date: Mon, 24 Feb 2020 10:08:30 -0500

Support.

I am not aware of any relevant IPR.

Thanks,
- Xufeng

---

From: LEI LIU <[email-masked]>
Date: Mon, 24 Feb 2020 08:28:24 -0800

Thanks,
Best Regards,

Lei