Subject: Re: WG last call for draft-ietf-rtgwg-policy-model

From: Xufeng Liu <[email-masked]>
Date: Thu, 3 Sep 2020 12:35:06 -0400

I support the publication as a co-author.
I am not aware of any relevant IPR.

Thanks,
- Xufengh

On Mon, Aug 17, 2020 at 5:49 PM Chris Bowers <[email-masked]>
wrote:

> RTGWG,
>
> This email starts the two week WG last call for draft-ietf-rtgwg-policy-model.
>
> Please indicate support for, or opposition to, the publication of this
> document as Proposed Standard, along with the reasoning behind that support or
> opposition.
>
> Jeff Tantsura is a co-author of the document, so he won't be involved
> in judging consensus.
>
> IPR:
>
> If you are listed as a document author or contributor, please respond to
> this email stating whether or not you are aware of any relevant IPR. The
> response needs to be sent to the RTGWG mailing list. The document will
> not advance until a response has been received from each author and
> each individual that has contributed to the document.
>
> This WG last call will end on September 2, 2020.
>
> Thanks,
>
> Chris
>
>
>
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg
>

---

From: Chris Bowers <[email-masked]>
Date: Thu, 3 Sep 2020 15:50:12 -0500

RTGWG,

An objection has been raised with respect to requesting publication of
draft-ietf-rtgwg-policy-model at this time.  The main concern expressed is
that changes in draft-ietf-idr-bgp-model may require changes in
draft-ietf-rtgwg-policy-model.

The main area of concern is the text in section 7 of
draft-ietf-rtgwg-policy-model, which illustrates how the current version of
draft-ietf-idr-bgp-model augments rpol:defined-sets, rpol:conditions, and
rpol:actions with bp:bgp-defined-sets, bp:bgp-conditions, and
bp:bgp-actions.

I would like to suggest adding the following text to section 7 to make it
clear that this text is not normative.

=================
The example below provides an illustration of how another data model can
augment parts of this routing policy data model.
It uses specific examples from draft-ietf-idr-bgp-model-09 to show in a
concrete manner how the different pieces fit together.  This example is not
normative with respect to draft-ietf-idr-bgp-model.
=================

Would this text, or something similar, help to address this concern?

Thanks,
Chris

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 3 Sep 2020 20:51:36 +0000

Hi Chris,
I agree and will make the changes tomorrow.
Thanks,
Acee

From: rtgwg <[email-masked]> on behalf of Chris Bowers <[email-masked]>
Date: Thursday, September 3, 2020 at 4:50 PM
To: Routing WG <[email-masked]>, rtgwg-chairs <[email-masked]>
Subject: Re: WG last call for draft-ietf-rtgwg-policy-model

RTGWG,

An objection has been raised with respect to requesting publication of draft-ietf-rtgwg-policy-model at this time.  The main concern expressed is that changes in draft-ietf-idr-bgp-model may require changes in draft-ietf-rtgwg-policy-model.

The main area of concern is the text in section 7 of draft-ietf-rtgwg-policy-model, which illustrates how the current version of draft-ietf-idr-bgp-model augments rpol:defined-sets, rpol:conditions, and rpol:actions with bp:bgp-defined-sets, bp:bgp-conditions, and bp:bgp-actions.

I would like to suggest adding the following text to section 7 to make it clear that this text is not normative.

=================
The example below provides an illustration of how another data model can augment parts of this routing policy data model.
It uses specific examples from draft-ietf-idr-bgp-model-09 to show in a concrete manner how the different pieces fit together.  This example is not normative with respect to draft-ietf-idr-bgp-model.
=================

Thanks,
Chris

On Mon, Aug 17, 2020 at 4:45 PM Chris Bowers <[email-masked]<mailto:[email-masked]>> wrote:

RTGWG,

opposition.

IPR:

Thanks,

Chris

---

From: Yingzhen Qu <[email-masked]>
Date: Thu, 3 Sep 2020 22:31:59 +0000

Hi Chris,

Thank you for your suggestion, really appreciate. Version -21 has been uploaded with added text as you suggested.

Please let us know if you have any other comments.

Thanks,
Yingzhen

From: rtgwg <[email-masked]> on behalf of "Acee Lindem (acee)" <acee=[email-masked]>
Date: Thursday, September 3, 2020 at 1:52 PM
To: Chris Bowers <[email-masked]>, RTGWG <[email-masked]>, rtgwg-chairs <[email-masked]>
Subject: Re: WG last call for draft-ietf-rtgwg-policy-model
Resent-From: <[email-masked]>

Hi Chris,

RTGWG,

=================

Thanks,
Chris

RTGWG,

opposition.

IPR:

Thanks,

Chris

---

From: tom petch <[email-masked]>
Date: Fri, 4 Sep 2020 14:05:48 +0000

From: rtgwg <[email-masked]> on behalf of Chris Bowers <[email-masked]>
Sent: 03 September 2020 21:50

RTGWG,

=================

<tp>
mmm sounds like me:-)

I misread it at first as saying that the BGP model is not a Normative module as opposed to this not being a  Normative Reference but have not got a better wording.#
I would like something added about the prefix.  I commented on BGP that the prefix were not used consistently and were not a good choice in IMHO while the YANG doctor review suggests a major restructuring of BGP which could impact on the prefix.

I think that this module should spell out which BGP module it is referring to with this prefix and perhaps choose a prefix other than bp:  I think it should be bgp-... such as bgp-pol with all the BGP modules have prefixe bgp-... but that is of course for the IDR WG to decide.

Tom Petch

Thanks,
Chris

RTGWG,

IPR:

Thanks,

Chris

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 5 Sep 2020 20:55:10 +0000

Hi Tom, 

On 9/4/20, 10:06 AM, "rtgwg on behalf of tom petch" <[email-masked] on behalf of [email-masked]> wrote:

    RTGWG,

    =================

    <tp>
    mmm sounds like me:-)

<Acee> 
The authors of ietf-routing-policy really don't have any control over the BGP submodule prefixes. We can't use a different prefix since the BGP modules import ietf-routing-policy - not vice-versa. That is why this section is non-normative. 
</Acee>

<Acee>
I can add some text that provides the mapping of BGP submodules to the prefixes. However,  I can't just use a different prefix in the example. Would it help if we also moved the examples to appendices? 

</Acee>

Thanks,
Acee

    Tom Petch

    Thanks,
    Chris

    RTGWG,

    IPR:

    Thanks,

    Chris

---

From: tom petch <[email-masked]>
Date: Mon, 7 Sep 2020 09:30:24 +0000

From: Acee Lindem (acee) <[email-masked]>
Sent: 05 September 2020 21:55

Hi Tom,

    RTGWG,

    =================

    <tp>
    mmm sounds like me:-)

<Acee>
The authors of ietf-routing-policy really don't have any control over the BGP submodule prefixes. We can't use a different prefix since the BGP modules import ietf-routing-policy - not vice-versa. That is why this section is non-normative.
<tp>
Of course we can use a different prefix. When bgp-model imports routing-policy, it does not use the prefix specified in routing-policy but creates its own - we could return the compliment:-)

And the definition of prefix in bgp-model is invalid, inconsistent and so has to change!

More seriously, bgp-model makes a poor choice of prefix IMHO and there is scope for routing-policy to do better while trying to persuade bgp-model to make a better choice.  Technically, a YANG import can use any prefix it likes although YANG Guidelines says that the proper module prefix MUST be used.  Given that this is not a YANG import, is not valid YANG, I think that we could have licence to define our own, such as bgp-pol or bgpp with a note to the effect that that is what has been done.  I think that a note that the prefix, whatever is chosen, refers to the module bgp-policy is needed to guide the reader.

Tom Petch

</Acee>

<Acee>

</Acee>

Thanks,
Acee

    Tom Petch

    Thanks,
    Chris

    RTGWG,

    IPR:

    Thanks,

    Chris

---

From: Chris Bowers <[email-masked]>
Date: Wed, 9 Sep 2020 15:07:38 -0500

RTGWG,

I think there is rough WG consensus to submit draft-ietf-rtgwg-policy-model
to the IESG for publication.  I will include a description of the
discussion related to draft-ietf-idr-bgp-model in the shepherd writeup.  It
will likely take the IESG several months to publish
draft-ietf-rtgwg-policy-model.  If there are changes in
draft-ietf-idr-bgp-model that make it desirable to change the text of the
example in draft-ietf-rtgwg-policy-model before publication, then any
changes in draft-ietf-rtgwg-policy-model will be discussed within RTGWG.

Thanks,
Chris

---

From: tom petch <[email-masked]>
Date: Thu, 10 Sep 2020 15:44:15 +0000

From: rtgwg <[email-masked]> on behalf of Chris Bowers <[email-masked]>
Sent: 09 September 2020 21:07

RTGWG,

I think there is rough WG consensus to submit draft-ietf-rtgwg-policy-model to the IESG for publication.  I will include a description of the discussion related to draft-ietf-idr-bgp-model in the shepherd writeup.  It will likely take the IESG several months to publish draft-ietf-rtgwg-policy-model.  If there are changes in draft-ietf-idr-bgp-model that make it desirable to change the text of the example in draft-ietf-rtgwg-policy-model before publication, then any changes in draft-ietf-rtgwg-policy-model will be discussed within RTGWG.

<tp>
Chris
The other thought that I had was that the treatment of bgp-model, which I would regard as unusual, might attract some interesting comment from such as Genart or Opsdir reviews so it might be valuable to get those done earlier rather than later.

Tom Petch

Thanks,
Chris

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 10 Sep 2020 22:09:31 +0000

Hi Tom, 

As previously noted, the BGP model augments the routing-policy model and not the other way around. Hence, resolution of BGP model issues is not a prerequisite for publication of this YANG model. AFAIK, none of the open issues with the BGP model are related to its augmentation of the routing-policy model. 

Now, I'd like to see the BGP model issues addressed and the model progress as much as you but there is absolutely nothing unusual regarding its treatment. 

Thanks,
Acee

On 9/10/20, 11:44 AM, "rtgwg on behalf of tom petch" <[email-masked] on behalf of [email-masked]> wrote:

    RTGWG,

    <tp>
    Chris

    Tom Petch

    Thanks,
    Chris

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 15 Sep 2020 20:37:19 +0000

Hi Tom, Chris, et al, 
I've moved the non-normative sections to appendixes in the -22 version. Also, at the risk of being redundant, I included an explicit reference for the unpopular BGP sub-module prefixes. 
Thanks
Acee

On 9/10/20, 6:10 PM, "rtgwg on behalf of Acee Lindem (acee)" <[email-masked] on behalf of acee=[email-masked]> wrote:

    Hi Tom, 

    Thanks,
    Acee

        RTGWG,

        <tp>
        Chris

        Tom Petch

        Thanks,
        Chris

---

From: tom petch <[email-masked]>
Date: Wed, 16 Sep 2020 10:00:30 +0000

From: Acee Lindem (acee) <[email-masked]>
Sent: 15 September 2020 21:37

Hi Tom, Chris, et al,

<tp>
Looks good.

Every time I read this, I see something:-(  So some trivia for as and when a new version is needed:

container prefixes has 'is is'

container conditions /returns control the/returns control to the/
and
should or SHOULD? (an AD is bound to ask if we meant this:-)

'chain' is probably worth expanding on.  It appears in 4.4 and is relied on in s.5 without ever a formal definition and it might not be obvious how it is represented in the YANG model. I infer that it is the leaf-list import-policy or export-policy but chain does not appear in the descriptions thereof.  So I think a sentence in 4.4 saying what a chain looks like as YANG would help as would a mention of chain alongside list in the description of export-policy and import-policy.  If my inference is wrong, then please tell me what a chain is!

Tom Petch

Thanks
Acee

    Hi Tom,

    Thanks,
    Acee

        RTGWG,

        <tp>
        Chris

        Tom Petch

        Thanks,
        Chris

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 16 Sep 2020 15:53:37 +0000

Hi Tom, 

On 9/16/20, 6:01 AM, "tom petch" <[email-masked]> wrote:

    Hi Tom, Chris, et al,

    <tp>
    Looks good.

<acee>
Fixed in -22.  
</acee>

<acee>
Fixed in -22
</acee>

    and

<acee>
I think it should... Started a thread on this amongst YANG doctors. There is no consistency in published models on "description" statement validation. However, in times we've discussed this on the NETMOD list, these descriptions are normative. 
</acee>

<acee>
Good catch. I think the problem here is that "policy chain" is used for both the list of import or export policies and the list of statement within a called policy. This is clearly wrong and policy chain should only be used for the former.  Let me assure my co-authors agree.  

Thanks,
Acee
</acee>

Thanks,
Acee

    Tom Petch

    Thanks
    Acee

        Hi Tom,

        Thanks,
        Acee

            RTGWG,

            <tp>
            Chris

            Tom Petch

            Thanks,
            Chris

---

From: tom petch <[email-masked]>
Date: Wed, 16 Sep 2020 16:32:28 +0000

From: Acee Lindem (acee) <[email-masked]>
Sent: 16 September 2020 16:53
To: tom petch; Acee Lindem (acee); Chris Bowers; RTGWG
Cc: rtgwg-chairs
Subject: Re: WG last call for draft-ietf-rtgwg-policy-model

Hi Tom,

    Hi Tom, Chris, et al,

    <tp>
    Looks good.

    and

<acee>

<acee>

<tp2>
Well yes, I think I coped with that one but it is more that I cannot program a chain in YANG the way I can in other languages, forward pointers, backward pointers and so on,  and an ordered by user leaf-list is not an immediately obvious substitute to so I would add in s.4/s.5
'A policy chain is represented in YANG by a user-ordered leaf-list such as ...'
and then in the YANG
'This leaf-list implements a policy  chain as described in ...'

Tom Petch
Thanks,
Acee
</acee>

Thanks,
Acee

    Tom Petch

    Thanks
    Acee

        Hi Tom,

        Thanks,
        Acee

            RTGWG,

            <tp>
            Chris

            Tom Petch

            Thanks,
            Chris

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 16 Sep 2020 17:47:39 +0000

Hi Tom, et al, 
I have clarified the usage of policy chain and added the normative language in the YANG description constraints - which I believe is the right approach. 
Thanks,
Acee

On 9/16/20, 12:33 PM, "tom petch" <[email-masked]> wrote:

    Hi Tom,

        Hi Tom, Chris, et al,

        <tp>
        Looks good.

        and

    <acee>

    <acee>

    <tp2>

    Tom Petch
    Thanks,
    Acee
    </acee>

    Thanks,
    Acee

        Tom Petch

        Thanks
        Acee

            Hi Tom,

            Thanks,
            Acee

                RTGWG,

                <tp>
                Chris

                Tom Petch

                Thanks,
                Chris

---

From: tom petch <[email-masked]>
Date: Thu, 17 Sep 2020 10:35:31 +0000

From: Acee Lindem (acee) <[email-masked]>
Sent: 16 September 2020 18:47

Hi Tom, et al,

<tp>

Looks good.

Some more trivia:-(
In container prefixes you fixed the 'is is' but I did not notice
'outcome outcome'
or 
'statisfied'
Sigh.  I suggest holding these (which my spell-checking MUA is complaining about:-) until something else comes along.

Tom Petch
Thanks,
Acee

    Hi Tom,

        Hi Tom, Chris, et al,

        <tp>
        Looks good.

        and

    <acee>

    <acee>

    <tp2>

    Tom Petch
    Thanks,
    Acee
    </acee>

    Thanks,
    Acee

        Tom Petch

        Thanks
        Acee

            Hi Tom,

            Thanks,
            Acee

                RTGWG,

                <tp>
                Chris

                Tom Petch

                Thanks,
                Chris

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 18 Sep 2020 20:02:48 +0000

Hi Tom, 
I went ahead and fixed and ran it through a spell-checker. 
Thanks,
Acee

On 9/17/20, 6:35 AM, "tom petch" <[email-masked]> wrote:

    Hi Tom, et al,

    <tp>

    Looks good.

    Some more trivia:-(

    Tom Petch
    Thanks,
    Acee

        Hi Tom,

            Hi Tom, Chris, et al,

            <tp>
            Looks good.

            and

        <acee>

        <acee>

        <tp2>

        Tom Petch
        Thanks,
        Acee
        </acee>

        Thanks,
        Acee

            Tom Petch

            Thanks
            Acee

                Hi Tom,

                Thanks,
                Acee

                    RTGWG,

                    <tp>
                    Chris

                    Tom Petch

                    Thanks,
                    Chris