Subject: RTGWG-chairs: slot for RTGWG@109 to present on GRASP ? (was: Re: draft-li-rtgwg-protocol-assisted-protocol (was: Re: IETF 105 mic comments on draft-li-rtgwg-protocol-assisted-protocol))

From: Toerless Eckert <[email-masked]>
Date: Tue, 10 Nov 2020 17:57:24 +0100

In followup to the discuss on  draft-li-rtgwg-protocol-assisted-protocol:

Checking RTGWG agenda, it seems you might still have time available,
so if you are interested, i would be happy to whip up a few slides
to five an overview of GRASP and how we imagine it to be useable
to automate operational workflows for various services, including
routing protocols.

Cheers
    Toerless

In-Reply-To: <[email-masked]>

On Tue, Nov 10, 2020 at 05:52:35PM +0100, Toerless Eckert wrote:
> I see subject draft is again on the agenda of RTGWG'109 and the authors also asked
> for a slot to present to ANIMA (which we would be happy to have, time permitting). 
> 
> Some thoughts as contributor, maybe ANIMA chair:
> 
> Reading the draft it looks like a reinvention of the ANIMA GRASP protocol
> that we finished almost 3 years ago, but without many of the mechanisms
> that make GRASP a well reuseable, easily extensible protocol. So i wonder
> why we would want to also do another more imited protocol for the same
> goals.
> 
> On the mike RTGWG @IETF105, interest was raised to see a more comprehensive
> signalling enxchange example. Version 03 of the document seems to have
> expanded the BGP example a bit, but still not comprehensive enough for me
> to understand if/how this approach would ultimately work.
> 
> I would like to encourage the authors to concentrate on fully specifying
> intended use-cases - ideally by simply specifying the use-case as
> solution using GRASP (we call this GRASP objectives). I am sure
> ANIMA participants (including me) would be happy to help explaining how
> to specify such a protocol on top of GRASP once we understand the use-case.
> 
> Cheers
>     Toerless
> 
> On Mon, Jul 22, 2019 at 11:02:31AM -0400, Jeffrey Haas wrote:
> > To repeat my comments from the microphone regarding this draft:
> > 
> > We already have per-protocol operational and configuration state via the
> > IETF yang models for a given protocol.
> > 
> > We also have mechanisms to fetch operational state for such protocols; e.g.
> > netconf and restconf.
> > 
> > Rather than inventing a new mechanism to do troubleshooting for a protocol,
> > I'd suggest it makes better sense to augment existing IETF yang models to
> > include RPCs for interacting with troubleshooting for that protocol.
> > 
> > -- Jeff
> > 
> > _______________________________________________
> > rtgwg mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/rtgwg
> 
> -- 
> ---
> [email-masked]

-- 
---
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 11 Nov 2020 08:47:54 +1300

I'd like to underline what Toerless said. I looked at the two use casess
in the protocol-assisted-protocol draft and they seem very easy to
map onto GRASP. I don't really have time before the meeting to do
that but they are certainly use cases we could have included in the
original use case BOF that led to ANIMA.

Regards
   Brian Carpenter

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 10 Nov 2020 16:13:15 -0800

Toerless,

We will provide a slot, most likely during the 2nd meeting.
Please send an email to RTGWG with a short intro so people who might be interested have the time read up.

Thanks!

Cheers,
Jeff

---

From: Yingzhen Qu <[email-masked]>
Date: Wed, 11 Nov 2020 19:12:42 +0000

Hi Toerless,

We’ll provide you a 20-mins slot in RTGWG Wednesday session. Would you please provide some details/pointers about your presentation? I need to update the agenda with the info so people have time to read up.

Thanks,
Yingzhen
From: rtgwg <[email-masked]>
Date: Tuesday, November 10, 2020 at 4:14 PM
To: Toerless Eckert <[email-masked]>, [email-masked] <[email-masked]>, Jeffrey Haas <[email-masked]>, 陈双龙( 00419335) <[email-masked]>, [email-masked] <[email-masked]>, Lizhenbin <[email-masked]>, [email-masked] <[email-masked]>, Guyunan <[email-masked]>, [email-masked] <[email-masked]>, Brian E Carpenter <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: RTGWG-chairs: slot for RTGWG@109 to present on GRASP ? (was: Re: draft-li-rtgwg-protocol-assisted-protocol (was: Re: IETF 105 mic comments on draft-li-rtgwg-protocol-assisted-protocol))
Toerless,

Thanks!

Cheers,
Jeff

Regards
Brian Carpenter

Cheers
Toerless

Cheers
Toerless

-- Jeff

--
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 14 Nov 2020 10:48:22 +0100

Slides uploaded via propose slide. Hope that worked...

Cheers
    Toerless

On Wed, Nov 11, 2020 at 07:12:42PM +0000, Yingzhen Qu wrote:
> Hi Toerless,
> 
> We??ll provide you a 20-mins slot in RTGWG Wednesday session. Would you please provide some details/pointers about your presentation? I need to update the agenda with the info so people have time to read up.
> 
> Thanks,
> Yingzhen
> To: Toerless Eckert <[email-masked]>, [email-masked] <[email-masked]>, Jeffrey Haas <[email-masked]>, ??????( 00419335) <[email-masked]>, [email-masked] <[email-masked]>, Lizhenbin <[email-masked]>, [email-masked] <[email-masked]>, Guyunan <[email-masked]>, [email-masked] <[email-masked]>, Brian E Carpenter <[email-masked]>

-- 
---
[email-masked]

---

From: Yingzhen Qu <[email-masked]>
Date: Sun, 15 Nov 2020 23:23:15 +0000

Hi Toerless,

Please double check your slides in the meeting materials and let me know if there is any problem.

Thanks,
Yingzhen

On 11/14/20, 1:48 AM, "Toerless Eckert" <[email-masked]> wrote:

    Cheers
        Toerless

    On Wed, Nov 11, 2020 at 07:12:42PM +0000, Yingzhen Qu wrote:
    > https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Frtgwg&amp;data=04%7C01%7Cyingzhen.qu%40futurewei.com%7C1783663bf3e04584c4d008d888827083%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637409441120194999%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=syHLZW2J3aFagjDgsOx2mgNbQr115o5BVZ2Nt4tcB0k%3D&amp;reserved=0
    > 
    > --
    > ---
    > [email-masked]
    > 

    -- 
    ---
    [email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 16 Nov 2020 19:01:55 +1300

If anyone is interested, there's a generic introduction to GRASP at
https://github.com/becarpenter/graspy/blob/master/GRASP-intro.pdf
(with a very small overlap with the slides from Toerless).

Regards
   Brian